[NTG-context] writetolist causes mystery blank

2010-07-08 Thread Michael Murphy

Hi all,

I'm having a but of a problem using writetolist. In principle, I want to 
insert something into the table of contents, but I don't want to disturb 
the flow of the text. Unfortunately, the following code seems to 
generate a blank at the top of the page:


\showframe
\showmakeup

\starttext
\writetolist[section]{}{}%
\framed{This box has been pushed down}
\stoptext

I've also tried using a section command where the output has been set to 
empty:


\showframe
\showmakeup

\setuphead[section][
  before=,
  after=,
  command=\mydonothing]

\def\mydonothing#1#2{}

\starttext
\section{}%
\framed{This box has been pushed down}
\stoptext

but that also gets me a blank. Incidentally, the same thing happens with 
writebetweenlist, (except that this seems to sometimes push content onto 
a new page for some reason).


Any ideas?

--
Michael Murphy
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] writetolist causes mystery blank

2010-07-08 Thread Hans Hagen

On 8-7-2010 7:33, Michael Murphy wrote:

Hi all,

I'm having a but of a problem using writetolist. In principle, I want to
insert something into the table of contents, but I don't want to disturb
the flow of the text. Unfortunately, the following code seems to
generate a blank at the top of the page:


mkii or mkiv or both?



\showframe
\showmakeup

\starttext
\writetolist[section]{}{}%
\framed{This box has been pushed down}
\stoptext

I've also tried using a section command where the output has been set to
empty:

\showframe
\showmakeup

\setuphead[section][
before=,
after=,
command=\mydonothing]

\def\mydonothing#1#2{}

\starttext
\section{}%
\framed{This box has been pushed down}
\stoptext

but that also gets me a blank. Incidentally, the same thing happens with
writebetweenlist, (except that this seems to sometimes push content onto
a new page for some reason).

Any ideas?




--

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] writetolist causes mystery blank

2010-07-08 Thread Michael Murphy

I'm having a but of a problem using writetolist. In principle, I want to
insert something into the table of contents, but I don't want to disturb
the flow of the text. Unfortunately, the following code seems to
generate a blank at the top of the page:


mkii or mkiv or both?


It looks like it only happens on mkiv.

--
Michael Murphy
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___