Re: [NTG-context] Installation Bug with Minimals

2014-02-21 Thread Hans Hagen

On 2/21/2014 2:02 AM, Troy Henderson wrote:

I have identified the problem.  I have ConTeXt minimals installed
simultaneously with ConTeXt from TeXLive 2013.  Unsetting the
environmental variable TEXMFMAIN (which was set to my TeXLive 2013 TEXMF
directory) fixes the problem.  Perhaps the minimals installation should
unset (or ignore) this variable.


originally we did 'reset' these variables but at some point we stopped 
doing that because the recommended method is to let it be set 
automatically (from the cnf file) - also, in the meantime we figured 
that other distributions didn't set those vars any longer - i'm not too 
fond on changing setuptex in oscillating ways (every year a new policy)


Hans

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Installation Bug with Minimals

2014-02-20 Thread Troy Henderson
I have identified the problem.  I have ConTeXt minimals installed
simultaneously with ConTeXt from TeXLive 2013.  Unsetting the environmental
variable TEXMFMAIN (which was set to my TeXLive 2013 TEXMF directory) fixes
the problem.  Perhaps the minimals installation should unset (or ignore)
this variable.

Troy
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] Installation Bug with Minimals

2014-02-16 Thread Wolfgang Schuster

Am 16.02.2014 um 03:35 schrieb Troy Henderson thend...@gmail.com:

 I've done the following steps on two different machines (both running Gentoo 
 Linux) for installing ConTeXt minimals.
 
  mkdir /opt/context
  cd /opt/context
  rsync -av rsync://contextgarden.net/minimals/setup/first-setup.sh .
  ./first-setup.sh
  cd working directory for foo.tex
  . /opt/context/tex/setuptex
  context foo.tex
 
 There seems to be problems with ConTeXt finding fonts.  The output from the 
 `context foo.tex` run(s) is below:
 
 Troy
 
 --
 
  context foo.tex

Can you show the content of your file foo.tex.

 fonts!! No bodyfont has been defined and no defaults have been
 fonts!! loaded (maybe due to a missing \starttext).

Wolfgang___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] Installation Bug with Minimals

2014-02-16 Thread Troy Henderson
 Can you show the content of your file foo.tex.



\starttext
Hello World
\stoptext

but it does this for ALL ConTeXt source files that I try to build (even
ones that have built fine in the past).

Troy
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] Installation Bug with Minimals

2014-02-16 Thread Wolfgang Schuster

Am 16.02.2014 um 12:09 schrieb Troy Henderson thend...@gmail.com:

 
 Can you show the content of your file foo.tex.
 
 
 \starttext
 Hello World
 \stoptext
 
 but it does this for ALL ConTeXt source files that I try to build (even ones 
 that have built fine in the past).

Have you tried using source to run the setuptex script, e.g.

cd working directory for foo.tex
source . /opt/context/tex/setuptex
context foo.tex

Wolfgang___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] Installation Bug with Minimals

2014-02-16 Thread Troy Henderson

 Have you tried using source to run the setuptex script, e.g.

 cd working directory for foo.tex
 source . /opt/context/tex/setuptex
 context foo.tex


It fails because

bash: source: .: is a directory

but removing the . in the source command gives the same effect as the
original posting. :-(

Troy
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

[NTG-context] Installation Bug with Minimals

2014-02-15 Thread Troy Henderson
I've done the following steps on two different machines (both running
Gentoo Linux) for installing ConTeXt minimals.

 mkdir /opt/context
 cd /opt/context
 rsync -av rsync://contextgarden.net/minimals/setup/first-setup.sh .
 ./first-setup.sh
 cd working directory for foo.tex
 . /opt/context/tex/setuptex
 context foo.tex

There seems to be problems with ConTeXt finding fonts.  The output from the
`context foo.tex` run(s) is below:

Troy

--

 context foo.tex

mtx-context | run 1: luatex
--fmt=/opt/context/tex/texmf-cache/luatex-cache/context/5fe67e0bfe781ce0dde776fb1556f32e/formats/luatex/cont-en
--jobname=foo
--lua=/opt/context/tex/texmf-cache/luatex-cache/context/5fe67e0bfe781ce0dde776fb1556f32e/formats/luatex/cont-en.lui
--no-parse-first-line --c:currentrun=1 --c:fulljobname=./foo.tex
--c:input=./foo.tex --c:kindofrun=1 --c:maxnofruns=8 cont-yes.mkiv
This is LuaTeX, Version beta-0.78.2 (TeX Live 2014/dev) (rev 4746)
 \write18 enabled.
(/opt/context/tex/texmf-context/tex/context/base/cont-yes.mkiv

ConTeXt  ver: 2014.02.14 17:07 MKIV beta  fmt: 2014.2.15  int:
english/english

system   'cont-new.mkiv' loaded
(/opt/context/tex/texmf-context/tex/context/base/cont-new.mkiv)
system   files  jobname 'foo', input './foo', result 'foo'
fontslatin modern fonts are not preloaded
languageslanguage 'en' is active
(/home/thenders/tmp/foo.tex{/opt/context/tex/texmf-context/fonts/map/pdftex/context/mkiv-base.map}
fontspreloading latin modern fonts (second stage)
fontsdefining  font with asked name 'lmroman12-regular' is
not found using lookup 'file'
fontsdefining  unknown font 'lmroman12-regular', loading
aborted
fontsdefining  unable to define 'lmroman12-regular' as
'modern-designsize-12pt-rm-tf-0--0'
fontsdefining  forced type 'otf' of
'latinmodern-math-regular' not found
fontsdefining  font with asked name
'latinmodern-math-regular' is not found using lookup 'file'
fontsdefining  unknown font 'latinmodern-math-regular',
loading aborted
fontsdefining  unable to define
'latinmodern-math-regular.otf' as 'modern-designsize-12pt-mm-mr--3'
fontsdefining  forced type 'otf' of
'latinmodern-math-regular' not found
fontsdefining  font with asked name
'latinmodern-math-regular' is not found using lookup 'file'
fontsdefining  unknown font 'latinmodern-math-regular',
loading aborted
fontsdefining  unable to define
'latinmodern-math-regular.otf' as 'modern-designsize-12pt-mm-mr--2'
fontsdefining  forced type 'otf' of
'latinmodern-math-regular' not found
fontsdefining  font with asked name
'latinmodern-math-regular' is not found using lookup 'file'
fontsdefining  unknown font 'latinmodern-math-regular',
loading aborted
fontsdefining  unable to define
'latinmodern-math-regular.otf' as 'modern-designsize-12pt-mm-mr--1'
fontsdefining  forced type 'otf' of
'latinmodern-math-regular' not found
fontsdefining  font with asked name
'latinmodern-math-regular' is not found using lookup 'file'
fontsdefining  unknown font 'latinmodern-math-regular',
loading aborted
fontsdefining  unable to define
'latinmodern-math-regular.otf' as 'modern-designsize-12pt-mm-mb--3'
fontsdefining  forced type 'otf' of
'latinmodern-math-regular' not found
fontsdefining  font with asked name
'latinmodern-math-regular' is not found using lookup 'file'
fontsdefining  unknown font 'latinmodern-math-regular',
loading aborted
fontsdefining  unable to define
'latinmodern-math-regular.otf' as 'modern-designsize-12pt-mm-mb--2'
fontsdefining  forced type 'otf' of
'latinmodern-math-regular' not found
fontsdefining  font with asked name
'latinmodern-math-regular' is not found using lookup 'file'
fontsdefining  unknown font 'latinmodern-math-regular',
loading aborted
fontsdefining  unable to define
'latinmodern-math-regular.otf' as 'modern-designsize-12pt-mm-mb--1'
fontsmath: unset for global bodyfont modern-designsize at 12pt
fontsmath: unset for global bodyfont modern-designsize at 12pt
fonts'fallback modern rm 12pt' is loaded
fontsmath: unset for global bodyfont modern-designsize at 12pt
fontsmath: unset for global bodyfont modern-designsize at 12pt
backend  xmp  using file
'/opt/context/tex/texmf-context/tex/context/base/lpdf-pdx.xml'
pagesflushing realpage 1, userpage 1

fonts!! No bodyfont has been defined and no defaults have been
fonts!! loaded (maybe due to a missing \starttext).

 ) )

mkiv lua stats   used config file: selfautoparent:/texmf/web2c/texmfcnf.lua
mkiv lua stats   used cache path:
/opt/context/tex/texmf-cache/luatex-cache/context/5fe67e0bfe781ce0dde776fb1556f32e
mkiv lua stats