Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-14 Thread Thomas A. Schmitz
On Apr 13, 2008, at 9:30 AM, Taco Hoekwater wrote: Roland wrote: Anybody? Makes no sense to me. I hope Thomas can have a look. Something obviously goes wrong for you, but I have never yet see it go _so_ wrong. Is there a chance of a corrupted download of something? Best wishes,

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-13 Thread Taco Hoekwater
Roland wrote: Anybody? Makes no sense to me. I hope Thomas can have a look. Something obviously goes wrong for you, but I have never yet see it go _so_ wrong. Is there a chance of a corrupted download of something? Best wishes, Taco

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-13 Thread Mojca Miklavec
On Sat, Apr 12, 2008 at 4:24 PM, Roland wrote: @Mojca, I found that /usr/texbin was pointing to a missing directory, so this caused the problem mentioned below. I took /usr/texbin out of the $PATH and replaced it with /usr/local/texlive/2007/bin/i386-darwin -- this lets luatools

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-12 Thread Roland
Hmmm this produces something funny: $ luatools --selfupdate LuaTools | to be replaced old script /usr/texbin/luatools LuaTools | unable to locate new script LuaTools | LuaTools | runtime: 0.005 seconds Perhaps some link is wrong or I shouldn't use the alias /usr/texbin (as installed by MacTeX)?

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-12 Thread Roland
@Mojca, I found that /usr/texbin was pointing to a missing directory, so this caused the problem mentioned below. I took /usr/texbin out of the $PATH and replaced it with /usr/local/texlive/2007/bin/i386-darwin -- this lets luatools --selfupdate run correctly: LuaTools | to be replaced

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-09 Thread Taco Hoekwater
Roland wrote: ) (/usr/local/texlive/texmf-local/tex/context/base/core-ref.tex loading : Context Core Macros / Cross Referencing (/usr/local/texlive/texmf-local/tex/context/base/sort-lan.tex loading : Context Sorting Macros (languages)

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-08 Thread Roland
yes, here goes: $ luatools --ini --verbose --compile cont-en LuaTools | version 1.1.1 - 2006+ - PRAGMA ADE / CONTEXT LuaTools | skipping configuration for /texmf-local/web2c from /tmp/luatex-cache/context/fcf214085bb2c4fcd9a0f9a9f0d0aecf/trees/d80510d450a3fa2a64df4d3741825f1d LuaTools |

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-08 Thread Hans Hagen
Roland wrote: yes, here goes: (/usr/local/texlive/texmf-local/tex/context/base/sort-lan.mkiv))error: al/texlive/texmf-local/tex/context/base/node-ini.lua:345: attempt to index field 'otf' (a nil value) .. l.3174 it looks like tex is typesetting something (otherwise there is no reason

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-07 Thread Taco Hoekwater
Roland wrote: Hi Taco, thanks for the quick reply. Something seems to work better now (no more errors about missing texmf directories) but I still get an error message after installing the new binary you pointed me to: (/usr/local/texlive/texmf-local/tex/context/base/sort-lan.tex

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-06 Thread Taco Hoekwater
Roland wrote: Hi, I've been following Thomas Schmitz's great instructions at http://www.ntg.nl/pipermail/ntg-context/2007/027418.html to set up Luatex. All works fine and without errors but the last step: Hans and me are to blame, for not keeping the binaries on www.luatex.org synced.

Re: [NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-06 Thread Roland
Hi Taco, thanks for the quick reply. Something seems to work better now (no more errors about missing texmf directories) but I still get an error message after installing the new binary you pointed me to: (/usr/local/texlive/texmf-local/tex/context/base/sort-lan.tex loading :

[NTG-context] LuaTex error attempt to index global 'lang' (a nil value)

2008-04-05 Thread Roland
Hi, I've been following Thomas Schmitz's great instructions at http://www.ntg.nl/pipermail/ntg-context/2007/027418.html to set up Luatex. All works fine and without errors but the last step: $ luatools --ini --verbose --compile cont-en LuaTools | version 1.1.1 - 2006+ - PRAGMA ADE /