[NTG-context] Upgrading to git repo.

2012-11-02 Thread Andre Caldas
Hello!

I have the context standalone installed.
How do I update it to reflect the last changes in the GIT repo?
http://gitorious.org/context


Cheers,
André Caldas.
-- 
- Por que altera a ordem natural da conversação!
- Por que não?
- Eu não gosto, não.
- Você gosta quando copiam a mensagem original ao final do e-mail?
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] upgrading to the latest alpha

2009-01-12 Thread Mojca Miklavec
Hello,

Just some basic feedback ...

- GUI on Windows (written by Vyatcheslav) doesn't offer --context=alpha switch
- There's nothing wrong with just overwriting the existing files with
files extracted from PRAGMA; first-setup.sh doesn't do much more than
that.
- The luatools --selfupdate and mtxrun --selfupdate are not supposed
to be FAQ items, but they are rather a flaw that should be fixed in
distribution itself

To Mehdi:
   luatools --selfupdate
   mtxrun --selfupdate
   luatools --generate
   context --make en

If you ask me -- none of the first three commands should be needed,
but then I'm the one to blame for the first two and for the reason why
these are not fixed yet.

Mojca
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] upgrading to the latest alpha

2009-01-12 Thread Mehdi Omidali
Thanks Mojca, Wolfgang, Yue
Now it is working.

On 1/12/09, Mojca Miklavec mojca.miklavec.li...@gmail.com wrote:
 Hello,

 Just some basic feedback ...

 - GUI on Windows (written by Vyatcheslav) doesn't offer --context=alpha
 switch
 - There's nothing wrong with just overwriting the existing files with
 files extracted from PRAGMA; first-setup.sh doesn't do much more than
 that.
 - The luatools --selfupdate and mtxrun --selfupdate are not supposed
 to be FAQ items, but they are rather a flaw that should be fixed in
 distribution itself

 To Mehdi:
luatools --selfupdate
mtxrun --selfupdate
luatools --generate
context --make en

 If you ask me -- none of the first three commands should be needed,
 but then I'm the one to blame for the first two and for the reason why
 these are not fixed yet.

 Mojca
 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] upgrading to the latest alpha

2009-01-11 Thread Mehdi Omidali
Hi,
I want to update my minimal installation on windows to the latest alpha.
Seems that just copying the files in the base folder of the latest alpha to
the corresponding folder in the minimal distribution is not working. Should
I do something else?
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] upgrading to the latest alpha

2009-01-11 Thread Yue Wang
what do you mean by not working?

btw, you'd better upgrade using context minimal's first-setup.sh

On 1/11/09, Mehdi Omidali mehd...@gmail.com wrote:
 Hi,
 I want to update my minimal installation on windows to the latest alpha.
 Seems that just copying the files in the base folder of the latest alpha to
 the corresponding folder in the minimal distribution is not working. Should
 I do something else?

 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] upgrading to the latest alpha

2009-01-11 Thread Mehdi Omidali
I use the minimal gui installer.

On Sun, Jan 11, 2009 at 4:41 PM, Yue Wang yuleo...@gmail.com wrote:

 what do you mean by not working?

 btw, you'd better upgrade using context minimal's first-setup.sh

 On 1/11/09, Mehdi Omidali mehd...@gmail.com wrote:
  Hi,
  I want to update my minimal installation on windows to the latest alpha.
  Seems that just copying the files in the base folder of the latest alpha
 to
  the corresponding folder in the minimal distribution is not working.
 Should
  I do something else?
 
 
 ___
  If your question is of interest to others as well, please add an entry to
  the Wiki!
 
  maillist : ntg-context@ntg.nl /
  http://www.ntg.nl/mailman/listinfo/ntg-context
  webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
  archive  : https://foundry.supelec.fr/projects/contextrev/
  wiki : http://contextgarden.net
 
 ___
 
 

 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net

 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] upgrading to the latest alpha

2009-01-11 Thread Yue Wang
change the --context= from stable to latest in your first-setup.sh and
run it again.

On Sun, Jan 11, 2009 at 9:19 PM, Mehdi Omidali mehd...@gmail.com wrote:
 I use the minimal gui installer.

 On Sun, Jan 11, 2009 at 4:41 PM, Yue Wang yuleo...@gmail.com wrote:

 what do you mean by not working?

 btw, you'd better upgrade using context minimal's first-setup.sh

 On 1/11/09, Mehdi Omidali mehd...@gmail.com wrote:
  Hi,
  I want to update my minimal installation on windows to the latest alpha.
  Seems that just copying the files in the base folder of the latest alpha
  to
  the corresponding folder in the minimal distribution is not working.
  Should
  I do something else?
 
 
  ___
  If your question is of interest to others as well, please add an entry
  to
  the Wiki!
 
  maillist : ntg-context@ntg.nl /
  http://www.ntg.nl/mailman/listinfo/ntg-context
  webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
  archive  : https://foundry.supelec.fr/projects/contextrev/
  wiki : http://contextgarden.net
 
  ___
 
 

 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net

 ___


 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] upgrading to the latest alpha

2009-01-11 Thread Mehdi Omidali
I did --context=alpha and after installation after I run
luatools --generate
context --make en
I got the error
.
?:0 :attemts to index global tracker a nil value
luatools |
luatools | runtime : 0.776 seconds
MtxRun | totalruntime 0.859

On 1/11/09, Yue Wang yuleo...@gmail.com wrote:
 change the --context= from stable to latest in your first-setup.sh and
 run it again.

 On Sun, Jan 11, 2009 at 9:19 PM, Mehdi Omidali mehd...@gmail.com wrote:
 I use the minimal gui installer.

 On Sun, Jan 11, 2009 at 4:41 PM, Yue Wang yuleo...@gmail.com wrote:

 what do you mean by not working?

 btw, you'd better upgrade using context minimal's first-setup.sh

 On 1/11/09, Mehdi Omidali mehd...@gmail.com wrote:
  Hi,
  I want to update my minimal installation on windows to the latest
  alpha.
  Seems that just copying the files in the base folder of the latest
  alpha
  to
  the corresponding folder in the minimal distribution is not working.
  Should
  I do something else?
 
 
  ___
  If your question is of interest to others as well, please add an entry
  to
  the Wiki!
 
  maillist : ntg-context@ntg.nl /
  http://www.ntg.nl/mailman/listinfo/ntg-context
  webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
  archive  : https://foundry.supelec.fr/projects/contextrev/
  wiki : http://contextgarden.net
 
  ___
 
 

 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net

 ___


 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___


 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : https://foundry.supelec.fr/projects/contextrev/
 wiki : http://contextgarden.net
 ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] upgrading to the latest alpha

2009-01-11 Thread Wolfgang Schuster


Am 11.01.2009 um 21:50 schrieb Mehdi Omidali:


I did --context=alpha and after installation after I run
luatools --generate
context --make en
I got the error
.
?:0 :attemts to index global tracker a nil value
luatools |
luatools | runtime : 0.776 seconds
MtxRun | totalruntime 0.859


This is a faq, you need

  luatools --selfupdate
  mtxrun --selfupdate

before

  content --make en

Wolfgang

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Upgrading ConTeXt and testing

2005-08-29 Thread Taco Hoekwater


Hi Idris (and all),

Idris Samawi Hamid wrote:

When a new ConTeXt is released, Taco or someone else could then document which 
bugs are fixed, features added, and, most importantly, what features are 
changed or broken. 


Whenever someone reports a problem, the release notes on the wiki
enable me to quickly look up changes in the code (to check for
possible regression errors). It has saved me a lot of time in the
last half year or so.

But the release notes is not enough, we are aware of that. Three
other projects in the pipeline are:

* A read-only CVS containing as many of the old ConTeXt releases as
  we can find, for reference and regression checks.
  This cannot be started immediately because we first have to collect
  all of the old zips, so they can be imported in the correct order.
  (assigned to Patrick and me)

* A limited-access CVS with Hans' current working sources, so that
  some of the active developers can apply patches themselves
  (assigned to Hans)

* A test suite, precisely as you proposed (not assigned to anybody
  yet wink)
  The best way to boot this project is to request/create a project
  on Fabrice Popineau's gforge/subversion server:
https://foundry.supelec.fr/

  (we intend to use the same gforge server for the read-only CVS)

A related point (disussed before) is that ConTeXt needs to become completely 
independent of the TeX distributions. mswincontext.zip is a good start (I no 
longer use fpTeX), but things like dvipdfmx and the plain format (for testing 
purposes) need to be thoroughly supported and tested. 


Yeah, I very much agree. Here is the run-down on last night's
problem:

Hans does not ship lang-us.pat, probably because someone told him
not to (that sort of stuff is a whole different story). What
happens then is that context's file synonym mechanism tries to
find a replacement file for lang-us.pat.

I do not have ushyphmax.tex installed, so on my system, that means
ushyph.tex, and it works fine. But apparently (sometimes? dependant
on install options perhaps?) miktex ships a ushyphmax.tex. And a
broken one, at that. It took most of yesterday-evening to discover
that. :-(

Again, a support team 
for Hans is needed (especially for Mac OSX and Unix), and I'm willing to help 
as far as my skills will allow.


Lately, we get a lot of bug reports for miktex, which is problematic
since none of us use miktex: I believe Hans has a fptex-ish system,
and most other 'core' people are either linux or macintosh based.

A volunteer for miktex would be brilliant (even better: someone who
knows how to compile miktex executables).


Greetings, Taco
___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] Upgrading ConTeXt and testing

2005-08-29 Thread Hans Hagen

Taco Hoekwater wrote:



Hi Idris (and all),

Idris Samawi Hamid wrote:

When a new ConTeXt is released, Taco or someone else could then 
document which bugs are fixed, features added, and, most importantly, 
what features are changed or broken. 



Whenever someone reports a problem, the release notes on the wiki
enable me to quickly look up changes in the code (to check for
possible regression errors). It has saved me a lot of time in the
last half year or so.

But the release notes is not enough, we are aware of that. Three
other projects in the pipeline are:

* A read-only CVS containing as many of the old ConTeXt releases as
  we can find, for reference and regression checks.


subversion -)

i'll set that up as soon as possible and taco can mirror that 
(interesting experiment anyway, mirroring a svn archive)


we can  use fabrices gforce archive if needed


  This cannot be started immediately because we first have to collect
  all of the old zips, so they can be imported in the correct order.
  (assigned to Patrick and me)


-)


* A limited-access CVS with Hans' current working sources, so that
  some of the active developers can apply patches themselves
  (assigned to Hans)


indeed; i'll open a svn repository for that with access for approved dev's


* A test suite, precisely as you proposed (not assigned to anybody
  yet wink)
  The best way to boot this project is to request/create a project
  on Fabrice Popineau's gforge/subversion server:
https://foundry.supelec.fr/


indeed


  (we intend to use the same gforge server for the read-only CVS)


right

A related point (disussed before) is that ConTeXt needs to become 
completely independent of the TeX distributions. mswincontext.zip is 
a good start (I no longer use fpTeX), but things like dvipdfmx and 
the plain format (for testing purposes) need to be thoroughly 
supported and tested. 



Yeah, I very much agree. Here is the run-down on last night's
problem:

Hans does not ship lang-us.pat, probably because someone told him
not to (that sort of stuff is a whole different story). What
happens then is that context's file synonym mechanism tries to
find a replacement file for lang-us.pat.

I do not have ushyphmax.tex installed, so on my system, that means
ushyph.tex, and it works fine. But apparently (sometimes? dependant
on install options perhaps?) miktex ships a ushyphmax.tex. And a
broken one, at that. It took most of yesterday-evening to discover
that. :-(


sigh, what a mess; so, we set up a repository for that as well:

context - sources (copy from one of our internal servers)
history
generic patterns
distribution
manuals (copy from one of our internal servers)

Again, a support team for Hans is needed (especially for Mac OSX and 
Unix), and I'm willing to help as far as my skills will allow.



Lately, we get a lot of bug reports for miktex, which is problematic
since none of us use miktex: I believe Hans has a fptex-ish system,
and most other 'core' people are either linux or macintosh based.



A volunteer for miktex would be brilliant (even better: someone who
knows how to compile miktex executables).


yeah, i have to pick up that thread, since newtexexec needs to be miktex aware; 

Hans 


-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] Upgrading ConTeXt and testing

2005-08-29 Thread Brooks Moses

At 06:04 AM 8/29/2005, Hans Hagen [EMAIL PROTECTED] wrote:

Taco Hoekwater wrote:

* A read-only CVS containing as many of the old ConTeXt releases as
  we can find, for reference and regression checks.


subversion -)

i'll set that up as soon as possible and taco can mirror that (interesting 
experiment anyway, mirroring a svn archive)


Recently, I came across something called SVK, which apparently is 
specifically intended for mirroring and merging subversion archives.  It 
looks like it might also solve the problem you (Hans) were mentioning 
earlier of wanting to have a local version of the repository on your laptop 
that you could periodically merge with the main repository.


There's a webpage on it here:
  http://svk.elixus.org/

Personally, I haven't used it yet, but I got the link from a friend of mine 
who is a very competent sysadmin, and he seemed happy with it.


- Brooks

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] Upgrading ConTeXt and testing

2005-08-29 Thread jjgod

Taco Hoekwater wrote:


Lately, we get a lot of bug reports for miktex, which is problematic
since none of us use miktex: I believe Hans has a fptex-ish system,
and most other 'core' people are either linux or macintosh based.


The problem is, currently MikTeX (2.4) does not have a SDK, the 
maintainer said a SDK will be released in version 2.5, but the release 
date is not fixed yet.


MikTeX use a different way (compare to tetex) to load web2c config file, 
so the kpathsea library in MikTeX is just a wrapper of function calls to 
the MikTeX library. Without a SDK we have to fetch all the source code 
of MikTeX to compile such a library, which is rather difficult.


To name one problem I encounted, the Win32 binaries of afm2pl (from 
http://tex.aanhet.net/afm2pl/) does not work in MikTeX (because the 
reason I just described), but it's really hard to compile a binary (with 
libkpse support) by myself.




A volunteer for miktex would be brilliant (even better: someone who
knows how to compile miktex executables).


- jjgod.
___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


[NTG-context] Upgrading ConTeXt and testing

2005-08-28 Thread Idris Samawi Hamid
Dear gang,

I understand that ConTeXt is a HUGE system, and it is impossible for Hans to 
micro-test everything. However, it is not infrequent that upgrades by users 
lead to sometimes days of lost productivity. For example, a recent change in 
the indentation code ruined a 425-page manuscript and it took me hours to 
identify the source of the problem. And that was only one problem.

Given the problems some of us have faced when upgrading, I think that we 
really need a test suite of documents that provide some benchmarks for each 
part of the system, from building supported format files to features to 
supported output formats. Maybe this would take a long time; but perhaps the 
task could be delegated among is. I would be willing to be part of that team 
(including but not exclusively the aleph-dvipdfmx cycle).

When a new ConTeXt is released, Taco or someone else could then document which 
bugs are fixed, features added, and, most importantly, what features are 
changed or broken. That way, upgrading does not always have to be a leap in 
the dark with fingers crossed.

The above is just an idea. I hope it can be developed into something actually 
workable and useful.

A related point (disussed before) is that ConTeXt needs to become completely 
independent of the TeX distributions. mswincontext.zip is a good start (I no 
longer use fpTeX), but things like dvipdfmx and the plain format (for testing 
purposes) need to be thoroughly supported and tested. Again, a support team 
for Hans is needed (especially for Mac OSX and Unix), and I'm willing to help 
as far as my skills will allow.

Best
Idris


Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


[NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Idris Samawi Hamid
Dear gang,

Have not updated in a while, noticed a new mswincontext.zip, now trying to 
upgrade to the latest.

First thing:

System complains that pdfetex.dll cannot be found. Sure enough, there is no 
such dll in the distribution.

2. Can I go back to the last mswincontext and just use cont-tmf, or are there 
some new features in the latest mswincontext that we need?

Best
Idris


Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Hans Hagen

Idris Samawi Hamid wrote:


Dear gang,

Have not updated in a while, noticed a new mswincontext.zip, now trying to 
upgrade to the latest.


First thing:

System complains that pdfetex.dll cannot be found. Sure enough, there is no 
such dll in the distribution.


2. Can I go back to the last mswincontext and just use cont-tmf, or are there 
some new features in the latest mswincontext that we need?
 

just use the old pdfetex and pdfetex.pool (i'll fix the mswin zip files 

Hans 


-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Idris Samawi Hamid
= Original Message From Hans Hagen [EMAIL PROTECTED] =
System complains that pdfetex.dll cannot be found. Sure enough, there is no
such dll in the distribution.

just use the old pdfetex and pdfetex.pool (i'll fix the mswin zip files

One more question:

I have a lot of private/generated stuff in texmf-local and texmf-fonts, much 
of it generated by texfont etc. Is it safe (after backup) to just drop the new 
C:/ConTeXt on top of the older one?

Is engine path working? Is there one command to generate both aleph and 
pdfetex formats or do I have to do this separately?

Any other upgrade tips are appreciated!

Best
Idris


Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Hans Hagen

Idris Samawi Hamid wrote:

I have a lot of private/generated stuff in texmf-local and texmf-fonts, much 
of it generated by texfont etc. Is it safe (after backup) to just drop the new 
C:/ConTeXt on top of the older one?


 


i think so

Is engine path working? Is there one command to generate both aleph and 
pdfetex formats or do I have to do this separately?
 


should work automatically


Any other upgrade tips are appreciated!
 

keep testing 

Hans 


-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Idris Samawi Hamid
= Original Message From Hans Hagen [EMAIL PROTECTED] =
Is engine path working? Is there one command to generate both aleph and
pdfetex formats or do I have to do this separately?


should work automatically

1. Can I do something in e.g. texexec.ini so that

texexec --make

generates both pdfetex and aleph formats? Right now I still have to compile 
the aleph format separately.

2. Also:

Although the tex engine per se is no longer needed, we still need to be able 
to e.g.,

aleph --ini *plain \dump

right now some files (like manfnt) are missing from the distribution. It's 
very important to be able to compile aleph in plain fmt for testing purposes 
(it's how i found at least a couple of context-aleph bugs, for ex.).

Best
Idris

Best
Idris


Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Hans Hagen

Idris Samawi Hamid wrote:


texexec --make

generates both pdfetex and aleph formats? Right now I still have to compile 
the aleph format separately.


 

in newtexexec it's possible to do that as well as add teh engine in the 
banner of the tex file so that the right format is taken


(i have to document that)


2. Also:

Although the tex engine per se is no longer needed, we still need to be able 
to e.g.,


aleph --ini *plain \dump

right now some files (like manfnt) are missing from the distribution. It's 
very important to be able to compile aleph in plain fmt for testing purposes 
(it's how i found at least a couple of context-aleph bugs, for ex.).
 

hm, just make me a list of files then 

i'll look into it when i'm back from the tug conference (china) 

Hans 



-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] upgrading to latest ConTeXt

2005-08-18 Thread Idris Samawi Hamid
Another bug/feature:

Something has apparently changed in the way fonts/maps are loaded.

The following used to work, now does not


% output=pdf interface=en

\usetypescriptfile[type-mpoow]
\usetypescript[MinionProOptow]
\setupbodyfont[minionprooptow,10pt]

\starttext

\dots

\stoptext


The typescript file is my own, but the following line is relevant:

=
\definetypeface [minionprooptow]
[mm] [math] [euler] [default] [encoding=texnansi,rscale=0.89]
=

When I process this the log gives

=
Warning: pdfetex.exe (file eurm10): Font eurm10 at 64 not found
=

Second: why doesn't the ellipsis use the main text font? I guess that \dots is 
obtained from the math font, but in running text this makes no sense.

Shouldn't ConTeXt define \dots with respect the text font? Or does it use 
something other than \dots?

Best
Idris


Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] Upgrading...

2005-03-17 Thread Hans Hagen
Idris Samawi Hamid wrote:
On Sat, 05 Mar 2005 23:51:50 +0100, h h extern [EMAIL PROTECTED] wrote:
when needed, unzip the latest cont-tfm (beta) and cont-lmr archives in 
texmf-local and remake formats

Where are the cont-lmr archives? I can't find them...
on our website there is a zip (beta location) in the texmf structure
Hans
-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
 tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] Upgrading...

2005-03-16 Thread Hans Hagen
ishamid wrote:
I must be making this way too complicated, anyway...
I placed C:\ConTeXt\texmf-mswin\bin ahead of TeXLive in my NT PATH (Windows 
2000) so those binaries get called first. I tried to make the aleph format:

===
C:\ConTeXt\texmf-mswin\web2caleph --ini *plain \dump
This is Alephk, Version 3.141592-1.15-2.1-0.0-rc4 (Web2c 7.5.3) (INIALEPH)
 %-line parsing enabled.
this is a plain tex issue ... looks likemanfnt is not on your system
Hans
-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
 tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] Upgrading...

2005-03-16 Thread ishamid
= Original Message From Hans Hagen [EMAIL PROTECTED] =
 ===
 C:\ConTeXt\texmf-mswin\web2caleph --ini *plain \dump
 This is Alephk, Version 3.141592-1.15-2.1-0.0-rc4 (Web2c 7.5.3) (INIALEPH)
  %-line parsing enabled.

this is a plain tex issue ... looks likemanfnt is not on your system

1. ok, how do I get

C:\ConTeXt\texmf-mswin\bin

to secondarily search C:\TeXLive, where manfnt is located?

2. Also, I need both pdfetex and aleph; how do I get both, since both

texexec --make en -tex=aleph

and

texexec --make en -tex=pdfetex

produce the same file, cont-en.fmt?

Idris

Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] Upgrading...

2005-03-15 Thread ishamid
= Original Message From Idris Samawi Hamid [EMAIL PROTECTED] =
On Sat, 05 Mar 2005 23:51:50 +0100, h h extern [EMAIL PROTECTED] wrote:

 when needed, unzip the latest cont-tfm (beta) and cont-lmr archives in
 texmf-local and remake formats

Where are the cont-lmr archives? I can't find them...

Ok, I see that lmr comes with the mswincontext distribution, so cont-lmr will 
be put up if/when improvements are made?

Idris

Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] Upgrading...

2005-03-15 Thread ishamid
 just download the windows zip file from our website and install that one
 in a separate tree, e.g. under

 c:\context

 then, you can initialize that tree with

 c:\context\setuptex c:\context

 and voila ...

Ok, I followed the above. Now I have two trees, c:\TeXLive and c:\ConTeXt

Issues:

1. I ``initialized'' the \ConTeXt tree and ran

texexec --make

but no aleph format, so a batch file is called:

cd C:\ConTeXt\texmf-mswin\web2c
aleph --ini *plain \dump
texexec --make en -tex=aleph
aleph --ini *cont-en

but...

C:\ConTeXt\texmf-mswin\web2caleph --ini *plain \dump
! aleph.pool doesn't match; otangle me again (or fix the path).

How do I get aleph working?

2. How do I get my OS to recognize/prioritize the C:\ConTeXt tree (when I call 
texexec from my editor it still calls from c:\TeXLive)? Do I have to uninstall 
ConTeXt from my c:\TeXLive path? What is the cleanest way to do that?

3. I presume that 
\ConTeXt\texmf-local\web2c\texmf.cnf 
is the one 
texexec --make
uses. Have you already optimized/tested 
\ConTeXt\texmf-local\web2c\texmf.cnf 
for aleph (there were a few issues as you may recall...)?

Best
Idris

Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


RE: [NTG-context] Upgrading...

2005-03-15 Thread ishamid
I must be making this way too complicated, anyway...

I placed C:\ConTeXt\texmf-mswin\bin ahead of TeXLive in my NT PATH (Windows 
2000) so those binaries get called first. I tried to make the aleph format:

===
C:\ConTeXt\texmf-mswin\web2caleph --ini *plain \dump
This is Alephk, Version 3.141592-1.15-2.1-0.0-rc4 (Web2c 7.5.3) (INIALEPH)
 %-line parsing enabled.
Copyright (c) 2002--2004 the Aleph task force
entering extended mode
(c:/ConTeXt/texmf/tex/plain/base/plain.tex Preloading the plain format: codes,
registers, parameters, fonts, more fonts,
! Font \preloaded=manfnt not loadable: Metric (TFM/OFM) file not found.
to be read again
   \par
l.468

?
===

It works fine in TeXLive.

Another problem: how can I have both the aleph and the pdfetex formats?

texexec --make en -tex=aleph

overides the default cont-en.fmt made by

texexec --make

Question: how can I configure mktexlsr so that it updates both C:\ConTeXt as 
well as C:\TeXLive?

best
Idris

Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


[NTG-context] Upgrading...

2005-03-05 Thread ishamid
Dear syndicate,

While I have not closely kept up with all developments it seems that 
installation/upgrade procedures have been improved. I also went through a lot 
of pain the last time I upgraded so I ask:

Given that:

1. I have not updated my context since Aug. of last year;

2. my fpTeX is from last July.

What is the wisest and most efficient way to upgrade my ConTeXt distribution 
today?

Should I replace fpTeX (including Aleph) with the ConTeXt/TeX distribution 
from the website?

Are there any Aleph-related issues?

Any tips will be appreciated

Thanks
Idris

Professor Idris Samawi Hamid
Department of Philosophy
Colorado State University
Fort Collins, CO 80523

___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] Upgrading...

2005-03-05 Thread h h extern
ishamid wrote:
Dear syndicate,
While I have not closely kept up with all developments it seems that 
installation/upgrade procedures have been improved. I also went through a lot 
of pain the last time I upgraded so I ask:

Given that:
1. I have not updated my context since Aug. of last year;
2. my fpTeX is from last July.
What is the wisest and most efficient way to upgrade my ConTeXt distribution 
today?

Should I replace fpTeX (including Aleph) with the ConTeXt/TeX distribution 
from the website?

Are there any Aleph-related issues?
Any tips will be appreciated
just download the windows zip file from our website and install that one in a 
separate tree, e.g. under

c:\context
then, you can initialize that tree with
c:\context\setuptex c:\context
and voila ...
when needed, unzip the latest cont-tfm (beta) and cont-lmr archives in 
texmf-local and remake formats

Hans
-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
 tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context