Re: [NTG-context] XeTeX and lmtypewriter10-regular

2008-11-20 Thread Hans Hagen
Bart C. Wise wrote:
 I'm running TeXLive 2008.
 When I compile for XeTeX (texexec --xtx) I get the following output that 
 appears to be generating the lmtypewriter10-regular font.  The bad part is 
 that this is very slow.  The part that's even worse, it does this probably 
 20...30...40 times?  A compilation takes 145 seconds, and about 130+ seconds 
 of time seem to be dealing with lmtypewriter10-regular.
 
 This doesn't happen on small test files, so I know I'm doing something wrong. 
  
 Any ideas?
 
 Thanks,
 Bart
 
 
 kpathsea: Running mktextfm lmtypewriter10-regular
 mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; 
 input lmtypewriter10-regular
 This is METAFONT, Version 2.718281 (Web2C 7.5.7)  
   
 
 
 kpathsea: Running mktexmf lmtypewriter10-regular
 ! I can't find file `lmtypewriter10-regular'.   
 * ...; nonstopmode; input lmtypewriter10-regular
   
 Please type another input file name   
 ! Emergency stop. 
 * ...; nonstopmode; input lmtypewriter10-regular
   
 Transcript written on mfput.log.  
 grep: lmtypewriter10-regular.log: No such file or directory
 mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input 
 lmtypewriter10-regular' failed to make lmtypewriter10-regular.tfm.
   

 kpathsea: Appending font creation commands to missfont.log.   


The file name is : lmmono10-regular
The font name is : LMTypewriter10-Regular

You can do (in context):

\definefontsynonym [MyMono] [file:lmmono10-regular]
\definefontsynonym [MyMono] [name:LMTypewriter10-Regular]

(i'm not sure if xetex is case sensitive)

All th emessages that you see on the console concern xetex calling 
metafont to generate a font which does not exist (a kind of fallback 
behaviour)



-
   Hans Hagen | PRAGMA ADE
   Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
  tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
  | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] XeTeX and lmtypewriter10-regular

2008-11-19 Thread Bart C. Wise
I'm running TeXLive 2008.
When I compile for XeTeX (texexec --xtx) I get the following output that 
appears to be generating the lmtypewriter10-regular font.  The bad part is 
that this is very slow.  The part that's even worse, it does this probably 
20...30...40 times?  A compilation takes 145 seconds, and about 130+ seconds 
of time seem to be dealing with lmtypewriter10-regular.

This doesn't happen on small test files, so I know I'm doing something wrong.  
Any ideas?

Thanks,
Bart


kpathsea: Running mktextfm lmtypewriter10-regular
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; 
input lmtypewriter10-regular
This is METAFONT, Version 2.718281 (Web2C 7.5.7)



kpathsea: Running mktexmf lmtypewriter10-regular
! I can't find file `lmtypewriter10-regular'.   
* ...; nonstopmode; input lmtypewriter10-regular
  
Please type another input file name   
! Emergency stop. 
* ...; nonstopmode; input lmtypewriter10-regular
  
Transcript written on mfput.log.  
grep: lmtypewriter10-regular.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input 
lmtypewriter10-regular' failed to make lmtypewriter10-regular.tfm.  

   
kpathsea: Appending font creation commands to missfont.log. 
 


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___