Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-03 Thread Pablo Rodriguez
On 08/03/2017 08:50 AM, Hans Hagen wrote:
> On 8/3/2017 7:49 AM, Pablo Rodriguez wrote:
>> Hans,
>>
>> since it seems you don’t reproduce the bug, I wonder whether this might
>> be caused by Linux 32bit luatex binaries being version 1.0.5 and Windows
>> 64bt has version 1.0.6.x.
> no, it's more that i always have a newer luatex so older stuff has to be 
> simulated

Many thanks for the explanation and for the fix, Hans.

Beta from 2017.08.03 11:02 works perfectly fine with the two texts I
checked.

Many thanks for your help,

Pablo
-- 
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-03 Thread Hans Hagen

On 8/3/2017 7:49 AM, Pablo Rodriguez wrote:

On 08/03/2017 07:13 AM, Pablo Rodriguez wrote:

On 08/02/2017 11:08 PM, Hans Hagen wrote:

ok i uploaded a new beta (but with some experimental font stuff so who
knows what happens now)


I’m afraid I get a new crash with the same source (the log contains it):
[...]
lua error   > lua error on line 1 in file tex-bug.tex:

...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: You
cannot set field glue_sign in a node of type glue_spec
stack traceback:
[C]: in function 'setfield'
...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: in
function 'setboxglue'
...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>

1 >>  \setupnote[footnote]
2 [align={hanging}]


Hans,

since it seems you don’t reproduce the bug, I wonder whether this might
be caused by Linux 32bit luatex binaries being version 1.0.5 and Windows
64bt has version 1.0.6.x.
no, it's more that i always have a newer luatex so older stuff has to be 
simulated


Hans

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-02 Thread Pablo Rodriguez
On 08/03/2017 07:13 AM, Pablo Rodriguez wrote:
> On 08/02/2017 11:08 PM, Hans Hagen wrote:
>> ok i uploaded a new beta (but with some experimental font stuff so who 
>> knows what happens now)
> 
> I’m afraid I get a new crash with the same source (the log contains it):
> [...]
> lua error   > lua error on line 1 in file tex-bug.tex:
> 
> ...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: You
> cannot set field glue_sign in a node of type glue_spec
> stack traceback:
>   [C]: in function 'setfield'
>   ...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: in
> function 'setboxglue'
>   ...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
> function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>
> 
> 1 >>  \setupnote[footnote]
> 2 [align={hanging}]

Hans,

since it seems you don’t reproduce the bug, I wonder whether this might
be caused by Linux 32bit luatex binaries being version 1.0.5 and Windows
64bt has version 1.0.6.x.

Just in case it helps,

Pablo
-- 
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-02 Thread Pablo Rodriguez
On 08/02/2017 11:08 PM, Hans Hagen wrote:
> ok i uploaded a new beta (but with some experimental font stuff so who 
> knows what happens now)

Hans,

I’m afraid I get a new crash with the same source (the log contains it):

open source > level 1, order 1, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/base/mkiv/cont-yes.mkiv'
system  >
system  > ConTeXt  ver: 2017.08.02 23:00 MKIV beta  fmt:
2017.8.3  int: english/english
system  >
system  > 'cont-new.mkiv' loaded
open source > level 2, order 2, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/base/mkiv/cont-new.mkiv'
close source> level 2, order 2, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/base/mkiv/cont-new.mkiv'
system  > files > jobname 'tex-bug', input './tex-bug.xml',
result 'tex-bug'
fonts   > latin modern fonts are not preloaded
languages   > language 'en' is active
open source > level 2, order 3, name 'tex-bug.tex'
fonts   > beware: no fonts are loaded yet, using 'lm mono' in box
fonts   > preloading latin modern fonts (second stage)
fonts   > 'fallback modern-designsize rm 12pt' is loaded
open source > level 3, order 4, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/sample/common/knuth.tex'
close source> level 3, order 4, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/sample/common/knuth.tex'

lua error   > lua error on line 1 in file tex-bug.tex:

...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: You
cannot set field glue_sign in a node of type glue_spec
stack traceback:
[C]: in function 'setfield'
...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: in
function 'setboxglue'
...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>

1 >>  \setupnote[footnote]
2 [align={hanging}]
3
4 \starttext
5 a\footnote{\input knuth}
6 \stoptext
7


?

lua error   > lua error on line 1 in file tex-bug.tex:

...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: You
cannot set field glue_sign in a node of type glue_spec
stack traceback:
[C]: in function 'setfield'
...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:965: in
function 'setboxglue'
...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>

1 >>  \setupnote[footnote]
2 [align={hanging}]
3
4 \starttext
5 a\footnote{\input knuth}
6 \stoptext
7

End of file on the terminal!

Many thanks for your help
-- 
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-02 Thread Hans Hagen

On 8/2/2017 10:53 PM, Pablo Rodriguez wrote:


lua error   > lua error on line 1 in file /home/ousia/tex-bug.tex:

...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:962: attempt
to call global 'setfield' (a nil value)
stack traceback:
...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:962: in
function 'setboxglue'
...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>

1 >>  \setupnote[footnote]
2 [align={hanging}]
3
4 \starttext
5 a\footnote{\input knuth}
6 \stoptext
7

End of file on the terminal!

Many thanks for your help,
ok i uploaded a new beta (but with some experimental font stuff so who 
knows what happens now)


Hans

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-02 Thread Pablo Rodriguez
On 08/02/2017 10:43 PM, Hans Hagen wrote:
> On 8/2/2017 9:58 PM, Pablo Rodriguez wrote:
>> Hans,
>>
>> I’m afraid latest beta (2017.08.02 18:59) crashes with this source:
>> [...]
> crashes with what message?
Hans,

here you have the log contents:

open source > level 1, order 1, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/base/mkiv/cont-yes.mkiv'
system  >
system  > ConTeXt  ver: 2017.08.02 18:59 MKIV beta  fmt:
2017.8.2  int: english/english
system  >
system  > 'cont-new.mkiv' loaded
open source > level 2, order 2, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/base/mkiv/cont-new.mkiv'
close source> level 2, order 2, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/base/mkiv/cont-new.mkiv'
system  > files > jobname 'tex-bug', input './tex-bug', result
'tex-bug'
fonts   > latin modern fonts are not preloaded
languages   > language 'en' is active
open source > level 2, order 3, name '/home/ousia/tex-bug.tex'
fonts   > beware: no fonts are loaded yet, using 'lm mono' in box
fonts   > preloading latin modern fonts (second stage)
fonts   > 'fallback modern-designsize rm 12pt' is loaded
open source > level 3, order 4, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/sample/common/knuth.tex'
close source> level 3, order 4, name
'/home/ousia/ctxbeta/tex/texmf-context/tex/context/sample/common/knuth.tex'

lua error   > lua error on line 1 in file /home/ousia/tex-bug.tex:

...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:962: attempt
to call global 'setfield' (a nil value)
stack traceback:
...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:962: in
function 'setboxglue'
...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>

1 >>  \setupnote[footnote]
2 [align={hanging}]
3
4 \starttext
5 a\footnote{\input knuth}
6 \stoptext
7


?

lua error   > lua error on line 1 in file /home/ousia/tex-bug.tex:

...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:962: attempt
to call global 'setfield' (a nil value)
stack traceback:
...eta/tex/texmf-context/tex/context/base/mkiv/node-nut.lua:962: in
function 'setboxglue'
...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:131: in
function <...eta/tex/texmf-context/tex/context/base/mkiv/pack-rul.lua:64>

1 >>  \setupnote[footnote]
2 [align={hanging}]
3
4 \starttext
5 a\footnote{\input knuth}
6 \stoptext
7

End of file on the terminal!

Many thanks for your help,

Pablo
-- 
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-02 Thread Hans Hagen

On 8/2/2017 9:58 PM, Pablo Rodriguez wrote:

Hans,

I’m afraid latest beta (2017.08.02 18:59) crashes with this source:

 \setupnote[footnote]
 [align={hanging}]

 \starttext
 a\footnote{\input knuth}
 \stoptext

I’m afraid it might be a bug.

crashes with what message?


-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

[NTG-context] bug in latest beta (2017.08.02 18:59)

2017-08-02 Thread Pablo Rodriguez
Hans,

I’m afraid latest beta (2017.08.02 18:59) crashes with this source:

\setupnote[footnote]
[align={hanging}]

\starttext
a\footnote{\input knuth}
\stoptext

I’m afraid it might be a bug.

Pablo
-- 
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___