Re: [NTG-context] issue with font loading

2016-03-03 Thread Wolfgang Schuster
Pablo Rodriguez 2. März 2016 um 23:18 Many thanks for your reply, Wolfgang. I wanted to avoid the installation of the font, because I had another version of GaramondNo8 already installed. So, I renamed the font and installed it. Everything works fine now. This is

Re: [NTG-context] issue with font loading

2016-03-03 Thread Wolfgang Schuster
Pablo Rodriguez 2. März 2016 um 16:56 Even if the font is on the same directory as the ConTeXt source file? I invoke it by its file name. Sorry, this was outside the ConTeXt tree. And I didn’t know that it has to be indexed by ConTeXt. Loading font by filename whoch are

Re: [NTG-context] issue with font loading

2016-03-03 Thread Hans Hagen
On 3/2/2016 7:25 PM, Thomas A. Schmitz wrote: On 03/02/2016 07:12 PM, Wolfgang Schuster wrote: Don’t write just some garbage as third argument for the \definefontfamily or \definefallbackfamily commands. In the attached picture you can see the fonforge information for the font names, needed

Re: [NTG-context] issue with font loading

2016-03-02 Thread Pablo Rodriguez
On 03/02/2016 07:12 PM, Wolfgang Schuster wrote: >> Pablo Rodriguez 2. März 2016 um 17:17 >> [...] >> If another "key=value" pair is specified, "tf=file:newg8-regular" >> doesn’t seem to work. >> >> What am I doing wrong? > > Don’t write just some garbage as third argument for the >

Re: [NTG-context] issue with font loading

2016-03-02 Thread Thomas A. Schmitz
On 03/02/2016 07:12 PM, Wolfgang Schuster wrote: Don’t write just some garbage as third argument for the \definefontfamily or \definefallbackfamily commands. In the attached picture you can see the fonforge information for the font names, needed for the \definefontfamily command is the "family

Re: [NTG-context] issue with font loading

2016-03-02 Thread Wolfgang Schuster
Pablo Rodriguez 2. März 2016 um 17:17 Wolfgang, I’m afraid that even with that, I’m afraid it doesn’t work well: \definefallbackfamily[mainface][rm][Latin Modern Math] [tf=file:newg8-regular, scale=0.88, range=0x22C0] \definefallbackfamily[mainface][rm][Latin Greek Math]

Re: [NTG-context] issue with font loading

2016-03-02 Thread Pablo Rodriguez
On 03/02/2016 04:56 PM, Pablo Rodriguez wrote: > On 03/02/2016 03:59 PM, Wolfgang Schuster wrote: >> >> The \definefontfamily can only use font which are indexed by context >> (mtxrun --script font --reload) which doesn’t seem to be the case here. Wolfgang, I’m afraid that even with that, I’m

Re: [NTG-context] issue with font loading

2016-03-02 Thread Pablo Rodriguez
On 03/02/2016 03:59 PM, Wolfgang Schuster wrote: > > The \definefontfamily can only use font which are indexed by context > (mtxrun --script font --reload) which doesn’t seem to be the case here. Even if the font is on the same directory as the ConTeXt source file? I invoke it by its file name.

Re: [NTG-context] issue with font loading

2016-03-02 Thread Wolfgang Schuster
Pablo Rodriguez 2. März 2016 um 15:43 Wolfgang, I’m afraid it doesn’t work. Just in case it helps, directly generated from http://github.com/rbrito/urw-garamond/, you have the font itsef at http://ousia.tk/newg8-regular.otf. Many thanks for your help, Pablo Wolfgang

Re: [NTG-context] issue with font loading

2016-03-02 Thread Pablo Rodriguez
On 03/02/2016 02:54 PM, Wolfgang Schuster wrote: >> Pablo Rodriguez 2. März 2016 um 12:11 >> [...] >> \definefontfamily[mainface][rm][Latin Modern Roman] >> \definefontfamily[mainface][ss][GaraMath][file={newg8-regular.otf}] > > Does this work? > >

Re: [NTG-context] issue with font loading

2016-03-02 Thread Wolfgang Schuster
Pablo Rodriguez 2. März 2016 um 12:11 Dear list, I have the following sample: \definefontfamily[mainface][rm][Latin Modern Roman] \definefontfamily[mainface][ss][GaraMath][file={newg8-regular.otf}] Does this work?

Re: [NTG-context] issue with font loading

2016-03-02 Thread Hans Hagen
On 3/2/2016 1:07 PM, Pablo Rodriguez wrote: On 03/02/2016 12:28 PM, Hans Hagen wrote: On 3/2/2016 12:11 PM, Pablo Rodriguez wrote: [...] I don’t get a sans typeface different from Latin Modern Roman. If the font is on the same directory as the ConTeXt source file, what is wrong in my code?

Re: [NTG-context] issue with font loading

2016-03-02 Thread Pablo Rodriguez
On 03/02/2016 12:28 PM, Hans Hagen wrote: > On 3/2/2016 12:11 PM, Pablo Rodriguez wrote: >> [...] >> I don’t get a sans typeface different from Latin Modern Roman. >> >> If the font is on the same directory as the ConTeXt source file, what is >> wrong in my code? > > doesn't the log tell you

Re: [NTG-context] issue with font loading

2016-03-02 Thread Hans Hagen
On 3/2/2016 12:11 PM, Pablo Rodriguez wrote: Dear list, I have the following sample: \definefontfamily[mainface][rm][Latin Modern Roman] \definefontfamily[mainface][ss][GaraMath][file={newg8-regular.otf}] \setupbodyfont[mainface] \starttext a{\ss a}b{\ss b}c{\ss

[NTG-context] issue with font loading

2016-03-02 Thread Pablo Rodriguez
Dear list, I have the following sample: \definefontfamily[mainface][rm][Latin Modern Roman] \definefontfamily[mainface][ss][GaraMath][file={newg8-regular.otf}] \setupbodyfont[mainface] \starttext a{\ss a}b{\ss b}c{\ss c}g{\ss g} \stoptext I don’t get a sans typeface