Re: [NTG-context] mkiv MathML bug?

2019-06-27 Thread Duncan Hothersall
On Thu, 27 Jun 2019, 20:46 Hans Hagen,  wrote:

> On 6/27/2019 6:35 PM, Duncan Hothersall wrote:
> > I'm not sure this is something more general in the MathML module or if
> > it's specific to the vertical bar in this particular context, but here
> > is a minimal example showing that the "=0" at the end of the equation is
> > disappearing:
>
> there is indeed some issue, i'll look into it
>

Thanks Hans.

>
>
> you can also try
>
>  
>B
>C
>

I did try that, it didn't seem to work quite as expected either.

Thanks again.

Duncan

>
>
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] mkiv MathML bug?

2019-06-27 Thread Hans Hagen

On 6/27/2019 6:35 PM, Duncan Hothersall wrote:
I'm not sure this is something more general in the MathML module or if 
it's specific to the vertical bar in this particular context, but here 
is a minimal example showing that the "=0" at the end of the equation is 
disappearing:


there is indeed some issue, i'll look into it


\usemodule[mathml]
\starttext
\xmlprocessdata{}{
         
           A
           
             B
             |
             C
           
           =
           0
         
       }{}
\stoptext


you can also try


  B
  C



And here is a workaround using  instead of  for the vertical 
bar which makes the "=0" magically reappear again:


\usemodule[mathml]
\starttext
\xmlprocessdata{}{
         
           A
           
             B
             |
             C
           
           =
           0
         
       }{}
\stoptext

Flagged up mainly in case it is a bigger problem than just vertical bars 
in this specific context.


Thanks,

Duncan


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___




--

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


[NTG-context] mkiv MathML bug?

2019-06-27 Thread Duncan Hothersall
I'm not sure this is something more general in the MathML module or if it's
specific to the vertical bar in this particular context, but here is a
minimal example showing that the "=0" at the end of the equation is
disappearing:

\usemodule[mathml]
\starttext
\xmlprocessdata{}{

  A
  
B
|
C
  
  =
  0

  }{}
\stoptext

And here is a workaround using  instead of  for the vertical bar
which makes the "=0" magically reappear again:

\usemodule[mathml]
\starttext
\xmlprocessdata{}{

  A
  
B
|
C
  
  =
  0

  }{}
\stoptext

Flagged up mainly in case it is a bigger problem than just vertical bars in
this specific context.

Thanks,

Duncan
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___