Re: [NTG-context] parsing issue with \math{} inside natural table

2010-07-12 Thread Hans Hagen

On 9-7-2010 10:12, Brian R. Landy wrote:

Hi, I ran into a case where a natural table has an issue when it
contains inline math and an alignment character is used. Here's a small
example which triggers the problem:

\starttext
\bTABLE
\bTABLEbody
\bTR
\bTD[alignmentcharacter={.},aligncharacter=yes]{\le 4.0\math{-}}\eTD
\eTR
\eTABLEbody
\eTABLE
\stoptext

However, if I replace \math{-} with $-$, the file works. Am I correct
that $-$ and \math{-} should be interchangeable?


side effect of alignmentcharacter that triggers expansion of cell 
content, so just use $ here


-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] parsing issue with \math{} inside natural table

2010-07-12 Thread Brian R. Landy
Thanks for the reply.  I'm actually generating TeX from an application 
that interprets $ in it's own code and occasionally this causes me 
trouble in passing the $ through to TeX to use in math mode (I think 
they have a bug and am hoping I can get that fixed).  So I tend to use 
\math{}  to avoid complications with escaping $, but was stuck in this 
case because I couldn't use $ or \math{}.


Anyway, I just now solved my problem in the other application and am 
able pass through $ appropriately so it's no longer an issue for me.


Thanks,
Brian

On Mon, 12 Jul 2010, Hans Hagen wrote:


On 9-7-2010 10:12, Brian R. Landy wrote:

Hi, I ran into a case where a natural table has an issue when it
contains inline math and an alignment character is used. Here's a 
small

example which triggers the problem:

\starttext
\bTABLE
\bTABLEbody
\bTR
\bTD[alignmentcharacter={.},aligncharacter=yes]{\le 4.0\math{-}}\eTD
\eTR
\eTABLEbody
\eTABLE
\stoptext

However, if I replace \math{-} with $-$, the file works. Am I correct
that $-$ and \math{-} should be interchangeable?


side effect of alignmentcharacter that triggers expansion of cell 
content, so just use $ here


-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
| www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry 
to the Wiki!


maillist : ntg-context@ntg.nl / 
http://www.ntg.nl/mailman/listinfo/ntg-context

webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___



___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] parsing issue with \math{} inside natural table

2010-07-12 Thread Aditya Mahajan

On Mon, 12 Jul 2010, Brian R. Landy wrote:

Thanks for the reply.  I'm actually generating TeX from an application that 
interprets $ in it's own code and occasionally this causes me trouble in 
passing the $ through to TeX to use in math mode (I think they have a bug and 
am hoping I can get that fixed).  So I tend to use \math{}  to avoid 
complications with escaping $, but was stuck in this case because I couldn't 
use $ or \math{}.


With expansion problems, sometimes using \noexpand\math{...} works.

Aditya
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] parsing issue with \math{} inside natural table

2010-07-09 Thread Brian R. Landy
Hi, I ran into a case where a natural table has an issue when it 
contains inline math and an alignment character is used.  Here's a small 
example which triggers the problem:


\starttext
\bTABLE
\bTABLEbody
\bTR
\bTD[alignmentcharacter={.},aligncharacter=yes]{\le 4.0\math{-}}\eTD
\eTR
\eTABLEbody
\eTABLE
\stoptext

However, if I replace \math{-} with $-$, the file works.  Am I correct 
that $-$ and \math{-} should be interchangeable?


Thanks,
Brian
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___