Re: [NTG-context] placefigure right or left error in ver: 2018.04.04 00:51 MKIV

2019-09-27 Thread Pablo Rodriguez
On 9/27/19 2:33 PM, Philippe Oechslin wrote: > Hello there, > > I recently upgraded to ConTeXt ver: 2018.04.04 00:51 MKIV and found that > the following simple code gives an error, where as it compiled without > complaining in ver: 2017.05.15 21:48. > [...] > I am running a freshly installed

[NTG-context] placefigure right or left error in ver: 2018.04.04 00:51 MKIV

2019-09-27 Thread Philippe Oechslin
Hello there, I recently upgraded to ConTeXt ver: 2018.04.04 00:51 MKIV and found that the following simple code gives an error, where as it compiled without complaining in ver: 2017.05.15 21:48. \setupexternalfigures[location={local,default}] \starttext \input ward

Re: [NTG-context] placefigure and listoffigures

2016-03-15 Thread Alan BRASLAU
On Tue, 15 Mar 2016 23:01:46 +0100 Wolfgang Schuster wrote: > \startplacefigure [location={inmargin,none}] Thank you, clean and elegant (and much easier than Willi's suggestion). The syntax is a bit magical, though ("location" of the caption). Alan

Re: [NTG-context] placefigure and listoffigures

2016-03-15 Thread Wolfgang Schuster
Alan BRASLAU 15. März 2016 um 21:43 Hi, How can one suppress the addition of a placed figure to the listoffigures? In the following MWE, list=no places "no" as an alternative to the (blank) title. Alan \starttext \startplacefigure

Re: [NTG-context] placefigure and listoffigures

2016-03-15 Thread Willi Egger
I would define another float and assign this not to be listed float to this new float-type something like \definefloat[Notlisted][figure] and then \startplaceNotlisted \externalf… \stopplaceNotlisted Best wishes Willi > On 15 mrt. 2016, at 21:43, Alan BRASLAU

[NTG-context] placefigure and listoffigures

2016-03-15 Thread Alan BRASLAU
Hi, How can one suppress the addition of a placed figure to the listoffigures? In the following MWE, list=no places "no" as an alternative to the (blank) title. Alan \starttext \startplacefigure [location=inmargin,number=no,list=no] \externalfigure [cow] [width=1cm] \stopplacefigure \input

[NTG-context] \placefigure[right,high] in two column mode

2015-06-11 Thread Mojca Miklavec
Hello, Is it possible to place a figure to the right in two column mode? I always get it centered for some reason. \setupexternalfigures[location={local,global,default}] \starttext \startcolumns[two] % doesn't work \startplacefigure[location={nonumber,right,high}]

[NTG-context] \placefigure and title bug in latest beta

2014-04-06 Thread Alan Bowen
Hans-- In today's beta, the following produces a figure entitled Figure 1 title: \setupexternalfigures[location={local,default}] \starttext \useexternalfigure[cow.pdf] \startplacefigure[title={A cow}] {\externalfigure[Graphic][cow.pdf]} \stopplacefigure \stoptext Alan

Re: [NTG-context] \placefigure and title bug in latest beta

2014-04-06 Thread Otared Kavian
Hi, I can confirm this… This is probably due to the new features Hans added today. Also, the new feature \placelist[figure][criterium=text] places indeed the list of the figures, but the names of the figures, or rather their captions are all indicated by the word « list ». Best

[NTG-context] \placefigure[right or left] failing in footnotes

2014-03-03 Thread Alan Bowen
The following does not work as it should: setupexternalfigures[location={local,default}] \starttext text% \footnote{\hangsidefloat[2] \placefigure[right,none]{} {\externalfigure[cow][width=.1\textwidth]} \dorecurse{3}{\input ward}} %for comparison \hangsidefloat[2] \placefigure[right,none]{}

Re: [NTG-context] \placefigure[right or left] failing in footnotes

2014-03-03 Thread Wolfgang Schuster
Am 03.03.2014 um 16:04 schrieb Alan Bowen bowenala...@gmail.com: The following does not work as it should: setupexternalfigures[location={local,default}] \starttext text% \footnote{\hangsidefloat[2] \placefigure[right,none]{} {\externalfigure[cow][width=.1\textwidth]}

Re: [NTG-context] \placefigure[right or left] failing in footnotes

2014-03-03 Thread Alan Bowen
Again, thanks. My tests so far indicate that the only way to go in footnotes is with \starthanging[location-right]...\stophanging--and to be happy with the output as it is (which is quite nice, when all is said and done). Alan On Mon, Mar 3, 2014 at 11:24 AM, Wolfgang Schuster

Re: [NTG-context] Placefigure without Caption-Numbering

2013-12-01 Thread Alan Braslau
On Sat, 30 Nov 2013 21:06:20 +0100 Jan Tosovsky j.tosov...@email.cz wrote: Indeed much cleaner. But that numbering option seems to be ignored ;-) Does it work for you? Sorry, it is number=no. Alan ___ If your

Re: [NTG-context] Placefigure without Caption-Numbering

2013-11-30 Thread Jan Tosovsky
On 2013-04-16 Wolfgang Schuster wrote: Am 16.04.2013 um 18:56 schrieb H. Özoguz h.oezoguz at mmnetz.de: How to deactive the Caption-Numbering: \starttext \placefigure[here]{Blub}{\externalfigure[image][width=6cm]} \stoptext I want the caption Blub, but not the Figure 1

Re: [NTG-context] Placefigure without Caption-Numbering

2013-11-30 Thread Alan Braslau
On Sat, 30 Nov 2013 19:42:54 +0100 Jan Tosovsky j.tosov...@email.cz wrote: On 2013-04-16 Wolfgang Schuster wrote: Am 16.04.2013 um 18:56 schrieb H. Özoguz h.oezoguz at mmnetz.de: How to deactive the Caption-Numbering: \starttext

Re: [NTG-context] Placefigure without Caption-Numbering

2013-11-30 Thread Jan Tosovsky
On 2013-11-30 Alan Braslau wrote: On Sat, 30 Nov 2013 19:42:54 +0100 Jan Tosovsky j.tosov...@email.cz wrote: On 2013-04-16 Wolfgang Schuster wrote: Am 16.04.2013 um 18:56 schrieb H. Özoguz How to deactive the Caption-Numbering: \starttext

[NTG-context] placefigure problem

2013-08-20 Thread Wim W. Wilhelm
Dear all, I encountered a problem with TexLive 2013 context. The problem persisted with the context beta. With LuaTex version beta-0.77.0-2013081719 (rev 4640) and ConTeXt ver: 2013.08.18 18:32 MKIV beta fmt: 2013.8.20 int: english/english I compiled: \starttext \chapter{c-titel}

Re: [NTG-context] placefigure problem

2013-08-20 Thread Hans Hagen
On 8/20/2013 12:08 PM, Wim W. Wilhelm wrote: Dear all, I encountered a problem with TexLive 2013 context. The problem persisted with the context beta. With LuaTex version beta-0.77.0-2013081719 (rev 4640) and ConTeXt ver: 2013.08.18 18:32 MKIV beta fmt: 2013.8.20 int: english/english I

[NTG-context] Placefigure inner/outer

2013-08-04 Thread Tim Steenvoorden
Hi all! This worked in MkII but doesn't in MkIV. Did something changed? Cheers, Tim \starttext \input knuth \placefigure[left]{}{\externalfigure[figurename]} \input knuth \placefigure[inner]{}{\externalfigure[figurename]} \input knuth \stoptext

Re: [NTG-context] Placefigure inner/outer

2013-08-04 Thread Marco Patzer
On 2013–08–04 Tim Steenvoorden wrote: \starttext \input knuth \placefigure[left]{}{\externalfigure[figurename]} \input knuth \placefigure[inner]{}{\externalfigure[figurename]} What do you want to do? Place it in the margin? \placefigure[inleft]{}{\externalfigure[figurename]} Marco

Re: [NTG-context] Placefigure inner/outer

2013-08-04 Thread Tim Steenvoorden
No. I want to place the figure to the left of the text if it is on a odd page and to the right of the text if it is on a even page. Thus the same effect left and right have as keywords, but depending on the page it is on. Cheers, Tim 2013/8/4 Marco Patzer home...@lavabit.com: On 2013–08–04 Tim

Re: [NTG-context] Placefigure inner/outer

2013-08-04 Thread Wolfgang Schuster
Am 04.08.2013 um 22:40 schrieb Marco Patzer home...@lavabit.com: On 2013–08–04 Tim Steenvoorden wrote: \starttext \input knuth \placefigure[left]{}{\externalfigure[figurename]} \input knuth \placefigure[inner]{}{\externalfigure[figurename]} What do you want to do? Place it in the

Re: [NTG-context] Placefigure inner/outer

2013-08-04 Thread Tim Steenvoorden
Pitty. I used it a lot in a project I'm porting to MkIV. Will it be fixed someday? 2013/8/4 Wolfgang Schuster schuster.wolfg...@gmail.com: Am 04.08.2013 um 22:40 schrieb Marco Patzer home...@lavabit.com: On 2013–08–04 Tim Steenvoorden wrote: \starttext \input knuth

Re: [NTG-context] Placefigure inner/outer

2013-08-04 Thread Wolfgang Schuster
Am 04.08.2013 um 22:53 schrieb Tim Steenvoorden tim.steenvoor...@gmail.com: Pitty. I used it a lot in a project I'm porting to MkIV. Will it be fixed someday? It depends on Hans, I’ll send him a mail about the problem. Wolfgang

Re: [NTG-context] Placefigure inner/outer

2013-08-04 Thread Tim Steenvoorden
Thanks Wolfgang! 2013/8/4 Wolfgang Schuster schuster.wolfg...@gmail.com: Am 04.08.2013 um 22:53 schrieb Tim Steenvoorden tim.steenvoor...@gmail.com: Pitty. I used it a lot in a project I'm porting to MkIV. Will it be fixed someday? It depends on Hans, I’ll send him a mail about the

[NTG-context] Placefigure without Caption-Numbering

2013-04-16 Thread H. Özoguz
How to deactive the Caption-Numbering: \starttext \placefigure[here]{Blub}{\externalfigure[image][width=6cm]} \stoptext I want the caption Blub, but not the Figure 1 label. Thanks! Huseyin ___ If your question

Re: [NTG-context] Placefigure without Caption-Numbering

2013-04-16 Thread Wolfgang Schuster
Am 16.04.2013 um 18:56 schrieb H. Özoguz h.oezo...@mmnetz.de: How to deactive the Caption-Numbering: \starttext \placefigure[here]{Blub}{\externalfigure[image][width=6cm]} \stoptext I want the caption Blub, but not the Figure 1 label. \placefigure[here,nonumber]{…}{…} Wolfgang

[NTG-context] placefigure

2013-03-21 Thread Hans Hagen
Hi, while fixing some buglets that showed up in the test suite I ran into: \starttext test \placefigure[somewhere:alpha][whatever]{alpha}{} test \placefigure[somewhere:beta] [whatever]{beta}{} test \placefigure[somewhere:gamma][whatever]{gamma}{} test

Re: [NTG-context] placefigure

2013-03-21 Thread Sietse Brouwer
On 21 March 2013 17:26, Hans Hagen pra...@wxs.nl wrote: while fixing some buglets that showed up in the test suite I ran into \placenamedfloat maybe worth wikifying (bug will be solved in beta) Wikified: http://wiki.contextgarden.net/Command/placenamedfloat Below is what I wrote; is that

Re: [NTG-context] placefigure

2013-03-21 Thread Hans Hagen
On 3/21/2013 11:04 PM, Sietse Brouwer wrote: On 21 March 2013 17:26, Hans Hagen pra...@wxs.nl wrote: while fixing some buglets that showed up in the test suite I ran into \placenamedfloat maybe worth wikifying (bug will be solved in beta) Wikified:

[NTG-context] Placefigure without numbering

2013-02-01 Thread H. Özoguz
Hi there, how to deactivate numbering for the following (empty) picture? \placefigure[here][fig:demo]{My description under the picture.}{} Thanks, Huseyin P.S.: I know that for multi-line code my email-client seems to format the code with many spaces, how to control that, I am using Mozilla

Re: [NTG-context] Placefigure without numbering

2013-02-01 Thread Marco Patzer
On 2013–02–01 H. Özoguz wrote: how to deactivate numbering for the following (empty) picture? \placefigure[here][fig:demo]{My description under the picture.}{} \startplacefigure [title=My description, reference=fig:demo, number=no] … \stopplacefigure Marco signature.asc Description:

Re: [NTG-context] Placefigure without numbering

2013-02-01 Thread H. Özoguz
Am 01.02.2013 21:58, schrieb ntg-context-requ...@ntg.nl: \startplacefigure [title=My description, reference=fig:demo, number=no] ? \stopplacefigure Thanks Marco, and how to align the title at the center under the picture? (Now it is flushright) Thanks Huseyin

Re: [NTG-context] Placefigure without numbering

2013-02-01 Thread H. Özoguz
Am 01.02.2013 21:58, schrieb ntg-context-requ...@ntg.nl: \startplacefigure [title=My description, reference=fig:demo, number=no] ? \stopplacefigure Thanks Marco, and how to align the title at the center under the picture? (Now it is flushright) Thanks Huseyin

Re: [NTG-context] Placefigure without numbering

2013-02-01 Thread Alan BRASLAU
On Fri, 1 Feb 2013 22:42:10 +0100 H. Özoguz h.oezo...@mmnetz.de wrote: Am 01.02.2013 21:58, schrieb ntg-context-requ...@ntg.nl: \startplacefigure [title=My description, reference=fig:demo, number=no] ? \stopplacefigure Thanks Marco, and how to align the title at the center under the

[NTG-context] \placefigure[margin] but in left margin?

2013-01-03 Thread Mikael P. Sundqvist
Dear list, I want to have the effect I get with \placefigure[margin] but I want it _always_ in the left margin instead of the right margin where it ends up by default. I have tried several other keys but with leftmargin, inleft the figure is not put in the top of the page, independent of the

Re: [NTG-context] \placefigure[margin] but in left margin?

2013-01-03 Thread Wolfgang Schuster
Am 03.01.2013 um 13:48 schrieb Mikael P. Sundqvist mic...@gmail.com: Dear list, I want to have the effect I get with \placefigure[margin] but I want it _always_ in the left margin instead of the right margin where it ends up by default. I have tried several other keys but with

Re: [NTG-context] \placefigure[margin] but in left margin?

2013-01-03 Thread Mikael P. Sundqvist
On Thu, Jan 3, 2013 at 3:58 PM, Wolfgang Schuster wolfgang.schus...@gmail.com wrote: Am 03.01.2013 um 13:48 schrieb Mikael P. Sundqvist mic...@gmail.com: Dear list, I want to have the effect I get with \placefigure[margin] but I want it _always_ in the left margin instead of the right

Re: [NTG-context] \placefigure[margin] but in left margin?

2013-01-03 Thread Wolfgang Schuster
Am 03.01.2013 um 17:13 schrieb Mikael P. Sundqvist mic...@gmail.com: On Thu, Jan 3, 2013 at 3:58 PM, Wolfgang Schuster wolfgang.schus...@gmail.com wrote: Am 03.01.2013 um 13:48 schrieb Mikael P. Sundqvist mic...@gmail.com: Dear list, I want to have the effect I get with

Re: [NTG-context] \placefigure[margin] but in left margin?

2013-01-03 Thread Mikael P. Sundqvist
On Thu, Jan 3, 2013 at 5:16 PM, Wolfgang Schuster wolfgang.schus...@gmail.com wrote: Am 03.01.2013 um 17:13 schrieb Mikael P. Sundqvist mic...@gmail.com: On Thu, Jan 3, 2013 at 3:58 PM, Wolfgang Schuster wolfgang.schus...@gmail.com wrote: Am 03.01.2013 um 13:48 schrieb Mikael P.

Re: [NTG-context] placefigure adds break

2012-04-12 Thread Alan BRASLAU
Hello, A follow-up on the solution \startpostponing [+0] \startplacefigure … \stopplacefigure \stoppostponing As a side effect, one then needs to be careful to surround ALL placefigures with \startpostponing[+0]\stoppostponing, even those that occur after a paragraph end (where one is not

[NTG-context] placefigure vs grid problem

2012-03-20 Thread Honza Hejzl
Hello, I have found that placing figures in grid mode does problems with [left,right...] parameters. The figure brokes the text flow. (It suffice to turn grid=yes.) Any solution, please? Thanks, Honza \enableregime[utf] \mainlanguage[cz] \setuppapersize[A5][A5] \setuplayout[ *grid=yes* ]

Re: [NTG-context] \placefigure padding

2012-03-11 Thread Wolfgang Schuster
Am 11.03.2012 um 04:12 schrieb Kip Warner: Hey list, The following minimal typesets a dummy figure. Note how there is about two lines of empty space below the figure. How do I control the amount of padding that surrounds the figure, such as the bottom? With \setupfloats [spacebefore=…,

Re: [NTG-context] \placefigure padding

2012-03-11 Thread Kip Warner
On Sun, 2012-03-11 at 10:01 +0100, Wolfgang Schuster wrote: \setupfloats [spacebefore=, spaceafter=] you can control the space before and after the float, accepted are all values for \blank (dimensions and keywords). That's probably the command I need, but I can't find any useful

[NTG-context] \placefigure padding

2012-03-10 Thread Kip Warner
Hey list, The following minimal typesets a dummy figure. Note how there is about two lines of empty space below the figure. How do I control the amount of padding that surrounds the figure, such as the bottom? \setupexternalfigures [frame=off, corner=rectangular, rulethickness=0.5pt]

[NTG-context] placefigure shifting up?

2012-01-11 Thread Meer, H. van der
In my document I have a number of \placefigures, some pdf's, some jpg's etc. Mostly the figure are placed correct with respect to, the caption but sometimes for no apparent reason I can spot, the picture is shifted up. In the first illustration taken from the document this is clearly seen,

Re: [NTG-context] placefigure shifting up?

2012-01-11 Thread Hans Hagen
On 11-1-2012 20:01, Meer, H. van der wrote: In my document I have a number of \placefigures, some pdf's, some jpg's etc.. Mostly the figure are placed correct with respect to, the caption but sometimes for no apparent reason I can spot, the picture is shifted up. In the first illustration

Re: [NTG-context] placefigure shifting up?

2012-01-11 Thread Hans van der Meer
I might add to this report the following observation: In a document with \setuppapersize [S8][S8] the shifts appear now and then, whereas these are typeset normally when the document is place on \setuppapersize [A4][A4]. It seems that the papersize and placefigure sometimes have a problem

Re: [NTG-context] placefigure shifting up?

2012-01-11 Thread Meer, H. van der
I think I can nail the responsible one. As far as I can see the problem is tightly coupled with the following structure: \placefigure[][]{caption}{\startcombination[]{contents}{}{contents}{}\stopcombination} The other figures I have seem to placed well enough, the above structures behaving

Re: [NTG-context] \placefigure and \em (again)

2011-02-25 Thread Henning Hraban Ramm
Am 2011-02-25 um 08:56 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: --- \starttext \placefigure [left,none] {} { \startMPcode draw (0,0)--(6cm,6cm); \stopMPcode } This is a normal text -- it flows around the picture on the left side of the page as expected.

Re: [NTG-context] \placefigure and \em (again)

2011-02-25 Thread Wolfgang Schuster
Am 25.02.2011 um 08:56 schrieb Procházka Lukáš Ing. - Pontex s. r. o.: Hello, sorry for repeating this topic, maybe it's not too attractive. Please, have a look to the following problem. I wonder why the behaviour described bellow occurs and how to typeset a paragraph starting with

Re: [NTG-context] \placefigure and \em (again)

2011-02-25 Thread Wolfgang Schuster
Am 25.02.2011 um 09:16 schrieb Henning Hraban Ramm: You can add a \strut in front of {\em - that’s a usual workaround for problems with non-letters starting a paragraph. The usual workaround is \dontleavehmode. Wolfgang

Re: [NTG-context] \placefigure and \em (again)

2011-02-25 Thread Procházka Lukáš Ing . - Pontex s . r . o .
... Thanks for the answers. I'm familiar with using \dontleavehmode when needing to keep a figure midaligned; I had no idea that this would be a similar situation (and solution). Best regards, Lukas On Fri, 25 Feb 2011 09:37:40 +0100, Wolfgang Schuster schuster.wolfg...@googlemail.com

Re: [NTG-context] \placefigure and \em (again)

2011-02-25 Thread Willi Egger
Hello, of course I do not have the solution for the underlaying problem. I found out, that you can put a \strut in front of the problematic text and then it comes out ok. Another point is, that placing the whole text-part i.e. all 4 paragraphs in your example between \bgroup \egroup results in

Re: [NTG-context] \placefigure and \em (again)

2011-02-25 Thread Hans Hagen
On 25-2-2011 9:44, Procházka Lukáš Ing. - Pontex s. r. o. wrote: ... Thanks for the answers. I'm familiar with using \dontleavehmode when needing to keep a figure midaligned; I had no idea that this would be a similar situation (and solution). {\em xxx ..} the first x triggers the start of a

[NTG-context] \placefigure and \em (again)

2011-02-24 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello, sorry for repeating this topic, maybe it's not too attractive. Please, have a look to the following problem. I wonder why the behaviour described bellow occurs and how to typeset a paragraph starting with some text enclosed into {\em ...} group inside the free area formed (affected)

Re: [NTG-context] placefigure ?

2010-09-30 Thread Wolfgang Schuster
Am 29.09.2010 um 19:44 schrieb R. Bastian: On Tue, 28 Sep 2010 13:39:56 +0300 Mari Voipio mari.voi...@iki.fi scribit: On Tue, Sep 28, 2010 at 13:22, R. Bastian rbast...@free.fr wrote: In Mk II, I need to place figures - with numbers and captions - but \placefigure is for floats and never

Re: [NTG-context] placefigure ?

2010-09-29 Thread R. Bastian
On Tue, 28 Sep 2010 13:39:56 +0300 Mari Voipio mari.voi...@iki.fi scribit: On Tue, Sep 28, 2010 at 13:22, R. Bastian rbast...@free.fr wrote: In Mk II, I need to place figures - with numbers and captions - but \placefigure is for floats and never places the figure [here]. Is there another

Re: [NTG-context] placefigure ?

2010-09-28 Thread Mari Voipio
On Tue, Sep 28, 2010 at 13:22, R. Bastian rbast...@free.fr wrote: In Mk II, I need to place figures - with numbers and captions - but \placefigure is for floats and never places the figure [here]. Is there another way? I've found that mostly [here,force] will do the trick, but sometimes a

[NTG-context] \placefigure setups

2009-11-01 Thread Vyatcheslav Yatskovsky
Hello, Sorry for another newbie question, but how can I setup \placefigure so that its caption appeared as Рис. 1.1? That is, with Рис. prefix and numbered by subsection? Best regards, Vyatcheslav ___ If your

Re: [NTG-context] \placefigure setups

2009-11-01 Thread Wolfgang Schuster
Am 01.11.2009 um 15:23 schrieb Vyatcheslav Yatskovsky: Hello, Sorry for another newbie question, but how can I setup \placefigure so that its caption appeared as Рис. 1.1? That is, with Рис. prefix and numbered by subsection? \setuplabeltext[ru][figure=Рис. ] Wolfgang

Re: [NTG-context] placefigure broken in mkiv?

2009-10-16 Thread Hans Hagen
Alan BRASLAU wrote: However, on the subject of \placefigure, there appears to be a small bug in mkiv. (Untested) minimal example: \usemodule[bib] \starttext \placefigure[right,none]{}{\externalfigure[file][width=.3\textwidth] Text...\cite{Me2009} \blank[2*line]

Re: [NTG-context] placefigure broken in mkiv?

2009-10-16 Thread Vyatcheslav Yatskovsky
Hello, Thanks, Wolfgang. \placefigure[middle,none]{}{...} the official way in mkiv (please add this to the new mkii/mkiv difference page on the wiki) OK, but where this page is? (Oh, I we could get rid of these empty parenthesizes, it would be even nicer. Let's clean the syntax! )

Re: [NTG-context] placefigure broken in mkiv?

2009-10-16 Thread Wolfgang Schuster
Am 16.10.2009 um 15:29 schrieb Vyatcheslav Yatskovsky: please add this to the new mkii/mkiv difference page on the wiki) OK, but where this page is? http://wiki.contextgarden.net/MkIV_Differences (Oh, I we could get rid of these empty parenthesizes, it would be even nicer. Let's clean

[NTG-context] placefigure broken in mkiv?

2009-10-15 Thread Vyatcheslav Yatskovsky
Hello, A document that was previously compiled successfully a few months ago, now throws an exception. My code: \placefigure [middle] {none} {\externalfigure[2009-05-26_200309s][width=0.9\textwidth]} My result: ! Missing number, treated as zero. to be read again

Re: [NTG-context] placefigure broken in mkiv?

2009-10-15 Thread Wolfgang Schuster
Am 15.10.2009 um 16:04 schrieb Vyatcheslav Yatskovsky: Hello, A document that was previously compiled successfully a few months ago, now throws an exception. My code: \placefigure [middle] {none} {\externalfigure[2009-05-26_200309s][width=0.9\textwidth]}

Re: [NTG-context] placefigure broken in mkiv?

2009-10-15 Thread Alan BRASLAU
On Thursday 15 October 2009 17:29:12 Wolfgang Schuster wrote: Am 15.10.2009 um 16:04 schrieb Vyatcheslav Yatskovsky: Hello, A document that was previously compiled successfully a few months ago, now throws an exception. My code: \placefigure [middle] {none}

[NTG-context] placefigure[right] draws figures inside framed text

2009-07-08 Thread Jos van Gisbergen
Hello, I'm using framed text to display verbatim sourse code. The frame should use the entire textwidth, so I use width=broad. A problem occurs when I use a figure placed at the right side of the page, before a framed text section: the figure is drawn *inside* the frame. With non-framed text

Re: [NTG-context] placefigure[right] draws figures inside framed text

2009-07-08 Thread Willi Egger
Hi, use \framedtext[width=.5\textwidth]{...}. Framed text breaks over the lines. Do not use a \vbox Willi On Jul 8, 2009, at 1:54 PM, Jos van Gisbergen wrote: Hello, I'm using framed text to display verbatim sourse code. The frame should use the entire textwidth, so I use width=broad.

Re: [NTG-context] placefigure[right] draws figures inside framed text (Willi Egger)

2009-07-08 Thread Jos van Gisbergen
Message: 4 Date: Wed, 8 Jul 2009 16:44:11 +0200 From: Willi Egger w.eg...@boede.nl Subject: Re: [NTG-context] placefigure[right] draws figures inside framedtext To: mailing list for ConTeXt users ntg-context@ntg.nl Message-ID: c9d22320-b2b1-4a77-b38c-6dd553ec2

Re: [NTG-context] \placefigure not centering

2008-08-28 Thread Taco Hoekwater
Marcin Borkowski wrote: Dnia Wed, Aug 27, 2008 at 11:14:26AM +0200, Marcin Borkowski napisa#322;(a): Why this does not center the figure horizontally? What should I do to center it? \placefigure{none}{ \starttikzpicture[scale=0.3] \draw (0,0) -- (5,0) -- (4.5,6) --

[NTG-context] \placefigure not centering

2008-08-27 Thread Marcin Borkowski
Hey! Seems I'm going to ask lots of questions here - I'm starting to _really_ use ConTeXt;). Why this does not center the figure horizontally? What should I do to center it? \placefigure{none}{ \starttikzpicture[scale=0.3] \draw (0,0) -- (5,0) -- (4.5,6) -- (1.5,6) -- cycle;

Re: [NTG-context] \placefigure not centering

2008-08-27 Thread Marcin Borkowski
Dnia Wed, Aug 27, 2008 at 11:14:26AM +0200, Marcin Borkowski napisa#322;(a): Why this does not center the figure horizontally? What should I do to center it? \placefigure{none}{ \starttikzpicture[scale=0.3] \draw (0,0) -- (5,0) -- (4.5,6) -- (1.5,6) -- cycle;

Re: [NTG-context] \placefigure not centering

2008-08-27 Thread Hans Hagen
Marcin Borkowski wrote: Dnia Wed, Aug 27, 2008 at 11:14:26AM +0200, Marcin Borkowski napisa#322;(a): Why this does not center the figure horizontally? What should I do to center it? \placefigure{none}{ \starttikzpicture[scale=0.3] \draw (0,0) -- (5,0) -- (4.5,6) --

[NTG-context] placefigure[hang] in columns

2007-10-01 Thread Christof Meigen
Hi, I'm quite new to ConTeXT, so excuse me if the solution is obvious. I'm trying to typeset a document with three columns which contains _a lot_ of graphics, most of which are pretty small, about one third of a column. Unfortunately, while \placefigure[left,hang] works fine with one

Re: [NTG-context] placefigure[hang] in columns

2007-10-01 Thread Hans Hagen
Christof Meigen wrote: Hi, I'm quite new to ConTeXT, so excuse me if the solution is obvious. I'm trying to typeset a document with three columns which contains _a lot_ of graphics, most of which are pretty small, about one third of a column. Unfortunately, while

Re: [NTG-context] placefigure

2007-07-28 Thread Sanjoy Mahajan
you can load the eps graphic in ghostview, then hit the i-key. but i agree, that this method is a pain in the ???, if you have many graphics. The following command often finds the right bounding box: gs -sDEVICE=bbox -dSAFER -dBATCH -dNOPAUSE -q file.eps -Sanjoy Creativity can be a social

Re: [NTG-context] placefigure

2007-07-28 Thread Liesbeth van der Plas
Hallo Sanjoy, I tried your command but it doens't work on my pc. Liesbeth 2007/7/28, Sanjoy Mahajan [EMAIL PROTECTED]: you can load the eps graphic in ghostview, then hit the i-key. but i agree, that this method is a pain in the ???, if you have many graphics. The following command

Re: [NTG-context] placefigure

2007-07-28 Thread Wolfgang Schuster
On Sat, 28 Jul 2007 09:19:45 +0200 Liesbeth van der Plas [EMAIL PROTECTED] wrote: Hallo Sanjoy, I tried your command but it doens't work on my pc. Liesbeth try gswin32c -sDEVICE=bbox -dSAFER -dBATCH -dNOPAUSE -q file.eps Wolfgang

Re: [NTG-context] placefigure

2007-07-28 Thread Sanjoy Mahajan
I tried your command but it doesn't work on my pc. Maybe ghostscript isn't installed? What was the exact error? On my system (i386 laptop with Ubuntu GNU/Linux): $ gs -h GPL Ghostscript 8.54 (2006-05-17) but most versions of ghostscript should work. -Sanjoy Creativity can be a social

Re: [NTG-context] placefigure

2007-07-27 Thread Peter Rolf
Liesbeth van der Plas schrieb: Hello Patrick, Peter,.. The 3-step method doesn't work? I tried it over and over again. yes, sorry about that. only changing the media size works. Changing the media size by hand does work if I guess the size of the picture (I don't have an option bb or

Re: [NTG-context] placefigure

2007-07-27 Thread Jörg Hagmann
I use Illustrator. That certainly works -- you can save the pictures as pdfs (it's Adobe, after all). Liesbeth van der Plas wrote: Hello Patrick, Peter,.. The 3-step method doesn't work? I tried it over and over again. Changing the media size by hand does work if I guess the size of the

Re: [NTG-context] placefigure

2007-07-27 Thread Liesbeth van der Plas
Hello Patrick, Peter,.. The 3-step method doesn't work? I tried it over and over again. Changing the media size by hand does work if I guess the size of the picture (I don't have an option bb or bounding box). I think I can work with this method for the time being. Do you know if this

Re: [NTG-context] placefigure

2007-07-27 Thread Sanjoy Mahajan
Here are the three most important files from yesterday's map. I looked at the .eps file in emacs, and it has junk at the beginning and the end. My system (GNU/Linux) says: $ file testPlaatje.eps testPlaatje.eps: DOS EPS Binary File Postscript starts at byte 30 length 4085 Metafile

Re: [NTG-context] placefigure

2007-07-26 Thread Patrick Gundlach
Hello Liesbeth, Yesterday I sent a few files, but I got a return that the message body was too big. Here are the three most important files from yesterday's map. epstopdf breaks with this file. If, by chance, you use Mac OS X, you can use 'pstopdf' (the distiller from adobe). Then the pdf

Re: [NTG-context] placefigure

2007-07-26 Thread Peter Rolf
Peter Rolf schrieb: Hi Liesbeth, There is a problem with the bounding box (bb) of the eps file. Although gs shows it correctly (Info), it uses the media size (default A4) as border for the pdf. You can change the media size by hand (set it to bb), but it's less error prone to use

Re: [NTG-context] placefigure

2007-07-26 Thread olivier Turlier
Le Thu, 26 Jul 2007 08:36:53 +0200, Liesbeth van der Plas a écrit : Hallo Patrick, Yesterday I sent a few files, but I got a return that the message body was too big. Here are the three most important files from yesterday's map. Liesbeth 2007/7/25, Liesbeth van der Plas [EMAIL

Re: [NTG-context] placefigure

2007-07-26 Thread Peter Rolf
Hi Liesbeth, There is a problem with the bounding box (bb) of the eps file. Although gs shows it correctly (Info), it uses the media size (default A4) as border for the pdf. You can change the media size by hand (set it to bb), but it's less error prone to use extract... or ps to eps from the

Re: [NTG-context] placefigure

2007-07-26 Thread Patrick Gundlach
I use Windows XP. Sorry Liesbeth, I am out of my wits then, perhaps there is somebody out here with some tricks. Perhaps you can use some special printer driver that is able to create different kind of eps or pdf and then use 'print to file' to create the pdf. Does ghostscript offer such a

Re: [NTG-context] placefigure

2007-07-26 Thread Liesbeth van der Plas
I use Windows XP. 2007/7/26, Patrick Gundlach [EMAIL PROTECTED]: Hello Liesbeth, Yesterday I sent a few files, but I got a return that the message body was too big. Here are the three most important files from yesterday's map. epstopdf breaks with this file. If, by chance, you use Mac OS

Re: [NTG-context] placefigure

2007-07-25 Thread Liesbeth van der Plas
In GhostScript: Options àEPS Clip File à Convert à pdfwrite, Variable Page File à Convert à pdfwrite, Fixed Page Size File à Convert à pdfwrite, Shrink to fit Page Size I do get the picture now, but it is inbedded in a

Re: [NTG-context] placefigure

2007-07-25 Thread Patrick Gundlach
Hello Liesbeth, do you have a small sample eps file which gives you a problem? That way we might be able to help you better. Patrick ___ If your question is of interest to others as well, please add an entry to the

[NTG-context] placefigure

2007-07-24 Thread Liesbeth van der Plas
Hallo context users, I have a basic problem on laoding vector drawings. The photograph loads all right, the cat-drawing doensn't show up. \useexternalfigure[jpgPhotoSmall][photo][type=jpg,width=2cm]

Re: [NTG-context] placefigure

2007-07-24 Thread luigi scarso
On 7/24/07, Liesbeth van der Plas [EMAIL PROTECTED] wrote: Hallo context users, I have a basic problem on laoding vector drawings. The photograph loads all right, the cat-drawing doensn't show up.

Re: [NTG-context] placefigure

2007-07-24 Thread Patrick Gundlach
Hello, I have a basic problem on laoding vector drawings. The photograph loads all right, the cat-drawing doensn't show up. Perhaps this is due to the fact that pdftex doesn't handle eps? If this is true, you can convert eps files to pdf with epstopdf, that ships with texlive. Patrick

Re: [NTG-context] placefigure

2007-07-24 Thread Liesbeth van der Plas
I don't succeed in using the program epstopdf for my drawing. Probably it is also not very handy to alter a lot of drawings bij hand first? Or maybe there is a way to make MetaPost drawings without learning the MetaPost language? I have a lot of drawings made in Macromedia(=Adobe) Flash (or

Re: [NTG-context] placefigure

2007-07-24 Thread Roelof Langman
This is a simple case of rtfm. From chapter 7 of the pdftex manual: pdfTEX supports inclusion of pictures in png, jpeg, tiff and pdf format. The most common technique -the inclusion of eps figures- is replaced by pdf inclusion. eps files can be converted to pdf by GhostScript, Acrobat Distiller

Re: [NTG-context] placefigure

2007-07-24 Thread Martin Schröder
2007/7/24, Roelof Langman [EMAIL PROTECTED]: This is a simple case of rtfm. From chapter 7 of the pdftex manual: pdfTEX supports inclusion of pictures in png, jpeg, tiff and pdf format. Please update. tiff is long gone... Best Martin

Re: [NTG-context] \placefigure problems in Xetex

2007-04-23 Thread Mojca Miklavec
Hello, Just to let you all know: ConTeXt with pdfTeX creates PDF version 1.5 by default, and xdvipdfmx driver of XeTeX (which became the default one) isn't capable to handle those files. It handles PDF 1.4 OK, so if you have some PDFs with a too recent version, you should convert them to a lower

Re: [NTG-context] \placefigure problems in Xetex

2007-04-23 Thread luigi scarso
On 4/23/07, Mojca Miklavec [EMAIL PROTECTED] wrote: Hello, Just to let you all know: ConTeXt with pdfTeX creates PDF version 1.5 by default, and xdvipdfmx driver of XeTeX (which became the default one) isn't capable to handle those files. It handles PDF 1.4 OK, so if you have some PDFs with

  1   2   >