Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Andy
Does mtxrun --verbose --noquotes bin:vim -u NONE work correctly on windows? Yes. What about if you run texexec --lua instead of context (with noquote changed to noquotes in t-vim.tex)? Same problem. The log shows: MTXrun | MTXrun | executing: vim -u NONE -e -C -n -c set tabstop=8 -c

Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Aditya Mahajan
On Fri, 10 Apr 2009, Andy wrote: Does mtxrun --verbose --noquotes bin:vim -u NONE work correctly on windows? Yes. What about if you run texexec --lua instead of context (with noquote changed to noquotes in t-vim.tex)? Same problem. The log shows: MTXrun | MTXrun | executing: vim -u

Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Andy Wong
It should be -u NONE (all capitals) -u NONE is the same result. It is mtxrun related. It works in linux, so it could be windows related. I do not have a windows machine to test (and not enough diskspace to install windows on a VM). mtxrun seems not execute the vim command line correctly.

Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Aditya Mahajan
On Thu, 9 Apr 2009, Andy Wong wrote: Hello, I have tried the example using the vim mode to typeset some c codes. When I run the sample file, context stop with errors. the sample file and log file as list below. I use the windowsXP with the minimal context from ConTeXt garden and \write18 is

Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Andy Wong
It did not work, either. Same problem. Andy On Fri, Apr 10, 2009 at 3:13 PM, Aditya Mahajan adit...@umich.edu wrote: On Thu, 9 Apr 2009, Andy Wong wrote: Hello, I have tried the example using the vim mode to typeset some c codes. When I run the sample file, context stop with errors. the

Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Aditya Mahajan
On Fri, 10 Apr 2009, Andy Wong wrote: It did not work, either. Same problem. Then, for the moment use your workaround of having a batch file. I will try to get access to a windows environment in a few days and then check what is going wrong on windows. Aditya

Re: [NTG-context] t-vim failed under windows

2009-04-10 Thread Andy Wong
Thanks. Andy On Fri, Apr 10, 2009 at 3:28 PM, Aditya Mahajan adit...@umich.edu wrote: On Fri, 10 Apr 2009, Andy Wong wrote: It did not work, either. Same problem. Then, for the moment use your workaround of having a batch file. I will try to get access to a windows environment in a few

[NTG-context] t-vim failed under windows

2009-04-09 Thread Andy Wong
Hello, I have tried the example using the vim mode to typeset some c codes. When I run the sample file, context stop with errors. the sample file and log file as list below. I use the windowsXP with the minimal context from ConTeXt garden and \write18 is enabled. From the log file, it seems the

Re: [NTG-context] t-vim failed under windows

2009-04-09 Thread Aditya Mahajan
On Thu, 9 Apr 2009, Andy Wong wrote: Hello, I have tried the example using the vim mode to typeset some c codes. When I run the sample file, context stop with errors. the sample file and log file as list below. I use the windowsXP with the minimal context from ConTeXt garden and \write18 is

Re: [NTG-context] t-vim failed under windows

2009-04-09 Thread Andy Wong
The same problem. It seems the \shellescapedquote generated to the wrong position. So vim complains the -c parameters is wrong. Andy. On Thu, Apr 9, 2009 at 4:22 PM, Aditya Mahajan adit...@umich.edu wrote: On Thu, 9 Apr 2009, Andy Wong wrote: Hello, I have tried the example using the vim

Re: [NTG-context] t-vim failed under windows

2009-04-09 Thread Aditya Mahajan
On Thu, 9 Apr 2009, Andy Wong wrote: The same problem. It seems the \shellescapedquote generated to the wrong position. So vim complains the -c parameters is wrong. Does mtxrun --verbose --noquotes bin:vim -u NONE work correctly on windows? What about if you run texexec --lua instead of