[NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
I installed ConTeXt in 2009 in my laptop and wrote some documents. Now I
have installed ConTeXt in other computer and tried to process some of those
documents but it doesn't work.

It looks that there is something wrong with Metapost/Metafun. I have tried
a simple program like

\starttext

Testing

\startuseMPgraphic{gh}
draw thelabel.rt(the right way,a) withcolor .625red ;
\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext

Then I get:

system   begin file kk2.tex at line 1
metapost initializing instance 'metafun' using format 'metafun'
metapost loading 'metafun.mp' (experimental metapost version two)
! terminal:  a
 (3,0)
! Not implemented: (unknown numeric)+(pair).
to be read again
   -
thelabel-...((EXPR4)+labeloffset*laboff(SUFFIX2)-

(labxf(SUFFIX2)*lrcorner.p...
*  draw thelabel.rt(the right way,a)
 withcolor .625red ; ;
.
system   tex  error on line 10 in file kk2.tex: terminal:  a
 (3,0)
! Not implemented: (unknown numeric)+(pair).
to be read again
   -
thelabel-...((EXPR4)+labeloffset*laboff(SUFFIX2)-

(labxf(SUFFIX2)*lrcorner.p...
*  draw thelabel.rt(the right way,a)
 withcolor .625red ; ;


Any ideas? Thank you.
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread luigi scarso
On Mon, May 28, 2012 at 2:43 PM, Alfredo Catalina
alfredo.catal...@gmail.com wrote:
 I installed ConTeXt in 2009 in my laptop and wrote some documents. Now I
 have installed ConTeXt in other computer and tried to process some of those
 documents but it doesn't work.

 It looks that there is something wrong with Metapost/Metafun. I have tried a
 simple program like

 \starttext

 Testing

 \startuseMPgraphic{gh}
 draw thelabel.rt(the right way,a) withcolor .625red ;
 \stopuseMPgraphic

 \useMPgraphic{gh}

 \stoptext

 Then I get:

 system   begin file kk2.tex at line 1
 metapost     initializing instance 'metafun' using format 'metafun'
 metapost     loading 'metafun.mp' (experimental metapost version two)
 ! terminal:  a
 (3,0)
 ! Not implemented: (unknown numeric)+(pair).
 to be read again
    -
 thelabel-...((EXPR4)+labeloffset*laboff(SUFFIX2)-

 (labxf(SUFFIX2)*lrcorner.p...
 *  draw thelabel.rt(the right way,a)
  withcolor .625red ; ;
 .
 system   tex  error on line 10 in file kk2.tex: terminal:  a
 (3,0)
 ! Not implemented: (unknown numeric)+(pair).
 to be read again
    -
 thelabel-...((EXPR4)+labeloffset*laboff(SUFFIX2)-

 (labxf(SUFFIX2)*lrcorner.p...
 *  draw thelabel.rt(the right way,a)
  withcolor .625red ; ;


 Any ideas? Thank you.


 ___
 If your question is of interest to others as well, please add an entry to
 the Wiki!

 maillist : ntg-context@ntg.nl /
 http://www.ntg.nl/mailman/listinfo/ntg-context
 webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
 archive  : http://foundry.supelec.fr/projects/contextrev/
 wiki     : http://contextgarden.net
 ___

What is the value of a ?

This is ok with mkii

\setupcolors[state=start]
\starttext

Testing

\startuseMPgraphic{gh}
pair a;
a:=(0,0);
draw thelabel.rt(the right way,a) withcolor .625red ;
\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext


-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
Sorry, that's right, it works. I forgot the definition. I have been trying
some things before.

In fact the problem is this:

\starttext

Testing

\startuseMPgraphic{gh}

textX:=87.51u;
textY:=96.31u;
pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
draw pic shifted (textX, textY);

\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext
And  I get:

! terminal:  pic
 picture
! Equation cannot be performed (numeric=picture).
to be read again
   ;
* ...rt(rawtextext({Test}) scaled 1.00,(0,0));
   draw pic shifted (textX,
...
 pic
 (0.90863textY,textY)
! Not implemented: (unknown numeric)shifted(unknown pair).
to be read again
   ;
* ...00,(0,0)); draw pic shifted (textX, textY);
   ;
 0.90863textY
! Undefined x coordinate has been replaced by 0.
to be read again
   withpen
draw-...:also(EXPR0)else:doublepath(EXPR0)withpen
  .currentpen.fi._op_
to be read again
   ;
* ...00,(0,0)); draw pic shifted (textX, textY);
   ;
 textY
! Undefined y coordinate has been replaced by 0.
to be read again
   withpen
draw-...:also(EXPR0)else:doublepath(EXPR0)withpen
  .currentpen.fi._op_
to be read again
   ;
* ...00,(0,0)); draw pic shifted (textX, textY);
   ;
.
system   tex  error on line 14 in file kk2.tex: terminal:  pic
 picture
! Equation cannot be performed (numeric=picture).
to be read again
   ;
* ...rt(rawtextext({Test}) scaled 1.00,(0,0));
   draw pic shifted (textX,
...
 pic
 (0.90863textY,textY)
! Not implemented: (unknown numeric)shifted(unknown pair).
to be read again
   ;
* ...00,(0,0)); draw pic shifted (textX, textY);
   ;
 0.90863textY
! Undefined x coordinate has been replaced by 0.
to be read again
   withpen
draw-...:also(EXPR0)else:doublepath(EXPR0)withpen
  .currentpen.fi._op_
to be read again
   ;
* ...00,(0,0)); draw pic shifted (textX, textY);
   ;
 textY
! Undefined y coordinate has been replaced by 0.
to be read again
   withpen
draw-...:also(EXPR0)else:doublepath(EXPR0)withpen
  .currentpen.fi._op_
to be read again
   ;
* ...00,(0,0)); draw pic shifted (textX, textY);
   ;
 ...
 4
 5 \startuseMPgraphic{gh}
 6
 7 textX:=87.51u;
 8 textY:=96.31u;
 9 pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
10 draw pic shifted (textX, textY);
11
12 \stopuseMPgraphic
13
14   \useMPgraphic{gh}
15
16 \stoptext
17
inserted text ...re.mp ; fi ; ]===], false)}

\processMPgraphic ...e ;\!!es , \MPaskedfigure )}}
  \egroup \placeMPgraphic
\d...
\handleuseMPgraphic ...hics \processMPgraphic {#3}
  \endgroup
\douseMPgraphic ...{\@@MPG \currentMPgraphicname }
  \empty \endMPgraphicgroup
to be read again

l.14 \useMPgraphic{gh}
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread Hans Hagen

On 28-5-2012 15:35, Alfredo Catalina wrote:

Sorry, that's right, it works. I forgot the definition. I have been trying
some things before.

In fact the problem is this:

\starttext

Testing

\startuseMPgraphic{gh}

textX:=87.51u;
textY:=96.31u;


picture pic;


pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
draw pic shifted (textX, textY);

\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext
And  I get:

! terminal:  pic



-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] thelabel problem

2012-05-28 Thread luigi scarso
On Mon, May 28, 2012 at 3:35 PM, Alfredo Catalina
alfredo.catal...@gmail.com wrote:
 Sorry, that's right, it works. I forgot the definition. I have been trying
 some things before.

 In fact the problem is this:

 \starttext

 Testing

 \startuseMPgraphic{gh}

 textX:=87.51u;
 textY:=96.31u;
 pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
 draw pic shifted (textX, textY);

 \stopuseMPgraphic

 \useMPgraphic{gh}

 \stoptext
Still something to define


\starttext

Testing

\startuseMPgraphic{gh}
picture pic;
numeric u;
u:=1;
textX:=87.51u;
textY:=96.31u;
pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
draw pic shifted (textX, textY);

\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext

-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
Thank you. I check it, and you are right. I forgot to include the
definitions when I cut and paste that part of the code. I thought the
problem was related to the btex command, but it's not.

The first line is:

u=1.000mm; linecap:=butt; linejoin:=mitered; path pp; picture pic;
labeloffset:=0;

I compared it with your code. The numeric u; definition is missing in my
file. I have included it and now it works!!

It's really weird since I compiled it in 2009 and it worked as is. I still
have the pdf output file...??

Finally I have a problem in this line:

externalfigure aciddrops1.png xscaled 80.13u yscaled 60.09u shifted
(69.85u,20.30u) ;

Then I got:

 terminal:  picture
! Isolated expression.
to be read again
   ;
* ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
   ;
.
system   tex  error on line 99 in file kk2.tex: terminal: 
picture
! Isolated expression.
to be read again
   ;
* ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
   ;
 ...
 89 fill pp--cycle withcolor (0.000,0.000,0.000);
 90
pp:=(150.24u,73.96u)--(152.93u,72.91u)--(153.10u,74.30u)--(150.24u,73.96u);
 91 draw pp--cycle withpen pencircle scaled 0.30mm withcolor
(0.000,0.000,0.000);
 92
 93 setbounds currentpicture to
(67.85u,18.30u)--(197.56u,18.30u)--(197.56u,102.23u)--(67.85u,102.23u)--cycle;
 94
 95 externalfigure aciddrops1.png xscaled 80.13u yscaled 60.09u
shifted (69.85u,20.30u) ;
 96
 97 \stopuseMPgraphic
 98
 99   \useMPgraphic{gh}
100
101 \stoptext
102
inserted text ...re.mp ; fi ; ]===], false)}

\processMPgraphic ...e ;\!!es , \MPaskedfigure )}}
  \egroup \placeMPgraphic
\d...
\handleuseMPgraphic ...hics \processMPgraphic {#3}
  \endgroup
\douseMPgraphic ...{\@@MPG \currentMPgraphicname }
  \empty \endMPgraphicgroup
to be read again

l.99 \useMPgraphic{gh}
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread luigi scarso
On Mon, May 28, 2012 at 5:36 PM, Alfredo Catalina
alfredo.catal...@gmail.com wrote:
 Thank you. I check it, and you are right. I forgot to include the
 definitions when I cut and paste that part of the code. I thought the
 problem was related to the btex command, but it's not.

 The first line is:

 u=1.000mm; linecap:=butt; linejoin:=mitered; path pp; picture pic;
 labeloffset:=0;

 I compared it with your code. The numeric u; definition is missing in my
 file. I have included it and now it works!!

 It's really weird since I compiled it in 2009 and it worked as is. I still
 have the pdf output file...??

 Finally I have a problem in this line:

 externalfigure aciddrops1.png xscaled 80.13u yscaled 60.09u shifted
 (69.85u,20.30u) ;

 Then I got:

  terminal:  picture
 ! Isolated expression.
 to be read again
    ;
 * ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
    ;
 .
 system   tex  error on line 99 in file kk2.tex: terminal: 
 picture

This is ok here
(mill.png is in tex/texmf-context/tex/context/sample)

\starttext

Testing

\startuseMPgraphic{gh}
picture pic;
numeric u;
u:=1;
textX:=87.51u;
textY:=96.31u;
pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
draw pic shifted (textX, textY);
externalfigure mill.png xscaled 80.13u yscaled 60.09u shifted
(69.85u,20.30u) ;
\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext

-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
I've tried to compile that code and I got:

! terminal:  picture
! Isolated expression.
to be read again
   ;
* ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
   ;

.

system   tex  error on line 17 in file kk.tex: terminal: 
picture
! Isolated expression.
to be read again
   ;
* ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
   ;

 ...

 7 numeric u;
 8 u:=1;
 9 textX:=87.51u;
10 textY:=96.31u;
11 pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
12 draw pic shifted (textX, textY);
13 externalfigure mill.png xscaled 80.13u yscaled 60.09u shifted
14 (69.85u,20.30u) ;
15 \stopuseMPgraphic
16
17   \useMPgraphic{gh}
18
19 \stoptext
20
inserted text ...re.mp ; fi ; ]===], false)}

\processMPgraphic ...e ;\!!es , \MPaskedfigure )}}
  \egroup \placeMPgraphic
\d...
\handleuseMPgraphic ...hics \processMPgraphic {#3}
  \endgroup
\douseMPgraphic ...{\@@MPG \currentMPgraphicname }
  \empty \endMPgraphicgroup
to be read again

l.17 \useMPgraphic{gh}

-

I have no idea of what to do. Any ideas? Thanks
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread luigi scarso
On Mon, May 28, 2012 at 6:11 PM, Alfredo Catalina
alfredo.catal...@gmail.com wrote:
 I've tried to compile that code and I got:

 ! terminal:  picture

 ! Isolated expression.
 to be read again
    ;
 * ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
    ;

 .

 system   tex  error on line 17 in file kk.tex: terminal: 
 picture


 ! Isolated expression.
 to be read again
    ;
 * ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
    ;

  ...

  7 numeric u;
  8 u:=1;
  9 textX:=87.51u;
 10 textY:=96.31u;
 11 pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
 12 draw pic shifted (textX, textY);
 13 externalfigure mill.png xscaled 80.13u yscaled 60.09u shifted
 14 (69.85u,20.30u) ;
 15 \stopuseMPgraphic
 16
 17   \useMPgraphic{gh}
 18
 19 \stoptext
 20

 inserted text ...re.mp ; fi ; ]===], false)}

 \processMPgraphic ...e ;\!!es , \MPaskedfigure )}}
   \egroup \placeMPgraphic
 \d...
 \handleuseMPgraphic ...hics \processMPgraphic {#3}
   \endgroup
 \douseMPgraphic ...{\@@MPG \currentMPgraphicname }
   \empty \endMPgraphicgroup
 to be read again

 l.17 \useMPgraphic{gh}

 -

 I have no idea of what to do. Any ideas? Thanks
It's ok here --- do you have
shell_escape=t
?
Can you post the log ?
-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
I checked that I have

shell_escape = t
shell_escape.context  = t
shell_escape_commands.context = mtxrun,luatools,texmfstart,texexec,mpost

in C:\context\tex\texmf\web2c\texmf.cnf

Please find attached the file log (kk.log).

Thanks in advance.


kk.log
Description: Binary data
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
Contents of the log file:

(kk.tex
ConTeXt  ver: 2011.05.18 18:04 MKIV  fmt: 2012.5.28  int: english/english
system   cont-new.mkiv loaded
(C:/context/tex/texmf-context/tex/context/base/cont-new.mkiv
system   beware: some patches loaded from cont-new.mkiv
)
system   kk.top loaded
system   options  begin of optionfile
system   options 
system   options  % runtime options files (command line driven)
system   options  \unprotect
system   options  % feedback and basic job control
system   options  % handy for special styles
system   options  \startluacode
system   options  document = document or { }
system   options  document.arguments={
system   options   [autopdf]=true,
system   options  }
system   options  document.files={
system   options   kk.tex,
system   options  }
system   options  \stopluacode
system   options  % process info
system   options  \setupsystem[inputfile=kk.tex]
system   options  \setupsystem[\c!n=1,\c!m=1]
system   options  % modes
system   options  % options (not that important)
system   options  \startsetups *runtime:options
system   options  \stopsetups
system   options  % styles and modules
system   options  \startsetups *runtime:modules
system   options  \stopsetups
system   options  % done
system   options  \protect \endinput
system   options 
system   options  end of optionfile
(kk.top)
fontslatin modern fonts are not preloaded
languageslanguage en is active
{C:/context/tex/texmf-context/fonts/map/pdftex/context/mkiv-base.map}
fontspreloading latin modern fonts (second stage)
(C:/context/tex/texmf-context/tex/context/base/type-siz.mkiv)
(C:/context/tex/texmf-context/tex/context/base/type-otf.mkiv){C:/context/tex/texmf/fonts/map/dvips/lm/lm-math.map}{C:/context/tex/texmf/fonts/map/dvips/lm/lm-rm.map}
fontsvirtual math  unable to resolve name mapsfromchar
fontsfallback modern rm 12pt is loaded
system   begin file kk.tex at line 1
metapost initializing instance 'metafun' using format 'metafun'
metapost loading 'metafun.mp' (experimental metapost version two)
! terminal:  picture
! Isolated expression.
to be read again
   ;
* ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
   ;
.
system   tex  error on line 17 in file kk.tex: terminal: 
picture
! Isolated expression.
to be read again
   ;
* ...3u yscaled 60.09u shifted (69.85u,20.30u) ;
   ;
 ...
 7 numeric u;
 8 u:=1;
 9 textX:=87.51u;
10 textY:=96.31u;
11 pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
12 draw pic shifted (textX, textY);
13 externalfigure mill.png xscaled 80.13u yscaled 60.09u shifted
14 (69.85u,20.30u) ;
15 \stopuseMPgraphic
16
17   \useMPgraphic{gh}
18
19 \stoptext
20
inserted text ...re.mp ; fi ; ]===], false)}

\processMPgraphic ...e ;\!!es , \MPaskedfigure )}}
  \egroup \placeMPgraphic
\d...
\handleuseMPgraphic ...hics \processMPgraphic {#3}
  \endgroup
\douseMPgraphic ...{\@@MPG \currentMPgraphicname }
  \empty \endMPgraphicgroup
to be read again

l.17 \useMPgraphic{gh}

?
! Emergency stop.
system   tex  error on line 17 in file kk.tex: Emergency stop ...
 7 numeric u;
 8 u:=1;
 9 textX:=87.51u;
10 textY:=96.31u;
11 pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
12 draw pic shifted (textX, textY);
13 externalfigure mill.png xscaled 80.13u yscaled 60.09u shifted
14 (69.85u,20.30u) ;
15 \stopuseMPgraphic
16
17   \useMPgraphic{gh}
18
19 \stoptext
20
inserted text ...re.mp ; fi ; ]===], false)}

\processMPgraphic ...e ;\!!es , \MPaskedfigure )}}
  \egroup \placeMPgraphic
\d...
\handleuseMPgraphic ...hics \processMPgraphic {#3}
  \endgroup
\douseMPgraphic ...{\@@MPG \currentMPgraphicname }
  \empty \endMPgraphicgroup
to be read again

l.17 \useMPgraphic{gh}

End of file on the terminal!
!  == Fatal error occurred, no output PDF file produced!


On Mon, May 28, 2012 at 8:50 PM, Alfredo Catalina 
alfredo.catal...@gmail.com wrote:

 I checked that I have

 shell_escape = t
 shell_escape.context  = t
 shell_escape_commands.context = mtxrun,luatools,texmfstart,texexec,mpost

 in C:\context\tex\texmf\web2c\texmf.cnf

 Please find attached the file log (kk.log).

 Thanks in advance.


Re: [NTG-context] thelabel problem

2012-05-28 Thread luigi scarso
On Mon, May 28, 2012 at 8:54 PM, Alfredo Catalina
alfredo.catal...@gmail.com wrote:
 Contents of the log file:

 (kk.tex
 ConTeXt  ver: 2011.05.18 18:04 MKIV  fmt: 2012.5.28  int: english/english
 system   cont-new.mkiv loaded
Ah --- are you running mkiv ?
It's ok with mkii, ie
mtxrun texexec kk.tex

I need to check with mkiv, ie
context kk.tex


-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread luigi scarso
On Mon, May 28, 2012 at 9:06 PM, luigi scarso luigi.sca...@gmail.com wrote:
 Ah --- are you running mkiv ?
 It's ok with mkii, ie
 mtxrun texexec kk.tex

 I need to check with mkiv, ie
 context kk.tex
mkiv has
draw externalfigure
while mkii has
externalfigure

This is ok

\starttext

Testing

\startuseMPgraphic{gh}
picture pic;
numeric u;
u:=1;
textX:=87.51u;
textY:=96.31u;
pic:=thelabel.urt(btex {Test} etex scaled 1.00,(0,0));
draw pic shifted (textX, textY);
draw externalfigure mill.png xscaled 80.13u yscaled 60.09u shifted
(69.85u,20.30u) ;


\stopuseMPgraphic

\useMPgraphic{gh}

\stoptext

Also search
externalfigure vs. draw externalfigure in metafun
in this ml

-- 
luigi
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
This is what I get with mtxrun texexec kk.tex

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/W32TeX)
(format=cont-en 2012.5.28)  28 MAY 2012 21:18
entering extended mode
 \write18 enabled.
 (c:/context/tex/texmf-context/web2c/natural.tcx)
**kk.tex
(./kk.tex
ConTeXt  ver: 2012.05.26 16:40 MKII  fmt: 2012.5.28  int: english/english
system  : cont-new.mkii loaded
(c:/context/tex/texmf-context/tex/context/base/cont-new.mkii
FatalError  : Your format does not match the base files!
FormatVersion   : 2012.05.26 16:40 MKII
FilesVersion: 2011.05.18 18:04
 ) )
Here is how much of TeX's memory you used:
 47 strings out of 255946
 829 string characters out of 1273077
 2595900 words of memory out of 400
 41195 multiletter control sequences out of 15000+10
 7 words of font info for 0 fonts, out of 200 for 5000
 397 hyphenation exceptions out of 8191
 20i,0n,15p,81b,471s stack positions out of
1i,500n,1p,400b,5s
No pages of output.
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___

Re: [NTG-context] thelabel problem

2012-05-28 Thread Alfredo Catalina
Yes!!! It works!!

Now I can use both commands and it works!

I very much appreciate your support.

Thanks Luigi!

On Mon, May 28, 2012 at 10:20 PM, luigi scarso luigi.sca...@gmail.comwrote:

 On Mon, May 28, 2012 at 9:20 PM, Alfredo Catalina
 alfredo.catal...@gmail.com wrote:
  This is what I get with mtxrun texexec kk.tex
 
  This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/W32TeX)
  (format=cont-en 2012.5.28)  28 MAY 2012 21:18
  entering extended mode
   \write18 enabled.
   (c:/context/tex/texmf-context/web2c/natural.tcx)
  **kk.tex
  (./kk.tex
  ConTeXt  ver: 2012.05.26 16:40 MKII  fmt: 2012.5.28  int:
 english/english
  system  : cont-new.mkii loaded
  (c:/context/tex/texmf-context/tex/context/base/cont-new.mkii
  FatalError  : Your format does not match the base files!
  FormatVersion   : 2012.05.26 16:40 MKII
  FilesVersion: 2011.05.18 18:04

 Hm,  try
 mtxrun texexec --make
 and
 context --make

 Both are ok at my end.

 --
 luigi

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___