Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-22 Thread luigi scarso
On Thu, Nov 22, 2018 at 4:15 PM Ulrike Fischer wrote: > Am Thu, 22 Nov 2018 14:46:57 +0100 schrieb luigi scarso: > > >> > >> A palette entry index value of 0x is a special case indicating > >> that the text foreground color (defined by a higher-level client) > >> should be used and

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-22 Thread Ulrike Fischer
Am Thu, 22 Nov 2018 14:46:57 +0100 schrieb luigi scarso: >> >> A palette entry index value of 0x is a special case indicating >> that the text foreground color (defined by a higher-level client) >> should be used and shall not be treated as actual index into CPAL >> ColorRecord array. >>

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-22 Thread Hans Hagen
On 11/22/2018 2:12 PM, Ulrike Fischer wrote: A palette entry index value of 0x is a special case indicating that the text foreground color (defined by a higher-level client) should be used and shall not be treated as actual index into CPAL ColorRecord array. unrelated ... 0x

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-22 Thread luigi scarso
On Thu, Nov 22, 2018 at 2:13 PM Ulrike Fischer wrote: > Am Thu, 22 Nov 2018 13:50:08 +0100 schrieb Hans Hagen: > > >> When I use this definitions I still get partly blue glyphs with this > >> preamble. Don't you get them? > > > well, i don't know what to expect > > Khaled mentioned this link

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-22 Thread Ulrike Fischer
Am Thu, 22 Nov 2018 13:50:08 +0100 schrieb Hans Hagen: >> When I use this definitions I still get partly blue glyphs with this >> preamble. Don't you get them? > well, i don't know what to expect Khaled mentioned this link which shows how (harfbuzz-based) browsers like firefox interpret the

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-22 Thread Hans Hagen
On 11/21/2018 9:04 PM, Ulrike Fischer wrote: Am Wed, 21 Nov 2018 20:37:29 +0100 schrieb luigi scarso: \definefontfeature[quran][mode=node,language=dflt,script=arab, init=yes,medi=yes,fina=yes,isol=yes, ccmp=yes,locl=yes,calt=yes, liga=yes,clig=yes,dlig=yes,rlig=yes,

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-21 Thread Ulrike Fischer
Am Wed, 21 Nov 2018 20:37:29 +0100 schrieb luigi scarso: > \definefontfeature[quran][mode=node,language=dflt,script=arab, > init=yes,medi=yes,fina=yes,isol=yes, >ccmp=yes,locl=yes,calt=yes, >liga=yes,clig=yes,dlig=yes,rlig=yes, >mark=yes,mkmk=yes,kern=yes,curs=yes, >

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-21 Thread luigi scarso
On Wed, Nov 21, 2018 at 7:04 PM Ulrike Fischer wrote: > Am Wed, 21 Nov 2018 18:46:44 +0100 schrieb Hans Hagen: > > > I'm not sure what yoy mwan with 0x as that's intercepted > > With this example (font from > https://github.com/alif-type/amiri/blob/master/AmiriQuranColored.ttf) > > a part of

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-21 Thread Ulrike Fischer
Am Wed, 21 Nov 2018 18:46:44 +0100 schrieb Hans Hagen: > I'm not sure what yoy mwan with 0x as that's intercepted With this example (font from https://github.com/alif-type/amiri/blob/master/AmiriQuranColored.ttf) a part of the glyphs are in blue. Khaled claims that this is wrong, that the

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-21 Thread Hans Hagen
On 11/21/2018 1:37 PM, Ulrike Fischer wrote: Am Wed, 21 Nov 2018 13:01:47 +0100 schrieb Ulrike Fischer: Khaled wrote that "is that [the code] uses the last palette color A bit too much deleted. It should say "it is a bug that ..." in context use the context interface (which uses a

Re: [NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-21 Thread Ulrike Fischer
Am Wed, 21 Nov 2018 13:01:47 +0100 schrieb Ulrike Fischer: > Khaled wrote that "is that [the code] uses the last palette color A bit too much deleted. It should say "it is a bug that ..." -- Ulrike Fischer http://www.troubleshooting-tex.de/

[NTG-context] font-ocl.lua:76: attempt to call a nil value (field 'register')

2018-11-21 Thread Ulrike Fischer
I tried to register a demo colorpalette: \starttext \directlua{fonts.handlers.otf.registerpalette("demo", { { g=1 }, %accents { b=1 }, %06dd { r=0.5, g=0.5, b=0.5 }, %unused? { g = 0.5, b=0, r=1 }, } )} blub \stoptext and got the error font-ocl.lua:76: attempt to call a nil va

Re: [NTG-context] issue with signature field

2017-05-25 Thread Pablo Rodriguez
On 05/24/2017 11:57 AM, luigi scarso wrote: > On Sun, May 21, 2017 at 9:17 PM, Pablo Rodriguez <oi...@gmx.es> wrote: >> Dear list, >> >> some time ago, Hans implemented signature fields: >> >> \setupinteraction[state=start] >> \starttext >

Re: [NTG-context] issue with signature field

2017-05-25 Thread Pablo Rodriguez
On 05/24/2017 11:00 AM, Hans Hagen wrote: > On 5/21/2017 9:17 PM, Pablo Rodriguez wrote: >> \setupinteraction[state=start] >> \starttext >> \definefield[x][signature] >> \field[x] >> \stoptext >> >> I’m afraid I’m n

Re: [NTG-context] issue with signature field

2017-05-24 Thread luigi scarso
On Sun, May 21, 2017 at 9:17 PM, Pablo Rodriguez <oi...@gmx.es> wrote: > Dear list, > > some time ago, Hans implemented signature fields: > > \setupinteraction[state=start] > \starttext > \definefield[x][signature] > \field[x] > \stoptext &g

Re: [NTG-context] issue with signature field

2017-05-24 Thread Hans Hagen
On 5/21/2017 9:17 PM, Pablo Rodriguez wrote: Dear list, some time ago, Hans implemented signature fields: \setupinteraction[state=start] \starttext \definefield[x][signature] \field[x] \stoptext I’m afraid I’m not able to sign it using Acrobat 9.5.5, which

[NTG-context] issue with signature field

2017-05-21 Thread Pablo Rodriguez
Dear list, some time ago, Hans implemented signature fields: \setupinteraction[state=start] \starttext \definefield[x][signature] \field[x] \stoptext I’m afraid I’m not able to sign it using Acrobat 9.5.5, which is the latest version released for Linux. Acrobat Reader 9.5.5

Re: [NTG-context] btx/xml tree - entry with missing field

2016-12-22 Thread Michael Eidenbenz
thanks a lot hans! > Am 22.12.2016 um 18:30 schrieb Hans Hagen <pra...@wxs.nl>: > > On 12/22/2016 6:06 PM, Michael Eidenbenz wrote: >> Hello >> >> I use the xml interface to list all publications that dont match a >> search crit

Re: [NTG-context] btx/xml tree - entry with missing field

2016-12-22 Thread Hans Hagen
On 12/22/2016 6:06 PM, Michael Eidenbenz wrote: Hello I use the xml interface to list all publications that dont match a search criteria: /field[@name='keywords' and not (contains(text(),'alpha'))] but there are entries where the keywords field is missing. how can I include

[NTG-context] btx/xml tree - entry with missing field

2016-12-22 Thread Michael Eidenbenz
Hello I use the xml interface to list all publications that dont match a search criteria: /field[@name='keywords' and not (contains(text(),'alpha'))] but there are entries where the keywords field is missing. how can I include them (here "test-3") in the output

[NTG-context] short field no longer accepts control sequences

2015-02-01 Thread Idris Samawi Hamid ادريس سماوي حامد
Dear Cabal, Things like the following used to work, now give an error: \starttext \setuppublications[alternative=apa] \startpublication[k=corbin81, t=book, a=Corbin, y=1981, s=\hbox{}Corbin81]

Re: [NTG-context] short field no longer accepts control sequences

2015-02-01 Thread Hans Hagen
On 2/1/2015 4:27 PM, Idris Samawi Hamid ادريس سماوي حامد wrote: Dear Cabal, Things like the following used to work, now give an error: s=\hbox{}Corbin81] This is not mission-critical in my case, I can live without it at least for now, but it did used to work. May be

Re: [NTG-context] short field no longer accepts control sequences

2015-02-01 Thread Idris Samawi Hamid ادريس سماوي حامد
On Sun, 01 Feb 2015 17:56:31 -0700, Hans Hagen pra...@wxs.nl wrote: On 2/1/2015 4:27 PM, Idris Samawi Hamid ادريس سماوي حامد wrote: Dear Cabal, Things like the following used to work, now give an error: s=\hbox{}Corbin81] This is not mission-critical in my case, I can

[NTG-context] Resizing multi-line fill-in field

2014-07-01 Thread Michael Guravage
I am re-posting a previous question. Is it possible to increase the height of a multi-line fill-in field when the cumulative height of the lines typed into it exceeds the field's initial height? Here's an example where the field's initial height in 10em. \usemodule[fields] \setupinteraction

Re: [NTG-context] Resizing multi-line fill-in field

2014-07-01 Thread Hans Hagen
On 7/1/2014 12:37 PM, Michael Guravage wrote: I am re-posting a previous question. Is it possible to increase the height of a multi-line fill-in field when the cumulative height of the lines typed into it exceeds the field's initial height? Here's an example where the field's initial height

Re: [NTG-context] Widget and mandatory Rect field?

2011-04-18 Thread Hans Hagen
this: Error: Annotation rectangle is wrong type Though it opens it fine and no problems at all. there can also be a puzzling FormFieldButton::setState called on a readOnly field I googled a bit and found a bug report on this: https://bugs.freedesktop.org/show_bug.cgi?id=29954 There it is said

Re: [NTG-context] Widget and mandatory Rect field?

2011-04-18 Thread Reviczky, Adam
) /MK /CA () /F 4 /Rect [0 0 59.7758 11.9552] endobj which look like Annot's with Rect's to me. There is a parent field I was puzzled by this too, but apparently its the parent where the error message is thrown out (rightly or falsely). Are you saying that Evince does forms (and Javascript

[NTG-context] Widget and mandatory Rect field?

2011-04-17 Thread Reviczky, Adam
Though it opens it fine and no problems at all. I googled a bit and found a bug report on this: https://bugs.freedesktop.org/show_bug.cgi?id=29954 There it is said that its ConTeXt's fault, as It has a Widget annotation without the mandatory Rect field. Is it really so? I couldn't find any threads

[NTG-context] Third field of useURL

2011-03-05 Thread Cecil Westerhof
At http://wiki.contextgarden.net/Reference/en/useURL there is a description of useURL. I am using it for HTTP and e-mail referencing. But I do not understand where the third parameter is used for, -- Cecil Westerhof

Re: [NTG-context] Third field of useURL

2011-03-05 Thread Philipp Gesang
On 2011-03-05 19:33:45, Cecil Westerhof wrote: At http://wiki.contextgarden.net/Reference/en/useURL there is a description of useURL. I am using it for HTTP and e-mail referencing. But I do not understand where the third parameter is used for, Good evening, Cecil There’s a minimal explanation

Re: [NTG-context] Third field of useURL

2011-03-05 Thread Cecil Westerhof
2011/3/5 Philipp Gesang pges...@ix.urz.uni-heidelberg.de On 2011-03-05 19:33:45, Cecil Westerhof wrote: At http://wiki.contextgarden.net/Reference/en/useURL there is a description of useURL. I am using it for HTTP and e-mail referencing. But I do not understand where the third parameter

[NTG-context] field alignment bug in latest beta

2011-01-25 Thread Reviczky, Adam
Hi, The alignment doesn't apply anymore to the first field (widget) in the latest beta. Here's the minimal example: % begin of example \starttext \setupfield [ShortLine] [label,frame,horizontal] [offset=4pt,height=fit,framecolor=green,background=screen,backgroundscreen=.80] [height=18pt,width

[NTG-context] mtx-context.lua:1161: attempt to call field 'join' (a nil value)

2010-08-26 Thread Peter Münster
Hello, context --purgeall gives this error: ...ex/texmf-context/scripts/context/lua/mtx-context.lua:1161: attempt to call field 'join' (a nil value) Cheers, Peter -- Contact information: http://pmrb.free.fr/contact

[NTG-context] strc-not.lua:87: attempt to index field '?' (a nil value)

2010-07-26 Thread Peter Münster
Hello, Perhaps I don't use localfootnotes the right way? Example: \starttext blub\footnote{blub} bla \startlocalfootnotes blub\footnote{blub} \placelocalfootnotes \stoplocalfootnotes \stoptext Cheers, Peter -- Contact information: http://pmrb.free.fr/contact/

Re: [NTG-context] strc-not.lua:87: attempt to index field '?' (a nil value)

2010-07-26 Thread Hans Hagen
On 26-7-2010 11:33, Peter Münster wrote: Hello, Perhaps I don't use localfootnotes the right way? Example: \starttext blub\footnote{blub} bla \startlocalfootnotes blub\footnote{blub} \placelocalfootnotes \stoplocalfootnotes \stoptext fixed in next upload

[NTG-context] LuaTeX error: attempt to index field '?' (a nil value)

2010-06-26 Thread Alan BRASLAU
latest minimals: $ context contextman ! LuaTeX error ...text/tex/texmf-context/tex/context/base/strc-not.lua:87: attempt to index field '?' (a nil value) stack traceback: ...text/tex/texmf-context/tex/context/base/strc-not.lua:87: in function 'listindex' ...text/tex/texmf

Re: [NTG-context] spac-ver.lua:580: attempt to index field 'spec'

2009-11-05 Thread Hans Hagen
Peter Münster wrote: Hello, With this test-file: \starttext \blank[force] bla \stoptext I get the following error: error: ...text/tex/texmf-context/tex/context/base/spac-ver.lua:580: attempt to index field 'spec' (a nil value) Workaround: \starttext \strut\blank bla \stoptext or \blank

[NTG-context] Invalid field in Mark IV

2009-05-13 Thread Flavien Lambert
Dear all, I didn't use ConTeXt for some time and, so, have just re-installed the minimals tonight. When running on some of my files, Mark II does its job well but Mark IV tells me error: Invalid field id nucleus for node type choice (0) . l.133 ... M décrit l'axe $({\rm O};\vect{e_{x

Re: [NTG-context] Invalid field in Mark IV

2009-05-13 Thread Aditya Mahajan
On Wed, 13 May 2009, Flavien Lambert wrote: Dear all, I didn't use ConTeXt for some time and, so, have just re-installed the minimals tonight. When running on some of my files, Mark II does its job well but Mark IV tells me error: Invalid field id nucleus for node type choice (0) . l.133 ... M

Re: [NTG-context] Invalid field in Mark IV

2009-05-13 Thread Flavien Lambert
didn't use ConTeXt for some time and, so, have just re-installed the minimals tonight. When running on some of my files, Mark II does its job well but Mark IV tells me error: Invalid field id nucleus for node type choice (0) . l.133 ... M décrit l'axe $({\rm O};\vect{e_{x

Re: [NTG-context] Invalid field in Mark IV

2009-05-13 Thread Aditya Mahajan
On Wed, 13 May 2009, Flavien Lambert wrote: In the following example, it is the ; that leads to the error \def\vect#1{% \overrightarrow{#1} } \starttext $({\rm O};\vect{e_{x}})$ \stoptext If you suppress it, it works fine. (???) Taco, the error also occurs with cambria. So, by your

Re: [NTG-context] Invalid field in Mark IV

2009-05-13 Thread Hans Hagen
Flavien Lambert wrote: In the following example, it is the ; that leads to the error \def\vect#1{% \overrightarrow{#1} } \starttext $({\rm O};\vect{e_{x}})$ \stoptext math-noa.lua: if nc == po then local last_noad = next_noad.next

Re: [NTG-context] Invalid field in Mark IV

2009-05-13 Thread Taco Hoekwater
Aditya Mahajan wrote: On Wed, 13 May 2009, Flavien Lambert wrote: In the following example, it is the ; that leads to the error \def\vect#1{% \overrightarrow{#1} } \starttext $({\rm O};\vect{e_{x}})$ \stoptext If you suppress it, it works fine. (???) Taco, the error also occurs with

Re: [NTG-context] Letter: address field

2008-07-09 Thread Wolfgang Schuster
On Tue, Jul 8, 2008 at 3:29 PM, Wolfgang Schuster [EMAIL PROTECTED] wrote: On Tue, Jul 8, 2008 at 2:49 PM, Oliver Buerschaper [EMAIL PROTECTED] wrote: Dear Wolfgang, is it possible to centre the text block in the address field vertically? At the moment the address is typeset with a constant

Re: [NTG-context] Letter: address field

2008-07-08 Thread Wolfgang Schuster
On Tue, Jul 8, 2008 at 2:49 PM, Oliver Buerschaper [EMAIL PROTECTED] wrote: Dear Wolfgang, is it possible to centre the text block in the address field vertically? At the moment the address is typeset with a constant vertical offset (measured from the top) which causes lengthy address data

Re: [NTG-context] Interactive slides---hidden field on every page

2007-09-17 Thread Peter Rolf
. I've got the navigation buttons in the bottom. Now I'd like to add one more button that would open a field on the current page---a field containing the list of content. I'd like it to go to the \Topic I want to discuss and disappear. I tried this: \definefield[Content][check][HelpSetup

[NTG-context] Interactive slides---hidden field on every page

2007-09-12 Thread Michal Kvasnička
Good morning or whatever you have now in Europe. I'm preparing my slides. Every slide is divided to three parts (backgrounds): text, header, and bottom. I've got the navigation buttons in the bottom. Now I'd like to add one more button that would open a field on the current page---a field

Re: [NTG-context] using of field failed when arrange subpages

2007-04-17 Thread Hans Hagen
Zhichu Chen wrote: Hi, I've tried Hans' example introduced at mwidget-p.pdf, it's perfect. But when I was trying some subpage arrangements, it just failed. How could it happen? I guess either shiping out subpages forget the fields or something has covered over them. Here's a small

Re: [NTG-context] using of field failed when arrange subpages

2007-04-17 Thread Zhichu Chen
Thank you any way. I hope it won't be a problem one day. On 4/17/07, Hans Hagen [EMAIL PROTECTED] wrote: Zhichu Chen wrote: Hi, I've tried Hans' example introduced at mwidget-p.pdf , it's perfect. But when I was trying some subpage arrangements, it just failed. How could it happen? I

Re: [NTG-context] using of field failed when arrange subpages

2007-04-16 Thread Zhichu Chen
Hi everybody, I figured out that it is not because the fields are not treated nor they are overlapped by other materials. Only the JavaScript failed to excute the Toggle_Hide function. When I deleted hidden from \setupfield [HelpSetup] [width=1.2em,height=fit,frame=off,option={readonly,hidden}]

[NTG-context] using of field failed when arrange subpages

2007-04-15 Thread Zhichu Chen
Hi, I've tried Hans' example introduced at mwidget-p.pdf, it's perfect. But when I was trying some subpage arrangements, it just failed. How could it happen? I guess either shiping out subpages forget the fields or something has covered over them. Here's a small example (by the way, I don't

[NTG-context] Question about field

2006-09-08 Thread luigi scarso
I wish to understand how to make nested fields (is it's possible, of course), or better, how to make a tree of field. \clonefield seem to be some work, maybe it's a good place to start. luigi ___ ntg-context mailing list ntg-context@ntg.nl http

Re: [NTG-context] 'german' indention in radio field - [FINAL]

2004-10-27 Thread Peter Rolf
Thank you, Hans! From now on I'll test my minmal examples on contextgarden, before sending them. Greetings, Peter Hans Hagen wrote: Peter Rolf wrote: Hi there! After a new installation of Texlife my radio field example (4.10.) works (now?). But if you simply add \mainlanguage[de] the first

Re: [NTG-context] 'german' indention in radio field

2004-10-26 Thread Hans Hagen
Peter Rolf wrote: Hi there! After a new installation of Texlife my radio field example (4.10.) works (now?). But if you simply add \mainlanguage[de] the first button is indented again. Hmmm, it seems that my first example was too minimal. I've also tried [en] and [dk]; no problems. You need

Re: [NTG-context] first element in radio field

2004-10-07 Thread Peter Rolf
, that this button is inactive (X-ing off); only one button can be active in a radio field 3 When clicking on the second button the contents of the first butten changes into the value NormalX ... May be I do not get the idea of the radio-button ... maybe this is not a good example for learning radio

[NTG-context] first element in radio field

2004-10-05 Thread Peter Rolf
Hello all! This is my first attempt with fields, so I am not sure if this is a bug in context or my fault :) Anyway, the first element of my radio field is indented, while the following elements are ok. This is the case in horizontal and vertical arrangment. I added a minimal example... ConTeXt

Re: [NTG-context] first element in radio field

2004-10-05 Thread Hans Hagen
Peter Rolf wrote: Hello all! This is my first attempt with fields, so I am not sure if this is a bug in context or my fault :) Anyway, the first element of my radio field is indented, while the following elements are ok. This is the case in horizontal and vertical arrangment. I added a minimal

Re: [NTG-context] first element in radio field

2004-10-05 Thread Willi Egger
in context or my fault :) Anyway, the first element of my radio field is indented, while the following elements are ok. This is the case in horizontal and vertical arrangment. I added a minimal example... ConTeXt ver: 2004.10.1 fmt: 2004.10.3 int: english mes: german systems: pdfTeX version

[NTG-context] Re: Stumped on Field

2003-09-02 Thread Patrick Gundlach
[EMAIL PROTECTED] writes: In s-mag-01.tex, I am completely baffled by: \startusableMPgraphic{text} StartPage ; for i=Header,Text,Footer: for j=LeftEdge,LeftMargin,Text,RightMargin,RightEdge: draw Field[i][j] withpen pencircle scaled 0.5pt; endfor; endfor; StopPage

[NTG-context] Stumped on Field

2003-08-14 Thread darnold
All, In s-mag-01.tex, I am completely baffled by: \startusableMPgraphic{text} StartPage ; for i=Header,Text,Footer: for j=LeftEdge,LeftMargin,Text,RightMargin,RightEdge: draw Field[i][j] withpen pencircle scaled 0.5pt; endfor; endfor; StopPage; setbounds currentpicture to Field

Re: [NTG-context] Stumped on Field

2003-08-05 Thread Sebastian Rooks
[EMAIL PROTECTED] wrote: All, In s-mag-01.tex, I am completely baffled by: \startusableMPgraphic{text} StartPage ; for i=Header,Text,Footer: for j=LeftEdge,LeftMargin,Text,RightMargin,RightEdge: draw Field[i][j] withpen pencircle scaled 0.5pt; endfor; endfor; StopPage; setbounds