Re: [NTG-context] Can \getmarking take more than one argument?

2015-08-09 Thread tala...@fastmail.fm
[header] {\doifoddpageelse {\getmarking[section]} {\getmarking[chapter]} } \doiftextelse {\getmarking[chapter]} \stopsetups — The problem is that some of my ‘section’s are not sections, but ‘subject’s (because I don’t want that section

Re: [NTG-context] Can \getmarking take more than one argument?

2015-08-09 Thread Hans Hagen
On 8/9/2015 2:42 AM, tala...@fastmail.fm wrote: Hello, I currently use the following to define my even and odd page headers. — \startsetups[header] {\doifoddpageelse {\getmarking[section]} {\getmarking[chapter]} } \doiftextelse

[NTG-context] Can \getmarking take more than one argument?

2015-08-08 Thread tala...@fastmail.fm
Hello, I currently use the following to define my even and odd page headers. — \startsetups[header] {\doifoddpageelse {\getmarking[section]} {\getmarking[chapter]} } \doiftextelse {\getmarking[chapter]} \stopsetups

Re: [NTG-context] bug: \getmarking with mixedcolumns

2013-11-26 Thread Lars Huttar
On 11/22/2013 4:34 PM, Hans Hagen wrote: On 11/21/2013 7:01 PM, Lars Huttar wrote: I now have a MWE that shows the problem. Where top and bottom work fine outside of columns, in mixedcolumns, any keyword I use with \getmarking always seem to return the *last* item on the page. Here's the MWE

Re: [NTG-context] bug: \getmarking with mixedcolumns

2013-11-22 Thread Hans Hagen
On 11/21/2013 7:01 PM, Lars Huttar wrote: I now have a MWE that shows the problem. Where top and bottom work fine outside of columns, in mixedcolumns, any keyword I use with \getmarking always seem to return the *last* item on the page. Here's the MWE: I changed the example a bit

Re: [NTG-context] bug: \getmarking with mixedcolumns

2013-11-22 Thread Lars Huttar
On 11/22/2013 4:34 PM, Hans Hagen wrote: On 11/21/2013 7:01 PM, Lars Huttar wrote: I now have a MWE that shows the problem. Where top and bottom work fine outside of columns, in mixedcolumns, any keyword I use with \getmarking always seem to return the *last* item on the page. Here's the MWE

[NTG-context] bug: \getmarking with mixedcolumns

2013-11-21 Thread Lars Huttar
. Thanks. // // -- previous : last before sync // -- next : first after sync // // -- top : first in sync // -- bottom : last in sync // // -- first: first not top in sync // -- last : last not bottom in sync // // That is exactly what's in the wiki (Command/getmarking

Re: [NTG-context] bug: \getmarking with mixedcolumns

2013-11-21 Thread Lars Huttar
On 11/21/2013 1:01 PM, Lars Huttar wrote: I now have a MWE that shows the problem. Where top and bottom work fine outside of columns, in mixedcolumns, any keyword I use with \getmarking always seem to return the *last* item on the page. I sometimes forget to include our version info. MKIV

[NTG-context] Problem with getmarking and setupheadertexts

2013-04-03 Thread H. Özoguz
Hi together, what is wrong with the following shortexample? \setupheadertexts [] [{\cap\getmarking[chapter]}] [][] \starttext \startchapter[ title={Long long long title, it is indeed}, marking = {Shorter Title}, ] \stopchapter \stoptext

Re: [NTG-context] Problem with getmarking and setupheadertexts

2013-04-03 Thread Philipp Gesang
···date: 2013-04-03, Wednesday···from: H. Özoguz··· Hi together, what is wrong with the following shortexample? \setupheadertexts [] [{\cap\getmarking[chapter]}] [][] \starttext \startchapter[ title={Long long long title, it is indeed

Re: [NTG-context] solved-how to make \getmarking[title] show using default font size?

2011-07-26 Thread Wolfgang Schuster
Am 26.07.2011 um 06:04 schrieb Jeong Dalyoung: Dear all, For the header text, I used \getmarking as follows: \setupheadertexts[][{\getmarking[{\v!title}]}] * This problem comes from my setting which is as follows: \title{\ss\bf\tfb Title} I changed it by using

[NTG-context] how to make \getmarking[title] show using default font size?

2011-07-25 Thread Jeong Dalyoung
Dear all, For the header text, I used \getmarking as follows: \setupheadertexts[][{\getmarking[{\v!title}]}] Then it showed title in the header as shown in the text which is bigger than default bodyfont size. It is rather big for the header text. How to make it using the default font size

[NTG-context] solved-how to make \getmarking[title] show using default font size?

2011-07-25 Thread Jeong Dalyoung
Dear all, For the header text, I used \getmarking as follows: \setupheadertexts[][{\getmarking[{\v!title}]}] * This problem comes from my setting which is as follows: \title{\ss\bf\tfb Title} I changed it by using the definition as follows: \def\Mytitle#1{% \framedtext [width

Re: [NTG-context] getmarking and empty chapter number

2011-05-24 Thread Oliver Buerschaper
%D \macros %D {doiftextelse, doiftext} %D %D When \type {\doifelse} cum suis hopelessly fail, for %D instance because we pass data, we can fall back on the next %D macro: %D %D \starttyping %D \doiftextelse {data} {then branch} {else branch} %D \doiftext {data} {then branch} %D

[NTG-context] getmarking and empty chapter number

2011-05-23 Thread Oliver Buerschaper
Hi all, I'm just trying to wrap my mind around why the following doesn't work as I expect: -- \setupheadertexts [] [{\doifsomething{\getmarking[sectionnumber]}{\getmarking[sectionnumber]\enskip}\getmarking[section]}] [{\doifsomething{\getmarking[chapternumber

Re: [NTG-context] getmarking and empty chapter number

2011-05-23 Thread Aditya Mahajan
On Mon, 23 May 2011, Oliver Buerschaper wrote: Hi all, I'm just trying to wrap my mind around why the following doesn't work as I expect: -- \setupheadertexts [] [{\doifsomething{\getmarking[sectionnumber]}{\getmarking[sectionnumber]\enskip}\getmarking[section

[NTG-context] \getmarking notworking?

2011-01-06 Thread Khaled Hosny
}] [] \startsetups text:header:odd \getmarking[chapter][current] \quad\vrule\quad \pagenumber \stopsetups \startsetups text:header:even \pagenumber \quad\vrule\quad \getmarking[section][current] \stopsetups \starttext \chapter{Chapter} \dorecurse{10} { \section{Section} \input

Re: [NTG-context] \getmarking notworking?

2011-01-06 Thread Hans Hagen
On 6-1-2011 4:04, Khaled Hosny wrote: The following used to work (still working in texlive) but no longer working (latest minimals), I get the page number and the rule but not the text. Bug? sort of ... chapter refers to a section-* name so we need to get the parent: methods[v_current] =

Re: [NTG-context] \getmarking notworking?

2011-01-06 Thread Khaled Hosny
On Thu, Jan 06, 2011 at 04:53:16PM +0100, Hans Hagen wrote: On 6-1-2011 4:04, Khaled Hosny wrote: The following used to work (still working in texlive) but no longer working (latest minimals), I get the page number and the rule but not the text. Bug? sort of ... chapter refers to a

[NTG-context] Bug: delay in \getmarking

2010-12-17 Thread Steffen Wolfrum
Hi, I don't no exactly when it changed, but it still worked in ConTeXt ver: 2010.09.05 13:23 MKIV. Now, there is a one page delay in \getmarking! Please run minimal exmaple below and look at page 7: Section = 1.2 B Header = 1.2 A Steffen --- \setuppagenumbering [alternative

Re: [NTG-context] Problems with getmarking

2010-11-26 Thread luigi scarso
this is the correct solution: \unprotect %setvalue{\??nh:\??mk:y:\v!page }{\resetcurrentstructuremarks} % strc-sec.mkiv \setvalue{\??nh:\??mk:y:\v!page }{} \protect \setuphead[part][placehead=yes,marking=page] \setupheadertexts[{\getmarking[part][first]\ – \getmarking[chapter][first

Re: [NTG-context] Problems with getmarking

2010-11-26 Thread Hans Hagen
On 23-11-2010 12:32, Wolfgang Schuster wrote: Am 23.11.2010 um 11:14 schrieb luigi scarso: Hm I cannot see a solution --- perhaps a bug ? I think so and i hope this is the correct solution: \unprotect %setvalue{\??nh:\??mk:y:\v!page }{\resetcurrentstructuremarks} % strc-sec.mkiv

Re: [NTG-context] Problems with getmarking

2010-11-26 Thread luigi scarso
On Fri, Nov 26, 2010 at 5:11 PM, Hans Hagen pra...@wxs.nl wrote: On 23-11-2010 12:32, Wolfgang Schuster wrote: Am 23.11.2010 um 11:14 schrieb luigi scarso: Hm I cannot see a solution --- perhaps a bug ? I think so and i hope this is the correct solution: \unprotect

Re: [NTG-context] Problems with getmarking

2010-11-23 Thread luigi scarso
On Mon, Nov 22, 2010 at 3:47 PM, luigi scarso luigi.sca...@gmail.com wrote: With this code mkii and mkiv make differents pdf : mkiv doesn't show the header after the second \part. Perhaps \getmarking is obsolete ? \setuppagenumbering[way=bytext,partnumber=no,location={margin},alternative

Re: [NTG-context] Problems with getmarking

2010-11-23 Thread Wolfgang Schuster
[part][placehead=yes,marking=page] \setupheadertexts[{\getmarking[part][first]\ – \getmarking[chapter][first]\ – \getmarking[section][first]}] \starttext \dorecurse{2} {\part{Part #1} \dorecurse{2} {\chapter{Chapter #1-##1} \section{Section #1-##1}}} \stoptext Wolfgang

Re: [NTG-context] Problems with getmarking

2010-11-23 Thread luigi scarso
}{\resetcurrentstructuremarks} % strc-sec.mkiv \setvalue{\??nh:\??mk:y:\v!page }{} \protect \setuphead[part][placehead=yes,marking=page] \setupheadertexts[{\getmarking[part][first]\ – \getmarking[chapter][first]\ – \getmarking[section][first]}] \starttext \dorecurse{2}  {\part{Part #1

[NTG-context] Problems with getmarking

2010-11-22 Thread luigi scarso
With this code mkii and mkiv make differents pdf : mkiv doesn't show the header after the second \part. Perhaps \getmarking is obsolete ? \setuppagenumbering[way=bytext,partnumber=no,location={margin},alternative=doublesided] \setupcolors[state=start] \setupinteraction[state=start

[NTG-context] getmarking does not use mark?

2010-09-27 Thread Steffen Wolfrum
Hi, did I misunderstood something ... or is this simply a bug?! In that example below \getmarking uses the value of title ... and not of mark! (is there an other command to access the value of mark?) Steffen --- \def\KolumneL{\headnumber[chapter]\enskip\getmarking[chapter]} \def

Re: [NTG-context] getmarking does not use mark?

2010-09-27 Thread Wolfgang Schuster
Am 27.09.2010 um 17:36 schrieb Steffen Wolfrum: Hi, did I misunderstood something ... or is this simply a bug?! In that example below \getmarking uses the value of title ... and not of mark! The name of the key is marking”. Wolfgang

Re: [NTG-context] getmarking does not use mark?

2010-09-27 Thread Steffen Wolfrum
Am 27.09.2010 um 17:50 schrieb Wolfgang Schuster: Am 27.09.2010 um 17:36 schrieb Steffen Wolfrum: Hi, did I misunderstood something ... or is this simply a bug?! In that example below \getmarking uses the value of title ... and not of mark! The name of the key is marking

Re: [NTG-context] getmarking does not use mark?

2010-09-27 Thread Wolfgang Schuster
Am 27.09.2010 um 18:16 schrieb Steffen Wolfrum: In that example below \getmarking uses the value of title ... and not of mark! The name of the key is marking”. I don't understand. In context-excursion it says ... After the definition texts can be marked by: \marking[.1.]{.2

Re: [NTG-context] getmarking does not use mark?

2010-09-27 Thread Steffen Wolfrum
Am 27.09.2010 um 18:21 schrieb Wolfgang Schuster: Am 27.09.2010 um 18:16 schrieb Steffen Wolfrum: In that example below \getmarking uses the value of title ... and not of mark! The name of the key is marking”. I don't understand. In context-excursion it says ... After

Re: [NTG-context] should \getmarking[title] work?

2009-06-26 Thread Hans Hagen
Michael Green wrote: On Jun 25, 2009, at 3:00 AM, Wolfgang Schuster wrote: Am 25.06.2009 um 00:51 schrieb Michael Green: I expected \getmarking[title] to give me the contents of \title. It used to work (as of late spring). Perhaps something has changed. MTXrun | current version: 2009.06.14

[NTG-context] should \getmarking[title] work?

2009-06-25 Thread Michael Green
I expected \getmarking[title] to give me the contents of \title. It used to work (as of late spring). Perhaps something has changed. MTXrun | current version: 2009.06.14 21:01 This is LuaTeX, Version beta-0.40.5-2009061123 (Web2C 2009) luatex.web = v2471 Test file: \starttext \title

Re: [NTG-context] should \getmarking[title] work?

2009-06-25 Thread Wolfgang Schuster
Am 25.06.2009 um 00:51 schrieb Michael Green: I expected \getmarking[title] to give me the contents of \title. It used to work (as of late spring). Perhaps something has changed. MTXrun | current version: 2009.06.14 21:01 This is LuaTeX, Version beta-0.40.5-2009061123 (Web2C 2009

Re: [NTG-context] should \getmarking[title] work?

2009-06-25 Thread Michael Green
On Jun 25, 2009, at 3:00 AM, Wolfgang Schuster wrote: Am 25.06.2009 um 00:51 schrieb Michael Green: I expected \getmarking[title] to give me the contents of \title. It used to work (as of late spring). Perhaps something has changed. MTXrun | current version: 2009.06.14 21:01 This is LuaTeX

[NTG-context] [***SPAM***] Bug? \getmarking fails under some circumstances

2009-05-12 Thread Oliver Heins
Hello, I'm new to ConTeXt, so this is perhaps not a bug but a fault on my side. Under some circumstances, the living column heads fail to refer to the subsubject. As you can see from the attached minimal example \startsetups[header] \getmarking[subject]\ $\cdot$ \getmarking[subsubject