Re: [NTG-context] References and formulae numbers in upshape

2008-03-15 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Wolfgang Schuster skrev: On Fri, 14 Mar 2008 22:30:30 +0100 Morgan Brassel [EMAIL PROTECTED] wrote: Le Friday 14 March 2008 09:00:49 Wolfgang Schuster, vous avez écrit : What do you want seems to be not possible but you could use the following

Re: [NTG-context] References and formulae numbers in upshape

2008-03-15 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Johan Sandblom skrev: I believe the easy way is \mainlanguage{sv] which also has lots of other useful side effects. Johan, also from Sweden 2008/3/15, Jan-Erik Hägglöf [EMAIL PROTECTED]: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1

Re: [NTG-context] References and formulae numbers in upshape

2008-03-15 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Wolfgang Schuster skrev: Good to have more pals from sweden! Thanks for the answer, actually it was not what I meant. I already use \mainlanguage[sv], but how do you customize so it appears like: Bild 1 , Bild 2, .. or whatever 1 whatever 2

[NTG-context] properties file for gedit

2008-04-02 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 HI! Has anyone a clue how to make gedit texteditor contextable? Best Regards Janneman -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.6 (GNU/Linux) Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

[NTG-context] scite properties enable utf8 and customizing

2008-04-04 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 HI! I am trying to make Scite work in a context way by copying context.properties and friends, and it does work . The problem seems to be that make scite automatic be in utf8 mode. I have copying following parameters in the file .SciTEUser.properies

Re: [NTG-context] scite properties enable utf8 and customizing

2008-04-07 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hans Hagen skrev: Jan-Erik Hägglöf wrote: -BEGIN PGP SIGNED MESSAGE- Hash: SHA1 HI! I am trying to make Scite work in a context way by copying context.properties and friends, and it does work . The problem seems to be that make scite

Re: [NTG-context] [dev-context] New context release

2008-04-16 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Hans Hagen skrev: Norbert Preining wrote: Hi all, On Mi, 16 Apr 2008, Taco Hoekwater wrote: http://wiki.contextgarden.net/Release_Note for everything we did change and patch in the past 24 hours. If nothing bad happens, this release will go

Re: [NTG-context] Minimals - how to use?

2008-04-23 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 David skrev: On Tue, 22 Apr 2008 18:53:10 -0400 (EDT), Aditya Mahajan wrote: For my purposes (my requirements are not large, I'm not in a hurry, and I don't want to waste time learning multiple ways of doing things), I have decided to do

[NTG-context] correct installation gnuplot module question

2008-04-24 Thread Jan-Erik Hägglöf
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 HI! I have minimal context installation installed in my $USER/ctx-test/ directory tree and have two questions. First: I've downloaded the 2007.02.16 zip and placed the containing 3 files in my case

Re: [NTG-context] How to make caption for any table?

2008-06-09 Thread Jan-Erik Hägglöf
, before=\bTABLE,after=\eTABLE] \starttext \placetable[split][tab:test-tabell]{En testad tabell} {\startMyTable $ \delta $ 45 23 11 $ \omega $ 22 67 88 \stopMyTable} \stoptext I suppose there is a slight different syntax to make this work! Thanks in advance! Jan-Erik

[NTG-context] Problem with TSV tables

2008-06-10 Thread Jan-Erik Hägglöf
Hi! Followed the MyWay creating tables using CSV..in order to create tables from datafiles in tab separated columns. A weird message \line= ... stop appears Can someone figure it out? Thanks in advance Jan-Erik Hägglöf % engine=luatex \mainlanguage[sv] % \environments \usemodule[database

[NTG-context] how to prevent document resize in acrobat reader when click on an ref object

2008-06-27 Thread Jan-Erik Hägglöf
HI! I'm often use \setupinteraction[state=start] \setupcolor[state=start] \starttext \placesomething[somewhere][ref]{caption} ... ... So in the text I refer to \in{something}[ref] so I can click on it in the resulting pdf so I get there. \stoptext The question is how to change the default

[NTG-context] strange output in pdf when using the filter module

2012-02-22 Thread Jan-Erik Hägglöf
for a particular purpose. I am having all these installed on mac osx 10.7 lion Thanks in advance Jan-Erik Hägglöf test4.pdf Description: Adobe PDF document test4.tex Description: Binary data Generated .tex file by output from pandoc test3.tex Description: Binary data Log messages test4.log

Re: [NTG-context] strange output in pdf when using the filter module

2012-02-22 Thread Jan-Erik Hägglöf
Updating to latest beta with ./first-setup.sh did the trick, thanks a lot mvh Janneman 22 feb 2012 kl. 18:15 skrev Aditya Mahajan: On Wed, 22 Feb 2012, Aditya Mahajan wrote: On Wed, 22 Feb 2012, Jan-Erik Hägglöf wrote: Having an issue in my pdf-output after processing a markdown file

[NTG-context] context minimals path and directory structure question

2008-10-20 Thread Jan-Erik Hägglöf
Hello! I'm using context-minimal version: 2008.10.01 19:13 and have a generally question. I'm writing several documents with similar structure and design and have collected all common settings in settings.tex like following: \startenvironment settings ... ... ... \stopenvironment and just do

[NTG-context] exported figures from DIA to Metapost including in document

2008-11-24 Thread Jan-Erik Hägglöf
Hi All! I'm in beginning to write a thesis in physics(undergraduate level) and one of many things I wanna do is, cause I create much illustrations in DIA http://www.gnome.org/projects/dia/ and the program can export to figure.mp, to include these in my document. I've read the instructions on

Re: [NTG-context] exported figures from DIA to Metapost including in document

2008-11-24 Thread Jan-Erik Hägglöf
mån 2008-11-24 klockan 09:08 -0500 skrev Aditya Mahajan: On Mon, 24 Nov 2008, Jan-Erik Hägglöf wrote: Hi All! I'm in beginning to write a thesis in physics(undergraduate level) and one of many things I wanna do is, cause I create much illustrations in DIA http://www.gnome.org/projects

Re: [NTG-context] exported figures from DIA to Metapost including in document

2008-11-24 Thread Jan-Erik Hägglöf
mån 2008-11-24 klockan 10:40 -0500 skrev Aditya Mahajan: On Mon, 24 Nov 2008, Jan-Erik Hägglöf wrote: Thanks to all answers. I got it work, though a minor problem left, it seems that calligraphy is not working. line 108 draw btex { $ \vec{\cal B }$} etex. see the new attached

Re: [NTG-context] exported figures from DIA to Metapost including in document

2008-11-24 Thread Jan-Erik Hägglöf
It worked! Thanks a lot! mån 2008-11-24 klockan 16:23 -0500 skrev Aditya Mahajan: On Mon, 24 Nov 2008, Jan-Erik Hägglöf wrote: I tried to do some fontsettings, maybe it was the wrong way setting up things. You can see in the updated file. This is not your fault. There is a bug in MKIV

[NTG-context] Gedit in Ubuntu as a ConteXt editor

2008-12-02 Thread Jan-Erik Hägglöf
HI ConTeXt friends! I've been using Gedit on my ubuntu system for quite some time and is very much happy with it. Here are some advantages: * UTF-8 encoding by default (which is in mind for LuaTeX). * highly configurable code snippets. reading xml-files. * Defining your own typesetting

Re: [NTG-context] Gedit in Ubuntu as a ConteXt editor

2008-12-02 Thread Jan-Erik Hägglöf
tis 2008-12-02 klockan 14:03 +0200 skrev Khaled Hosny: On Tue, Dec 02, 2008 at 11:41:12AM +0100, Jan-Erik Hägglöf wrote: * Some learning curve to learn how to create special ConTeXt plugin like this http://live.gnome.org/Gedit/LaTeXPlugin I spent some time porting LaTeXPlugin to ConTeXt

[NTG-context] Howto make citations work in aps bibtex

2009-01-21 Thread Jan-Erik Hägglöf
Hi All! Have an issue getting \cite command working properly. Working on a undergraduate thesis in physics and the bibliography. I have read in bibmod-doc.pdf(Tacos manual) and also on the wiki about how to make this work properly. So I did set this in the preamble of my document. It sees the

Re: [NTG-context] Howto make citations work in aps bibtex

2009-01-21 Thread Jan-Erik Hägglöf
ons 2009-01-21 klockan 13:04 +0100 skrev Taco Hoekwater: Jan-Erik Hägglöf wrote: Hi All! Have an issue getting \cite command working properly. Working on a undergraduate thesis in physics and the bibliography. I have read in bibmod-doc.pdf(Tacos manual) and also on the wiki about

Re: [NTG-context] Howto make citations work in aps bibtex

2009-01-21 Thread Jan-Erik Hägglöf
\mycite[Gombosi1998pot] kap 3, sid 53. Detta är ... ? end output Something went wrong with the macro? ons 2009-01-21 klockan 14:55 +0100 skrev Taco Hoekwater: Jan-Erik Hägglöf wrote: Example: These statements has been declared

Re: [NTG-context] Howto make citations work in aps bibtex

2009-01-21 Thread Jan-Erik Hägglöf
, Version snapshot-0.31.3 (uppsats.tex ConTeXt ver: 2009.01.14 11:29 MKIV fmt: 2009.1.16 int: english/english //Janneman ons 2009-01-21 klockan 16:03 +0100 skrev Jan-Erik Hägglöf: HI! So I did as you proposed \def\mycite[#1]{[{\cite[author][#1]},({\cite[year][#1]})]} in my preamble

Re: [NTG-context] interesting arrange effect with interface=xp

2009-02-09 Thread Jan-Erik Hägglöf
HI! Which fun? .. this? Setting /home/djsameman/context/tex as TEXROOT. djsame...@lundby:~$ cd Dokument/context/funwith_xp_iface/ djsame...@lundby:~/Dokument/context/funwith_xp_iface$ texexec --lua --interface=xp --arrange TeXExec | version 6.2.0 - 1997-2006 - PRAGMA ADE/POD TeXExec |

[NTG-context] error on

2009-02-13 Thread Jan-Erik Hägglöf
HI! After updating I did(according to the wiki at http://wiki.contextgarden.net/ConTeXt_Minimals ) After Installing section ctxtools --update luatools --ini --compile --verbose cont-uk cont-en Above commands failed with following error(the last lines in output): loading : Context

[NTG-context] Howto make a handy script to handle dia exported *.mp files

2009-03-06 Thread Jan-Erik Hägglöf
HI ALL! According to an earlier post that was very much helpful, I now wish to know how to write a shell script or similar to automate this exporting process. http://archive.contextgarden.net/message/20081124.122842.38fee2f4.en.html I discover it is a lot of typing work to get these work as

[NTG-context] customized item list symbol/graphic

2010-12-11 Thread Jan-Erik Hägglöf
HI All Contexters out there! I'm a Guy from sweden who will appreciate a possible solution to following problem. I'm interested in to do a personalized itemlist with a symbol created in metapost. Here is an example: \startuniqueMPgraphic{square} draw roundedsquare(20,20,2) withrgbcolor

Re: [NTG-context] customized item list symbol/graphic

2010-12-11 Thread Jan-Erik Hägglöf
On 2010-12-11 14:42, Taco Hoekwater wrote: On 12/11/2010 02:27 PM, Jan-Erik Hägglöf wrote: HI All Contexters out there! I'm a Guy from sweden who will appreciate a possible solution to following problem. I'm interested in to do a personalized itemlist with a symbol created in metapost. Here

Re: [NTG-context] customized item list symbol/graphic

2010-12-11 Thread Jan-Erik Hägglöf
On 2010-12-11 16:23, Wolfgang Schuster wrote: Am 11.12.2010 um 15:37 schrieb Jan-Erik Hägglöf: Thanks that worked but how to manage more vertical whitespace? Before and after the list you can set the vertical space with \setupitemize [before={\blank[dimension orkeyword]}, after

Re: [NTG-context] customized item list symbol/graphic

2010-12-11 Thread Jan-Erik Hägglöf
On 2010-12-11 17:14, Jan-Erik Hägglöf wrote: On 2010-12-11 16:23, Wolfgang Schuster wrote: Am 11.12.2010 um 15:37 schrieb Jan-Erik Hägglöf: Thanks that worked but how to manage more vertical whitespace? Before and after the list you can set the vertical space with \setupitemize [before

Re: [NTG-context] customized item list symbol/graphic [solved]

2010-12-11 Thread Jan-Erik Hägglöf
On 2010-12-11 18:24, Wolfgang Schuster wrote: Am 11.12.2010 um 17:14 schrieb Jan-Erik Hägglöf: None of the above setting worked for me. Even tried \startitemize[columns,2*broad][inbetween={\blank[1cm]}] With the „columns“ keyword you get also packed items, to unset this setting add „unpacked

[NTG-context] contextgarden down?

2010-12-30 Thread Jan-Erik Hägglöf
Is contextgarden down, cannot access it for some reason? /Janneman ___ If your question is of interest to others as well, please add an entry to the Wiki! maillist : ntg-context@ntg.nl /

Re: [NTG-context] contextgarden down?

2010-12-30 Thread Jan-Erik Hägglöf
On 2010-12-30 14:43, luigi scarso wrote: On Thu, Dec 30, 2010 at 2:27 PM, Khaled Hosnykhaledho...@eglug.org wrote: On Thu, Dec 30, 2010 at 02:12:11PM +0100, luigi scarso wrote: On Thu, Dec 30, 2010 at 1:53 PM, Jan-Erik Hägglöf janerik.hagg...@bredband.net wrote: Is contextgarden down

Re: [NTG-context] about \sym{} and n*broad

2009-09-15 Thread Jan-Erik Hägglöf
dalyoung skrev: Dear all, I try next code to get the following form of text. \startitemize[4*broad] \sym{Type 1} This is a test. bla bla ...bla bla bla ...bla bla bla \sym{Type 2} This is the second item. bla bla bla ... bla bla bla \stopitemize Type 1 This is a test. bla bla bla

Re: [NTG-context] bibtex referencelist doesn't show up with mkiv

2009-09-23 Thread Jan-Erik Hägglöf
Aditya Mahajan skrev: On Tue, 22 Sep 2009, Thomas A. Schmitz wrote: On Sep 22, 2009, at 9:17 PM, Janneman wrote: Hi All! It seems to be broken in some way when I try this example This works here: \setuppublications[state=start] \setupbibtex[database=testbib] \starttext \section{one}

[NTG-context] itemize fail in mkiv

2009-09-23 Thread Jan-Erik Hägglöf
HI ALL! When using following example in ConTeXt ver: 2009.09.21 17:39 MKII fmt: 2009.9.21 \starttext \startitemize[n,packed,broad] \item first item \item second item \item third item \stopitemize \stoptext it works as expected, except for the mysterious warning pdfTeX warning: pdftex: no

Re: [NTG-context] bibtex referencelist doesn't show up with mkiv

2009-09-23 Thread Jan-Erik Hägglöf
The only sequence that has effect is \completepublications[criterium=all] and this shows only the cited titles as I wished but fairly expected. So this should be clarified on the wiki or in bibmod-doc. Regards Janneman

Re: [NTG-context] bibtex referencelist doesn't show up with mkiv

2009-09-23 Thread Jan-Erik Hägglöf
Taco Hoekwater skrev: Jan-Erik Hägglöf wrote: The only sequence that has effect is \completepublications[criterium=all] and this shows only the cited titles as I wished but fairly expected. So this should be clarified on the wiki or in bibmod-doc. If you feel bibmod-doc is unclear

Re: [NTG-context] [OT] creating-a-style-file-in-context

2009-10-25 Thread Jan-Erik Hägglöf
Here is a test and the attached output and also the path of where the fonts are placed in file font.dir and the output from mtxrun --script fonts list museo* in fonts.list Janneman Can you test what happens with a minimal file: \definefont[testfont][name:museo700] \starttext \testfont

Re: [NTG-context] [OT] creating-a-style-file-in-context

2009-10-25 Thread Jan-Erik Hägglöf
Aditya Mahajan skrev: On Sun, 25 Oct 2009, Jan-Erik Hägglöf wrote: Here is a test and the attached output and also the path of where the fonts are placed in file font.dir and the output from mtxrun --script fonts list museo* in fonts.list Can context read the fonts? One way to check

Re: [NTG-context] [OT] creating-a-style-file-in-context

2009-10-25 Thread Jan-Erik Hägglöf
Aditya Mahajan skrev: On Sun, 25 Oct 2009, Jan-Erik Hägglöf wrote: Here is a test and the attached output and also the path of where the fonts are placed in file font.dir and the output from mtxrun --script fonts list museo* in fonts.list Can context read the fonts? One way to check

Re: [NTG-context] [OT] creating-a-style-file-in-context

2009-10-25 Thread Jan-Erik Hägglöf
Wolfgang Schuster skrev: Am 21.10.2009 um 11:05 schrieb luigi scarso: http://randomdeterminism.wordpress.com/2009/10/21/creating-a-style-file-in-context/ Why not simplefonts instead of typescript files, there is also a definefont command \definesimplefont[interludefont][Museo700 at

Re: [NTG-context] [OT] creating-a-style-file-in-context

2009-10-25 Thread Jan-Erik Hägglöf
Wolfgang Schuster skrev: Am 25.10.2009 um 15:17 schrieb Jan-Erik Hägglöf: Thanks for the fonts i've replaced them , moved everything my home/user/.fonts directory Can you put them in your TeX directory and see what happens, on my system the font lies here: /Users/wolf/context/tex/texmf

[NTG-context] Label in externalfigures

2020-02-12 Thread Jan-Erik Hägglöf
Dear Members! I have a question on how to achieve something like this. \IncludePicture[picture.pdf][xpos=2, ypos= 4, label=some text] I know there is a similar function in the simple slides module but I need it in my documents, often exams to my students, so caption is mainly not necessary.

Re: [NTG-context] Label in externalfigures

2020-02-12 Thread Jan-Erik Hägglöf
Wolfgang Schuster > : > > On Wed, 12 Feb 2020 16:49:02 +0100 > Jan-Erik Hägglöf wrote: > >> Dear Members! >> >> I have a question on how to achieve something like this. >> >> \IncludePicture[picture.pdf][xpos=2, ypos= 4, label=some text] > &g

[NTG-context] Error in MetaFun LMTX

2020-02-25 Thread Jan-Erik Hägglöf
The following code gives an error, my goal is to draw 4 different arrows but only three functions successfully. The error log shows metapost> initializing number mode 'scaled' metapost log> metapost log> loading metafun, including plain.mp version 1.004 for metafun iv and xl

Re: [NTG-context] Error in MetaFun LMTX

2020-02-25 Thread Jan-Erik Hägglöf
Sorry, I discovered the issue myself Space between the : and = sign was the origin of error. Problem solved by itself > 25 feb. 2020 kl. 18:34 skrev Jan-Erik Hägglöf : > > The following code gives an error, my goal is to draw 4 different arrows but > only three functions

Re: [NTG-context] European style Circuitikz error

2020-02-27 Thread Jan-Erik Hägglöf
as rectangles instead /Janne > 27 feb. 2020 kl. 13:23 skrev Jan-Erik Hägglöf : > > In page 8 inte e Circuitikz manual the settings to get European style > components e.g resistors like rectangular boxes instead of default looking. > > It says this > > \usemodule[circuitikz][

[NTG-context] European style Circuitikz error

2020-02-27 Thread Jan-Erik Hägglöf
In page 8 inte e Circuitikz manual the settings to get European style components e.g resistors like rectangular boxes instead of default looking. It says this \usemodule[circuitikz][american] When I do this \usemodule[circuitikz][european] It gives an error. ! Package pgfkeys Error: I do

Re: [NTG-context] Label in externalfigures

2020-02-14 Thread Jan-Erik Hägglöf
edrawarrow linje withcolor black ;draw thelabel("37°",(160,-330));draw thelabel("$5,0$m",(150,-160));\stopMPcodeThis was a fun learning experience so thanks again13 feb. 2020 kl. 10:35 skrev Jan-Erik Hägglöf <janerik.hagg...@bahnhof.se>:I’ve tested this but it appears outsi

Re: [NTG-context] Label in externalfigures

2020-02-13 Thread Jan-Erik Hägglöf
,27.367201)); \stopMPcode Thanks /Janne > 12 feb. 2020 kl. 20:10 skrev Hans Hagen : > > On 2/12/2020 6:01 PM, Jan-Erik Hägglöf wrote: >> The expected output should be like this, see example in the link below >> https://drive.google.com/file/d/13pCuUvNeL7T_Hs7-qrKZclkadcJ7_jVV/vie

[NTG-context] running gnuplot failure

2020-03-29 Thread Jan-Erik Hägglöf
Hi!I have tried to run the following codeexample with no success\usemodule[gnuplot] \setupGNUPLOTterminal[context][width=5in,height=2.5in,fontscale=0.9] \setupGNUPLOTterminal[tikz][width=5in,height=2.5in,fontscale=0.9] \starttext\startGNUPLOTinclusionsset samples 400set key left Left

Re: [NTG-context] running gnuplot failure

2020-03-29 Thread Jan-Erik Hägglöf
That was working just fine, thank you so much! Janne > 30 mars 2020 kl. 01:48 skrev Hans Hagen : > > On 3/29/2020 8:32 PM, Jan-Erik Hägglöf wrote: >> Hi! >> I have tried to run the following codeexample with no success >> \usemodule >> [gnuplot] > in lmtx g

Re: [NTG-context] Typesetting Markdown - Part 8

2020-04-28 Thread Jan-Erik Hägglöf
cd $HOME/dev/writing/book > ./build -V -c -y -i jekyll-hyde -d standard-ebooks/jekyll-hyde \ > -b robert-louis-stevenson_the-strange-case-of-dr-jekyll-and-mr-hyde > > This is noted at the bottom of the preamble section. > > Enjoy! > > On Tue, Apr

Re: [NTG-context] Typesetting Markdown - Part 8

2020-04-28 Thread Jan-Erik Hägglöf
Is there a running example ? I’m not sure how to fill in the commandline > 28 apr. 2020 kl. 09:33 skrev Henning Hraban Ramm : > > Yes, the naming is completely up to you. > > I use: > > project_something.tex > env_something.tex > prd_oneissue.tex > c_onechapter.tex > > That’s also what my

Re: [NTG-context] contextproject script (was: Typesetting Markdown - Part 8)

2020-04-28 Thread Jan-Erik Hägglöf
That was clarifying. Thanks a lot and good work done by you! Take Care Best wishes, Janne > 28 apr. 2020 kl. 16:39 skrev Henning Hraban Ramm : > > >> Am 28.04.2020 um 16:12 schrieb Jan-Erik Hägglöf : >> >>> 28 apr. 2020 kl. 09:33 skrev Henning Hraban R

Re: [NTG-context] Setting up macvim in mac os catalina to work with LMTX

2020-04-22 Thread Jan-Erik Hägglöf
ms to have no effect > 22 apr. 2020 kl. 17:22 skrev janerik.hagglof : > > In what file do I put the path setting and which location? > > Thanks and regards > > > > > > Med Vänlig Hälsning > > Jan-Erik Hägglöf > > > Originalmeddelande ---

Re: [NTG-context] Setting up macvim in mac os catalina to work with LMTX

2020-04-22 Thread Jan-Erik Hägglöf
: E40: Kan inte öppna felfil /Users/janneman/Documents/CTX/GNUPLOT/test3.log > 22 apr. 2020 kl. 17:22 skrev janerik.hagglof : > > In what file do I put the path setting and which location? > > Thanks and regards > > > > > > Med Vänli

[NTG-context] Setting up macvim in mac os catalina to work with LMTX

2020-04-21 Thread Jan-Erik Hägglöf
Hi ! I am curious about testing macvim and it seems doing fine in edit mode. But how do i set up the typesetting engine? As far as I understand, there is, the command :ConteXt with guidance from the wiki https://wiki.contextgarden.net/Vim But I do not

Re: [NTG-context] Setting up macvim in mac os catalina to work with LMTX

2020-04-22 Thread Jan-Erik Hägglöf
the question is where do I put this line permanent because it is strange to type this every time I want to typeset something. Regards Janne > 22 apr. 2020 kl. 16:49 skrev Nicola : > > On 2020-04-21, Jan-Erik Hägglöf wrote: >> Hi ! >> >> I am curious about testing mac

[NTG-context] Issue with rendering arrows in lmtx

2020-03-17 Thread Jan-Erik Hägglöf
Hi All! When I invoke this command \startMPcode picture p ; p := lmt_svg [ filename ="pil.svg" ]; draw p; \stopMPcode I get weird results, the arrowhead points in wrong direction and is very tiny compared to the size it was meant to have. Here is the .svg code from the saved file (pil.svg)

Re: [NTG-context] Issue with rendering arrows in lmtx

2020-03-17 Thread Jan-Erik Hägglöf
Ok, thanks for your advice. It seems that it is better to do framework in MetaFun and use svg picture as a component instead of opposite. Best wishes to you all Janne > 17 mars 2020 kl. 16:58 skrev Taco Hoekwater : > > > >> On 17 Mar 2020, at 15:51, Jan-Erik Hägglöf &

Re: [NTG-context] error running wiki example with labels

2020-06-25 Thread Jan-Erik Hägglöf
t;t...@elvenkind.com>:Hi,On 24 Jun 2020, at 23:13, Jan-Erik Hägglöf <janerik.hagg...@bahnhof.se> wrote:Is the difference when I’m running mtxrun … inside macvimI would suspect PATH problems. Try running this bit of code both ways,and compare the differences:\starttext\startluacodefor a,v in pair

[NTG-context] error running wiki example with labels

2020-06-24 Thread Jan-Erik Hägglöf
Hello All! In the page https://wiki.contextgarden.net/Labels I’ve tried with no success to run those examples given at the page. The error complaint as the log shows below return { ["filename"]="./labels3.tex", ["lastluaerror"]="function call [801]:

Re: [NTG-context] error running wiki example with labels

2020-06-24 Thread Jan-Erik Hägglöf
ext ? in the terminal24 juni 2020 kl. 21:05 skrev Jan-Erik Hägglöf <janerik.hagg...@bahnhof.se>:lua error       > lua error on line 70 in file ./labels3.tex:function call [801]: ...-64/tex/texmf-context/tex/context/base/mkiv/node-syn.lua:435: attempt to index a nil value (upvalue

Re: [NTG-context] error running wiki example with labels

2020-06-24 Thread Jan-Erik Hägglöf
From the terminal running context it works fine but the problem appeared inside macvim so it seems to be related to macvim. > 24 juni 2020 kl. 21:24 skrev Aditya Mahajan : > > On Wed, 24 Jun 2020, Jan-Erik Hägglöf wrote: > >> Hello All! >> >> In the page https:/

Re: [NTG-context] error running wiki example with labels

2020-06-26 Thread Jan-Erik Hägglöf
xgyrepagella-math.otf, texgyrepagella-regular.otf mkiv lua stats > font engine: otf 3.111, afm 1.513, tfm 1.000, 7 instances, 3 shared in backend, 3 common vectors, 0 common hashes, load time 0.223 seconds mkiv lua stats > font embedding time: 0.015 seconds, 1 fonts mkiv lua stats