Re: [NTG-context] Two issues with character alignment

2014-09-05 Thread Hans Hagen

On 9/4/2014 10:58 PM, Maggyero wrote:

I have found two issues with character alignment (see the following
minimal example): one when \\ is used in a cell instead of \crlf,
another one when \high or \low are used in a cell. Is it a bug?


\starttext

\setupTABLE[%
 aligncharacter=yes,
 alignmentcharacter=.,
 align=middle]

\subject{Reference}

\startTABLE
 \NC Foo\crlf bar\NC \NR
 \NC 1.1 \NC \NR
 \NC 11.1\NC \NR
\stopTABLE

\subject{Double backslash issue}

\startTABLE
 \NC Foo\\bar\NC \NR
 \NC 1.1 \NC \NR
 \NC 11.1\NC \NR
\stopTABLE

\subject{Sub/superscript issue}

\startTABLE
 \NC Foo\high{bar}   \NC \NR
 \NC 1.1 \NC \NR
 \NC 11.1\NC \NR
\stopTABLE

\startTABLE
 \NC Foo\low{bar}\NC \NR
 \NC 1.1 \NC \NR
 \NC 11.1\NC \NR
\stopTABLE

\stoptext


\startTABLE
\NC \nocharacteralign Foo\crlf bar\NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\subject{Double backslash issue}

\startTABLE
\NC \nocharacteralign Foo\\bar\NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\subject{Sub/superscript issue}

\startTABLE
\NC \nocharacteralign Foo\high{bar}   \NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\startTABLE
\NC \nocharacteralign Foo\low{bar}\NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE


--

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
 | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


[NTG-context] Two issues with character alignment

2014-09-04 Thread Maggyero
I have found two issues with character alignment (see the following minimal
example): one when \\ is used in a cell instead of \crlf, another one when
\high or \low are used in a cell. Is it a bug?


\starttext

\setupTABLE[%
aligncharacter=yes,
alignmentcharacter=.,
align=middle]

\subject{Reference}

\startTABLE
\NC Foo\crlf bar\NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\subject{Double backslash issue}

\startTABLE
\NC Foo\\bar\NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\subject{Sub/superscript issue}

\startTABLE
\NC Foo\high{bar}   \NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\startTABLE
\NC Foo\low{bar}\NC \NR
\NC 1.1 \NC \NR
\NC 11.1\NC \NR
\stopTABLE

\stoptext
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___