Re: [NTG-context] latest standalone—lua error

2021-04-30 Thread Hans Hagen
On 4/30/2021 5:47 PM, Alan Bowen wrote: I removed and then reinstalled luametex: the problem persists. The stix fonts changed names (again) so the 2 in the names are gone and text is in the filenames ... Can you check if your names.tma has 2 in names? Here it works ok with 'two's. Hans

Re: [NTG-context] latest standalone—lua error

2021-04-30 Thread Hans Hagen
On 4/30/2021 5:47 PM, Alan Bowen wrote: I removed and then reinstalled luametex: the problem persists. A. On Fri, Apr 30, 2021 at 11:21 AM Alan Bowen > wrote: Hi, Wolfgang— The mwe is: \definefontfamily[mainface][rm][STIX Two Text]

Re: [NTG-context] latest standalone—lua error

2021-04-30 Thread Alan Bowen
I removed and then reinstalled luametex: the problem persists. A. On Fri, Apr 30, 2021 at 11:21 AM Alan Bowen wrote: > Hi, Wolfgang— > > The mwe is: > \definefontfamily[mainface][rm][STIX Two Text] > [protrusion=quality, > expansion=quality, > mode=node, > force=yes, > features={default,

Re: [NTG-context] latest standalone—lua error

2021-04-30 Thread Alan Bowen
Hi, Wolfgang— The mwe is: \definefontfamily[mainface][rm][STIX Two Text] [protrusion=quality, expansion=quality, mode=node, force=yes, features={default, f:oldstyle}, ] ] \definefallbackfamily[mainface] [mm] [STIX Two Text] [range=digitsnormal, force=yes, features=f:oldstyle]

Re: [NTG-context] latest standalone—lua error

2021-04-30 Thread Wolfgang Schuster
Alan Bowen schrieb am 30.04.2021 um 13:19: Hi, Wolfgang— I copied all the fonts to a new document (file attached) and ran ConTeXt. The problem persists. The cause, I think, comes in the lines: \definefallbackfamily[mainface] [mm] [STIX Two Text] [range=digitsnormal, force=yes,

Re: [NTG-context] latest standalone—lua error

2021-04-30 Thread Alan Bowen
Hi, Wolfgang— I copied all the fonts to a new document (file attached) and ran ConTeXt. The problem persists. The cause, I think, comes in the lines: \definefallbackfamily[mainface] [mm] [STIX Two Text] [range=digitsnormal, force=yes, features=f:oldstyle] which used to give me oldstyle

Re: [NTG-context] latest standalone—lua error

2021-04-29 Thread Wolfgang Schuster
Alan Bowen schrieb am 29.04.2021 um 18:29: With  ConTeXt  ver: 2021.04.28 18:39 LMTX  fmt: 2021.4.29  int, I am now getting the following error on compiling with files that were OK previously. Is there something that I need to change? The error is caused by the fallback font for math but you

[NTG-context] latest standalone—lua error

2021-04-29 Thread Alan Bowen
With ConTeXt ver: 2021.04.28 18:39 LMTX fmt: 2021.4.29 int, I am now getting the following error on compiling with files that were OK previously. Is there something that I need to change? Alan lua error > lua error on line 232 in file ../../env_Aestimatio-00.tex: registered function

Re: [NTG-context] latest LMTX breaks XML compilation

2021-02-08 Thread Hans Hagen
On 2/8/2021 10:11 PM, Pablo Rodriguez wrote: Hans, using latest from (2021.02.08 17:03) with all my XML sources breaks compilation with the following error: > tex error on line 2 in file : Argument of \xmlw has an extra } How I can detect when ConTeXt uses \xmlw? put a \tracingall

[NTG-context] latest LMTX breaks XML compilation

2021-02-08 Thread Pablo Rodriguez
Hans, using latest from (2021.02.08 17:03) with all my XML sources breaks compilation with the following error: > tex error on line 2 in file : Argument of \xmlw has an extra } How I can detect when ConTeXt uses \xmlw? Latest from 2021.02.08 17:03 doesn’t have this problem. Many thanks for

Re: [NTG-context] latest lmtx, \startitemeze and Multipage TABLEs no longer works

2020-11-16 Thread Bertrand Masson
Thanks, I'm waiting for the next version Le 16/11/2020 à 17:36, Wolfgang Schuster a écrit : Bertrand Masson schrieb am 16.11.2020 um 14:29: Hello With the latest version of lmtx (ConTeXt  ver: 2020.11.04 09:40 LMTX  fmt: 2020.11.14) \ startitemeze [2] no longer works. Bullets (-) no longer

Re: [NTG-context] latest lmtx, \startitemeze and Multipage TABLEs no longer works

2020-11-16 Thread Wolfgang Schuster
Bertrand Masson schrieb am 16.11.2020 um 14:29: Hello With the latest version of lmtx (ConTeXt  ver: 2020.11.04 09:40 LMTX fmt: 2020.11.14) \ startitemeze [2] no longer works. Bullets (-) no longer appear! This is already fixed, you're just a few versions behind. Multipage TABLEs with

Re: [NTG-context] latest lmtx, \startitemeze and Multipage TABLEs no longer works

2020-11-16 Thread Hans van der Meer
Shouldn't it be \startitemize ? Or is there another problem? dr. Hans van der Meer > On 16 Nov 2020, at 14:29, Bertrand Masson wrote: > > Hello > With the latest version of lmtx (ConTeXt ver: 2020.11.04 09:40 LMTX fmt: > 2020.11.14) \ startitemeze [2] no longer works. Bullets (-) no longer

[NTG-context] latest lmtx, \startitemeze and Multipage TABLEs no longer works

2020-11-16 Thread Bertrand Masson
Hello With the latest version of lmtx (ConTeXt  ver: 2020.11.04 09:40 LMTX  fmt: 2020.11.14) \ startitemeze [2] no longer works. Bullets (-) no longer appear! Multipage TABLEs with \bTABLE[split=repeat,option=stretch] no longer works. Bertrand

Re: [NTG-context] latest lmtx

2020-11-15 Thread Hans Hagen
On 11/15/2020 12:05 AM, Thomas A. Schmitz wrote: On 11/14/20 12:17 AM, j.ha...@xs4all.nl wrote: Take today's upload. Hi Hans, since you mentioned that such buglets may occur, here's another one, but in this case, the error message is obscure to me, and I have no clue where in the

Re: [NTG-context] latest lmtx

2020-11-14 Thread Thomas A. Schmitz
On 11/14/20 12:17 AM, j.ha...@xs4all.nl wrote: Take today's upload. Hi Hans, since you mentioned that such buglets may occur, here's another one, but in this case, the error message is obscure to me, and I have no clue where in the environment file it is triggered (it's an xml-project):

Re: [NTG-context] latest lmtx

2020-11-14 Thread Thomas A. Schmitz
> On 14. Nov 2020, at 00:17, j.ha...@xs4all.nl wrote: > > Take today's upload. > > Hans > > Hi Hans, Yes, it works again! Thanks for the quick fix; I’m looking forward to new adventures in context land… All best Thomas

Re: [NTG-context] latest lmtx

2020-11-13 Thread j . hagen
Take today's upload.HansOp 13 nov. 2020 23:04 schreef "Thomas A. Schmitz" :Hi all, I hadn't upgraded in a couple of weeks because I was in the middle of a project. Now that I'm up to 2020.11.08, I have a problem: I can't load my third party modules; they all throw an error. The error message is

[NTG-context] latest lmtx

2020-11-13 Thread Thomas A. Schmitz
Hi all, I hadn't upgraded in a couple of weeks because I was in the middle of a project. Now that I'm up to 2020.11.08, I have a problem: I can't load my third party modules; they all throw an error. The error message is Use of \syst_modules_setup_yes doesn't match its definition So I

Re: [NTG-context] latest lmtx

2020-09-05 Thread Alan Bowen
Hi, Otared— I had #!/bin/zsh #set path= ($path /usr/texbin /Applications/LuaMetaTeX/tex/texmf-osx-64/bin) export PATH=~/context-osx-64/tex/texmf-osx-64/bin:~/context-osx-64/bin:~/context-osx-64/tex/texmf-osx-64/bin ~/context-osx-64/tex/texmf-osx-64/bin/mtxrun --autogenerate --script context

Re: [NTG-context] latest lmtx

2020-09-05 Thread Otared Kavian
Hi Alan, Where did you install LuaMetaTeX? For instance my LuaMetaTeX.engine contains the following three lines: #!/bin/bash export PATH=/context-osx-64/tex/texmf-osx-64/bin:/context-osx-64/bin:/context-osx-64/tex/texmf-osx-64/bin /context-osx-64/tex/texmf-osx-64/bin/mtxrun --autogenerate

Re: [NTG-context] latest lmtx

2020-09-05 Thread Alan Bowen
No, Hraban, and I have never had a directory /Users/bowen1/context-osx-64. Does Luametatex 2.10 (Context 2020.09.03) now require one? Alan On Sat, Sep 5, 2020 at 10:26 AM Henning Hraban Ramm wrote: > > > > Am 05.09.2020 um 16:08 schrieb Alan Bowen : > > > > When I process > > \starttext > >

Re: [NTG-context] latest lmtx

2020-09-05 Thread Henning Hraban Ramm
> Am 05.09.2020 um 16:08 schrieb Alan Bowen : > > When I process > \starttext > Hello, world! > \stoptext > I get the following error message: > > /Users/bowen1/Library/TeXShop/Engines/LuaMetaTeX.engine:9: no such file or > directory: /Users/bowen1/context-osx-64/tex/texmf-osx-64/bin/mtxrun >

[NTG-context] latest lmtx

2020-09-05 Thread Alan Bowen
When I process \starttext Hello, world! \stoptext I get the following error message: /Users/bowen1/Library/TeXShop/Engines/LuaMetaTeX.engine:9: no such file or directory: /Users/bowen1/context-osx-64/tex/texmf-osx-64/bin/mtxrun resolvers | formats | executing runner 'run luametatex

Re: [NTG-context] latest silly question - insert unicode character?

2020-06-25 Thread Hans Hagen
On 6/25/2020 12:38 AM, Mike Cooper wrote: How does one insert/use a special character?At this particular time, I want Double Prime: Unicode 02BA. \setupbodyfont[dejavu] \setupbodyfont[dejavu] \starttext \Uchar "02BA % followed by space or \relax or {} \utfchar{"02BA}%

[NTG-context] latest silly question - insert unicode character?

2020-06-24 Thread Mike Cooper
Hi. Me again. How does one insert/use a special character? At this particular time, I want Double Prime: Unicode 02BA. How?? THANKS! Mike Cooper Technical Trainer Murchison Drilling Schools, Inc. 2501 Juan Tabo NE Albuquerque, NM 87112 Tel: (505) 293-6271 Fax: (505) 298-5294 Email:

Re: [NTG-context] Latest changes in some size registers

2019-02-27 Thread Willi Egger
Wolfgang I would like to have your capacity of remembering things… Thank you so much! Willi > On 25 Feb 2019, at 23:30, Wolfgang Schuster > wrote: > > Willi Egger schrieb am 25.02.19 um 22:44: >> Hi Wolfgang, >> >> that is a nice coincidence! I was stuck just today with this very issue! >>

Re: [NTG-context] Latest changes in some size registers

2019-02-25 Thread Wolfgang Schuster
Willi Egger schrieb am 25.02.19 um 22:44: Hi Wolfgang, that is a nice coincidence! I was stuck just today with this very issue! Thank you for this information. You can try the two solutions (“grid=no” or “strut=no”) from this old thread:

Re: [NTG-context] Latest changes in some size registers

2019-02-25 Thread Willi Egger
Hi Wolfgang, that is a nice coincidence! I was stuck just today with this very issue! Thank you for this information. Best Willi > On 25 Feb 2019, at 18:39, Wolfgang Schuster > wrote: > > Martin Bruchanov schrieb am 22.02.19 um 04:37: >> Hi all, >> >> I have some very condensed documents

Re: [NTG-context] Latest changes in some size registers

2019-02-25 Thread Martin Bruchanov
Hi Wolfang, Thank you very much for both answers! I have updated it on wiki: https://wiki.contextgarden.net/Visual_Debugging#Layout Regards, BruXy On 2019-02-25 1:39 p.m., Wolfgang Schuster wrote: Martin Bruchanov schrieb am 22.02.19 um 04:37: Hi all, I have some very condensed documents

Re: [NTG-context] Latest changes in some size registers

2019-02-25 Thread Wolfgang Schuster
Martin Bruchanov schrieb am 22.02.19 um 04:37: Hi all, I have some very condensed documents which should fit on one page: http://gnulinux.guru/bash_cheatsheet.pdf Without any major change in style definition, there is more space around sections or itemize:

Re: [NTG-context] Latest changes in some size registers

2019-02-25 Thread Wolfgang Schuster
Martin Bruchanov schrieb am 25.02.19 um 17:39: I have just done some manual  changes to solve this:  before={\blank[1*small]} to  before={\blank[-5pt]},% Btw, is there any way to display values of these visual attributes when I need to debug "setupsection" setting? (I am usually changing a

Re: [NTG-context] Latest changes in some size registers

2019-02-25 Thread Martin Bruchanov
I have just done some manual  changes to solve this:  before={\blank[1*small]} to  before={\blank[-5pt]},% Btw, is there any way to display values of these visual attributes when I need to debug "setupsection" setting? (I am usually changing a lot of stuff and comparing it with Wiki and

[NTG-context] Latest changes in some size registers

2019-02-21 Thread Martin Bruchanov
Hi all, I have some very condensed documents which should fit on one page: http://gnulinux.guru/bash_cheatsheet.pdf Without any major change in style definition, there is more space around sections or itemize: http://gnulinux.guru/bash_cheatsheet_diff.pdf Source code is here:

Re: [NTG-context] latest beta (october 18th): likely bug in \mirror

2018-11-24 Thread Hans Hagen
On 11/23/2018 1:31 PM, mf wrote: A much simpler example: \starttext \ConTeXt\ version: \contextversion. A paragraph with a mirrored \mirror{word} inside. Another paragraph. \stoptext i'll send you a fix -

Re: [NTG-context] latest beta (November 18th): likely bug in \mirror

2018-11-23 Thread mf
Sorry for the mistake in the subject: the bug is in the latest beta of November, 18th. ___ If your question is of interest to others as well, please add an entry to the Wiki! maillist : ntg-context@ntg.nl /

Re: [NTG-context] latest beta (october 18th): likely bug in \mirror

2018-11-23 Thread mf
A much simpler example: \starttext \ConTeXt\ version: \contextversion. A paragraph with a mirrored \mirror{word} inside. Another paragraph. \stoptext mirror-not-ok.pdf Description: Adobe PDF document mirror-ok.pdf Description: Adobe PDF document

[NTG-context] latest beta (october 18th): likely bug in \mirror

2018-11-23 Thread mf
Hello list, the effect of \mirror in latest beta looks extended to the following content in the page. It seems a bug in the \mirror macro or another bug that is reflected in \mirror (forgive the pun). Massimiliano % (the following brace is a modified version of one posted by Wolfgang)

[NTG-context] Latest beta

2018-08-20 Thread Fabrice Couvreur
Hello, Compile error after context standalone update Thanks Fabrice Running `ConTeXt' on `Test' with ``context --once --texutil --purgeall --nonstop Test.tex'' resolvers | trees | analyzing 'home:texmf' mtx-context | run 1: luatex

Re: [NTG-context] latest beta (2018.08.14 23:10)

2018-08-15 Thread Pablo Rodriguez
On 08/15/2018 06:31 PM, Pablo Rodriguez wrote: > On 08/15/2018 05:49 PM, Alan Bowen wrote: >> When I run the latest standalone beta, the following >> >> \starttext >> Hello, world! >> \stoptext >> >> fails with the error message: >> [...] > > I can confirm the break in the compilation. Many

Re: [NTG-context] latest beta (2018.08.14 23:10)

2018-08-15 Thread Pablo Rodriguez
On 08/15/2018 05:49 PM, Alan Bowen wrote: > When I run the latest standalone beta, the following > > \starttext > Hello, world! > \stoptext > > fails with the error message: > [...] I can confirm that the break in the compilation. Exactly the same message here. Pablo -- http://www.ousia.tk

[NTG-context] latest beta (2018.110.14)

2018-08-15 Thread Alan Bowen
When I run the latest standalone beta, the following \starttext Hello, world! \stoptext fails with the error message: lua error > lua error on line 5 in file /Users/bowen1/Desktop/TestTeX/test-01.tex: ...eXt/tex/texmf-context/tex/context/base/mkiv/cldf-ini.lua:1120: no string to print

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Hans Hagen
On 6/25/2018 4:01 PM, Henning Hraban Ramm wrote: Am 2018-06-25 um 14:18 schrieb Hans Hagen : On 6/24/2018 10:07 PM, Henning Hraban Ramm wrote: \starttext \index{sample} \index{fun+games}\index{fun+stuff} %\index{fun} btw, index entries will only work well with an anchor so loose \index

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Alan Braslau
"Mathematics is the art of giving the same name to different things. It is enough that these things, though differing in matter, should be similar in form, to permit their being, so to speak, cast in the same mold. When the language has been carefully chosen, one is surprised to discover that all

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Henning Hraban Ramm
Am 2018-06-25 um 14:18 schrieb Hans Hagen : > On 6/24/2018 10:07 PM, Henning Hraban Ramm wrote: \starttext \index{sample} \index{fun+games}\index{fun+stuff} %\index{fun} > > btw, index entries will only work well with an anchor so loose \index without > something following

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Henning Hraban Ramm
Am 2018-06-25 um 14:15 schrieb Hans Hagen : > On 6/24/2018 10:07 PM, Henning Hraban Ramm wrote: >> Am 2018-06-24 um 21:57 schrieb Hans Hagen : >>> as there is no index entry blah, humbug or bug ... so you would be fooling >>> your reader >> I understand the rationale, and it could be a nice

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Hans Hagen
On 6/24/2018 10:07 PM, Henning Hraban Ramm wrote: \starttext \index{sample} \index{fun+games}\index{fun+stuff} %\index{fun} btw, index entries will only work well with an anchor so loose \index without something following it will not show the right page numbers (if at all)

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Hans Hagen
On 6/24/2018 10:07 PM, Henning Hraban Ramm wrote: Am 2018-06-24 um 21:57 schrieb Hans Hagen : On 6/23/2018 5:10 PM, Alan Bowen wrote: The latest beta (ConTeXtver: 2018.06.23 12:12 MKIV betafmt: 2018.6.23) processes without a hitch but \seeindex is still not working as expected. In \starttext

Re: [NTG-context] latest beta and \seeindex

2018-06-25 Thread Alan Bowen
I should add too that in this particular volume our contributors sometimes mention different terms for the same thing as in “This is called p or q”. Indexing both terms (p and q) separately and the adding x-ref is one way to go but indexing the more commonly used term and adding a mere x-ref for

Re: [NTG-context] latest beta and \seeindex

2018-06-24 Thread Henning Hraban Ramm
Am 2018-06-24 um 21:57 schrieb Hans Hagen : > On 6/23/2018 5:10 PM, Alan Bowen wrote: >> The latest beta (ConTeXtver: 2018.06.23 12:12 MKIV betafmt: 2018.6.23) >> processes without a hitch but \seeindex is still not working as expected. >> In >> \starttext >> \index{sample} >>

Re: [NTG-context] latest beta and \seeindex

2018-06-24 Thread Hans Hagen
On 6/23/2018 5:10 PM, Alan Bowen wrote: The latest beta (ConTeXtver: 2018.06.23 12:12 MKIV betafmt: 2018.6.23) processes without a hitch but \seeindex is still not working as expected. In \starttext \index{sample} \index{fun+games}\index{fun+stuff} %\index{fun} \seeindex{fun}{sample}% now

[NTG-context] latest beta and \seeindex

2018-06-23 Thread Alan Bowen
The latest beta (ConTeXt ver: 2018.06.23 12:12 MKIV beta fmt: 2018.6.23) processes without a hitch but \seeindex is still not working as expected. In \starttext \index{sample} \index{fun+games}\index{fun+stuff} %\index{fun} \seeindex{fun}{sample} % now with heading (as it should be)

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-09 Thread r . ermers
Hi all, I kindly ask for your attention for this problem again. I would like subitems to appear differently in the reference than they are in the listing: 1. item 1 a. subitem a, reference a b. item b c. Item c, reference c 2. Item 2, reference 2 See Item b, 2, 1

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread r . ermers
Hi Otared, Thanks for your time and trouble!. I had found \defineseparatorset[none][][] with the same result: it oppresses the dots. Yes, I want subitems to appear differently in the reference than they are in the listing: 1. item 1 a subitem b subitem 2. item 2 a

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread Otared Kavian
Hi Robert, Again I answered too quickly… excuse-me! If you want to have the subitems appear without the prefix, but references to them contain the number of the item where they appear, I don’t know how to do it. My previous message addresses only the separators between the numbers of the items

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread Otared Kavian
Hi Robert, Sorry I didn’t pay attention to the way you wanted the formatting of sub-items. If you want to remove the separator between numbers, then you may add the following two line after the setups of your itemgroups: \defineseparatorset[nothing][][]

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread r . ermers
Hi Otared, Thanks, the solution works to some extend. It yields the following output. 1. item 1 1.a. subitem a, reference a 1.b. item b 1.b.i. A sub-sub item 1.b.ii. Another sub-sub item, B 1.c. Item c, reference c 2. Item 2, reference 2 See Item 1.b, see

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread Otared Kavian
Hi Robert, I think the issue does not come from the version of Context you are using but rather from a lack of formatting your itemgroups with the keyword « repeat ». I guess what you want to obtain can be achieved with the following example below. At least here with either versions of Context

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread r . ermers
Hi Wolfgang, Otared and others, I installed a new standalone: mtx-context | main context file: /Applications/ContextStandalone/tex/texmf-context/tex/context/base/mkiv/context.mkiv mtx-context | current version: 2018.02.06 18:11 However, I do not manage to get it going. The minimal

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread Wolfgang Schuster
r.erm...@hccnet.nl 7. Februar 2018 um 10:58 Hi Otared, Thanks for your response. In mkii this worked flawlessly. I tried it in mkiv Texlive too (2017.05.15 21:48), but it does not work. Could this be because I have item [it:ref] rather than \startitem[it:ref] …

Re: [NTG-context] Latest beta: reference to items broken in mkiv

2018-02-07 Thread r . ermers
Hi Otared, Thanks for your response. In mkii this worked flawlessly. I tried it in mkiv Texlive too (2017.05.15 21:48), but it does not work. Could this be because I have item [it:ref] rather than \startitem[it:ref] … \stopitem? Anyway, I will install a new standalone - on my Mac (no TeXShop).

Re: [NTG-context] latest binaries for linux

2016-08-08 Thread Pablo Rodriguez
On 08/08/2016 05:41 PM, luigi scarso wrote: > Il 08/ago/2016 17:28, "Pablo Rodriguez" ha scritto: >> >> Dear Luigi, >> >> would it be possible to have version 0.98.0 binaries in the linux >> (32bit) platform for ConTeXt Standalone? >> >> This may fix a nasty bug with US English hyphenation. >> >>

Re: [NTG-context] latest binaries for linux

2016-08-08 Thread luigi scarso
Il 08/ago/2016 17:28, "Pablo Rodriguez" ha scritto: > > Dear Luigi, > > would it be possible to have version 0.98.0 binaries in the linux > (32bit) platform for ConTeXt Standalone? > > This may fix a nasty bug with US English hyphenation. > > Many thanks for your help, > > I can try

[NTG-context] latest binaries for linux

2016-08-08 Thread Pablo Rodriguez
Dear Luigi, would it be possible to have version 0.98.0 binaries in the linux (32bit) platform for ConTeXt Standalone? This may fix a nasty bug with US English hyphenation. Many thanks for your help, Pablo -- http://www.ousia.tk

[NTG-context] Latest LuaTeX version (was: Bug in command \framed)

2016-01-14 Thread Mojca Miklavec
On 12 January 2016 at 22:21, Hans Hagen wrote: > > the windows version is ok (0.87.2 so really the latest from trunk) > > so, what platforms are not 0.87.1 or higher? No single platform (other than Akira's binaries) provides 0.87.1 or later. The latest LuaTeX release was 0.87.0, see:

[NTG-context] latest beta

2015-10-13 Thread Thomas A. Schmitz
Hi Hans, the latest beta does not replace xml entities for which I have defined something like \xmltexentity{degree}{\textdegree} The problem is not there in 2015.09.13 13:31, but in 2015.10.09 21:28 (sorry don't have all the betas in between). I can make you a test file if you need it,

Re: [NTG-context] latest beta

2015-10-13 Thread Hans Hagen
Hi, the latest beta does not replace xml entities for which I have defined something like \xmltexentity{degree}{\textdegree} The problem is not there in 2015.09.13 13:31, but in 2015.10.09 21:28 (sorry don't have all the betas in between). I can make you a test file if you need it, but I

Re: [NTG-context] latest beta

2015-10-13 Thread Schmitz Thomas A.
> On 13 Oct 2015, at 13:41, Hans Hagen wrote: > > if you have a small example ... this whole entity stuff is a mess .. > officially entities are replaced at load time but tex code is delayed .. so > maybe i need to invent some other trick (there was an issue with & ; >

[NTG-context] Latest beta : command that no longer works

2015-04-03 Thread Fabrice Couvreur
With the latest version of Context Standalone, this command \filler[dots] no longer works. Best regards, Fabrice \definefiller[dots][left=\dontleavehmode, right=\hskip\ZeroPoint\par] \starttext \dorecurse{4}{\filler[dots]} \stoptext fab@debian:~$ source context/tex/setuptex Setting

Re: [NTG-context] Latest beta : command that no longer works

2015-04-03 Thread Hans Hagen
On 4/3/2015 8:02 PM, Fabrice Couvreur wrote: 1 \definefiller[dots][left=\dontleavehmode, right=\hskip\ZeroPoint\par] 2 \starttext 3 \dorecurse{4}{\filler[dots]} 4 \stoptext 5 %%% Local Variables: 6 %%% Mode: context 7 %%% End: \zeropoint (no Z P) you were probably

Re: [NTG-context] Latest beta : command that no longer works

2015-04-03 Thread Wolfgang Schuster
Am 03.04.2015 um 20:02 schrieb Fabrice Couvreur fabrice1.couvr...@gmail.com: With the latest version of Context Standalone, this command \filler[dots] no longer works. Best regards, Fabrice \definefiller[dots][left=\dontleavehmode, right=\hskip\ZeroPoint\par] \starttext

Re: [NTG-context] Latest beta : command that no longer works

2015-04-03 Thread Fabrice
Sorry for the mistake. Fabrice ___ If your question is of interest to others as well, please add an entry to the Wiki! maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context webpage :

[NTG-context] Latest beta: reference to items broken in mkiv

2015-04-01 Thread Otared Kavian
Hi Hans, It seems that referencing to items is broken in the latest beta mkiv: for example in the example below the command \in{Item}[ref:2] does not show item number 2. However it works fine in mkii and previous releases. Best regards: OK PS: a minimal example follows %%% begin

[NTG-context] Latest beta: bug with 'convert()'?

2014-12-12 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello, I'm getting the following failure: c:/Ctx-Beta/tex/texmf-context/tex/context/base/lpdf-xmp.lua:109: attempt to call field 'convert' (a nil value) stack traceback: c:/Ctx-Beta/tex/texmf-context/tex/context/base/lpdf-xmp.lua:109: in function 'valid_xmp'

Re: [NTG-context] Latest beta: bug with 'convert()'?

2014-12-12 Thread Hans Hagen
On 12/12/2014 10:32 AM, Procházka Lukáš Ing. - Pontex s. r. o. wrote: Hello, I'm getting the following failure: c:/Ctx-Beta/tex/texmf-context/tex/context/base/lpdf-xmp.lua:109: attempt to call field 'convert' (a nil value) stack traceback:

Re: [NTG-context] Latest beta: bug with 'convert()'?

2014-12-12 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello Hans, hard to imagine ... did you patch one of the lxml-*.lua files? I renewed Ctx now and it seems to work (the reported problem related to the yesterday's beta)... Best regards, Lukas -- Ing. Lukáš Procházka | mailto:l...@pontex.cz Pontex s. r. o. | mailto:pon...@pontex.cz |

Re: [NTG-context] Latest beta: bug with 'convert()'?

2014-12-12 Thread Hans Hagen
On 12/12/2014 1:16 PM, Procházka Lukáš Ing. - Pontex s. r. o. wrote: Hello Hans, hard to imagine ... did you patch one of the lxml-*.lua files? I renewed Ctx now and it seems to work (the reported problem related to the yesterday's beta)... still weird, as i cannot generate betas without

Re: [NTG-context] Latest beta stops loading some ttc fonts

2014-09-26 Thread Hans Hagen
On 9/26/2014 4:06 AM, Hongwen Qiu wrote: Don't know which one changed that caused the above example to fail. I havn't used nsimsun for months, and indeed the above code used to run properly. Just heard from someone that it works in the current but not in the beta. It has to do with the fact

[NTG-context] Latest beta stops loading some ttc fonts

2014-09-25 Thread Hongwen Qiu
The following minimal example used to work fine: \starttypescript [serif] [zhfonts] \definefontsynonym [Serif] [name:nsimsun] \stoptypescript \starttypescript [zhfonts] \definetypeface [zhfonts] [rm] [serif] [zhfonts] \stoptypescript \usetypescript [zhfonts] \setupbodyfont [zhfonts, rm,

Re: [NTG-context] Latest beta stops loading some ttc fonts

2014-09-25 Thread Hans Hagen
On 9/25/2014 10:50 AM, Hongwen Qiu wrote: The following minimal example used to work fine: \starttypescript [serif] [zhfonts] \definefontsynonym [Serif] [name:nsimsun] \stoptypescript \starttypescript [zhfonts] \definetypeface [zhfonts] [rm] [serif] [zhfonts] \stoptypescript

Re: [NTG-context] Latest beta stops loading some ttc fonts

2014-09-25 Thread Hongwen Qiu
在 2014年09月25日 18:50, Hans Hagen 写道: On 9/25/2014 10:50 AM, Hongwen Qiu wrote: The following minimal example used to work fine: \starttypescript [serif] [zhfonts] \definefontsynonym [Serif] [name:nsimsun] \stoptypescript \starttypescript [zhfonts] \definetypeface [zhfonts] [rm] [serif]

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-27 Thread Brian Landy
On Jun 26, 2014, at 5:24 PM, Hans Hagen pra...@wxs.nl wrote: On 6/26/2014 10:48 PM, Hans Hagen wrote: On 6/26/2014 5:06 AM, Brian Landy wrote: On Jun 25, 2014, at 6:53 PM, Hans Hagen pra...@wxs.nl wrote: On 6/25/2014 11:26 PM, Brian R. Landy wrote: When you say next beta do you mean a

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-27 Thread Hans Hagen
On 6/27/2014 8:04 PM, Brian Landy wrote: On Jun 26, 2014, at 5:24 PM, Hans Hagen pra...@wxs.nl wrote: On 6/26/2014 10:48 PM, Hans Hagen wrote: On 6/26/2014 5:06 AM, Brian Landy wrote: On Jun 25, 2014, at 6:53 PM, Hans Hagen pra...@wxs.nl wrote: On 6/25/2014 11:26 PM, Brian R. Landy wrote:

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-26 Thread Hans Hagen
On 6/26/2014 5:06 AM, Brian Landy wrote: On Jun 25, 2014, at 6:53 PM, Hans Hagen pra...@wxs.nl wrote: On 6/25/2014 11:26 PM, Brian R. Landy wrote: When you say next beta do you mean a subsequent minimals release (i.e., this fix should be the 2014.06.22 release)? Or do you mean a new beta

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-26 Thread Hans Hagen
On 6/26/2014 10:48 PM, Hans Hagen wrote: On 6/26/2014 5:06 AM, Brian Landy wrote: On Jun 25, 2014, at 6:53 PM, Hans Hagen pra...@wxs.nl wrote: On 6/25/2014 11:26 PM, Brian R. Landy wrote: When you say next beta do you mean a subsequent minimals release (i.e., this fix should be the

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-25 Thread Brian R. Landy
On Tue, 17 Jun 2014, Hans Hagen wrote: anyhow, i made it work a bit better with tables (extra pass needed) \starttext \enabletrackers[typesetters.characteralign] \bgroup \setupTABLE[column][1][aligncharacter=yes,alignmentcharacter={,}] \bTABLE \bTR \bTD 1,2 \eTD \bTD 1,2 \eTD \bTD

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-25 Thread Hans Hagen
On 6/25/2014 11:26 PM, Brian R. Landy wrote: On Tue, 17 Jun 2014, Hans Hagen wrote: anyhow, i made it work a bit better with tables (extra pass needed) \starttext \enabletrackers[typesetters.characteralign] \bgroup \setupTABLE[column][1][aligncharacter=yes,alignmentcharacter={,}] \bTABLE

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-25 Thread Brian Landy
On Jun 25, 2014, at 6:53 PM, Hans Hagen pra...@wxs.nl wrote: On 6/25/2014 11:26 PM, Brian R. Landy wrote: When you say next beta do you mean a subsequent minimals release (i.e., this fix should be the 2014.06.22 release)? Or do you mean a new beta that you announce more formally on the

[NTG-context] Latest Ctx Beta - input file coding problem?

2014-06-18 Thread Procházka Lukáš Ing . - Pontex s . r . o .
Hello, I cannot compile the following code: \mainlanguage[cz] \enableregime[cp1250] \starttext \section{Poznámky} \stoptext It worked so far - I guess something is wrong with the input file encoding specification. Best regards, Lukas -- Ing. Lukáš Procházka

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-17 Thread Hans Hagen
On 6/17/2014 5:49 AM, Brian Landy wrote: Almost all of the tables I generate via code, not by hand, so I found it more convenient to include a trailing % because I occasionally did run across an instance where it mattered, and wasn't (and am not) sufficiently skilled at TeX/ConTeXt to know

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-17 Thread Hans Hagen
On 6/16/2014 11:51 PM, Brian Landy wrote: Hi, I was testing the latest beta (2014.06.15) and noticed I am getting incorrect output using natural tables with alignment characters. I produced a small example that demonstrates the problem, and attached output created with the version I'm testing

[NTG-context] latest beta, problem with natural tables and alignment character

2014-06-16 Thread Brian Landy
Hi, I was testing the latest beta (2014.06.15) and noticed I am getting incorrect output using natural tables with alignment characters. I produced a small example that demonstrates the problem, and attached output created with the version I'm testing (bad.pdf) and my prior version (good.pdf,

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-16 Thread Hans Hagen
On 6/16/2014 11:51 PM, Brian Landy wrote: Hi, I was testing the latest beta (2014.06.15) and noticed I am getting incorrect output using natural tables with alignment characters. I produced a small example that demonstrates the problem, and attached output created with the version I'm testing

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-16 Thread Hans Hagen
so instead of \bTD[]{Bond}\eTD% use this: \bTD Bond \eTD - Hans Hagen | PRAGMA ADE Ridderstraat 27 | 8061 GH Hasselt | The Netherlands tel: 038 477 53 69 | voip: 087

Re: [NTG-context] latest beta, problem with natural tables and alignment character

2014-06-16 Thread Brian Landy
Almost all of the tables I generate via code, not by hand, so I found it more convenient to include a trailing % because I occasionally did run across an instance where it mattered, and wasn't (and am not) sufficiently skilled at TeX/ConTeXt to know how to predict those occurrences. It's

Re: [NTG-context] latest beta

2014-01-17 Thread Hans Hagen
On 1/16/2014 11:23 PM, Thomas A. Schmitz wrote: Hi, the following test file gives an error with the latest beta: \setupbodyfont[gentium,12pt] \starttext \buildtextaccent\greekdasia\greekalphamacron \stoptext it works with a somewhat older one (2013.12.30). The error is ! Missing number,

[NTG-context] latest beta

2014-01-16 Thread Thomas A. Schmitz
Hi, the following test file gives an error with the latest beta: \setupbodyfont[gentium,12pt] \starttext \buildtextaccent\greekdasia\greekalphamacron \stoptext it works with a somewhat older one (2013.12.30). The error is ! Missing number, treated as zero. system tex error on

[NTG-context] Latest beta: file publ-old.mkiv not found

2014-01-14 Thread Otared Kavian
Hi Hans, After updating to th elatest version, Context 2014.01.14 15:03 one cannot typeset anymore with mkiv because a file seems missing. Here is the error message: I can't find file `publ-old.mkiv'. to be read again \relax l.490

Re: [NTG-context] Latest beta: file publ-old.mkiv not found

2014-01-14 Thread Hans Hagen
On 1/14/2014 4:17 PM, Otared Kavian wrote: Hi Hans, After updating to th elatest version, Context 2014.01.14 15:03 one cannot typeset anymore with mkiv because a file seems missing. Here is the error message: I can't find file `publ-old.mkiv'. to be read again

Re: [NTG-context] Latest beta: file publ-old.mkiv not found

2014-01-14 Thread Otared Kavian
On 14 janv. 2014, at 16:27, Hans Hagen pra...@wxs.nl wrote: On 1/14/2014 4:17 PM, Otared Kavian wrote: Hi Hans, After updating to th elatest version, Context 2014.01.14 15:03 one cannot typeset anymore with mkiv because a file seems missing. Here is the error message: I

  1   2   3   4   >