Re: [NTG-context] \setupfooter[color=red]: red color spills with float over next page

2016-12-19 Thread Hans Hagen

On 12/18/2016 11:00 PM, Benjamin Buchmuller wrote:

Hi Hans,

I finally managed to make a MWE. The issue is related to me using \clip{…} onto 
external figures I would like to crop in conjunction with a colored footer 
set-up:

\starttext

\setupfooter[color=red]

\setupfootertexts
[]
[]
[any text] % issue related to put something in footer ...
[]

\input knuth

\input knuth

\input knuth

% … and moving to the top of the next page

\startplacefigure
[
width=fit,
title={
\input bryson
},
]
\clip[height=7.0cm]{ % issue related to clip
\externalfigure[fig_4.jpg][height=7.0cm, width=\textwidth]
}
\stopplacefigure

\stoptext


in back-pdf.mkiv you can patch this:

\unexpanded\def\dostartclipping#1#2#3%
  {\forcecolorhack % add this
   \PointsToBigPoints{#2}\width
   \PointsToBigPoints{#3}\height

and run

context --make


Thank you for your help.


Benjamin
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___




--

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] \setupfooter[color=red]: red color spills with float over next page

2016-12-18 Thread Pablo Rodriguez
On 12/18/2016 11:00 PM, Benjamin Buchmuller wrote:
> Hi Hans,
> 
> I finally managed to make a MWE. The issue is related to me using
> \clip{…} onto external figures I would like to crop in conjunction with
> a colored footer set-up:

Hallo Benjamin,

my question may be stupid, but what happens if you don’t use \clip?

Pablo

> \starttext
> 
> \setupfooter[color=red]
>   
> \setupfootertexts
>   []
>   []
>   [any text] % issue related to put something in footer ...
>   []
> 
> \input knuth
> 
> \input knuth
> 
> \input knuth
> 
> % … and moving to the top of the next page
> 
> \startplacefigure
>   [
>   width=fit,
>   title={
> \input bryson
>   },
>   ]
>   \clip[height=7.0cm]{ % issue related to clip
>   \externalfigure[fig_4.jpg][height=7.0cm, width=\textwidth]
>   }
> \stopplacefigure
> 
> \stoptext
> 
> Thank you for your help.
> 
> 
> Benjamin
> ___
> If your question is of interest to others as well, please add an entry to the 
> Wiki!
> 
> maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki : http://contextgarden.net
> ___
> 


-- 
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] \setupfooter[color=red]: red color spills with float over next page

2016-12-04 Thread Benjamin Buchmuller
Hi Hans,

thank you for your help. I tried exactly as you suggested, which worked fine, 
but adopting for the case being with 
\setupfootertexts[\strut{\color[MyColor]{footers}}\strut][][][…same…] (further, 
footer texts change in the course of the document and call markings, page 
numbers etc.), I ended up with the same result as before. 

I will provide a minimal example as soon as possible next week. 

Cheers, Benjamin 

> On 4 Dec 2016, at 12:00, ntg-context-requ...@ntg.nl wrote:
> 
> Send ntg-context mailing list submissions to
>   ntg-context@ntg.nl
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>   https://mailman.ntg.nl/mailman/listinfo/ntg-context
> or, via email, send a message with subject or body 'help' to
>   ntg-context-requ...@ntg.nl
> 
> You can reach the person managing the list at
>   ntg-context-ow...@ntg.nl
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of ntg-context digest..."
> Today's Topics:
> 
>   1. \setupfooter[color=red]: red color spills with float over
>  next page (Benjamin Buchmuller)
>   2. Re: \setupfooter[color=red]: red color spills with float over
>  next page (Hans Hagen)
> 
> From: Benjamin Buchmuller <benjamin.buchmul...@gmail.com>
> Subject: [NTG-context] \setupfooter[color=red]: red color spills with float 
> over next page
> Date: 4 December 2016 at 04:05:49 CET
> To: ntg-context@ntg.nl
> Reply-To: mailing list for ConTeXt users <ntg-context@ntg.nl>
> 
> 
> When I have
> 
> \setupfooter[color=red, style=bold] (same goes with \setupfooter[style=red])
> 
> and a
> 
> tex text text
> 
> % <<<< page breaks here after typesetting >>>>
> 
> \startplacefigure[
>   %location=force, % no matter what I do here
>   title={Caption.}
> ]
> … something …
> \stopplacefigure
> 
> other text
> 
> that is moved to the following page as first object, the entire page 
> including the figure’s rulers, caption, and the regular text prints in red 
> (but not bold!?) when I incorporate the file via \component … into my 
> project, but not when I typeset from within \startcomponent … \stopcomponent.
> 
> Since “bold” does not seem to float the same way, I guess it is related to 
> color handling at page breaks somehow.
> 
> I already tried to \setupfloats[before=\strut] to “force” black bodyfont 
> right before the figure (at least this is what I intended to do), but did not 
> work.
> 
> I’m sorry not to be able to provide a more elaborate minimal example 
> asserting the exact conditionals of this behaviour at the moment as I need to 
> hand in a report next week. Probably the footers have to go black this time.
> 
> Any suggestions?
> 
> Thank you for your help.
> 
> 
> Benjamin
> 
> 
> 
> From: Hans Hagen <pra...@wxs.nl>
> Subject: Re: [NTG-context] \setupfooter[color=red]: red color spills with 
> float over next page
> Date: 4 December 2016 at 11:42:19 CET
> To: ntg-context@ntg.nl
> Reply-To: mailing list for ConTeXt users <ntg-context@ntg.nl>
> 
> 
>> On 12/4/2016 4:05 AM, Benjamin Buchmuller wrote:
>> When I have
>> 
>> \setupfooter[color=red, style=bold] (same goes with \setupfooter[style=red])
>> 
>> and a
>> 
>> tex text text
>> 
>> % <<<< page breaks here after typesetting >>>>
>> 
>> \startplacefigure[
>>  %location=force, % no matter what I do here
>>  title={Caption.}
>> ]
>> … something …
>> \stopplacefigure
>> 
>> other text
>> 
>> that is moved to the following page as first object, the entire page 
>> including the figure’s rulers, caption, and the regular text prints in red 
>> (but not bold!?) when I incorporate the file via \component … into my 
>> project, but not when I typeset from within \startcomponent … \stopcomponent.
>> 
>> Since “bold” does not seem to float the same way, I guess it is related to 
>> color handling at page breaks somehow.
>> 
>> I already tried to \setupfloats[before=\strut] to “force” black bodyfont 
>> right before the figure (at least this is what I intended to do), but did 
>> not work.
>> 
>> I’m sorry not to be able to provide a more elaborate minimal example 
>> asserting the exact conditionals of this behaviour at the moment as I need 
>> to hand in a report next week. Probably the footers have to go black this 
>> time.
>> 
>> Any suggestions?
> 
> not many as i really need an example
> 
> you can try
> 
> \setupfootertexts[\strut{\red foo}\strut}
> 
> ins

Re: [NTG-context] \setupfooter[color=red]: red color spills with float over next page

2016-12-04 Thread Hans Hagen

On 12/4/2016 4:05 AM, Benjamin Buchmuller wrote:

When I have

\setupfooter[color=red, style=bold] (same goes with \setupfooter[style=red])

and a

tex text text

%  page breaks here after typesetting 

\startplacefigure[
%location=force, % no matter what I do here
title={Caption.}
]
… something …
\stopplacefigure

other text

that is moved to the following page as first object, the entire page including 
the figure’s rulers, caption, and the regular text prints in red (but not 
bold!?) when I incorporate the file via \component … into my project, but not 
when I typeset from within \startcomponent … \stopcomponent.

Since “bold” does not seem to float the same way, I guess it is related to 
color handling at page breaks somehow.

I already tried to \setupfloats[before=\strut] to “force” black bodyfont right 
before the figure (at least this is what I intended to do), but did not work.

I’m sorry not to be able to provide a more elaborate minimal example asserting 
the exact conditionals of this behaviour at the moment as I need to hand in a 
report next week. Probably the footers have to go black this time.

Any suggestions?


not many as i really need an example

you can try

\setupfootertexts[\strut{\red foo}\strut}

instead

Hans

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___