Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-03 Thread Idris Samawi Hamid ادريس سماوي حامد
On Thu, 03 Aug 2017 01:41:42 -0600, Henning Hraban Ramm   
wrote:



Am 2017-08-02 um 23:46 schrieb Aditya Mahajan :

I occasionally experience a similar issue (after an update wrong  
fontface is used, especially with math fonts) and reloading the fonts  
database with --force always fixes the issue for me. So, I have never  
bothered to investigate why the issue comes up in the first place.


Hm, is the general problem with ttc fonts fixed? Some leftover of that?


In the current project, occasionally a change in layout will cause cambria  
regular to change to italic.


mtxrun --script fonts --reload --force

fixes it again, but I have not been able to isolate the issue to a simple  
test file. E.g., on one occasion commenting


% \showframe

turned the document italic, but then after reloading it turned regular  
again and I couldn't repeat the error. So there seems to be a bug  
somewhere, perhaps ttc-related indeed...


Idris
--
Idris Samawi Hamid, Professor
Department of Philosophy
Colorado State University
Fort Collins, CO 80512
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-03 Thread Henning Hraban Ramm
Am 2017-08-02 um 23:46 schrieb Aditya Mahajan :

> I occasionally experience a similar issue (after an update wrong fontface is 
> used, especially with math fonts) and reloading the fonts database with 
> --force always fixes the issue for me. So, I have never bothered to 
> investigate why the issue comes up in the first place.

Hm, is the general problem with ttc fonts fixed? Some leftover of that?


Greetlings, Hraban
---
http://www.fiee.net
http://wiki.contextgarden.net
GPG Key ID 1C9B22FD

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Vladimir Lomov
Hello,
** Aditya Mahajan [2017-08-02 17:46:53 -0400]:

> On Wed, 2 Aug 2017, Idris Samawi Hamid ادريس سماوي حامد wrote:
> 
>> On Wed, 02 Aug 2017 15:15:59 -0600, Aditya Mahajan  wrote:
>> 
>>>  Not sure if it helps, but this is worth a try (note the force key):
>>> 
>>>  mtxrun --script fonts --reload --force
>> 
>> Hmm, now I get
>> 
>> mkiv lua stats  > loaded fonts: 1 files: cambria.ttc
>> 
>> and the pdf file is correct. Thanks, Aditya! (Although I still don't
>> understand why there was a problem to begin with!)
> 
> I occasionally experience a similar issue (after an update wrong fontface is
> used, especially with math fonts) and reloading the fonts database with
> --force always fixes the issue for me. So, I have never bothered to
> investigate why the issue comes up in the first place.
> 
> Aditya

Thanks for hint Aditya.

Idris, if you use Windows 10 then may be your OS has been updated (some
time ago one of host I has access with Windows 10 has been upgraded to
ver. Windows 10 1703) and then you have updated fonts, including
Cambria. AFAIU font cache tracks somehow font version, so in case fonts
update one has to update font cache.

---
WBR, Vladimir Lomov

-- 
 Feanor: u have no idea of the depth of the stupidty of american law
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Aditya Mahajan

On Wed, 2 Aug 2017, Idris Samawi Hamid ادريس سماوي حامد wrote:


On Wed, 02 Aug 2017 15:15:59 -0600, Aditya Mahajan  wrote:


 Not sure if it helps, but this is worth a try (note the force key):

 mtxrun --script fonts --reload --force


Hmm, now I get

mkiv lua stats  > loaded fonts: 1 files: cambria.ttc

and the pdf file is correct. Thanks, Aditya! (Although I still don't 
understand why there was a problem to begin with!)


I occasionally experience a similar issue (after an update wrong fontface 
is used, especially with math fonts) and reloading the fonts database with 
--force always fixes the issue for me. So, I have never bothered to 
investigate why the issue comes up in the first place.


Aditya___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Idris Samawi Hamid ادريس سماوي حامد

On Wed, 02 Aug 2017 15:17:07 -0600, Hans Hagen  wrote:


On 8/2/2017 11:05 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:

On Wed, 02 Aug 2017 14:34:25 -0600, Hans Hagen  wrote:


On 8/2/2017 10:21 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:

Dear gang,
 There appears to be something awry with type-imp-cambria.mkiv or  
type-imp-dejavu.mkiv. Consider the following:

 ===
\setupbodyfont
   [cambria,12pt]
 \starttext
Test % {\it Test} {\bf Test} {\bi Test}
\stoptext
===
 This produces a pdf with Cambria Italic instead of Cambria Regular.  
Uncommenting the other three options produces the expected results.

 Is this a bug or am I missing something? Awaiting your advice!

it's ok here; it could depend on the cambria on your machine

 Cambria Regular : cambria.ttc
Cambria Italic  : cambriai.ttf
 Inspection shows cambria.ttc is indeed regular.
 The log file says
:
mkiv lua stats  > loaded fonts: 2 files: cambria.ttc, cambriai.ttf
 Updating to "current version: 2017.08.02 18:59" and purging the cache  
doesn't help
 Why is cambriai.ttf being loaded at all? Fresh log (today's beta)  
attached


probably because it's the first 'name' that matches

you can try

cambria-x


=> LM


cambria-y


=> LM


cambria-a


=> LM


as variants ; here i have an official cambria


I only have the one that comes with the latest update to Windows 10

(Never tested Cambria with ConTeXt till a few days ago (\definefont  
worked), and never tested the typescript till last night.)


Aditya's suggestion did something that seems to have fixed it, not sure  
what..


Idris
--
Idris Samawi Hamid, Professor
Department of Philosophy
Colorado State University
Fort Collins, CO 80512
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Idris Samawi Hamid ادريس سماوي حامد
On Wed, 02 Aug 2017 15:15:59 -0600, Aditya Mahajan   
wrote:



On Wed, 2 Aug 2017, Idris Samawi Hamid ادريس سماوي حامد wrote:


On Wed, 02 Aug 2017 14:34:25 -0600, Hans Hagen  wrote:


On 8/2/2017 10:21 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:
> Dear gang,
>  There appears to be something awry with type-imp-cambria.mkiv or
>  type-imp-dejavu.mkiv. Consider the following:
>  ===
> \setupbodyfont
>[cambria,12pt]
> \starttext
> Test % {\it Test} {\bf Test} {\bi Test}
> \stoptext
> ===
>  This produces a pdf with Cambria Italic instead of Cambria Regular.
>  Uncommenting the other three options produces the expected results.
>  Is this a bug or am I missing something? Awaiting your advice!
it's ok here; it could depend on the cambria on your machine


Cambria Regular : cambria.ttc
Cambria Italic  : cambriai.ttf

Inspection shows cambria.ttc is indeed regular.

The log file says
:
mkiv lua stats  > loaded fonts: 2 files: cambria.ttc, cambriai.ttf

Updating to "current version: 2017.08.02 18:59" and purging the cache  
doesn't

help


Not sure if it helps, but this is worth a try (note the force key):

mtxrun --script fonts --reload --force


Hmm, now I get

mkiv lua stats  > loaded fonts: 1 files: cambria.ttc

and the pdf file is correct. Thanks, Aditya! (Although I still don't  
understand why there was a problem to begin with!)


Idris
--
Idris Samawi Hamid, Professor
Department of Philosophy
Colorado State University
Fort Collins, CO 80512
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Hans Hagen

On 8/2/2017 11:05 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:

On Wed, 02 Aug 2017 14:34:25 -0600, Hans Hagen  wrote:


On 8/2/2017 10:21 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:

Dear gang,
 There appears to be something awry with type-imp-cambria.mkiv or 
type-imp-dejavu.mkiv. Consider the following:

 ===
\setupbodyfont
   [cambria,12pt]
 \starttext
Test % {\it Test} {\bf Test} {\bi Test}
\stoptext
===
 This produces a pdf with Cambria Italic instead of Cambria Regular. 
Uncommenting the other three options produces the expected results.

 Is this a bug or am I missing something? Awaiting your advice!

it's ok here; it could depend on the cambria on your machine


Cambria Regular : cambria.ttc
Cambria Italic  : cambriai.ttf

Inspection shows cambria.ttc is indeed regular.

The log file says
:
mkiv lua stats  > loaded fonts: 2 files: cambria.ttc, cambriai.ttf

Updating to "current version: 2017.08.02 18:59" and purging the cache 
doesn't help


Why is cambriai.ttf being loaded at all? Fresh log (today's beta) attached


probably because it's the first 'name' that matches

you can try

cambria-x
cambria-y
cambria-a

as variants ; here i have an official cambria

Hans




-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Aditya Mahajan

On Wed, 2 Aug 2017, Idris Samawi Hamid ادريس سماوي حامد wrote:


On Wed, 02 Aug 2017 14:34:25 -0600, Hans Hagen  wrote:


On 8/2/2017 10:21 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:
> Dear gang,
>  There appears to be something awry with type-imp-cambria.mkiv or 
>  type-imp-dejavu.mkiv. Consider the following:

>  ===
> \setupbodyfont
>[cambria,12pt]
> \starttext
> Test % {\it Test} {\bf Test} {\bi Test}
> \stoptext
> ===
>  This produces a pdf with Cambria Italic instead of Cambria Regular. 
>  Uncommenting the other three options produces the expected results.

>  Is this a bug or am I missing something? Awaiting your advice!
it's ok here; it could depend on the cambria on your machine


Cambria Regular : cambria.ttc
Cambria Italic  : cambriai.ttf

Inspection shows cambria.ttc is indeed regular.

The log file says
:
mkiv lua stats  > loaded fonts: 2 files: cambria.ttc, cambriai.ttf

Updating to "current version: 2017.08.02 18:59" and purging the cache doesn't 
help


Not sure if it helps, but this is worth a try (note the force key):

mtxrun --script fonts --reload --force

Aditya___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Idris Samawi Hamid ادريس سماوي حامد

On Wed, 02 Aug 2017 14:34:25 -0600, Hans Hagen  wrote:


On 8/2/2017 10:21 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:

Dear gang,
 There appears to be something awry with type-imp-cambria.mkiv or  
type-imp-dejavu.mkiv. Consider the following:

 ===
\setupbodyfont
   [cambria,12pt]
 \starttext
Test % {\it Test} {\bf Test} {\bi Test}
\stoptext
===
 This produces a pdf with Cambria Italic instead of Cambria Regular.  
Uncommenting the other three options produces the expected results.

 Is this a bug or am I missing something? Awaiting your advice!

it's ok here; it could depend on the cambria on your machine


Cambria Regular : cambria.ttc
Cambria Italic  : cambriai.ttf

Inspection shows cambria.ttc is indeed regular.

The log file says
:
mkiv lua stats  > loaded fonts: 2 files: cambria.ttc, cambriai.ttf

Updating to "current version: 2017.08.02 18:59" and purging the cache  
doesn't help


Why is cambriai.ttf being loaded at all? Fresh log (today's beta) attached

Idris
--
Idris Samawi Hamid, Professor
Department of Philosophy
Colorado State University
Fort Collins, CO 80512

test-cambria.log
Description: Binary data
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___

Re: [NTG-context] Cambria official typescript (mis)behavior

2017-08-02 Thread Hans Hagen

On 8/2/2017 10:21 PM, Idris Samawi Hamid ادريس سماوي حامد wrote:

Dear gang,

There appears to be something awry with type-imp-cambria.mkiv or 
type-imp-dejavu.mkiv. Consider the following:


===
\setupbodyfont
   [cambria,12pt]

\starttext
Test % {\it Test} {\bf Test} {\bi Test}
\stoptext
===

This produces a pdf with Cambria Italic instead of Cambria Regular. 
Uncommenting the other three options produces the expected results.


Is this a bug or am I missing something? Awaiting your advice!

it's ok here; it could depend on the cambria on your machine



-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___