Re: [NTG-context] Example only works in mkii

2012-04-26 Thread Wolfgang Schuster

Am 25.04.2012 um 23:20 schrieb Bill Meahan:

 Hi, folks.
 
 I've tried running the example from the descriptions article on the wiki 
 and it works fine if I use MkII via texexec but fails miserably if I use 
 MlIV via context.  Outside of changing location to alternative in the 
 \definedescription command parameters, what else do I need to change to make 
 the example run with MkIV?

Which example doesn’t work?

Wolfgang
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Example only works in mkii

2012-04-26 Thread Bill Meahan


On 04/26/2012 11:11, Wolfgang Schuster wrote:

Am 25.04.2012 um 23:20 schrieb Bill Meahan:


Hi, folks.

I've tried running the example from the descriptions article on the wiki and it works fine if I use MkII via 
texexec but fails miserably if I use MlIV via context.  Outside of changing location to 
alternative in the \definedescription command parameters, what else do I need to change to make the example run with 
MkIV?

Which example doesn’t work?

Wolfgang


This one:

\setupdescriptions[descr][
  headstyle=bold,style=normal,align=left,alternative=hanging,
  width=fit,margin=1cm]

\definedescription[descr][
  headstyle=bold]

\starttext
\startdescr{Para}
  This is a shorter item label, and some text that talks about it.
  The text is wrapped into a paragraph, with successive lines indented.

  This is another paragraph under the Para item.
  \startdescr{Sub Item}
This is a description of an item which is within the
Para item.
  \stopdescr
  \startdescr{Sub Item}
Another Sub Item
  \stopdescr
\stopdescr
\startdescr{Short with long title}
  A short item that's not part of that really long Para item.
\stopdescr

\stoptext


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Example only works in mkii

2012-04-26 Thread Wolfgang Schuster

Am 26.04.2012 um 18:36 schrieb Bill Meahan:

 
 On 04/26/2012 11:11, Wolfgang Schuster wrote:
 Am 25.04.2012 um 23:20 schrieb Bill Meahan:
 
 Hi, folks.
 
 I've tried running the example from the descriptions article on the wiki 
 and it works fine if I use MkII via texexec but fails miserably if I use 
 MlIV via context.  Outside of changing location to alternative in the 
 \definedescription command parameters, what else do I need to change to 
 make the example run with MkIV?
 Which example doesn’t work?
 
 Wolfgang
 
 This one:
 
 \setupdescriptions[descr][
  headstyle=bold,style=normal,align=left,alternative=hanging,
  width=fit,margin=1cm]
 
 \definedescription[descr][
  headstyle=bold]
 
 \starttext
 \startdescr{Para}
  This is a shorter item label, and some text that talks about it.
  The text is wrapped into a paragraph, with successive lines indented.
 
  This is another paragraph under the Para item.
  \startdescr{Sub Item}
This is a description of an item which is within the
Para item.
  \stopdescr
  \startdescr{Sub Item}
Another Sub Item
  \stopdescr
 \stopdescr
 \startdescr{Short with long title}
  A short item that's not part of that really long Para item.
 \stopdescr
 
 \stoptext

The example works for me but it’s bad style to use \setup… before you have 
created the command with \define…

You can also remove “align=left” because this will make the whole text right 
aligned, with MkII this isn’t a problem because the setting doesn’t work.

Wolfgang

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Example only works in mkii

2012-04-26 Thread Bill Meahan

On 04/26/2012 13:10, Wolfgang Schuster wrote:

Am 26.04.2012 um 18:36 schrieb Bill Meahan:


[snip]

The example works for me but it’s bad style to use \setup… before you have 
created the command with \define…

You can also remove “align=left” because this will make the whole text right 
aligned, with MkII this isn’t a problem because the setting doesn’t work.

Wolfgang

[snip]

Switching the \define and \setup along with removing the align=left 
fixed it. Thanks!


BTW, the code was literally a copy-'n'-paste from the wiki page without 
any alteration by me. Probably should be fixed.


Thanks again!


___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___


Re: [NTG-context] Example only works in mkii

2012-04-26 Thread Henning Hraban Ramm

Am 2012-04-26 um 19:38 schrieb Bill Meahan:

BTW, the code was literally a copy-'n'-paste from the wiki page  
without any alteration by me. Probably should be fixed.


Just do it, if you're at it, therefore it’s a wiki.
Thanks.


Greetlings, Hraban
---
http://www.fiee.net/texnique/
http://wiki.contextgarden.net
https://www.cacert.org (I'm an assurer)

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki : http://contextgarden.net
___