Re: [NTG-context] LMTX and system fonts

2019-05-01 Thread Pablo Rodriguez
On 4/28/19 5:22 PM, Alan Braslau wrote:
>> On 28Apr19, at 02:55, Pablo Rodriguez wrote:
>>
>> I add the path, otherwise no mtxrun would be found.
>
> Of course, Otared is saying:
>
> $CONTEXTHOME/tex/texmf-osx-64/bin/mtxrun -generate
>
> where osx-64 is the platform.

Many thanks for your reply, Alan.

I’m afraid that LMTX isn’t able to recognize fonts when provided with a
symbolic link inside texmf-fonts in Linux.

Pablo
--
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-28 Thread Alan Braslau

> On 28Apr19, at 02:55, Pablo Rodriguez  wrote:
> 
> I add the path, otherwise no mtxrun would be found.


Of course, Otared is saying:

$CONTEXTHOME/tex/texmf-osx-64/bin/mtxrun -generate

where osx-64 is the platform.


--
Alan Braslau



___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-28 Thread Pablo Rodriguez
On 4/27/19 11:06 PM, Aditya Mahajan wrote:
> On Sat, 27 Apr 2019, Pablo Rodriguez wrote:
>> [...]
>> If the soft symlink for the fonts directory is itself tex/texmf-fonts/,
>> ConTeXt LMTX handles the fonts right.
>
> The texmf-fonts directory must follow TDS (tex document structure).
> Assuming that ~/Documents/ousia-fonts simply contains a bunch of
> directories with opentype fonts...

It contains a bunch of fonts, no directory.

> I'd try symlinking it to
>
> tex/texmf-fonts/font/opentype/data

It doesn’t work.

Adding a link in tex/texmf-fonts/ for each font file is the only thing
that works fine.

And I wonder what may be wrong with the fonts from c:\windows\fonts\ not
being read in Win7.

Many thanks for your help,

Pablo
--
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-28 Thread Pablo Rodriguez
On 4/27/19 9:50 PM, Otared Kavian wrote:
> Hi Pablo,
>
> I don't know if this may help, but in principle in order to use
> system fonts in LMTX you should invoke the mtxrun in the bin
> directory of your installation of LMTX. For me, working on MacOS, the
> following worked fine:
>
>   /context-osx-64/tex/texmf-osx-64/bin/mtxrun -generate

Hi Otared,

I add the path, otherwise no mtxrun would be found.

Many thanks for your help,

Pablo
--
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Aditya Mahajan

On Sat, 27 Apr 2019, Pablo Rodriguez wrote:


On 4/27/19 7:36 PM, Hans Hagen wrote:

On 4/27/2019 6:25 PM, Pablo Rodriguez wrote:

[...]
It seems as if LMTX couldn’t follow symlinks for directories in Linux.

On Windows, I will have to wait some days to have access to a computer
with it.

I tested linux on wsl and made a (soft) symlink there to a path under
/mnt/c and it just works. So i need more details.


I wish I could give more details.

Fonts are located in ~/Documents/ousia-fonts/. The soft link is
tex/texmf-fonts/ousia-fonts/.

If the soft symlink for the fonts directory is itself tex/texmf-fonts/,
ConTeXt LMTX handles the fonts right.


The texmf-fonts directory must follow TDS (tex document structure). 
Assuming that ~/Documents/ousia-fonts simply contains a bunch of 
directories with opentype fonts, I'd try symlinking it to


tex/texmf-fonts/font/opentype/data

Aditya___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Otared Kavian
Hi Pablo,

I don't know if this may help, but in principle in order to use systme fonts in 
LMTX you should invoke the mtxrun in the bin directory of your installation of 
LMTX. For me, working on MacOS, the following worked fine:

/context-osx-64/tex/texmf-osx-64/bin/mtxrun -generate

and then

/context-osx-64/tex/texmf-osx-64/bin/mtxrun --script font --reload

Best regards: OK

> On 27 Apr 2019, at 18:25, Pablo Rodriguez  wrote:
> 
> On 4/27/19 5:37 PM, Hans Hagen wrote:
>> On 4/27/2019 2:13 PM, Pablo Rodriguez wrote:
>>> [...]
>>> In Windows (I installed it again from scratch yesterday), system fonts
>>> (from c:/windows/fonts/) are simply ignored (I don’t know why).
>>> 
>>> In Linux, a symlink in tex/texmf-fonts/ to the directory where fonts are
>>> stored doesn’t work either.
>>> 
>>> The weird thing is that the ConTeXt Suite in both OSes works fine with
>>> system fonts or the mentioned symlink.
>> 
>> mtxrun --generate
>> mtxrun --script font --reload
> 
> I’m afraid it doesn’t work, Hans.
> 
> I even removed tex/texmf-cache/luatex-cache/, but no luck.
> 
> The only workaround I found in Linux is to add a symlinks to each font
> file. This works now.
> 
> It seems as if LMTX couldn’t follow symlinks for directories in Linux.
> 
> On Windows, I will have to wait some days to have access to a computer
> with it.
> 
> Many thanks for your help,
> 
> Pablo
> --
> http://www.ousia.tk
> ___
> If your question is of interest to others as well, please add an entry to the 
> Wiki!
> 
> maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
> archive  : https://bitbucket.org/phg/context-mirror/commits/
> wiki : http://contextgarden.net
> ___

___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Pablo Rodriguez
On 4/27/19 7:36 PM, Hans Hagen wrote:
> On 4/27/2019 6:25 PM, Pablo Rodriguez wrote:
>> [...]
>> It seems as if LMTX couldn’t follow symlinks for directories in Linux.
>>
>> On Windows, I will have to wait some days to have access to a computer
>> with it.
> I tested linux on wsl and made a (soft) symlink there to a path under
> /mnt/c and it just works. So i need more details.

I wish I could give more details.

Fonts are located in ~/Documents/ousia-fonts/. The soft link is
tex/texmf-fonts/ousia-fonts/.

If the soft symlink for the fonts directory is itself tex/texmf-fonts/,
ConTeXt LMTX handles the fonts right.

I’m going to test this in a Linux live version, but I need to get an
empty USB stick first.

Many thanks for your help,

Pablo
--
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Hans Hagen

On 4/27/2019 6:25 PM, Pablo Rodriguez wrote:

On 4/27/19 5:37 PM, Hans Hagen wrote:

On 4/27/2019 2:13 PM, Pablo Rodriguez wrote:

[...]
In Windows (I installed it again from scratch yesterday), system fonts
(from c:/windows/fonts/) are simply ignored (I don’t know why).

In Linux, a symlink in tex/texmf-fonts/ to the directory where fonts are
stored doesn’t work either.

The weird thing is that the ConTeXt Suite in both OSes works fine with
system fonts or the mentioned symlink.


mtxrun --generate
mtxrun --script font --reload


I’m afraid it doesn’t work, Hans.

I even removed tex/texmf-cache/luatex-cache/, but no luck.

The only workaround I found in Linux is to add a symlinks to each font
file. This works now.

It seems as if LMTX couldn’t follow symlinks for directories in Linux.

On Windows, I will have to wait some days to have access to a computer
with it.
I tested linux on wsl and made a (soft) symlink there to a path under 
/mnt/c and it just works. So i need more details.


Hans


-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Pablo Rodriguez
On 4/27/19 6:25 PM, Pablo Rodriguez wrote:
> [...]
> The only workaround I found in Linux is to add a symlinks to each font
> file. This works now.

I mean, to add a symlink in tex/texmf-font/ for each in the original
font directory.

But a symlink in tex/texmf-font/ for the font directory itself doesn’t work.

Pablo
--
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Pablo Rodriguez
On 4/27/19 5:37 PM, Hans Hagen wrote:
> On 4/27/2019 2:13 PM, Pablo Rodriguez wrote:
>> [...]
>> In Windows (I installed it again from scratch yesterday), system fonts
>> (from c:/windows/fonts/) are simply ignored (I don’t know why).
>>
>> In Linux, a symlink in tex/texmf-fonts/ to the directory where fonts are
>> stored doesn’t work either.
>>
>> The weird thing is that the ConTeXt Suite in both OSes works fine with
>> system fonts or the mentioned symlink.
>
> mtxrun --generate
> mtxrun --script font --reload

I’m afraid it doesn’t work, Hans.

I even removed tex/texmf-cache/luatex-cache/, but no luck.

The only workaround I found in Linux is to add a symlinks to each font
file. This works now.

It seems as if LMTX couldn’t follow symlinks for directories in Linux.

On Windows, I will have to wait some days to have access to a computer
with it.

Many thanks for your help,

Pablo
--
http://www.ousia.tk
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___


Re: [NTG-context] LMTX and system fonts

2019-04-27 Thread Hans Hagen

On 4/27/2019 2:13 PM, Pablo Rodriguez wrote:

Dear list,

fonts are my main problem using LMTX (on both Windows and Linux platforms).

In Windows (I installed it again from scratch yesterday), system fonts
(from c:/windows/fonts/) are simply ignored (I don’t know why).

In Linux, a symlink in tex/texmf-fonts/ to the directory where fonts are
stored doesn’t work either.

The weird thing is that the ConTeXt Suite in both OSes works fine with
system fonts or the mentioned symlink.

What am I missing here?

mtxrun --generate
mtxrun --script font --reload

-
  Hans Hagen | PRAGMA ADE
  Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
   tel: 038 477 53 69 | www.pragma-ade.nl | www.pragma-pod.nl
-
___
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki : http://contextgarden.net
___