Re: [NTG-context] no graph after compilation

2004-08-12 Thread Hans Hagen
Patrick Gundlach wrote:
Hello,
 

i did, but it has side-effects...
it will scale, but the color disappears too.
try.
   

This is indeed strange. Any metapost experts?
 

how did the graphic definition look? 

Hans  

-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-12 Thread Hans Hagen
Patrick Gundlach wrote:
There is no way to update this automaticalliy. But take a look at the
wiki and http://levana.de/context/  (still need to put this into the
wiki).
 

actually, if you run a minimal tree, you can do a sycn with the tree on out server using texsync, but i have to test that -) 

Hans 

-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-12 Thread Patrick Gundlach
Hello Floris,

 i got the update from pragma-ade.com, unzipped the files in
 c:\texlive\texmf i did run the texexec --make
 but i still have texexec 4.0 running...

Any windows / texlive users should be able to tell you more. 

But unzipping it on top of the texlive was not the very best idea I'd
guess. The directory structure has changed a bit with respect to the
location of scripts and metapost files, so your old texlive metafun
macros will be used.

Patrick
-- 
ConTeXt wiki: http://contextgarden.net
texshow-web:  http://texshow.contextgarden.net
List archive: http://archive.contextgarden.net
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-12 Thread Eros Albertazzi
Patrick Gundlach wrote:
But unzipping it on top of the texlive was not the very best idea I'd
guess. 
I agree... but be aware that in 
http://contextgarden.net/Linux_Installation this is just what is suggested
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-12 Thread Patrick Gundlach
Hi Floris,

 that is explaining the situation. But for an end-user (i try to keep
 myself on that level) it is *not* very convenient left with this
 situation (not knowing it exists in the first place)

Not all hope is lost. IIRC there were two important differences from
your texlive upto now:

1) paths of scripts have changed (now in texmf/scripts/context/perl/
   I don't remember were they were ... wait texmf/context/perltk)

2) metafun macros are now in metapost/context/base (hmm, it looks as
   if this is now since a long time ... OK found it: this was in
   metapost/context in version 2003.1.28 and in .../base in version
   2003.1.30 - long time before current texlive came out. You use the
   current texlive (almost a year old now))?

So you are probably only affected by 1). Any window user should tell
you how to use the texexec.pl from the scripts path and use this in
favour of the default one.

 I guess i have to uninstall the present pftex and start from
 scratch.

Oh no, don't do this. It looks fine. An uptodate texexec is not
extremely important.

 Which one is the best option to get Context,metafun,xml working?
 And i would like to have a similar working set on my OSX laptop too.
 Where are the experts ? :-)

You use texlive on your OS X laptop? That is what I have, too. I have
not taken the default ConTeXt, but downloaded a current one from
Pragma ADE page and installed it in a spearate directory and did a
few things that are mentioned on my old ConTeXt page
(http://levana.de/context).


 Hints for improvement:


[...]

I'll return to the live... next week, I'll save your (and the other)
suggestions until then.

Patrick

-- 
ConTeXt wiki: http://contextgarden.net
texshow-web:  http://texshow.contextgarden.net
List archive: http://archive.contextgarden.net
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-12 Thread Hans Hagen
Patrick Gundlach wrote:
that is explaining the situation. But for an end-user (i try to keep
myself on that level) it is *not* very convenient left with this
situation (not knowing it exists in the first place)
   

Not all hope is lost. IIRC there were two important differences from
your texlive upto now:
1) paths of scripts have changed (now in texmf/scripts/context/perl/
  I don't remember were they were ... wait texmf/context/perltk)
2) metafun macros are now in metapost/context/base (hmm, it looks as
  if this is now since a long time ... OK found it: this was in
  metapost/context in version 2003.1.28 and in .../base in version
  2003.1.30 - long time before current texlive came out. You use the
  current texlive (almost a year old now))?
So you are probably only affected by 1). Any window user should tell
you how to use the texexec.pl from the scripts path and use this in
favour of the default one.
 

if you have textools.rb:
textools --fixtexmftrees
will fix the tree
Hans
-
 Hans Hagen | PRAGMA ADE
 Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
| www.pragma-pod.nl
-
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-11 Thread Peter Rolf
Hello Floris,
it seems that you haven't reached page 307
Have fun,
   Peter
Floris van Manen wrote:
i'm working through the metafun manual.
i noticed at some point that changes to the source do not appear in
the pdf output. sometimes after another texexec round, sometimes not
at all until i do something different in the tex file...
how come (or how to work around :-)
thanks!
//f
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context
 

___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-11 Thread Patrick Gundlach
Floris van Manen [EMAIL PROTECTED] writes:

 VZ Floris, you are not alone. I also have not find the quick solution. So I
 VZ call texexec two times when working with MP graphics,
 VZ color definitions, ... :-(

 running it twice is something i can live with, but if it will not
 solve the problem, then it is... what do i do wrong?

Vit and Floris,

if your TeX source is one file only, please do me a favour: try the
TeX files on live.contextgarden.net and see if the output comes out
right. If it doesn't, I'd like to know about it. If it does, please
report on the list. Do you have write18 (texmf.cnf) enabled? How does your
cont-sys.tex look like? What distribution do you use?

I have (on live..) disabled write18, \runMPgraphicstrue
and \runMPTEXgraphicstrue.


Patrick
-- 
ConTeXt wiki: http://contextgarden.net
texshow-web:  http://texshow.contextgarden.net
List archive: http://archive.contextgarden.net
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-11 Thread Patrick Gundlach
Hello Floris,

 where do i do this?
 in C:\texLive\texmf\tex\context\user\cont-sys.rme ?
 and what do i type there?

see the wiki:

http://contextgarden.net/Cont-sys.tex
and
http://contextgarden.net/Texmf.cnf

Does this help?

Patrick
-- 
ConTeXt wiki: http://contextgarden.net
texshow-web:  http://texshow.contextgarden.net
List archive: http://archive.contextgarden.net
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-11 Thread Vit Zyka
VZ Floris, you are not alone. I also have not find the quick solution. So I
VZ call texexec two times when working with MP graphics,
VZ color definitions, ... :-(
running it twice is something i can live with, but if it will not
solve the problem, then it is... what do i do wrong?

Vit and Floris,
if your TeX source is one file only, please do me a favour: try the
TeX files on live.contextgarden.net and see if the output comes out
right. If it doesn't, I'd like to know about it. If it does, please
report on the list. Do you have write18 (texmf.cnf) enabled? How does your
cont-sys.tex look like? What distribution do you use?
I have (on live..) disabled write18, \runMPgraphicstrue
and \runMPTEXgraphicstrue.
Thank you, Patrick, I will monitor the case and I will let you know if 
it occures again.

I am using two distributions (the case was observed on both):
1) TeX Live 2002/Linux; write18 enabled
2) TeX Live 2003/Win 2K, updated ConTeXt on Win 2000;
   write18 disabled for a long time, but it was enabled a month ago
cont-sys.tex (without comments):
\usetypescript [berry] [\defaultencoding]
\runMPgraphicstrue
\runMPTEXgraphicstrue
\useMETAFUNformattrue
\newprettytrue
\protectbufferstrue
Vit
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context


Re: [NTG-context] no graph after compilation

2004-08-11 Thread Patrick Gundlach
Hello,

 i did, but it has side-effects...
 it will scale, but the color disappears too.
 try.

This is indeed strange. Any metapost experts?


Patrick
-- 
ConTeXt wiki: http://contextgarden.net
texshow-web:  http://texshow.contextgarden.net
List archive: http://archive.contextgarden.net
___
ntg-context mailing list
[EMAIL PROTECTED]
http://www.ntg.nl/mailman/listinfo/ntg-context