OpenBSD src changes summary for 2016-10-18
==========================================

Makefile                                distrib/notes
lib/libc                                regress/usr.bin
sbin/sysctl                             share/man
sys/arch/amd64/amd64                    sys/arch/i386/conf
sys/arch/sparc64/sparc64                sys/ddb
sys/dev                                 sys/net
usr.bin/cvs                             usr.bin/diff3
usr.bin/mandoc                          usr.bin/rcs
usr.bin/sendbug                         usr.bin/ssh
usr.bin/tmux                            usr.sbin/bgpd
usr.sbin/makefs                         usr.sbin/ntpd
usr.sbin/vmd                            

== Makefile ========================================================== 01/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/Makefile

Makefile


  > Swap 'make cleandir' and 'make includes' for real.
  > Should have been part of commitid uHRFWpwUBjIz0UuR.
  > Original message:
  > Move libcrypto, librpcsvc and gnu/usr.bin/cc/include from RDIRS to PRDIRS,
  > and add prereq targets, so some header files are generated by BUILDUSER
  > during 'make prereq' instead of by root during 'make includes'.
  > Switch the order of 'make cleandir' and 'make includes' during 'make build'
  > so we don't generate many files twice.
  > Except for some machine@ symlinks from ${MACHINE}/stand, /usr/obj is now
  > clean from files generated by root during 'make build'. Those will be
  > cleaned up in a second step.
  > help, testing & ok deraadt, input from natano, further testing rpe (tb@)

== distrib =========================================================== 02/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/distrib

notes

  ~ m4.common                             

  > typo fix and zap some trailing eol whitespace;
  > from claus assman (jmc@)

  ~ m4.common                             

  > spelling:
  > initialising -> initializing from Claus Assmann
  > artitions -> partitions from spell(1) (tb@)

== lib =============================================================== 03/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/lib

libc

  ~ gen/readpassphrase.c                  

  > Avoid generate SIGTTOU when restoring the terminal mode.  If we get
  > SIGTTOU it means the process is not in the foreground process group
  > which, in most cases, means that the shell has taken control of the
  > tty.  Requiring the user the fg the process in this case doesn't
  > make sense and can result in both SIGTSTP and SIGTTOU being sent
  > which can lead to the process being suspended again immediately
  > after being brought into the foreground. (millert@)

== regress =========================================================== 04/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/regress

usr.bin

  ~ mandoc/db/out/twosect.dout            

  > adjust after the ordering was made well-defined in mandocdb.c rev. 1.180
  > (schwarze@)

== sbin ============================================================== 05/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/sbin

sysctl

  ~ sysctl.c                              

  > Rewrite the kern.malloc.kmemstat in the same style as previous. This one
  > does
  > not overflow because the initial count includes empty slots; ok tb@ (otto@)

== share ============================================================= 06/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/share

man

  ~ man9/style.9                          

  > Use "continue;" instead of a bare ";" in the for() loop example
  > with no body. (millert@)

  ~ man9/style.9                          

  > Don't tell the programmer not to put variable declarations inside
  > blocks.  OK guenther@ kettenis@ (millert@)

== sys =============================================================== 07/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/sys

arch/amd64/amd64

  ~ vmm.c                                 

  > SVM on AMD CPUs is not supported yet, so don't attach there; ok mlarkin@
  > (naddy@)

arch/i386/conf

  ~ ld.script                             

  > put .openbsd.randomdata into rodata, since i386 can handle it (deraadt@)

arch/sparc64/sparc64

  ~ autoconf.c                            ~ db_interface.c
  ~ locore.s                              ~ trap.c

  > Delete remnants of "traptrace" support
  > ok deraadt@ (guenther@)

ddb

  ~ db_examine.c                          

  > Add the examine /m format, "display in unsigned hex with character
  > dump at the end of each line", which has always been documented but
  > not implemented.
  > Mostly from NetBSD, but I fixed the column alignment code.
  > ok mlarkin@, pirofti@ (naddy@)

dev

  ~ rnd.c                                 

  > when openbsd.randomdata was made readonly, the proto seed copy got done
  > too late, leading to poor rng in the kernel early on.  a behavioural
  > artifact in vmm spotted the issue.
  > ok tedu guenther mlarkin (deraadt@)

net

  ~ rtsock.c                              

  > Place splsoftnet() in route_input() to shut up splassert warnings
  > in sorwakeup().
  > Report from egorenar-dev at posteo.net; OK henning@ (bluhm@)

  ~ pf.c                                  

  > The checksum of a ICMP "need to frag" packet for TCP was wrong when
  > created from a ICMP6 "too big" packet.  The function pf_change_icmp_af()
  > has code to adjust the pseudo-header checksum in the ICMP6 case,
  > but pf_test_state_icmp() changed the proto before the case was
  > entered.
  > So call pf_change_icmp_af() before the pd->proto is converted in
  > the TCP and UDP payload case like it was already done for ICMP and
  > ICMP6 payload.
  > Found by sys/net/pf_forward regress test; OK henning@ (bluhm@)

  ~ pf.c                                  

  > The variable dlen is always positive and d may be negative.  So
  > declare both with the correct sign in pf_change_icmp_af().
  > OK henning@ (bluhm@)

  ~ pf.c                                  ~ pfvar.h

  > split pf_send_tcp() into the part that builds the mbuf and the actual
  > sending, needed soon. ok sashan mikeb lteo (henning@)

== usr.bin =========================================================== 08/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.bin

cvs

  ~ status.c                              

  > Add the branch revision to the status output much like GNU cvs does.
  > OK millert@ (joris@)

  ~ diff3.c                               

  > Using bitwise OR along with two assignments in the conditional of
  > a while() loop is a trap for the unwary programmer (albeit a clever
  > trap).  Break this up into two separate assignments and using boolean
  > OR for clarity.  OK otto@ (millert@)

diff3

  ~ diff3prog.c                           

  > Using bitwise OR along with two assignments in the conditional of
  > a while() loop is a trap for the unwary programmer (albeit a clever
  > trap).  Break this up into two separate assignments and using boolean
  > OR for clarity.  OK otto@ (millert@)

mandoc

  ~ mandocdb.c                            

  > Simplify and correct support for reproducible builds, such that database
  > entries come in a well-defined order even in the presence of MLINKS.
  > Do this by using the compar() argument of fts_open(3) rather than
  > trying to sort later, which missed some cases.
  > This also shortens the code by a few lines.
  > Diff from Ed Maste <emaste @ FreeBSD>, adapted to our tree
  > and tweaked a bit by me, final version confirmed by Ed. (schwarze@)

  ~ mandocdb.c                            

  > Fix a comment: We don't have manpath(1).  No code change. (schwarze@)

  ~ dbm.c                                 

  > The termination condition of the iteration logic in page_bymacro()
  > was overzealous.  Consequently, macro=substr and macro~regexp searches
  > only returned all pages containing the first matching macro value,
  > rather than all pages containing any of the matching macro values.
  > Bug reported by tb@ - thanks! (schwarze@)

rcs

  ~ diff3.c                               

  > Using bitwise OR along with two assignments in the conditional of
  > a while() loop is a trap for the unwary programmer (albeit a clever
  > trap).  Break this up into two separate assignments and using boolean
  > OR for clarity.  OK otto@ (millert@)

sendbug

  ~ sendbug.c                             

  > Use the files in /var/db/acpi instead of trying to run acpidump.
  > ok brynet@ (kettenis@)

ssh

  ~ sftp.c                                

  > Install a signal handler for tty-generated signals and wait for the
  > ssh child to suspend before suspending sftp.  This lets ssh restore
  > the terminal mode as needed when it is suspended at the password
  > prompt.  OK dtucker@ (millert@)

  ~ channels.c                            ~ channels.h

  > Remove channel_input_port_forward_request(); the only caller was the
  > recently-removed SSH1 server code so it's now dead code.  ok markus@
  > (dtucker@)

tmux

  ~ window.c                              

  > Store the right size in the pipe offset for pipe-pane. (nicm@)

  ~ screen-write.c                        

  > Zero dirty count after flushing. (nicm@)

  ~ cmd-queue.c                           ~ tmux.h

  > Give each item on queue a name for better logging. (nicm@)

  ~ cmd-find.c                            

  > Tweak a couple of log statements. (nicm@)

  ~ grid.c                                

  > Make grid_clear_cell set up the entry properly for 256 and RGB cells.
  > (nicm@)

  ~ tmux.1                                

  > xterm-keys was in the wrong place in the list; Dilyan Palauzov. (nicm@)

  ~ grid.c                                

  > Clear cell entry with grid_default_entry not grid_default_cell. (nicm@)

== usr.sbin ========================================================== 09/09 ==

  http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.sbin

bgpd

  ~ rde.c                                 ~ bgpd.conf.5

  > "Terminate the session after number prefixes have been received" means
  > that max-prefix 1 will close the session on the first prefix which is
  > off by one to what one would expect. Change it to No. received >
  > max-prefix, which is also in line with other implementations.
  > Found by jbg@ and deraadt@.
  > ok phessler@ deraadt@ henning@ claudio@ (benno@)

makefs

  - fs/cd9660/cd9660_rrip.h               - fs/cd9660/iso.h
  - fs/cd9660/iso_rrip.h                  ~ Makefile
  ~ cd9660.h                              ~ cd9660/iso9660_rrip.h
  + cd9660/cd9660_rrip.h                  + cd9660/iso.h
  + cd9660/iso_rrip.h                     

  > Merge fs/cd9660/ into cd9660. (natano@)

  - fs/msdosfs/bootsect.h                 - fs/msdosfs/bpb.h
  - fs/msdosfs/denode.h                   - fs/msdosfs/direntry.h
  - fs/msdosfs/fat.h                      - fs/msdosfs/msdosfs_conv.c
  - fs/msdosfs/msdosfs_fat.c              - fs/msdosfs/msdosfs_lookup.c
  - fs/msdosfs/msdosfs_unicode.c          - fs/msdosfs/msdosfsmount.h
  - newfs_msdos/mkfs_msdos.c              - newfs_msdos/mkfs_msdos.h
  ~ Makefile                              ~ msdos.c
  ~ msdos/msdosfs_denode.c                ~ msdos/msdosfs_vfsops.c
  ~ msdos/msdosfs_vnops.c                 + msdos/bootsect.h
  + msdos/bpb.h                           + msdos/denode.h
  + msdos/direntry.h                      + msdos/fat.h
  + msdos/mkfs_msdos.c                    + msdos/mkfs_msdos.h
  + msdos/msdosfs_conv.c                  + msdos/msdosfs_fat.c
  + msdos/msdosfs_lookup.c                + msdos/msdosfs_unicode.c
  + msdos/msdosfsmount.h                  

  > Merge fs/msdosfs/ and newfs_msdos/ into msdos/. (natano@)

  - ufs/ffs/ffs_subr.c                    - ufs/ffs/ffs_tables.c
  - ufs/ffs/fs.h                          - ufs/ufs/dinode.h
  - ufs/ufs/dir.h                         - ufs/ufs/ufs_bswap.h
  ~ Makefile                              ~ ffs.c
  ~ ffs.h                                 ~ ffs/ffs_alloc.c
  ~ ffs/ffs_balloc.c                      ~ ffs/mkfs.c
  ~ ffs/ufs_bmap.c                        + ffs/dinode.h
  + ffs/dir.h                             + ffs/ffs_subr.c
  + ffs/ffs_tables.c                      + ffs/fs.h
  + ffs/ufs_bswap.h                       

  > Merge ufs/{ufs,ffs}/ into ffs/. (natano@)

  ~ makefs.8                              ~ makefs.c

  > Remove the -B flag. Most of the byteswapping code was tedu'd already.
  > (natano@)

  ~ makefs.8                              ~ makefs.c

  > Only allow epoch timestamps for -T. A shared option for either using the
  > timestamps from a file or using an epoch timestamp is ridiculous. (natano@)

  ~ makefs.c                              

  > Remove setprogname(). (natano@)

  ~ Makefile                              

  > cleanup Makefile (deraadt@)

ntpd

  ~ constraint.c                          

  > Save the constraint process pid by getting the start_child() return value,
  > this should fix the problem with random ntpd(8) deaths.
  > ok deraadt@ (rzalamena@)

  ~ constraint.c                          

  > Check for EAGAIN on imsg_flush() return otherwise we might be failing
  > to send message to the child process. Do like we learned in httpd(8).
  > ok deraadt@ (rzalamena@)

vmd

  ~ virtio.c                              ~ vm.conf.5

  > When the guest OS gets a zero MAC address on a network interface, it should
  > create a randomized locally administrated address.  OpenBSD as a guest OS
  > does this correctly but we cannot rely on it for other guests, so randomize
  > the MAC address in vmd(8) on the host side if it is not specified by the
  > user.  I incremented the prefix by one to differentiate from the ones
  > that are generated by OpenBSD in the kernel; fe:e1:bb:xx:xx:xx.
  > OK deraadt@ mlarkin@ (reyk@)

===============================================================================
_______________________________________________
odc mailing list
odc@squish.net
http://www.squish.net/mailman/listinfo/odc

Reply via email to