RE: [PATCH] voicecall: Add EmergencyCall property.

2010-12-03 Thread John.Mathew
Hi Marcel, This was a question open for discussion. What would be the appropriate property name? As per my understanding, this property is only to provide the Emergency call indication to the application side, so that applications can display a different UI compared to the normal UI. In

[fix-isi-voicecall PATCHv5 2/4] isi/voicecall: add call id to queued requests

2010-12-03 Thread Pekka . Pessi
From: Pekka Pessi pekka.pe...@nokia.com --- drivers/isimodem/voicecall.c | 89 +++--- 1 files changed, 57 insertions(+), 32 deletions(-) diff --git a/drivers/isimodem/voicecall.c b/drivers/isimodem/voicecall.c index b89cbb3..e7126a8 100644 ---

[fix-isi-voicecall PATCHv5 4/4] isi/voicecall: fix handling of waiting calls

2010-12-03 Thread Pekka . Pessi
From: Pekka Pessi pekka.pe...@nokia.com Also, do not retrieve calls after isi_release_all_active() because retrieving is now only an unwanted side-effect . --- drivers/isimodem/voicecall.c | 114 - 1 files changed, 56 insertions(+), 58 deletions(-) diff

[fix-isi-voicecall PATCHv5 1/4] isi/voicecall: fix status reporting

2010-12-03 Thread Pekka . Pessi
From: Pekka Pessi pekka.pe...@nokia.com Do not report incoming calls to the oFono core until they can be answered. Report MT_RELEASED or MO_RELEASED via ofono_voicecall_notify(), TERMINATED calls via ofono_voicecall_disconnected(). --- drivers/isimodem/voicecall.c | 387

[fix-isi-voicecall PATCHv5 0/4] Call state fixes

2010-12-03 Thread Pekka . Pessi
Hi all, Here are the isi voicecall patches again, rebased with the NULL fixes. --Pekka ___ ofono mailing list ofono@ofono.org http://lists.ofono.org/listinfo/ofono

[PATCH] TODO: add blacklisting

2010-12-03 Thread Pekka . Pessi
From: Pekka Pessi pekka.pe...@nokia.com --- TODO |8 1 files changed, 8 insertions(+), 0 deletions(-) diff --git a/TODO b/TODO index a421a99..558c1d2 100644 --- a/TODO +++ b/TODO @@ -305,6 +305,14 @@ Voicecall Complexity: C2 Owner: Pekka Pessi pekka.pe...@nokia.com +-

[PATCH] coding-style M14: parenthesis around sizeof arg

2010-12-03 Thread Pekka . Pessi
From: Pekka Pessi pekka.pe...@nokia.com --- doc/coding-style.txt | 14 ++ 1 files changed, 14 insertions(+), 0 deletions(-) diff --git a/doc/coding-style.txt b/doc/coding-style.txt index 9dfdc09..9d7131d 100644 --- a/doc/coding-style.txt +++ b/doc/coding-style.txt @@ -230,6

Re: [PATCH] Skip unsolicited CREG/CGREG correctly

2010-12-03 Thread Tonny Tzeng
Hi Denis, Thanks for reviewing. On Fri, Dec 3, 2010 at 5:22 AM, Denis Kenzior denk...@gmail.com wrote:               /* Some firmware will report bogus lac/ci when unregistered */ +             /* in this case, we should skip it                          */               if (s != 1 s != 5) -

[PATCH 2/3] plugins: Enabling nettime plugin in Makefile.am

2010-12-03 Thread Antti Paila
--- Makefile.am |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/Makefile.am b/Makefile.am index a4c47e8..94dbaa1 100644 --- a/Makefile.am +++ b/Makefile.am @@ -296,6 +296,9 @@ builtin_modules += example_nettime builtin_sources += examples/nettime.c endif

[PATCH 1/3] plugins: Implementation of Network Time plugin

2010-12-03 Thread Antti Paila
--- include/dbus.h|1 + plugins/nettime.c | 293 + 2 files changed, 294 insertions(+), 0 deletions(-) create mode 100644 plugins/nettime.c diff --git a/include/dbus.h b/include/dbus.h index 9e29afb..0c48f83 100644 --- a/include/dbus.h

[PATCH 3/3] plugins: Test scripts for nettime plugin

2010-12-03 Thread Antti Paila
--- test/get-nettime | 25 + test/test-nettime | 46 ++ 2 files changed, 71 insertions(+), 0 deletions(-) create mode 100755 test/get-nettime create mode 100755 test/test-nettime diff --git a/test/get-nettime

Re: [PATCH] coding-style M14: parenthesis around sizeof arg

2010-12-03 Thread Aki Niemi
On Fri, 2010-12-03 at 11:05 +0200, ext pekka.pe...@nokia.com wrote: From: Pekka Pessi pekka.pe...@nokia.com --- doc/coding-style.txt | 14 ++ 1 files changed, 14 insertions(+), 0 deletions(-) Pushed, thanks. Cheers, Aki ___ ofono

Re: [fix-isi-voicecall PATCHv5 0/4] Call state fixes

2010-12-03 Thread Aki Niemi
On Fri, 2010-12-03 at 10:30 +0200, ext pekka.pe...@nokia.com wrote: Hi all, Here are the isi voicecall patches again, rebased with the NULL fixes. Pushed the lot, thanks. Are these fixes now also in the refactored gisi tree? ;) Cheers, Aki ___

[PATCH] TODO: Add task for NITZ name support in netreg

2010-12-03 Thread Aki Niemi
--- TODO | 10 ++ 1 files changed, 10 insertions(+), 0 deletions(-) diff --git a/TODO b/TODO index 6cf7202..457c9a1 100644 --- a/TODO +++ b/TODO @@ -497,3 +497,13 @@ Miscellaneous Priority: Medium Complexity: C2 Owner: Sjur Br??ndeland sjur.brandel...@stericsson.com + +- Add

[PATCH] TODO: Add task for GSMA name list support

2010-12-03 Thread Aki Niemi
--- TODO |9 + 1 files changed, 9 insertions(+), 0 deletions(-) diff --git a/TODO b/TODO index 457c9a1..b63b834 100644 --- a/TODO +++ b/TODO @@ -507,3 +507,12 @@ Miscellaneous Priority: Medium Complexity: C1 Owner: Aki Niemi aki.ni...@nokia.com + +- Add GSM Association

Re: [PATCH 1/3] plugins: Implementation of Network Time plugin

2010-12-03 Thread Aki Niemi
Hi Antti, 2010/12/3 Antti Paila antti.pa...@nokia.com: +static GDBusMethodTable nettime_methods[] = { +       { GetNetworkTime, , a{sv}, nettime_get_time }, +       { } +}; + +static GDBusSignalTable nettime_signals[] = { +       { NetworkTimeChanged, a{sv} }, +       { } +}; The only

[PATCH] network: query signal strength when status changes to registered or roaming.

2010-12-03 Thread Marit Henriksen
From: Marit Henriksen marit.henrik...@stericsson.com Signal strength is set to -1 whenever registration status changes and differs from registered or roaming. When registration status changes again to registered or roaming, the signal strength needs to be updated, so add query towards driver to

[PATCH v2] Skip unsolicied CREG/CGREG correctly while checking GPRS attach status

2010-12-03 Thread Tonny Tzeng
This patch is to skip unsolicited CGREG while checking the GPRS attach status, especially for Huawei modem which sends lac and ci strings in unquoted format, and casues at_util_parse_reg() return lac value as status. --- drivers/atmodem/atutil.c | 12 gatchat/gatresult.c |

[PATCH] Specify vendor ID for Huawei modem while creating GPRS context

2010-12-03 Thread Tonny Tzeng
--- plugins/huawei.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/plugins/huawei.c b/plugins/huawei.c index 25dfaca..32cf70d 100644 --- a/plugins/huawei.c +++ b/plugins/huawei.c @@ -454,7 +454,7 @@ static void huawei_disconnect(gpointer user_data)

Re: [PATCH] TODO: Add task for NITZ name support in netreg

2010-12-03 Thread Denis Kenzior
Hi Aki, On 12/03/2010 08:02 AM, Aki Niemi wrote: --- TODO | 10 ++ 1 files changed, 10 insertions(+), 0 deletions(-) diff --git a/TODO b/TODO index 6cf7202..457c9a1 100644 --- a/TODO +++ b/TODO @@ -497,3 +497,13 @@ Miscellaneous Priority: Medium Complexity: C2

Re: [PATCH] TODO: Add task for GSMA name list support

2010-12-03 Thread Denis Kenzior
Hi Aki, On 12/03/2010 08:02 AM, Aki Niemi wrote: --- TODO |9 + 1 files changed, 9 insertions(+), 0 deletions(-) diff --git a/TODO b/TODO index 457c9a1..b63b834 100644 --- a/TODO +++ b/TODO @@ -507,3 +507,12 @@ Miscellaneous Priority: Medium Complexity: C1

[PATCH -v3 1/5] modem: only unref pending if it is a powered pending

2010-12-03 Thread Gustavo F. Padovan
--- src/modem.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/src/modem.c b/src/modem.c index 52e647b..d6ab316 100644 --- a/src/modem.c +++ b/src/modem.c @@ -804,7 +804,7 @@ void ofono_modem_set_powered(struct ofono_modem *modem, ofono_bool_t powered)

[PATCH -v3 2/5] modem: add ofono_modem_reset() to modem.h

2010-12-03 Thread Gustavo F. Padovan
--- include/modem.h |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/include/modem.h b/include/modem.h index 7b13ee0..a92eb88 100644 --- a/include/modem.h +++ b/include/modem.h @@ -46,6 +46,8 @@ int ofono_modem_register(struct ofono_modem *modem); ofono_bool_t

[PATCH -v3 3/5] Add ofono_modem_reset()

2010-12-03 Thread Gustavo F. Padovan
Some modems can screw up everything and then we will need to do a silent reset of the modem. This patch take the modem back to the OFFLINE state. --- src/modem.c | 20 1 files changed, 20 insertions(+), 0 deletions(-) diff --git a/src/modem.c b/src/modem.c index

[PATCH -v3 4/5] phonesim: Add modem reset trigger

2010-12-03 Thread Gustavo F. Padovan
--- plugins/phonesim.c | 27 +++ 1 files changed, 27 insertions(+), 0 deletions(-) diff --git a/plugins/phonesim.c b/plugins/phonesim.c index 6b483ff..c7ef0d7 100644 --- a/plugins/phonesim.c +++ b/plugins/phonesim.c @@ -374,6 +374,30 @@ static void

[PATCH -v3 5/5] modem: add support to restore state when resetting the modem

2010-12-03 Thread Gustavo F. Padovan
--- src/modem.c | 74 +++ 1 files changed, 44 insertions(+), 30 deletions(-) diff --git a/src/modem.c b/src/modem.c index 3126af1..638c33f 100644 --- a/src/modem.c +++ b/src/modem.c @@ -70,6 +70,7 @@ struct ofono_modem { guint

Re: [PATCH 1/7] call-forwarding: Read/Write cfis/cphs-cff

2010-12-03 Thread Denis Kenzior
Hi Jeevaka, On 11/29/2010 04:37 AM, Jeevaka Badrappan wrote: --- src/call-forwarding.c | 266 +++- 1 files changed, 260 insertions(+), 6 deletions(-) diff --git a/src/call-forwarding.c b/src/call-forwarding.c index ce03c40..bb345a6 100644 ---

Re: [RFC PATCH 2/4] modem: add EmergencyMode property

2010-12-03 Thread Denis Kenzior
Hi Andras, snip +static void modem_change_online(struct ofono_modem *modem, + enum modem_state new_state) +{ + DBusConnection *conn = ofono_dbus_get_connection(); + enum modem_state old_state = modem-modem_state; + ofono_bool_t new_online = new_state

Re: [PATCHv4] voicecall: fix dial result handling

2010-12-03 Thread Denis Kenzior
Hi Pekka, On 11/26/2010 09:14 AM, pekka.pe...@nokia.com wrote: From: Pekka Pessi pekka.pe...@nokia.com The existing call will be automatically put on hold if there is an existing active call when dialing. On some modems the dial request returns only after the dialed call is active and the

[PATCH 2/2] drivers: use %m instead of strerror()

2010-12-03 Thread Rémi Denis-Courmont
--- drivers/isimodem/sim.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/drivers/isimodem/sim.c b/drivers/isimodem/sim.c index b79c52a..0b3d2ae 100644 --- a/drivers/isimodem/sim.c +++ b/drivers/isimodem/sim.c @@ -428,7 +428,8 @@ static void sim_reachable_cb(GIsiClient

[PATCH 1/2] plugins: use %m instead of strerror()

2010-12-03 Thread Rémi Denis-Courmont
--- plugins/hfp.c|4 ++-- plugins/isigen.c | 13 - plugins/n900.c | 14 +++--- plugins/nokia-gpio.c | 29 + 4 files changed, 34 insertions(+), 26 deletions(-) diff --git a/plugins/hfp.c b/plugins/hfp.c index

[RESEND] [PATCH] Mark ofono/*.h symbolink links as built sources

2010-12-03 Thread Rémi Denis-Courmont
This forces automake/make to build them first if needed (as before). But it avoids marking every single header as a dependency of every single object. Thus we do not need a bogus full rebuild of the tree everytime a header is added. --- Makefile.am |5 ++--- 1 files changed, 2 insertions(+),

RE: [PATCH 2/5] cdma-voicecall: Add CDMA MO Call Support

2010-12-03 Thread Dara Spieker-Doyle
Hi Rajesh On Fri, 2010-12-03 at 01:30 +0100, ext rajesh.naga...@elektrobit.com wrote: +enum cdma_call_status { + CDMA_CALL_STATUS_ACTIVE = 0, + CDMA_CALL_STATUS_DIALING = 1, + CDMA_CALL_STATUS_ALERTING = 2, + CDMA_CALL_STATUS_INCOMING = 4, Should be 3 ? Yes indeed. I will

RE: [PATCH 2/5] cdma-voicecall: Add CDMA MO Call Support

2010-12-03 Thread Rajesh.Nagaiah
Hi Dara, -Original Message- From: ofono-boun...@ofono.org [mailto:ofono-boun...@ofono.org] On Behalf Of Dara Spieker-Doyle Sent: 03 December 2010 13:21 +enum cdma_call_status { + CDMA_CALL_STATUS_ACTIVE = 0, + CDMA_CALL_STATUS_DIALING = 1, + CDMA_CALL_STATUS_ALERTING =

Re: [PATCH -v3 1/5] modem: only unref pending if it is a powered pending

2010-12-03 Thread Gustavo F. Padovan
* Gustavo F. Padovan pado...@profusion.mobi [2010-12-03 16:52:53 -0200]: --- src/modem.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/src/modem.c b/src/modem.c index 52e647b..d6ab316 100644 --- a/src/modem.c +++ b/src/modem.c @@ -804,7 +804,7 @@ void

[PATCH] modem: only unref pending if it is a powered pending

2010-12-03 Thread Gustavo F. Padovan
--- src/modem.c |3 ++- 1 files changed, 2 insertions(+), 1 deletions(-) diff --git a/src/modem.c b/src/modem.c index 52e647b..ae427b3 100644 --- a/src/modem.c +++ b/src/modem.c @@ -804,7 +804,8 @@ void ofono_modem_set_powered(struct ofono_modem *modem, ofono_bool_t powered)

[PATCH 1/2] modem: add Lockdown property to Modem interface

2010-12-03 Thread Gustavo F. Padovan
Setting Lockdown to TRUE means power down the modem and hold a lock that only permits the lock's owner power up the modem back. When released it restores the last state of the modem before holding the lock. --- doc/modem-api.txt |9 src/modem.c | 129

Re: [RESEND] [PATCH] Mark ofono/*.h symbolink links as built sources

2010-12-03 Thread Marcel Holtmann
Hi Remi, This forces automake/make to build them first if needed (as before). But it avoids marking every single header as a dependency of every single object. Thus we do not need a bogus full rebuild of the tree everytime a header is added. I have run some tests on this and seems fine to