Re: [OMPI packagers] Support timelines

2021-09-16 Thread Ralph Castain
Sorry nobody answered this right away. It isn't quite that simple as we don't do support on a timeline basis. We generally support two major releases at a time. So v4 would remain supported until v6 was released. Our original intent was to have one major release per year - so the policy would

Re: [OMPI packagers] Configure external prrte and arg forwarding to bundled deps?

2020-12-02 Thread Ralph Castain
Our original thought was to not have an external PRRTE, but we have since come around on that thinking as we are now seeing PRRTE itself being distributed. We would welcome a PR to add that option if you have time - otherwise, we'll get to it prior to v5 release. Thanks! Ralph > On Dec 2,

Re: [OMPI packagers] New RTE for OMPI v5

2020-04-30 Thread Ralph Castain
single) > version of PRRTE. However, I would say that if Fedora ends up packaging > PRRTE separately we would really rather that open-mpi build against that. > > HTH, > > Orion > > On 4/27/20 6:47 PM, Ralph Castain wrote: >> Just as an FYI - just learned that a maj

Re: [OMPI packagers] New RTE for OMPI v5

2020-04-27 Thread Ralph Castain
gt; > >> On Apr 14, 2020, at 12:40 PM, Ralph Castain wrote: >> >> Just pinging you all to ensure you got this. I need to know if we >> need to coordinate an official PRRTE release to coincide (and sync) with the >> release of OMPI v5.0, or if you are okay wi

Re: [OMPI packagers] New RTE for OMPI v5

2020-04-14 Thread Ralph Castain
, libevent, and PMIx - none of which are internally embedded. Thanks Ralph > On Apr 1, 2020, at 8:40 PM, Ralph Castain wrote: > > Hi folks > > I just wanted to alert you to the fact that we are replacing the ORTE runtime > environment in Open MPI with an external package c

[OMPI packagers] New RTE for OMPI v5

2020-04-01 Thread Ralph Castain
Hi folks I just wanted to alert you to the fact that we are replacing the ORTE runtime environment in Open MPI with an external package called PRRTE ("PMIx Reference RunTime Environment"). We will be including a copy of that package in the OMPI v5 tarball, just as we do libevent, hwloc, and