Re: [OMPI packagers] Shift focus to external libevent, hwloc, pmix

2018-07-17 Thread r...@open-mpi.org


> On Jul 17, 2018, at 10:50 AM, Jeff Squyres (jsquyres) via ompi-packagers 
>  wrote:
> 
> On Jul 10, 2018, at 5:11 PM, Geoffrey Paulsen  wrote:
>> 
>>   In Open MPI v4.0, one of the changes that we're making is to prefer 
>> external packages in configure versus our internal packages for libevent, 
>> hwloc, and pmix (also see https://github.com/open-mpi/ompi/issues/5031).  
>> There are some restrictions about only preferring external packages that are 
>> "compatible", but in general we hope this should make redistributing Open 
>> MPI easier as a whole.   We're working on this feature here 
>> https://github.com/open-mpi/ompi/pull/5395 if you want to follow along.
> 
> Heads up: Arrgh.  It looks like we're going to miss this feature -- 
> unfortunately, no one was able to devote enough time to finish it.  :-(
> 
> Sorry folks.  The existing "external" mechanisms will all still work, of 
> course, but our configure script won't "prefer" them, so to speak.  So it's 
> not a major deal for this feature to have missed v4.0.0, but it's still a bit 
> of a bummer.

Hold on there - that’s night quite a correct statement. The “prefer external” 
mechanism _is_ in place for PMIx and libevent - just not yet for hwloc (I 
believe).

> 
> -- 
> Jeff Squyres
> jsquy...@cisco.com
> 
> ___
> ompi-packagers mailing list
> ompi-packagers@lists.open-mpi.org
> https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers

___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers


Re: [OMPI packagers] Open MPI packagers email list

2018-07-12 Thread r...@open-mpi.org
Gilles took a look for me and discovered the problem - there is no external 
component for PMIx 3.x in the OMPI 3.x release series! Best we can figure is 
that you are picking up a “stale” component and using it, which would explain 
the failures. If he manually resolves the problem by making the ext2x component 
build against the PMIx v3.0.0 release, everything works fine.

Brian/Jeff: how do we want to resolve this? We could modify the ext2x component 
to accept PMIx v3 and above, or we could add an ext3x component (and make it 
work for PMIx >= v3), or we could declare this combination not supported, or...?

Ralph


> On Jul 11, 2018, at 9:44 AM, Alastair McKinstry  
> wrote:
> 
> I'm seeing errors of the form:
> 
> ===
> build: OK
> [runner-103358cc-project-28133-concurrent-0:04241] PMIX-XFER-VALUE: 
> UNSUPPORTED TYPE 28016
> [runner-103358cc-project-28133-concurrent-0:04241] PMIX ERROR: ERROR in file 
> ../../../src/server/pmix_server.c at line 332
> ERROR: Job failed: exit code 1
> ===
> 
> that i'm trying to debug (OMPI 3.1.1, PMIX 3.0.0)
> 
> regards
> Alastair
> 
> On 11/07/2018 17:04, Jeff Squyres (jsquyres) wrote:
>> Ralph: do you mean to say "Open MPI v4.0.x will be compatible with any PMIx 
>> >= v3.0.0"?
>> 
>> 
>>> On Jul 11, 2018, at 12:02 PM, r...@open-mpi.org <mailto:r...@open-mpi.org> 
>>> wrote:
>>> 
>>> Yes - with any OMPI of v3.x and above
>>> 
>>>> On Jul 11, 2018, at 3:41 AM, Alastair McKinstry 
>>>>  <mailto:alastair.mckins...@sceal.ie> wrote:
>>>> 
>>>> Hi Jeff
>>>> 
>>>> Whats the relationship between OpenMPI and the PMIX 3.0.0 release  ?
>>>> 
>>>> Are they compatible ?
>>>> 
>>>> regards
>>>> 
>>>> Alastair
>>>> 
>>>> 
>>>> 
>>>> On 10/07/2018 23:19, Jeff Squyres (jsquyres) wrote:
>>>>> Yo Alastair --
>>>>> 
>>>>> Would you mind joining the Open MPI packagers email list?  It's very low 
>>>>> volume:
>>>>> 
>>>>> https://lists.open-mpi.org/mailman/listinfo/ompi-packagers 
>>>>> <https://lists.open-mpi.org/mailman/listinfo/ompi-packagers>
>>>>> 
>>>>> As part of our attempt to provide better communications to our downstream 
>>>>> packagers, we just sent out a note about the upcoming v4.0.0:
>>>>> 
>>>>> 
>>>>> https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg2.html
>>>>>  
>>>>> <https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg2.html>
>>>>> 
>>>>> And there was one previous to this, too:
>>>>> 
>>>>> 
>>>>> https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg1.html
>>>>>  
>>>>> <https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg1.html>
>>>>> 
>>>> -- 
>>>> Alastair McKinstry,  <mailto:alast...@sceal.ie>, 
>>>>  <mailto:mckins...@debian.org>, 
>>>> https://diaspora.sceal.ie/u/amckinstry 
>>>> <https://diaspora.sceal.ie/u/amckinstry>
>>>> Commander Vimes didn’t like the phrase “The innocent have nothing to fear,”
>>>> believing the innocent had everything to fear, mostly from the guilty but 
>>>> in the longer term
>>>> even more from those who say things like “The innocent have nothing to 
>>>> fear.”
>>>> - T. Pratchett, Snuff
>>>> 
>>>> ___
>>>> ompi-packagers mailing list
>>>> ompi-packagers@lists.open-mpi.org 
>>>> <mailto:ompi-packagers@lists.open-mpi.org>
>>>> https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers 
>>>> <https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers>
>> 
> 
> -- 
> Alastair McKinstry,  <mailto:alast...@sceal.ie>, 
>  <mailto:mckins...@debian.org>, 
> https://diaspora.sceal.ie/u/amckinstry 
> <https://diaspora.sceal.ie/u/amckinstry>
> Commander Vimes didn’t like the phrase “The innocent have nothing to fear,”
>  believing the innocent had everything to fear, mostly from the guilty but in 
> the longer term
>  even more from those who say things like “The innocent have nothing to fear.”
>  - T. Pratchett, Snuff

___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers


Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread r...@open-mpi.org
Okay, let me be more precise:

OMPI v4.0 will be compatible with any PMIx >= v2.1. It will ship with PMIx v3.0 
in it

OMPI v3.x is compatible with any PMIx >= v2.1. It ships with PMIx v2.1.x in it

OMPI v2.x is compatible with PMIx = 1.x. It ships with PMIx v1.2.x in it. It is 
_not_ compatible with PMIx v2 to the best of my knowledge

Ralph


> On Jul 11, 2018, at 9:04 AM, Jeff Squyres (jsquyres)  
> wrote:
> 
> Ralph: do you mean to say "Open MPI v4.0.x will be compatible with any PMIx 
> >= v3.0.0"?
> 
> 
>> On Jul 11, 2018, at 12:02 PM, r...@open-mpi.org wrote:
>> 
>> Yes - with any OMPI of v3.x and above
>> 
>>> On Jul 11, 2018, at 3:41 AM, Alastair McKinstry 
>>>  wrote:
>>> 
>>> Hi Jeff
>>> 
>>> Whats the relationship between OpenMPI and the PMIX 3.0.0 release  ?
>>> 
>>> Are they compatible ?
>>> 
>>> regards
>>> 
>>> Alastair
>>> 
>>> 
>>> 
>>> On 10/07/2018 23:19, Jeff Squyres (jsquyres) wrote:
>>>> Yo Alastair --
>>>> 
>>>> Would you mind joining the Open MPI packagers email list?  It's very low 
>>>> volume:
>>>> 
>>>>https://lists.open-mpi.org/mailman/listinfo/ompi-packagers
>>>> 
>>>> As part of our attempt to provide better communications to our downstream 
>>>> packagers, we just sent out a note about the upcoming v4.0.0:
>>>> 
>>>>
>>>> https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg2.html
>>>> 
>>>> And there was one previous to this, too:
>>>> 
>>>>
>>>> https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg1.html
>>>> 
>>> 
>>> -- 
>>> Alastair McKinstry, , , 
>>> https://diaspora.sceal.ie/u/amckinstry
>>> Commander Vimes didn’t like the phrase “The innocent have nothing to fear,”
>>> believing the innocent had everything to fear, mostly from the guilty but 
>>> in the longer term
>>> even more from those who say things like “The innocent have nothing to 
>>> fear.”
>>> - T. Pratchett, Snuff
>>> 
>>> ___
>>> ompi-packagers mailing list
>>> ompi-packagers@lists.open-mpi.org
>>> https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers
>> 
> 
> 
> -- 
> Jeff Squyres
> jsquy...@cisco.com <mailto:jsquy...@cisco.com>
___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers


Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread r...@open-mpi.org
Yes - with any OMPI of v3.x and above

> On Jul 11, 2018, at 3:41 AM, Alastair McKinstry  
> wrote:
> 
> Hi Jeff
> 
> Whats the relationship between OpenMPI and the PMIX 3.0.0 release  ?
> 
> Are they compatible ?
> 
> regards
> 
> Alastair
> 
> 
> 
> On 10/07/2018 23:19, Jeff Squyres (jsquyres) wrote:
>> Yo Alastair --
>> 
>> Would you mind joining the Open MPI packagers email list?  It's very low 
>> volume:
>> 
>> https://lists.open-mpi.org/mailman/listinfo/ompi-packagers
>> 
>> As part of our attempt to provide better communications to our downstream 
>> packagers, we just sent out a note about the upcoming v4.0.0:
>> 
>> 
>> https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg2.html
>> 
>> And there was one previous to this, too:
>> 
>> 
>> https://www.mail-archive.com/ompi-packagers@lists.open-mpi.org/msg1.html
>> 
> 
> -- 
> Alastair McKinstry, mailto:alast...@sceal.ie>>, 
> mailto:mckins...@debian.org>>, 
> https://diaspora.sceal.ie/u/amckinstry 
> 
> Commander Vimes didn’t like the phrase “The innocent have nothing to fear,”
> believing the innocent had everything to fear, mostly from the guilty but in 
> the longer term
> even more from those who say things like “The innocent have nothing to fear.”
> - T. Pratchett, Snuff
> 
> ___
> ompi-packagers mailing list
> ompi-packagers@lists.open-mpi.org 
> https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers 
> 
___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers