Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread Alastair McKinstry
Hi Jeff Whats the relationship between OpenMPI and the PMIX 3.0.0 release  ? Are they compatible ? regards Alastair On 10/07/2018 23:19, Jeff Squyres (jsquyres) wrote: Yo Alastair -- Would you mind joining the Open MPI packagers email list? It's very low volume:

[OMPI packagers] Shift focus to external libevent, hwloc, pmix

2018-07-11 Thread Alastair McKinstry
Hi, For the v4.0 release, is it expected that the major library version will change again ? i.e. from so.40 currently on most libraries to so.50 ? If so, this will involve another transition on Debian/Ubuntu. Also, I'd like to revisit the Symbol versioning feature

Re: [OMPI packagers] Shift focus to external libevent, hwloc, pmix

2018-07-11 Thread Geoffrey Paulsen
I am HOPING it won't, but we have not done the analysis yet to determine if it's safe to NOT rev the .so version.  Best to assume it WILL rev.We should know more before the end of the month. ---Geoffrey PaulsenSoftware Engineer, IBM Spectrum MPIPhone: 720-349-2832Email:

Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread r...@open-mpi.org
Okay, let me be more precise: OMPI v4.0 will be compatible with any PMIx >= v2.1. It will ship with PMIx v3.0 in it OMPI v3.x is compatible with any PMIx >= v2.1. It ships with PMIx v2.1.x in it OMPI v2.x is compatible with PMIx = 1.x. It ships with PMIx v1.2.x in it. It is _not_ compatible

Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread Alastair McKinstry
I'm seeing errors of the form: === build: OK [runner-103358cc-project-28133-concurrent-0:04241] PMIX-XFER-VALUE: UNSUPPORTED TYPE 28016 [runner-103358cc-project-28133-concurrent-0:04241] PMIX ERROR: ERROR in file ../../../src/server/pmix_server.c at line 332 ERROR: Job failed: exit

Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread Jeff Squyres (jsquyres) via ompi-packagers
Ralph: do you mean to say "Open MPI v4.0.x will be compatible with any PMIx >= v3.0.0"? > On Jul 11, 2018, at 12:02 PM, r...@open-mpi.org wrote: > > Yes - with any OMPI of v3.x and above > >> On Jul 11, 2018, at 3:41 AM, Alastair McKinstry >> wrote: >> >> Hi Jeff >> >> Whats the

Re: [OMPI packagers] Open MPI packagers email list

2018-07-11 Thread r...@open-mpi.org
Yes - with any OMPI of v3.x and above > On Jul 11, 2018, at 3:41 AM, Alastair McKinstry > wrote: > > Hi Jeff > > Whats the relationship between OpenMPI and the PMIX 3.0.0 release ? > > Are they compatible ? > > regards > > Alastair > > > > On 10/07/2018 23:19, Jeff Squyres (jsquyres)