Re: [OMPI packagers] Possible to have multiple OpenMPIs simultaneously?

2020-11-29 Thread Aisha Tammy via ompi-packagers
On 11/29/20 9:39 PM, Gilles Gouaillardet wrote: > I made a quick check, and the latest 3.1 MPI standard is supported (at least) > from Open MPI 2.0.* > > (you can check the MPI_VERSION and MPI_SUBVERSION macros in > ompi/include/mpi.h[.in]) Amazing! Thanks a lot! Aisha > > > please do note that

Re: [OMPI packagers] Possible to have multiple OpenMPIs simultaneously?

2020-11-29 Thread Gilles Gouaillardet
Aisha, yes, you can install multiple Open MPI implementations in parallel, simply use a different prefix when running configure. Newer versions of Open MPI support the latest MPI standard (there is not a direct link between an Open MPI version and the MPI standard version though). That being

Re: [OMPI packagers] Possible to have multiple OpenMPIs simultaneously?

2020-11-29 Thread Aisha Tammy via ompi-packagers
On 11/29/20 7:45 PM, Gilles Gouaillardet wrote: > Aisha, > > yes, you can install multiple Open MPI implementations in parallel, > simply use a different prefix when running configure. > > Newer versions of Open MPI support the latest MPI standard Makes sense :D > (there is > not a direct link

Re: [OMPI packagers] Possible to have multiple OpenMPIs simultaneously?

2020-11-29 Thread Gilles Gouaillardet
I made a quick check, and the latest 3.1 MPI standard is supported (at least) from Open MPI 2.0.* (you can check the MPI_VERSION and MPI_SUBVERSION macros in ompi/include/mpi.h[.in]) please do note that the 2.0 and 2.1 series are no more supported. Cheers, Gilles On 11/30/2020 11:27