[OE-core] [PATCH] package_manager.py: Generate separate repo entries per arch

2017-04-13 Thread Ian.Arkver
dnf requires a serparate repo for each architecture. This patch writes one config file per PACKAGE_FEED_URIS entry with an entry for each architecture, if any. It also uses a space separated version of the repo id as the repo name instead of just the id again. Signed-off-by: Ian.Arkver

[OE-core] [PATCH] package_manager.py: Add a name for the generated dnf repo.

2017-04-11 Thread Ian.Arkver
This adds repo_name as the name, which is the same as the repo ID and hence a bit pointless, but it stops dnf from complaining that the repo doesn't have a configured name. Signed-off-by: Ian.Arkver <ian.arkver@gmail.com> --- meta/lib/oe/package_manager.py | 2 +- 1 file changed, 1 ins

[OE-core] [PATCH v2] package_manager.py: Split feed_archs for RPM repo URIs

2017-04-10 Thread Ian.Arkver
By default the feed_archs variable is split into single characters resulting in very many broken short repo_uris. Add a split() to split the string into words first. Signed-off-by: Ian.Arkver <ian.arkver@gmail.com> --- Changes since v1: Change shortlog message to meet style requi