Re: [API Review]: Node validation

2013-07-08 Thread Pavel Safrata
Hello, one more discussion topic: perhaps the validate name is too general? Maybe we can come up with more descriptive name? There are all kinds of nodes and sometimes this name can be misleading (not ringing the layout bell at all). For example TextField.validate() may look like validating

hg: openjfx/8/graphics/rt: Fixed since for FC initial file name

2013-07-08 Thread hang . vo
Changeset: 2f9f7e525e2d Author:Lubomir Nerad lubomir.ne...@oracle.com Date: 2013-07-08 13:36 +0200 URL: http://hg.openjdk.java.net/openjfx/8/graphics/rt/rev/2f9f7e525e2d Fixed since for FC initial file name ! modules/graphics/src/main/java/javafx/stage/FileChooser.java

Re: [API Review]: Node validation

2013-07-08 Thread Martin Sladecek
The plan is to have a final validate() method. Anyway, does anybody have a better suggestion? The validate should do both CSS and layout and I would like to avoid method name that's too descriptive (like validateLayoutAndCSS()) if possible. I think the most important thing about the method is

Re: [API Review]: Node validation

2013-07-08 Thread Ali Ebrahimi
just my suggestions: validation is a side effect free concept. but your validate contains css layout processing for Node, so validate is very poor name in this case. May be better use computeBounds instead. But alternates for validate( if method is a side effect free): verify() verfifyNode()

Re: [API Review]: Node validation

2013-07-08 Thread Mario Torre
On Mon, 2013-07-08 at 14:20 +0200, Martin Sladecek wrote: The plan is to have a final validate() method. Anyway, does anybody have a better suggestion? The validate should do both CSS and layout and I would like to avoid method name that's too descriptive (like validateLayoutAndCSS()) if

Gradle build, one step forward, two backward :)

2013-07-08 Thread Mario Torre
Hi all! I tried to compile JavaFX with the gradle build, and here are my results, with different settings: 1. *** Closed Everything *** JAVA_HOME=/closed/jdk-8-ea-96/ BINARY_STUB=/closed/jdk-8-ea-96/jre/lib/ext/jfxrt.jar [neugens@galactica rt]$ gradle jfxrt Loading ... :jfxrtLinux :jfxrt

Re: Gradle build, one step forward, two backward :)

2013-07-08 Thread Richard Bair
Caused by: java.lang.NullPointerException at com.sun.javafx.font.PrismFontLoader.loadFont(PrismFontLoader.java:220) at javafx.scene.text.Font.init(Font.java:318) at javafx.scene.text.Font.getDefault(Font.java:85) at

Re: [API Review]: Node validation

2013-07-08 Thread Richard Bair
OK, just throwing something wild out there. Right now we have a layout pass and a css pass. Can they be combined? Can we combine them just into something that happens during layout? And can the existing layout() method be the thing that kicks it all off? Wild and crazy but just throwing it out

Re: Node bounds documentation issue?

2013-07-08 Thread Richard Bair
I think you are right and the docs should be updated to indicate this. If you would like to file a JIRA and a patch that would be awesome. Thanks Richard On Jul 8, 2013, at 9:20 AM, Scott Palmer swpal...@gmail.com wrote: The javadocs discussing Bounding Rectangles for Node state: The

Re: [API Review]: Node validation

2013-07-08 Thread Scott Palmer
validateVisuals() ? Or something with the word visual as it combines layout and other CSS information. Scott On Mon, Jul 8, 2013 at 12:31 PM, Richard Bair richard.b...@oracle.comwrote: OK, just throwing something wild out there. Right now we have a layout pass and a css pass. Can they be

Re: [API Review]: Node validation

2013-07-08 Thread Ali Ebrahimi
I say validate should also not change state, otherwise computeBounds would be better name for method. Consider validate in input validation. On Mon, Jul 8, 2013 at 8:57 PM, Scott Palmer swpal...@gmail.com wrote: Since CSS is implicitly tied to layout, validateLayout() seems to be enough. I

Re: API REVIEW for TabPane tab content loading and fixed content size

2013-07-08 Thread Richard Bair
Hi Paru, I have a few questions. The first is, why does it make a difference whether the tab content is added to the scene graph or not? If a node is marked visible=false, it *should* be essentially the same as not being in the graph. That entire branch shouldn't be picked, etc. I don't doubt

hg: openjfx/8/graphics/rt: Added standalone IntelliJ Project for 3DViewer App

2013-07-08 Thread hang . vo
Changeset: 228c5ed14f8f Author:Jasper Potts Date: 2013-07-08 14:23 -0700 URL: http://hg.openjdk.java.net/openjfx/8/graphics/rt/rev/228c5ed14f8f Added standalone IntelliJ Project for 3DViewer App + apps/experiments/3DViewer/.idea/.name + apps/experiments/3DViewer/.idea/compiler.xml

hg: openjfx/8/controls/rt: 7 new changesets

2013-07-08 Thread hang . vo
Changeset: d6d09c8c7236 Author:jgiles Date: 2013-07-05 12:02 +1200 URL: http://hg.openjdk.java.net/openjfx/8/controls/rt/rev/d6d09c8c7236 Fix small regression due to RT-31173: custom skins could no longer be set on PopupControl but now they can. Thanks to Claudine Zillmann for