Re: [Openocd-development] (nor) flash broken

2009-12-07 Thread David Brownell
I thought I'd try mem info in GDB. Nothing. Why? The first thing I tried, by the way, was gdb_memory_map enable but that failed with extreme rudeness. :( How so? :) Immediate exit during startup. ___ Openocd-development

Re: [Openocd-development] [PATCH] minidriver: allow jtag_add_dr_out() to be inlined into inner loops

2009-12-07 Thread Øyvind Harboe
On Sun, Dec 6, 2009 at 2:51 PM, Øyvind Harboe oyvind.har...@zylin.com wrote:     1. Move the $(srcdir) from defining _DIR vars to their use. i.e.        set just the directory component. I'm not quite sure what you mean by this. I have a makefile rule that is only used with the minidriver,

[Openocd-development] help regression

2009-12-07 Thread Øyvind Harboe
The help command used to be able to search through *all* help text for any matches. If I type help image, I would expect this to list e.g. flash write_image. help load = should list load_image. The search was both on command names, options, help text, etc. -- Øyvind Harboe US toll free

[Openocd-development] [patch 0/4] ARM: target/arm.h

2009-12-07 Thread David Brownell
Here are four patches which largely finish the work of making sure we have a top level for ARM cores ... at least, as much as can be finished for the 0.4.0 release. The microcontroller profile cores (Cortex-M0/M1/M3, Thumb2-only and without all those CPU modes) won't fit until register access is

[Openocd-development] [patch 1/4] ARM: remove mrc_opcode(), use MRC() or MCR()

2009-12-07 Thread David Brownell
Get rid of mrc_opcode() in favor of ARMV4_5_MRC() or, where arm*20t should have used it, ARMV4_5_MCR() instead. Basically, *writing* coprocessor registers shouldn't have used the *read* opcode ... and both should stick to standard opcode constructors, not rearranging parameter sequence any more

[Openocd-development] [patch 3/4] ARM: rename some generic routines

2009-12-07 Thread David Brownell
Rename some (mostly) generic ARM functions: armv4_5_arch_state() -- arm_arch_state() armv4_5_get_gdb_reg_list() -- arm_get_gdb_reg_list() armv4_5_init_arch_info() -- arm_init_arch_info() Cores using the microcontroller profile may want a different arch_state() routine though.

[Openocd-development] [patch 2/4] ARM: move opcode macros to target/arm_opcodes.h

2009-12-07 Thread David Brownell
Move the ARM opcode macros from target/armv4_5.h, and a few Thumb2 ones from target/armv7m.h, to more appropriate homes in a new target/arm_opcodes.h file. Removed duplicate opcodes from that v7m/Thumb2 set. Protected a few macro argument references by adding missing parentheses. Tightening up

[Openocd-development] [patch 0/4] various cleanups

2009-12-07 Thread David Brownell
These apply on top of the previous patches. - User's guide shows simple setup, to help guide first-time users: openocd -f interface/ADAPTER.cfg -f board/BOARD.cfg will save a lot of head scratching, if it works. - Don't clone arm_arch_state(), just call it. - Add debug_reason_name()

[Openocd-development] [patch 4/4] ARM: use target/arm.h not armv4_5.h

2009-12-07 Thread David Brownell
Move most declarations in target/armv4_5.h to target/arm.h and update users. What's left in the older file is stuff that I think should be removed ... the old register cache access stuff, which makes it awkward to support microcontroller profile (Cortex-M) cores. The armv4_5_run_algorithm()

[Openocd-development] [patch 2/4] ARM: don't clone arm_arch_state() code

2009-12-07 Thread David Brownell
Have various ARM cores delegate to arm_arch_state() to display basic information, instead of duplicating that logic. This shrinks the code, makes them all report when semihosting is active, and highlights which data are specific to this core. (Like ARM720 not having separate instruction and data

[Openocd-development] [patch 1/4] User's Guide: add quickie setup notes

2009-12-07 Thread David Brownell
Add a brief setup with no customization note showing the how easily things can work if standard OpenOCD config scripts already exist. We've had some new users comment that this information is needlessly hard to find, so that starting to use OpenOCD is more difficult than it should be. Plus

Re: [Openocd-development] [PATCH] minidriver: allow jtag_add_dr_out() to be inlined into inner loops

2009-12-07 Thread Zach Welch
On Mon, 2009-12-07 at 12:26 +0100, Øyvind Harboe wrote: On Sun, Dec 6, 2009 at 2:51 PM, Øyvind Harboe oyvind.har...@zylin.com wrote: 1. Move the $(srcdir) from defining _DIR vars to their use. i.e. set just the directory component. I'm not quite sure what you mean by this. I

Re: [Openocd-development] [patch 0/4] ARM: target/arm.h

2009-12-07 Thread David Brownell
On Monday 07 December 2009, David Brownell wrote: Barring objections, I'll merge this later today; this change has been coming for a while, I don't think anyone should be surprised by it. Merged with the other patches, and some random stuff ... most notably disassembly for newish (ARMv6) SRS

[Openocd-development] multiple JTAG interfaces

2009-12-07 Thread Zach Welch
Hi all, The following list describes the things that might still be accomplished before the 0.4.0-rc cycle starts. These features are all mostly done in my tree; they work fine for me in limited testing. They should all be safe incremental steps to take. - generic driver/instance helper module

Re: [Openocd-development] [patch 2/4] ARM: move opcode macros to target/arm_opcodes.h

2009-12-07 Thread Nicolas Pitre
On Mon, 7 Dec 2009, David Brownell wrote: Move the ARM opcode macros from target/armv4_5.h, and a few Thumb2 ones from target/armv7m.h, to more appropriate homes in a new target/arm_opcodes.h file. What about changing the names of a couple of those macros as well? Say ARMV4_5_STMIA(). This

Re: [Openocd-development] help regression

2009-12-07 Thread Øyvind Harboe
On Mon, Dec 7, 2009 at 11:58 PM, Zach Welch z...@superlucidity.net wrote: On Mon, 2009-12-07 at 12:48 +0100, Øyvind Harboe wrote: The help command used to be able to search through *all* help text for any matches. If I type help image, I would expect this to list e.g. flash write_image.

Re: [Openocd-development] multiple JTAG interfaces

2009-12-07 Thread Øyvind Harboe
- multiple JTAG interface API support (internal to the JTAG module only) A particular concern for me is obviously that I do not want to see any performance degradation when there is only a single minidriver in the system. I first need to get the jtag_add_dr_out() fixes out of the door, then