My view point (which has been stated elsewhere) is that OpenSSL-3.0 is
about internal restructuring to allow for the various things noted in the
It is not about changing the feature set (in a feature reduction sense).
In future releases we will make the mixture of providers
On Thu, Jul 11, 2019 at 12:37 AM Dmitry Belyavsky wrote:
> Dear Tim,
> Formally I am a contributor with a signed CLA.
> I took a code definitely permitting any usage without any feedback,
> slightly modified it (at least by openssl-format-source and splitting
> between header and source), and
Previous assertions that if the license was compatible that we don't need a
CLA in order to accept a contribution were incorrect.
You are now questioning the entire purpose of contributor agreements and
effectively arguing they are superfluous and that our policy should be
You are (of
On Wed, Jul 10, 2019 at 1:58 AM Salz, Rich wrote:
> Thank you for the update. This brings to mind a few additional questions:
> 1. Does other code which is copyright/licensed under the Apache 2 license
also require CLAs?
See points 1-3 of previous email. CLAs are required for anything
sed on the license terms of a contribution
On Fri, Jun 21, 2019 at 4:24 PM Tim Hudson wrote:
> Unfortunately, the issue isn't the compatibility of the license - they do
> indeed look relatively compatible to me - and the discussion on this thread
> has so far been about tha
Unfortunately, the issue isn't the compatibility of the license - they do
indeed look relatively compatible to me - and the discussion on this thread
has so far been about that.
However the contributor license agreement requires that the copyright owner
grants such permission - it is the
On Thu, Jun 13, 2019 at 6:40 PM Salz, Rich wrote:
> The proper way to handle this, in my experience, is *DO NOT REUSE ERROR
No. This is a path to a rather unacceptable outcome.
Taking your example and running forward with it, having an out-of-memory
separate error code for every
On Fri, May 24, 2019 at 7:34 PM Matt Caswell wrote:
> On 24/05/2019 10:28, SHANE LONTIS wrote:
> > It doesn’t stop us both reviewing a PR. That doesn’t mean we both need
> to approve.
> Right...but in Matthias's version if you raise a PR, and then Pauli
> approves it,
> then you only then need
As part of various discussions, I've drafted a proposed (not yet put to a
formal vote) change to the committers policy to address the perception of a
potential conflict-of-interest situation. I don't believe that we have
actually encountered a conflict of interest in our current policy, but
We have discussed this at numerous OMC meetings in terms of how to managed
potential *perceived *conflicts of interest that might arise if people
outside of the fellows come from the same company and hence can effectively
turn the OMC review control mechanism into a single control rather than a
"handle" is the wrong name for this - if you want to have private const
data then do that rather than something which might be abused for instance
specific information. It could just be an int even or a short. It doesn't
have to be a pointer.
That would reduce the likely of it being used to hold
Looking at PR#8287 I think we need to get some naming schemes written down
and documented and followed consistently. The naming used in this PR seems
to be somewhat inconsistent.
For me, I think the naming convention most often used is
return_type SOMETHING_whatever(SOMETHING *,...)
Add a -r to your diff command so you recursively compare ... then you will
see the actual code changes.
Without the -r you are only comparing files in the top-level directory of
diff *-r* -dup openssl-1.0.2q openssl-1.0.2r
-- Forwarded message --
From: Hong Cho
On Mon, Feb 18, 2019 at 8:36 PM Matt Caswell wrote:
> On 18/02/2019 10:28, Tim Hudson wrote:
> > It should remain completely opaque.
> > As a general rule, I've never seen a context where someone regretted
> making a
> > structure opaque over time
It should remain completely opaque.
As a general rule, I've never seen a context where someone regretted making
a structure opaque over time, but the converse is not true.
This is opaque and should remain opaque.
We need the flexibility to adjust the implementation at will over time.
Tim - I think inline functions in public header files simply shouldn't be
Matt - I agree
Richard - I'm ambivalent... in the case of stack and lhash, the generated
functions we made static inline expressly to get better C type safety, and
On Thu, Jan 24, 2019 at 9:45 PM Matt Caswell wrote:
> > This notion of "handshake" is not supported by RFC 8446 uses the terms
> > handshake", "a handshake", and "post-handshake". "Post-handshake", in
> > particular, implies KeyUpdate are after the handshake, not part of it.
> I just
The function has been there for a long time (since then beginning) and it
is all about version related information - so both names aren't exactly
OpenSSL_version_information() would be a better name.
It would also argue that the "version" program should be renamed "info" as
I don't see a *substantial benefit* from going to C99 and I've worked on
numerous embedded platforms where it is highly unlikely that C99 support
will ever be available.
Kurt - do you have a specific list of features you think would be
beneficial - or is it just a general sense to move forward?
On Fri, Sep 28, 2018 at 4:55 PM Matt Caswell wrote:
> Either we go with semver and totally commit to it - or we stick with what
> we've already got. No
> half-way, "well we're kind of doing semver, but not really".
I see no point in changing what we are doing *without* getting the benefit
On Tue, Sep 25, 2018 at 11:02 PM Matt Caswell wrote:
> You're right on this one. I misread the diff.
Not a problem - you are doing the look-at-what-we-did and how it would be
impacted - and that is certainly what we should be doing - working through
what impact this would have had.
On Tue, Sep 25, 2018 at 10:37 PM Matt Caswell wrote:
> - Added some new macros:
No we didn't change our public API for this one - we changed *internals*.
The change to include/openssl/crypto.h was entirely changing *comments* to
document that the
On Tue, Sep 25, 2018 at 9:22 PM Matt Caswell wrote:
> Lets imagine we release version 5.0.0. We create a branch for it and
> declare a support period. Its an LTS release. This is a *stable*
> release, so we shouldn't de-stabilise it by adding new features.
> Later we do some work on some new
On Tue, Sep 25, 2018 at 8:07 PM Matt Caswell wrote:
> On 25/09/18 10:58, Tim Hudson wrote:
> > On Tue, Sep 25, 2018 at 7:23 PM Richard Levitte > <mailto:levi...@openssl.org>> wrote:
> > So what you suggest (and what I'm leaning toward) means that
On Tue, Sep 25, 2018 at 7:23 PM Richard Levitte wrote:
> So what you suggest (and what I'm leaning toward) means that we will
> change our habits.
Adoption of semantic versioning will indeed require us to change our habits
in a number of areas - that is the point of having a single clear
A fairly common approach that is used is that you can only remove something
that has been marked for deprecation at a MAJOR release version boundary.
That is entirely independent of the semantic versioning view of things -
which also happens to say the same thing (that adding a deprecation
On Sat, Sep 22, 2018 at 3:12 PM Viktor Dukhovni
> The proposal to move the minor version into nibbles 2 and 3 breaks this
> OpenSSH function.
No it doesn't - because I'm not talking about moving *anything* in the
current encoding for major and minor - see earlier post.
If you accept that we have a MAJOR.MINOR.FIX.PATCH encoding currently
documented and in place and that the encoding in OPENSSL_VERSION_NUMBER is
documented then the semantic versioning is an easy change.
We do not need to change our encoding of MAJOR.MINOR - that is documented
and fixed. We just
On Sat, Sep 22, 2018 at 11:55 AM Viktor Dukhovni
> this is an ad-hoc encoding with monitonicity as the
> the only constraint.
If you start from the position that the encoding of OPENSSL_VERSION_NUMBER
is free to change so long as the resulting value is larger than what we
On Sat, 22 Sep. 2018, 3:24 am Viktor Dukhovni,
> > On Sep 21, 2018, at 12:50 PM, Tim Hudson wrote:
> > If that is the case then our current practice of allowing ABI breakage
> > minor release changes (the middle number we document as the minor
> release n
On Sat, 22 Sep. 2018, 2:29 am Viktor Dukhovni,
> > On Sep 21, 2018, at 12:14 PM, Matt Caswell wrote:
> > I support Richard's proposal with an epoch of 1.
> > Grudgingly I would accept an epoch in the 3-8 range.
> > I would oppose an epoch of 2.
> I can live with that, though it
On Sat, Sep 22, 2018 at 1:39 AM Viktor Dukhovni
> The only change needed is a minor one in applications that actually
> parse the nibbles
What I was suggesting is that we don't need to break the current encoding
We have a major.minor.fix version encoded and documented in the
On Sat, Sep 22, 2018 at 1:34 AM Matthias St. Pierre <
> On 21.09.2018 17:27, Tim Hudson wrote:
> > We cannot remove the current major version number - as that concept
> exists and we have used it all along.
> > We
On Sat, Sep 22, 2018 at 1:16 AM Viktor Dukhovni
> > On Sep 21, 2018, at 11:00 AM, Tim Hudson wrote:
> > If you repeat that in semantic versioning concepts just using the labels
> for mapping you get:
> > - what is the major version number - the
On Sat, Sep 22, 2018 at 12:32 AM Viktor Dukhovni
> > On Sep 21, 2018, at 10:07 AM, Tim Hudson wrote:
> > And the output you get:
> > 0x10102000
> The trouble is that existing software expects to potential ABI changes
And the output you get:
On Fri, Sep 21, 2018 at 11:36 PM Richard Levitte
> In message w2o_njr8bfoor...@mail.gmail.com> on Fri, 21 Sep 20
Now I get the conceptual issue that Richard and Matt are differing on - and
it is about actually replacing OpenSSL's versioning concept with semantic
versioning compared to adopting semantic versioning principles without
actually being precisely a semantic version approach.
The whole concept of
Semantic versioning is about a consistent concept of version handling.
And that concept of consistency should be in a forms of the version - be it
text string or numberic.
That you see them as two somewhat independent concepts isn't something I
support or thing makes sense at all.
So as a concrete example - taking master and the current
"OpenSSL 1.1.2-dev xx XXX "
That is what I understand is the point of semantic versioning. You know how
to pull apart the version string.
-dev indicates a pre-release
On Fri, Sep 21, 2018 at 9:02 PM Matt Caswell wrote:
> I think this is an incorrect interpretation of Richard's proposal. The
> OPENSSL_VERSION_NUMBER value is an *integer* value. It does not and
> cannot ever conform to semantic versioning because, because version
> numbers in that scheme are
On Fri, Sep 21, 2018 at 7:58 PM Richard Levitte wrote:
> Our FAQ says that such changes *may* be part of a major
> release (we don't guarantee that breaking changes won't happen), while
> semantic versioning says that major releases *do* incur backward
> incompatible API changes.
I think you
On Mon, Sep 10, 2018 at 8:44 AM, Matt Caswell wrote:
> As far as the release criteria go we only count the ones shown in the
> Coverity tool. That's not to say we shouldn't fix issues in the tests as
> well (and actually I'd suggest we stop filtering out problems in the
> tests if anyone knows
On Sun, Sep 9, 2018 at 8:34 PM, Matt Caswell wrote:
> Please can someone freeze the repo:
> ssh openssl-...@git.openssl.org freeze openssl matt
> openssl-project mailing list
All PRs except #7145 now reviewed and marked ready.
On Fri, Sep 7, 2018 at 8:41 AM, Matt Caswell wrote:
> We currently have 8 1.1.1 PRs that are open. 3 of which are in the
> "ready" state. There are 2 which are alternative implementations of the
> same thing - so there are really on 4
We need to get this release out and available - there are a lot of people
waiting on the "production"release - and who won't go forward on a beta
(simple fact of life there).
I don't see the outstanding items as release blockers - and they will be
wrapped up in time.
Having the release date as a
On Thu, Sep 6, 2018 at 8:59 AM, Matt Caswell wrote:
> #7113 An alternative to address the SM2 ID issues
> (an alternative to the older PR, #6757)
> Updates made following earlier review. Awaiting another round of reviews.
> Owner: Paul Yang
All the previous comments have been addressed. I
Welcome to Paul Dale (OMC) , Paul Yang and Nicola Tuveri (Commiters).
See the blog post at https://www.openssl.org/blog/blog/2018/08/22/updates/
openssl-project mailing list
We don't have a formal policy of no NULL checks - we just have a few
members that think we should have such a policy but it has never been voted
on as we had sufficiently varying views for a consensus approach to not be
Personally I'm in favour of high-level APIs having NULL checks as
No that vote does not pass. All votes require participation by a majority
of active members. Failure to have a majority participation causes a vote
With only three out of eight members voting this vote simply did not pass.
On Thu, 24 May 2018, 12:59 am Salz, Rich,
Where we are stating that ABI compatibility is in place we should be
i.e. the older release binaries should be run against the current release
libraries - and that should be put into CI in my view.
Going the other direction isn't something I have thought we have ever
> In message <CAHEJ-S7o+ztC8gF3ZN_J7qoFPiCbxTOBYfrXr8AVK6s15Hd8C
> w...@mail.gmail.com> on Tue, 03 Apr 2018 15:36:15 +, Tim Hudson <
> t...@cryptsoft.com> said:
> tjh> And it should have a test - which has nothing to do with ASM and
> everything to d
Improved testing to me is something that is a good thing - and a value
It doesn't change libcrypto or libssl - and that to me is the way I think
Fixing tests and apps and Makefiles to me are different from adding
features to libcrypto or libssl.
On this one - the fuzz testing
One thing that should be noted is that if you are building with -Wall
-Werror (which many projects do) and you are using OpenSSL and things
change from a const perspective builds
We have been holding off on post-1.1.1 feature development for a long time
now - on the grounds that TLSv1.3 was just around the corner etc and the
release was close - and then we formed a release plan which we pushed back
It is long overdue that we get to start moving those other things
I too see this in the "bug fix" area - although you can make a reasonable
counter argument (but I don't see a lot of point in doing so).
Improving the build environment is a good thing IMHO ...
On Mon, Mar 19, 2018 at 10:27 PM, Salz, Rich wrote:
> I would consider it a
I've edited that to be closer to the list of items we are discussing and to
remove things which looked like commitments that are out of scope of our
As always, feedback is welcome - but we have had a few people referencing
We have to keep in mind what threats we care about and their practicality.
The security of a DRBG is dependent on both the secrecy of the seed
material provided and the security of the algorithm in terms of its output
not leaking information that materially leaks the internal state in a
This discussion has been taken to the OMC mailing list (where it continues)
rather than the openssl-project list as it goes across previous team
An update once that discussion completes will be sent to the
On Tue, Mar 13, 2018 at 11:22 AM, Salz,
If you are blocked on review please drop a note (like the one you just did)
to the group.
Some of us review the specifically blocked things when such notes are sent.
#3082 is already closed and merged - did you mean another PR?
#3958 approved (in case Richard doesn't get back to it)
> So I think we should either all vote in public, or nobody should vote in
You make a good point there - I agree.
openssl-project mailing list
> Now, the initial posting went to both the OMC and the project list,
> and some chose to vote with a simple "Reply All" without editing the
> recipients. If that was on purpose or because attention wasn't payed
> to that detail, I cannot say.
For my part, it was just a reply-all - but if I had
Before we look at removing things like this, I think we should look at
whether or not they actually have a significant maintenance cost.
On 11 Feb. 2018 7:08 am, "Salz, Rich" wrote:
This is derived from bureau/libcrypto-proposal that Emilila made in
Mail list logo