Re: Is OpenSSL 1.1.1g backward compatible with 1.0.2.f ?

2020-09-30 Thread Tomas Mraz
Hello,

unfortunately no, 1.1.1g is neither API nor ABI compatible with 1.0.2f.

You cannot directly replace 1.0.2f with 1.1.1g. The applications have
to support 1.1.1 release and be recompiled against it to work with it.

Regards,

Tomas Mraz

On Tue, 2020-09-22 at 14:08 +, Kapil Awate wrote:
> Hi,
>  
> Is OpenSSL 1.1.1g backward compatible with 1.0.2.f ? Can anyone help
> me with this ? Is there any impact on existing functionality after
> upgrading it to 1.1.1g ?
>  
> Thanks!
>  
> This email and any attachments thereto may contain private,
> confidential, and/or privileged material for the sole use of the
> intended recipient. Any review, copying, or distribution of this
> email (or any attachments thereto) by others is strictly prohibited.
> If you are not the intended recipient, please contact the sender
> immediately and permanently delete the original and any copies of
> this email and any attachments thereto.
-- 
Tomáš Mráz
No matter how far down the wrong road you've gone, turn back.
  Turkish proverb
[You'll know whether the road is wrong if you carefully listen to your
conscience.]




Is OpenSSL 1.1.1g backward compatible with 1.0.2.f ?

2020-09-30 Thread Kapil Awate
Hi,

Is OpenSSL 1.1.1g backward compatible with 1.0.2.f ? Can anyone help me with 
this ? Is there any impact on existing functionality after upgrading it to 
1.1.1g ?

Thanks!

This email and any attachments thereto may contain private, confidential, 
and/or privileged material for the sole use of the intended recipient. Any 
review, copying, or distribution of this email (or any attachments thereto) by 
others is strictly prohibited. If you are not the intended recipient, please 
contact the sender immediately and permanently delete the original and any 
copies of this email and any attachments thereto.


Is OpenSSL 1.1.1g backward compatible with 1.0.2.f ?

2020-09-30 Thread Kapil Awate
Hi,

Is OpenSSL 1.1.1g backward compatible with 1.0.2.f ? Can anyone help me with 
this ? Is there any impact on existing functionality after upgrading it to 
1.1.1g ?

Thanks!

This email and any attachments thereto may contain private, confidential, 
and/or privileged material for the sole use of the intended recipient. Any 
review, copying, or distribution of this email (or any attachments thereto) by 
others is strictly prohibited. If you are not the intended recipient, please 
contact the sender immediately and permanently delete the original and any 
copies of this email and any attachments thereto.