Re: [openstack-dev] [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-11-03 Thread Eduard Matei
is commenting using the name "Open vStorage CI" instead of "CloudFounders OpenvStorage CI". Thanks, Eduard On Thu, Sep 3, 2015 at 10:33 AM, Eduard Matei < eduard.ma...@cloudfounders.com> wrote: > > Hi, > > Trying to get more attention to this ... > >

Re: [openstack-dev] [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-11-03 Thread Eduard Matei
Hi Duncan, here is the review: https://review.openstack.org/#/c/241174 Thanks, Eduard __ OpenStack Development Mailing List (not for usage questions) Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe

Re: [openstack-dev] [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-11-03 Thread Eduard Matei
Hi, Thanks for the quick reply. What do you mean a review? Should i resubmit the driver code to the cinder repo? Do i need also the driver certification tests? Thanks, Eduard __ OpenStack Development Mailing List (not for

Re: [openstack-dev] [Cinder]Behavior when one cinder-volume service is down

2015-09-15 Thread Eduard Matei
Hi, Let me see if i got this: - running 3 (multiple) c-vols won't automatically give you failover - each c-vol is "master" of a certain number of volumes -- if the c-vol is "down" then those volumes cannot be managed by another c-vol What i'm trying to achieve is making sure ANY volume is

Re: [openstack-dev] [Cinder]Behavior when one cinder-volume service is down

2015-09-15 Thread Eduard Matei
Thanks Scott, But the question remains: if the "hacks" are not recommended then how can i perform Evacuate when the c-vol service of the volumes i need evacuated is "down", but there are two more controller node with c-vol services running? Thanks, Eduard

[openstack-dev] [Cinder]Behavior when one cinder-volume service is down

2015-09-15 Thread Eduard Matei
Hi, This all started when we were testing Evacuate with our storage driver. We thought we found a bug (https://bugs.launchpad.net/cinder/+bug/1491276) then Scott replied that we should be running cinder-volume service separate from nova-compute. For some internal reasons we can't do that - yet,

[openstack-dev] [Openstack-dev] Devstack broken - third party CI broken

2015-09-09 Thread Eduard Matei
Hi, Our Jenkins CI has been failing consistently last night during devstack install: 2015-09-08 21:56:33.585 | Error: Service ceilometer-acentral is not running 2015-09-08 21:56:33.585 | + for service in '$failures' 2015-09-08 21:56:33.586 | ++ basename

Re: [openstack-dev] [Openstack-dev] Devstack broken - third party CI broken

2015-09-09 Thread Eduard Matei
Line export DEVSTACK_LOCAL_CONFIG="disable_service ceilometer-acompute ceilometer-acentral ceilometer-collector ceilometer-api" in the job config did the trick. Thanks, Eduard __ OpenStack Development Mailing List (not for

[openstack-dev] Fwd: [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-09-03 Thread Eduard Matei
Hi, Trying to get more attention to this ... We had our driver removed by commit: https://github.com/openstack/cinder/commit/f0ab819732d77a8a6dd1a91422ac183ac4894419 due to no CI. Pls let me know if there is something wrong so we can fix it asap so we can have the driver back in Liberty (if

Re: [openstack-dev] [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-09-02 Thread Eduard Matei
Hi, Trying to get more attention to this ... We had our driver removed by commit: https://github.com/openstack/cinder/commit/f0ab819732d77a8a6dd1a91422ac183ac4894419 due to no CI. Pls let me know if there is something wrong so we can fix it asap so we can have the driver back in Liberty (if

Re: [openstack-dev] [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-08-20 Thread Eduard Matei
Hi, Trying to get more attention to this ... Also, The CI will (starting next week) be commenting using the name Open vStorage CI instead of CloudFounders OpenvStorage CI. Thanks, Eduard On Mon, Aug 17, 2015 at 5:44 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, We had our

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-20 Thread Eduard Matei
Hi, In case someone is still interested, 32768 is the fix. The number of PEs must be multiple of 1024 (not sure why). Eduard __ OpenStack Development Mailing List (not for usage questions) Unsubscribe:

Re: [openstack-dev] [openstack-deb] Devstack stable/juno fails to install

2015-08-20 Thread Eduard Matei
Hi, ATM our workaround is to manually pip install futures==2.2.0 before running stack.sh Any idea when an official fix will be available? Thanks, Eduard __ OpenStack Development Mailing List (not for usage questions)

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-18 Thread Eduard Matei
Hi, Further investigation shows there might be a relation between a test failing because it can't upload an image (most likely because there's not enough space left) and another test failing because lvm doesn't have enough extents - at the same time (due to tests running on two workers). So if

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-18 Thread Eduard Matei
Hi, Might be because volume backing size of 32G results in 8191 PE instead of 8192, so last volume create attempt sees only 1023 free extents. Will retry with 32768M Eduard __ OpenStack Development Mailing List (not for

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Eduard Matei
Hi, I can't find any way to change the image size of the vm used for testing (it's been created using nodepool-dib and managed by nodepoold). Anyway, tests are still (randomly) failing with lvm error (Volume group stack-volumes-lvmdriver-1 has insufficient free space (1023 extents): 1024

Re: [openstack-dev] [openstack-deb] Devstack stable/juno fails to install

2015-08-17 Thread Eduard Matei
Hi, It doesn't seem to help, install still fails with same error. Thanks, Eduard __ OpenStack Development Mailing List (not for usage questions) Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe

[openstack-dev] [cinder][ThirdPartyCI]CloudFounders OpenvStorage CI - request to re-add the cinder driver

2015-08-17 Thread Eduard Matei
Hi, We had our driver removed by commit: https://github.com/openstack/cinder/commit/f0ab819732d77a8a6dd1a91422ac183ac4894419 due to no CI. Last week we got it working again and it's been commenting for the last 3 days continuously. A normal run looks like this: *08:40:37* Ran: 1265 tests in

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Eduard Matei
Thanks, I didn't see that errror, seems to be caused by swift: 2015-08-17 03:13:43.940 2312 ERROR glance.api.v1.upload_utils BackendException: Failed to add object to Swift. I'll investigate further. But what about the lvmdriver-1 error? Isn't that related. Thanks, Eduard

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Eduard Matei
Thanks, I will try to increase the size of the dsvm disk, maybe that will help. No idea about the image size. The problem is that not all test runs fail, so it's not easy to trace. Eduard __ OpenStack Development Mailing

[openstack-dev] [openstack-deb] Devstack stable/juno fails to install

2015-08-17 Thread Eduard Matei
Hi, I noticed that devstack stable/juno fails to install on our CI with error: 2015-08-17 01:55:59.794 | + /usr/local/bin/cinder-manage db sync 2015-08-17 01:55:59.911 | Traceback (most recent call last): 2015-08-17 01:55:59.911 | File /usr/local/bin/cinder-manage, line 4, in module 2015-08-17

[openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Eduard Matei
Hi, I'm working on getting our CI working again, and i left it running over the weekend. Of the 50 jobs it ran. 6 of them failed because of different tests failed, but all with the same cause tempest.exceptions.VolumeBuildErrorException Looking in c-vol log i see Volume group

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Eduard Matei
Hi, Not sure what snippet you mean but here are all the logs for the failed test run: http://packages.cloudfounders.com/ci_logs/01/213501/3/check/dsvm-tempest-full/37aa6fe/ (console.html and c-vol.txt show more details). Thanks, Eduard

Re: [openstack-dev] ][third-party-ci]Running custom code before tests

2015-08-13 Thread Eduard Matei
Hi, I think you pointed me to the wrong file, the devstack-gate yaml (and line 2201 contains timestamps). I need an example of how to configure tempest to use my driver. I tried EXPORT in the jenkins job (before executing dsvm shell script) but looking at the tempest.txt (log) it shows that it

Re: [openstack-dev] ][third-party-ci]Running custom code before tests

2015-08-12 Thread Eduard Matei
Hi, Found some more info (finally): i added a function in the script part in the jenkins job and an export -f and it seems it's being called, so now my backend is installed and configured. I'm now trying to configure cinder to use my driver when running but i couldn't find a way to configure it.

Re: [openstack-dev] ][third-party-ci]Running custom code before tests

2015-08-10 Thread Eduard Matei
Hi, Replying to my own post... i found how/where to put the pre_test_hook (in the jenkins job, in the step that executes the devstack-vm script) The problem is that now i need to execute code BETWEEN installation of devstack and start of tests. Is there a hook i can define that will be executed

[openstack-dev] ][third-party-ci]Running custom code before tests

2015-08-07 Thread Eduard Matei
Hi, I managed to get the jobs triggered, i read https://wiki.openstack.org/wiki/Cinder/tested-3rdParty-drivers but i can't figure out where to put the code for pre_test_hook so i can setup my backend. Thanks, -- *Eduard Biceri Matei, Senior Software Developer* www.cloudfounders.com |

Re: [openstack-dev] [third-party-ci]Issue with running noop-check-communication

2015-08-06 Thread Eduard Matei
Thanks, Indeed running on a slave did the trick. Strange how i missed that part in the README. -- *Eduard Biceri Matei, Senior Software Developer* www.cloudfounders.com | eduard.ma...@cloudfounders.com __ OpenStack

[openstack-dev] [third-party-ci]Issue with running noop-check-communication

2015-08-05 Thread Eduard Matei
Hi, We're in the process of rebuilding the Jenkins CI for Cinder and i'm stuck at testing the noop job. I've setup using the latest changes from os-ext-testing and os-ext-testing-data using project-config, jjb and dib and i have a jenkins running which has the 2 jobs defined and i have 3 slaves

Re: [openstack-dev] [Cinder]Restrict volume creation based on type

2015-07-13 Thread Eduard Matei
Hi, Thanks for your replies. Got back to the team and tried to get more input: - the volume is created correctly (i misunderstood that part) - the problem is that (sometimes) the instance gets spawned on the 3rd node (which doesn't have the driver configured). This might be because of the

Re: [openstack-dev] [Cinder]Restrict volume creation based on type

2015-07-12 Thread Eduard Matei
Hi, Forgot to mention, indeed we configured extra_specs: volume_backend_name. The problem is that a volume of this type can get scheduled on a node where c-vol is not configured with this backend. F.e.: I have 3 storage nodes (c-vol) and two have the driver configured, the third one doesn't have

[openstack-dev] [Cinder]Restrict volume creation based on type

2015-07-10 Thread Eduard Matei
Hi, We've been testing a multi-node setup with our driver and ended up in a strange situation: - having a driver configured on multiple cinder nodes (But not all) - having a volume type (available) - creating a volume with specified volume type causes the volume to be created (attempted) on a

[openstack-dev] [Cinder]Cinder services issues after add/remove/add driver

2015-07-10 Thread Eduard Matei
Hi, Potential bug, but still investigating: - configured a driver on cinder (besides lvm) - all ok [service1] volume_driver = cinder.volume.drivers.openvstorage.OVSVolumeDriver volume_backend_name = service1 vpool_name = service1 - removed it, restarted services - all ok (cinder service-list

Re: [openstack-dev] ThirdPartyCI: Tempest job fails with Unexpected termination of the channel

2015-06-12 Thread Eduard Matei
Hi, After some more tests i was able to link the failure of the jenkins job with the errors in dmesg : [Fri Jun 12 11:04:37 2015] br100: port 2(vnet1) entered disabled state [Fri Jun 12 11:04:37 2015] device vnet1 left promiscuous mode [Fri Jun 12 11:04:37 2015] br100: port 2(vnet1) entered

[openstack-dev] ThirdPartyCI: Tempest job fails with Unexpected termination of the channel

2015-06-10 Thread Eduard Matei
Short story: - all runs of the tempest job are failing after ~ 1,5 - 2 hrs with FATAL: java.io.IOException: Unexpected termination of the channel and jenkins logs SEVERE: I/O error in channel d-p-c-local_01-1655 java.io.IOException: Unexpected termination of the channel Long story: - Host is 4

Re: [openstack-dev] Nodepool: puppet puts wrong key in authorized_keys in slave

2015-06-01 Thread Eduard Matei
Hi Ramy, I tried the disk-image-builder and now i can't ssh with any user with any key. Everytime i get Permission denied (publickey).. Here's my nodepool.yaml: script-dir: /etc/nodepool/scripts elements-dir: /etc/nodepool/elements images-dir: /opt/nodepool_dib dburi:

Re: [openstack-dev] Nodepool: puppet puts wrong key in authorized_keys in slave

2015-06-01 Thread Eduard Matei
Hi, Seems i missed a step, NODEPOOL_SSH_KEY was not exported so the image was not properly configured. Now i got an instance that is added to the jenkins master as slave and it's online. Thanks. Eduard __ OpenStack

[openstack-dev] Nodepool: puppet puts wrong key in authorized_keys in slave

2015-05-30 Thread Eduard Matei
Hi, Recently i updated nodepool and the devstack where it's supposed to create slaves. After some minor issues i managed to get it running, and it is able to create an image and i can login to an instance created from that image using user ubuntu (image is trusty). While trying to add the slave

Re: [openstack-dev] Nodepool: puppet fails to create image

2015-05-29 Thread Eduard Matei
Thanks, I updated nodepool and nodepool scripts and now it seems the image is building. Eduard On Thu, May 28, 2015 at 6:39 PM, Jeremy Stanley fu...@yuggoth.org wrote: On 2015-05-28 11:58:43 +0300 (+0300), Eduard Matei wrote: We had some issues with jenkins/devstack so i updated both

[openstack-dev] Nodepool: puppet fails to create image

2015-05-28 Thread Eduard Matei
Hi, We had some issues with jenkins/devstack so i updated both the jenkins version and the devstack. When starting nodepool it tries to create a new image but it fails after ~5 minutes: 2015-05-28 10:49:21,509 ERROR nodepool.image.build.local_01.d-p-c: + sudo puppet apply --detailed-exitcodes

[openstack-dev] [nova][oslo_messaging]Enabling notifications from nova

2015-04-16 Thread Eduard Matei
Hi, I've been trying to enable nova notifications on various actions, but nothing is actually sent. I found the cause in the _notify method of /usr/local/lib/python2.7/dist-packages/oslo_messaging/notify/notifier.py. There it performs a check if self._driver_mgr.extensions which always returns

Re: [openstack-dev] [nova][oslo_messaging]Enabling notifications from nova

2015-04-16 Thread Eduard Matei
Thanks Swann, that did the trick. Ed On Thu, Apr 16, 2015 at 2:44 PM, Swann Croiset swan...@gmail.com wrote: Hi, try to configure nova.conf: [DEFAULT] notification_driver=messaging BR 2015-04-16 11:04 GMT+02:00 Eduard Matei eduard.ma...@cloudfounders.com: Hi, I've been trying

Re: [openstack-dev] [cinder]Driver broken

2015-03-25 Thread Eduard Matei
Hi, Indeed our CI runs, and it reported SUCCESS, but it didn't run the tempest tests, only the openvstorage tests (my bad, looking into it as we speak). Meanwhile i'll create a patch to fix this. Thanks, Eduard __ OpenStack

[openstack-dev] [cinder]Driver broken

2015-03-25 Thread Eduard Matei
Hi, Just reported an issue: https://bugs.launchpad.net/cinder/+bug/1436367 Seems to be related to https://review.openstack.org/#/c/85847/ which introduced another parameter to be passed to the driver, but our driver didn't get updated so detach_volume fails for us. How can we get this fixed

Re: [openstack-dev] [cinder]Driver broken

2015-03-25 Thread Eduard Matei
Thanks, Indeed, our CI doesn't test this code path, we focused mainly on our internal functionality tests (which don't test for this), and the tempest tests are not running. This will be fixed asap. Thanks everyone, Eduard

Re: [openstack-dev] [Nova][Cinder] Questions re progress

2015-03-19 Thread Eduard Matei
Hi Adam, Disclaimer: i work for a company interested in providing solutions based on openstack, but this email should not be considered marketing/promotional Regarding your second question Using Swift as a back-end for Cinder, we already have a solution for this, a part of which is a Cinder

Re: [openstack-dev] [devstack]Specific Juno version

2015-03-04 Thread Eduard Matei
Hi, Indeed CINDER_BRANCH=2014.2.2 did the trick. Will properly report the issues once we start testing on 2014.2.3. Eduard __ OpenStack Development Mailing List (not for usage questions) Unsubscribe:

Re: [openstack-dev] [devstack]Specific Juno version

2015-03-04 Thread Eduard Matei
Hi Ihar, This is the error i see in c-vol screen: 2015-03-03 18:39:34.060 DEBUG taskflow.engines.action_engine.runner [req-87db2771-5c25-4c9b-a3bc-f7a504468315 4af0a30fe2c14deb9f9cf341a97daa9f 1fbab1e235ff414abf249c741fb3c6c9] Exiting old state 'WAITING' in response to event 'analyze' from

[openstack-dev] [devstack]Specific Juno version

2015-03-03 Thread Eduard Matei
Hi, Is there a way to specify the Juno version to be installed using devstack. For now we can only specify stable/juno *git clone -b stable/juno https://github.com/openstack-dev/devstack.git https://github.com/openstack-dev/devstack.git /opt/stack/devstack* but this installs 2014.2.3 which

[openstack-dev] [oslo_messaging]Notification listener for nova

2015-03-03 Thread Eduard Matei
Hi, I'm trying to listen to events of type compute.instance.* (e.g. compute.instance.update). I tried the following code: from oslo_config import cfg import oslo_messaging class NotificationEndpoint(object): filter_rule = oslo_messaging.NotificationFilter(publisher_id='compute.*',

Re: [openstack-dev] [cinder][horizon]Proper error handling/propagation to UI

2015-03-02 Thread Eduard Matei
with 2 drivers (ours, and lvmdriver), but our driver works, so not sure where it fails. Eduard On Mon, Mar 2, 2015 at 8:23 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Thanks @Duncan: I'll try with the lvm driver. @Avishay, i'm not trying to delete a volume created from a snapshot, i'm

Re: [openstack-dev] [cinder][horizon]Proper error handling/propagation to UI

2015-03-02 Thread Eduard Matei
device: Permission denied It's been configured with 2 drivers (ours, and lvmdriver), but our driver works, so not sure where it fails. Eduard On Mon, Mar 2, 2015 at 8:23 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Thanks @Duncan: I'll try with the lvm driver. @Avishay, i'm

Re: [openstack-dev] [cinder][horizon]Proper error handling/propagation to UI

2015-03-01 Thread Eduard Matei
should be caught well before it gets to the driver. Can you retry with the LVM driver please? On 27 February 2015 at 10:48, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, We've been testing our cinder driver extensively and found a strange behavior in the UI: - when trying

[openstack-dev] [cinder][horizon]Proper error handling/propagation to UI

2015-02-27 Thread Eduard Matei
Hi, We've been testing our cinder driver extensively and found a strange behavior in the UI: - when trying to delete a snapshot that has clones (created volume from snapshot) and error is raised in our driver which turns into error_deleting in cinder and the UI; further actions on that snapshot

Re: [openstack-dev] [thirdpartyCI][cinder] Question about certification

2015-02-24 Thread Eduard Matei
Thomas duncan.tho...@gmail.com wrote: If it is commenting (and not failing all the time) then you're fine. On 24 February 2015 at 12:47, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, With the deadline for ThirdPartyCI coming we were wondering what should we do next to ensure our CI

[openstack-dev] [Devstack] Devstack Install broken

2015-02-20 Thread Eduard Matei
Hi, I'm trying to install devstack and it keeps failing with: 2015-02-20 07:26:12.693 | ++ is_fedora 2015-02-20 07:26:12.693 | ++ [[ -z Ubuntu ]] 2015-02-20 07:26:12.693 | ++ '[' Ubuntu = Fedora ']' 2015-02-20 07:26:12.693 | ++ '[' Ubuntu = 'Red Hat' ']' 2015-02-20 07:26:12.693 | ++ '[' Ubuntu =

Re: [openstack-dev] [Devstack] Devstack Install broken

2015-02-20 Thread Eduard Matei
, and it has been working for at least 1 month, so not sure what changed, but it was on devstack side. Thanks, Eduard On Fri, Feb 20, 2015 at 3:48 PM, M Ranga Swami Reddy swamire...@gmail.com wrote: I too got this problem very frequently. On Fri, Feb 20, 2015 at 4:32 PM, Eduard Matei eduard.ma

[openstack-dev] [nova] Feature Freeze Exception request

2015-02-10 Thread Eduard Matei
Hi, I would like to request a FFE for https://review.openstack.org/#/c/134134/ It is a change that allows a driver to use type file instead of block for local volumes. It was blocked because at that time there was no use for it. Now, we have a driver merged which currently returns loca for

[openstack-dev] [devstack]Cannot install devstack on CI slave

2015-02-05 Thread Eduard Matei
Hi, For two days i've been trying to install devstack. It keeps failing at configuring neutron, i figured out that it needs two new params in localrc: PUBLIC_NETWORK_GATEWAY and NETWORK_GATEWAY On my dev machine i managed to install it manually with these params, but on the CI slave it fails with

[openstack-dev] [cinder]Questions about Gerrit workflow

2015-02-03 Thread Eduard Matei
Hi team, We have some questions regarding the Gerrit workflow and what should we do next for our patch to be merged: 1. Once we have a CodeReview +2 and a Jenkins Verified +1 what should we do next to get the patch merged? 2. If we have a CodeReview +2 and we want to fix an issue, does the next

Re: [openstack-dev] [cinder] Request for clarification regarding deadline for new drivers in Kilo

2015-01-26 Thread Eduard Matei
Hi, Any update on this? I added comments to the review. Meanwhile the nova review got abandoned, but i'll resubmit that once this is approved. Thanks, Eduard On Wed, Jan 21, 2015 at 7:31 PM, Mike Perez thin...@gmail.com wrote: On 11:24 Wed 21 Jan , Eduard Matei wrote: Hi

[openstack-dev] [cinder] Request for clarification regarding deadline for new drivers in Kilo

2015-01-21 Thread Eduard Matei
Hi, This weekend our driver [https://review.openstack.org/#/c/130733/] got a -2 stating that This is past the deadline for release of new drivers in Kilo. and the deadline for new drivers passed at the end of Kilo-1. This needs to wait for the L release. But, in another mail on the mailing list

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-19 Thread Eduard Matei
Hi Ramy, That didn't fix it, zuul-server still gets stuck Looking for lost builds, but zuul user can read gerrit event-stream. Any other ideas? Thanks, Eduard On Mon, Jan 19, 2015 at 9:09 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi Ramy, indeed user zuul could not read

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-18 Thread Eduard Matei
://ci.openstack.org/third_party.html#reading-the-event-stream Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Friday, January 16, 2015 6:57 AM *To:* OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev] [OpenStack-Infra

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-16 Thread Eduard Matei
as well. Ramy [1] http://docs.openstack.org/developer/devstack/configuration.html [2] http://docs.openstack.org/developer/devstack/plugins.html [3] https://wiki.openstack.org/wiki/Cinder/tested-3rdParty-drivers#Third_Party_CI_Requirements *From:* Eduard Matei

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-16 Thread Eduard Matei
16, 2015 at 4:20 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi Ramy, Still couldn't get my custom code to execute between installing devstack and starting tests... i'll try with some custom scripts and skip devstack-* scripts. Meanwhile i see another issue: 2015-01-16 11:02

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-15 Thread Eduard Matei
. Try doing a manual scp as Jenkins user from the slave to the log server (as Jenkins user there too). Regarding manually setting up the publisher, I don’t know. Jenkins Job Builder configuration I referenced below should work correctly. Ramy *From:* Eduard Matei [mailto:eduard.ma

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-15 Thread Eduard Matei
? Thanks, Eduard On Thu, Jan 15, 2015 at 2:56 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi Ramy, The issue with disconnect/abort no longer happens, so i guess it was some issues with networking. Regarding the ssh keys i finally used Jenkins Configuration Provider Plugin to inject

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-15 Thread Eduard Matei
the same issue with Zuul. Regards, Amit *CloudByte Inc.* http://www.cloudbyte.com/ On Thu, Jan 15, 2015 at 6:29 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, Just so i don't start another thread: it seems that sometimes Zuul gets stuck (sometimes in Looking for lost builds

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-14 Thread Eduard Matei
. Thanks, Eduard On Wed, Jan 14, 2015 at 10:40 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Thanks Ramy, i'll try to set it up manually. Meanwhile i found another problem: jobs are failing because of error or are being aborted. FATAL: java.io.IOException: Unexpected termination

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-14 Thread Eduard Matei
-driver.yaml.sample#L7 Zuul will then use this url when commenting in gerrit: https://github.com/rasselin/os-ext-testing/blob/master/puppet/modules/os_ext_testing/manifests/master.pp#L18 Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Tuesday, January 13, 2015 2:31 AM

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-13 Thread Eduard Matei
/authorized_keys in the template for Ubuntu and Jenkins users match $NODEPOOL_SSH_KEY? Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Monday, January 12, 2015 5:30 AM *To:* OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-12 Thread Eduard Matei
puppet to do the right thing with keys, so it gets forced here: https://github.com/rasselin/os-ext-testing/blob/master/puppet/install_master.sh#L197 Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Friday, January 09, 2015 8:58 AM *To:* OpenStack Development Mailing

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-12 Thread Eduard Matei
-ext-testing/blob/master/puppet/install_master.sh#L197 Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Friday, January 09, 2015 8:58 AM *To:* OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-09 Thread Eduard Matei
Thanks Patrick, Indeed it seems the cloud provider was setting up vms on a bridge whose eth was DOWN so the vms could not connect to the outside world so the prepare script was failing. Looking into that. Thanks, Eduard On Fri, Jan 9, 2015 at 6:44 PM, Patrick East patrick.e...@purestorage.com

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2015-01-09 Thread Eduard Matei
[4] https://review.openstack.org/#/c/138913/ *From:* Punith S [mailto:punit...@cloudbyte.com] *Sent:* Monday, January 05, 2015 10:22 PM *To:* Asselin, Ramy *Cc:* Eduard Matei; OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev] [OpenStack-Infra

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-26 Thread Eduard Matei
a. service Jenkins stop b. service zuul stop c. service zuul-merger stop d. service Jenkins start e. service zuul start f.service zuul-merger start Otherwise, I suggest you ask in #openstack-infra irc channel. Ramy *From:* Eduard Matei

Re: [openstack-dev] [OpenStack-dev][nova-net]Floating ip assigned as /32 from the start of the range

2014-12-22 Thread Eduard Matei
compute node and set that value as routing_source_ip=10.100.130.X (or my_ip) in nova.conf. Vish On Dec 19, 2014, at 7:00 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, I'm trying to create a vm and assign it an ip in range 10.100.130.0/16. On the host, the ip is assigned to br100

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-21 Thread Eduard Matei
:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Friday, December 19, 2014 3:36 AM *To:* Asselin, Ramy *Cc:* OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI Hi all, After a little

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-19 Thread Eduard Matei
it from the jenkins master. Any idea how i can manually trigger dsvm-tempest-full job to run and test the cloud provider without having to push a review to Gerrit? Thanks, Eduard On Thu, Dec 18, 2014 at 7:52 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Thanks for the input. I managed

[openstack-dev] [OpenStack-dev][nova-net]Floating ip assigned as /32 from the start of the range

2014-12-19 Thread Eduard Matei
Hi, I'm trying to create a vm and assign it an ip in range 10.100.130.0/16. On the host, the ip is assigned to br100 as inet 10.100.0.3/32 scope global br100 instead of 10.100.130.X/16, so it's not reachable from the outside. The localrc.conf : FLOATING_RANGE=10.100.130.0/16 Any idea what to

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-18 Thread Eduard Matei
/rasselin/os-ext-testing-data/blob/master/etc/jenkins_jobs/config/dsvm-cinder-driver.yaml.sample You can ask more questions in IRC freenode #openstack-cinder. (irc# asselin) Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Tuesday, December 16, 2014 12:41 AM

[openstack-dev] [OpenStack-dev][Cinder] Driver stats return value: infinite or unavailable

2014-12-18 Thread Eduard Matei
Hi everyone, We're in a bit of a predicament regarding review: https://review.openstack.org/#/c/130733/ Two days ago it got a -1 from John G asking to change infinite to unavailable although the docs clearly say that If the driver is unable to provide a value for free_capacity_gb or

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-18 Thread Eduard Matei
/#/c/139745/ *From:* Punith S [mailto:punit...@cloudbyte.com] *Sent:* Thursday, December 18, 2014 3:12 AM *To:* OpenStack Development Mailing List (not for usage questions); Eduard Matei *Subject:* Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI Hi Eduard

Re: [openstack-dev] [OpenStack-dev][Cinder] Driver stats return value: infinite or unavailable

2014-12-18 Thread Eduard Matei
Thanks John, I updated to unknown. Eduard On Thu, Dec 18, 2014 at 8:09 PM, John Griffith john.griffi...@gmail.com wrote: On Thu, Dec 18, 2014 at 1:56 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi everyone, We're in a bit of a predicament regarding review: https

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-17 Thread Eduard Matei
-testing-data/blob/master/etc/jenkins_jobs/config/dsvm-cinder-driver.yaml.sample You can ask more questions in IRC freenode #openstack-cinder. (irc# asselin) Ramy *From:* Eduard Matei [mailto:eduard.ma...@cloudfounders.com] *Sent:* Tuesday, December 16, 2014 12:41 AM *To:* Bailey

Re: [openstack-dev] [OpenStack-Infra] [ThirdPartyCI] Need help setting up CI

2014-12-16 Thread Eduard Matei
, 2014 at 1:59 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi Darragh, thanks for your input I double checked the job settings and fixed it: - build triggers is set to Gerrit event - Gerrit trigger server is Gerrit (configured from Gerrit Trigger Plugin and tested separately

[openstack-dev] [git] Rebase failed

2014-12-08 Thread Eduard Matei
Hi, My review got approved and it was ready to merge but automatic merge failed. I tried to rebase manually but it still fails. I'm not very familiar with git, can someone give a hand? git rebase -i master error: could not apply db4a3bb... New Cinder volume driver for openvstorage. When you

Re: [openstack-dev] [git] Rebase failed

2014-12-08 Thread Eduard Matei
at 10:18 AM, Sylvain Bauza sba...@redhat.com wrote: Le 08/12/2014 09:13, Eli Qiao a écrit : 在 2014年12月08日 16:05, Eduard Matei 写道: Hi, My review got approved and it was ready to merge but automatic merge failed. I tried to rebase manually but it still fails. I'm not very familiar with git

Re: [openstack-dev] [OpenStack-Infra][ThirdPartyCI] Need help setting up CI

2014-12-08 Thread Eduard Matei
on dev sandbox repo but couldn't trigger my job. Any ideas? Thanks, Eduard On Fri, Dec 5, 2014 at 10:32 AM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hello everyone, Thanks to the latest changes to the creation of service accounts process we're one step closer to setting up our own CI

Re: [openstack-dev] [nova]Can't run tests

2014-11-18 Thread Eduard Matei
On Tue, Nov 18, 2014 at 10:27 AM, Vineet Menon mvineetme...@gmail.com wrote: Hi, You should install mysql-dev for your distro using apt-get or yum. Regards, Vineet Menon On 18 November 2014 09:16, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, I'm trying to run nova's

Re: [openstack-dev] [nova]Can't run tests

2014-11-18 Thread Eduard Matei
Aha, didn't catch that. I just wanted to run the tests, didn't look at setting up a development environment. Thanks, Eduard On Tue, Nov 18, 2014 at 12:24 PM, Sylvain Bauza sba...@redhat.com wrote: Le 18/11/2014 10:11, Eduard Matei a écrit : Thanks Vineet. Indeed missing packages

[openstack-dev] [OpenStack-dev][Nova] Migration stuck - resize/migrating

2014-11-11 Thread Eduard Matei
Hi, I'm testing our cinder volume driver in the following setup: - 2 nodes, ubuntu, devstack juno (2014.2.1) - shared storage (common backend), our custom software solution + cinder volume on shared storage - 1 instance running on node 1, /instances directory on shared storage - kvm, libvirt

Re: [openstack-dev] Writing a cinder volume driver

2014-10-30 Thread Eduard Matei
Hi Darshan, Having just finished writing a volume driver i can say you need a lot of patience. First, to quickly answer your questions: 1. Read ALL the drivers in the official repo: ( https://github.com/openstack/cinder/tree/master/cinder/volume/drivers) and how they relate to the cinder-api (

Re: [openstack-dev] [cinder] Cinder plans for kilo: attention new driver authors!

2014-10-30 Thread Eduard Matei
Hi Mike, I saw your comment on my review, but i need some more info regarding Your driver passes the cert test and the results are posted. I assume you mean running cinder_driver_cert.sh - this is already passing - but how do i get the results posted, and where? I've been looking through some

Re: [openstack-dev] [cinder] Cinder plans for kilo: attention new driver authors!

2014-10-30 Thread Eduard Matei
*CloudByte Inc.* http://www.cloudbyte.com/ On Thu, Oct 30, 2014 at 5:55 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi Mike, I saw your comment on my review, but i need some more info regarding Your driver passes the cert test and the results are posted. I assume you mean

[openstack-dev] [nova]Instance console.log

2014-10-13 Thread Eduard Matei
Hi, Is there a way to disable console.log or redirect it to a custom location? Use-case: we have a custom distributed storage-solution, and to enable faster migration we symlinked the /opt/stack/dara/nova/instances to a directory on our mountpoint (which is backed by our shared storage). The

[openstack-dev] [Cinder] Get server side exception

2014-10-03 Thread Eduard Matei
Hi, I'm creating a cinder volume from a glance image (Fedora). The image is 199 Mb and since it's for testing, i created a volume of size 1GB. This fails, and puts image in status Error. (without any more info) Digging through screens i found an exception ImageUnacceptable (size is 2 GB and

[openstack-dev] [third party] New driver - questions regarding the process

2014-09-10 Thread Eduard Matei
Hi guys, We (CloudFounders) have been working on developing a storage solution that we want to integrate in OpenStack (we will release the software component as open source). From what i saw in the mailing list here we missed the Juno release so i guess we'll have to wait until Kilo. The