Re: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-31 Thread Samuel Bercovici
Hi,

I think that the current implementation is fine.
This are two different aspects.
The status describes whether the last a-sync activity is active or whether it 
is not.
The admin status describes what the user wishes for the object status to be.

Follows an example: If I update the VIP with admin status down, the status 
should be moved to PENDING_UPDATE, when the driver implements this than the 
status with be back to being ACTIVE.
The Term ACTIVE, might be wrong in that it might be renamed to something like 
APPLIED.

Regards,
-Sam.



From: Eugene Nikanorov [mailto:enikano...@mirantis.com]
Sent: Tuesday, October 29, 2013 11:19 AM
To: OpenStack Development Mailing List
Subject: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

Hi folks,

Currently there are two attributes of vips/pools/members that represent a 
status: 'status' and 'admin_state_up'.

The first one is used to represent deployment status and can be PENDING_CREATE, 
ACTIVE, PENDING_DELETE, ERROR.
We also have admin_state_up which could be True or False.

I'd like to know your opinion on how to change 'status' attribute based on 
admin_state_up changes.
For instance. If admin_state_up is updated to be False, how do you think 
'status' should change?

Also, speaking of reference implementation (HAProxy), changing vip or pool 
admin_state_up to False effectively destroys the balancer (undeploys it), while 
the objects remain in ACTIVE state.
There are two options to fix this discrepancy:
1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes to 
False
2) Don't destroy the loadbalancer and use HAProxy capability to disable 
frontend and backend while leave vip/pool in ACTIVE state

Please share your opinion.

Thanks,
Eugene.
___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-31 Thread Eugene Nikanorov
Hi Sam,

The question was based on the bug
https://bugs.launchpad.net/neutron/+bug/1242351
Where it is a real discrepancy: you bring the balancer down (and it's
really undeployed) but still remains active.
I guess I need to put it to PENDING_CREATE for haproxy, not PENDING_UPDATE
since this represents deployment status.
In fact i think this could be driver-specific and differ from driver to
driver.

Thanks,
Eugene.


On Thu, Oct 31, 2013 at 1:36 PM, Samuel Bercovici samu...@radware.comwrote:

  Hi,

 ** **

 I think that the current implementation is fine.

 This are two different aspects.

 The status describes whether the last a-sync activity is active or whether
 it is not.

 The admin status describes what the user wishes for the object status to
 be.

 ** **

 Follows an example: If I *update* the VIP with admin status down, the
 status should be moved to PENDING_UPDATE, when the driver implements this
 than the status with be back to being ACTIVE. 

 The Term ACTIVE, might be wrong in that it might be renamed to something
 like APPLIED.

 ** **

 Regards,

 -Sam.

 ** **

 ** **

 ** **

 *From:* Eugene Nikanorov [mailto:enikano...@mirantis.com]
 *Sent:* Tuesday, October 29, 2013 11:19 AM
 *To:* OpenStack Development Mailing List
 *Subject:* [openstack-dev] [Neutron][LBaaS] Object status and
 admin_state_up

 ** **

 Hi folks,

 ** **

 Currently there are two attributes of vips/pools/members that represent a
 status: 'status' and 'admin_state_up'.

 ** **

 The first one is used to represent deployment status and can be
 PENDING_CREATE, ACTIVE, PENDING_DELETE, ERROR.

 We also have admin_state_up which could be True or False.

 ** **

 I'd like to know your opinion on how to change 'status' attribute based on
 admin_state_up changes.

 For instance. If admin_state_up is updated to be False, how do you think
 'status' should change?

 ** **

 Also, speaking of reference implementation (HAProxy), changing vip or pool
 admin_state_up to False effectively destroys the balancer (undeploys it),
 while the objects remain in ACTIVE state.

 There are two options to fix this discrepancy:

 1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes
 to False

 2) Don't destroy the loadbalancer and use HAProxy capability to disable
 frontend and backend while leave vip/pool in ACTIVE state

 ** **

 Please share your opinion.

 ** **

 Thanks,

 Eugene.

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


[openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-29 Thread Eugene Nikanorov
Hi folks,

Currently there are two attributes of vips/pools/members that represent a
status: 'status' and 'admin_state_up'.

The first one is used to represent deployment status and can be
PENDING_CREATE, ACTIVE, PENDING_DELETE, ERROR.
We also have admin_state_up which could be True or False.

I'd like to know your opinion on how to change 'status' attribute based on
admin_state_up changes.
For instance. If admin_state_up is updated to be False, how do you think
'status' should change?

Also, speaking of reference implementation (HAProxy), changing vip or pool
admin_state_up to False effectively destroys the balancer (undeploys it),
while the objects remain in ACTIVE state.
There are two options to fix this discrepancy:
1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes to
False
2) Don't destroy the loadbalancer and use HAProxy capability to disable
frontend and backend while leave vip/pool in ACTIVE state

Please share your opinion.

Thanks,
Eugene.
___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-29 Thread Avishay Balderman
Hi
It feels like a driver specific topic.
So I am not sure we  can come to a generic solution in the lbaas core code.
Thanks
Avishay

From: Eugene Nikanorov [mailto:enikano...@mirantis.com]
Sent: Tuesday, October 29, 2013 11:19 AM
To: OpenStack Development Mailing List
Subject: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

Hi folks,

Currently there are two attributes of vips/pools/members that represent a 
status: 'status' and 'admin_state_up'.

The first one is used to represent deployment status and can be PENDING_CREATE, 
ACTIVE, PENDING_DELETE, ERROR.
We also have admin_state_up which could be True or False.

I'd like to know your opinion on how to change 'status' attribute based on 
admin_state_up changes.
For instance. If admin_state_up is updated to be False, how do you think 
'status' should change?

Also, speaking of reference implementation (HAProxy), changing vip or pool 
admin_state_up to False effectively destroys the balancer (undeploys it), while 
the objects remain in ACTIVE state.
There are two options to fix this discrepancy:
1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes to 
False
2) Don't destroy the loadbalancer and use HAProxy capability to disable 
frontend and backend while leave vip/pool in ACTIVE state

Please share your opinion.

Thanks,
Eugene.
___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-29 Thread Eugene Nikanorov
That's right, it is driver-specific, but we can come up with a generic
guideline for this.
Also, I'm interested in preferred solution for HAProxy.

Thanks,
Eugene.


On Tue, Oct 29, 2013 at 6:43 PM, Avishay Balderman avish...@radware.comwrote:

  Hi

 It feels like a driver specific topic.

 So I am not sure we  can come to a generic solution in the lbaas core code.
 

 Thanks

 Avishay

 ** **

 *From:* Eugene Nikanorov [mailto:enikano...@mirantis.com]
 *Sent:* Tuesday, October 29, 2013 11:19 AM
 *To:* OpenStack Development Mailing List
 *Subject:* [openstack-dev] [Neutron][LBaaS] Object status and
 admin_state_up

 ** **

 Hi folks,

 ** **

 Currently there are two attributes of vips/pools/members that represent a
 status: 'status' and 'admin_state_up'.

 ** **

 The first one is used to represent deployment status and can be
 PENDING_CREATE, ACTIVE, PENDING_DELETE, ERROR.

 We also have admin_state_up which could be True or False.

 ** **

 I'd like to know your opinion on how to change 'status' attribute based on
 admin_state_up changes.

 For instance. If admin_state_up is updated to be False, how do you think
 'status' should change?

 ** **

 Also, speaking of reference implementation (HAProxy), changing vip or pool
 admin_state_up to False effectively destroys the balancer (undeploys it),
 while the objects remain in ACTIVE state.

 There are two options to fix this discrepancy:

 1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes
 to False

 2) Don't destroy the loadbalancer and use HAProxy capability to disable
 frontend and backend while leave vip/pool in ACTIVE state

 ** **

 Please share your opinion.

 ** **

 Thanks,

 Eugene.

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-29 Thread Itsuro ODA
Hi,

I think INACTIVE is right for resources with admin_statu_up False.

BTW, there are following requirements:
* Change to ACTIVE from PENDING_CREATE/UPDATE when the serives
  is available actually. (ie. after lbaas_agent done the job.)
* Reflect a member is alive or not to the 'status' attribute of
  member resource. (ie. if a member is not alive, the status is
  DOWN.)

Note that we are planning to implement above requiremants to LVS
driver.

Thanks,
Itsuro Oda

On Tue, 29 Oct 2013 13:19:16 +0400
Eugene Nikanorov enikano...@mirantis.com wrote:

 Hi folks,
 
 Currently there are two attributes of vips/pools/members that represent a
 status: 'status' and 'admin_state_up'.
 
 The first one is used to represent deployment status and can be
 PENDING_CREATE, ACTIVE, PENDING_DELETE, ERROR.
 We also have admin_state_up which could be True or False.
 
 I'd like to know your opinion on how to change 'status' attribute based on
 admin_state_up changes.
 For instance. If admin_state_up is updated to be False, how do you think
 'status' should change?
 
 Also, speaking of reference implementation (HAProxy), changing vip or pool
 admin_state_up to False effectively destroys the balancer (undeploys it),
 while the objects remain in ACTIVE state.
 There are two options to fix this discrepancy:
 1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes to
 False
 2) Don't destroy the loadbalancer and use HAProxy capability to disable
 frontend and backend while leave vip/pool in ACTIVE state
 
 Please share your opinion.
 
 Thanks,
 Eugene.

-- 
Itsuro ODA o...@valinux.co.jp


___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Neutron][LBaaS] Object status and admin_state_up

2013-10-29 Thread Ravi Chunduru
Generally loadbalancer will have the following options

enable - configurationally enable
disable - configurationally disable

up - status alive
down - status down

If we have the above it will be meaningful to get actual status of the
object.

Thanks,
-Ravi.




On Tue, Oct 29, 2013 at 4:33 PM, Itsuro ODA o...@valinux.co.jp wrote:

 Hi,

 I think INACTIVE is right for resources with admin_statu_up False.

 BTW, there are following requirements:
 * Change to ACTIVE from PENDING_CREATE/UPDATE when the serives
   is available actually. (ie. after lbaas_agent done the job.)
 * Reflect a member is alive or not to the 'status' attribute of
   member resource. (ie. if a member is not alive, the status is
   DOWN.)

 Note that we are planning to implement above requiremants to LVS
 driver.

 Thanks,
 Itsuro Oda

 On Tue, 29 Oct 2013 13:19:16 +0400
 Eugene Nikanorov enikano...@mirantis.com wrote:

  Hi folks,
 
  Currently there are two attributes of vips/pools/members that represent a
  status: 'status' and 'admin_state_up'.
 
  The first one is used to represent deployment status and can be
  PENDING_CREATE, ACTIVE, PENDING_DELETE, ERROR.
  We also have admin_state_up which could be True or False.
 
  I'd like to know your opinion on how to change 'status' attribute based
 on
  admin_state_up changes.
  For instance. If admin_state_up is updated to be False, how do you think
  'status' should change?
 
  Also, speaking of reference implementation (HAProxy), changing vip or
 pool
  admin_state_up to False effectively destroys the balancer (undeploys it),
  while the objects remain in ACTIVE state.
  There are two options to fix this discrepancy:
  1) Change status of vip/pool to PENDING_CREATE if admin_state_up changes
 to
  False
  2) Don't destroy the loadbalancer and use HAProxy capability to disable
  frontend and backend while leave vip/pool in ACTIVE state
 
  Please share your opinion.
 
  Thanks,
  Eugene.

 --
 Itsuro ODA o...@valinux.co.jp


 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev




-- 
Ravi
___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev