Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-02-05 Thread Timur Sufiev
Okay, with https://review.openstack.org/#/c/276123/ finally merged tests
should pass more predictably now. Please, recheck and reverify your patches
now. I hope that recheck/reverify alone is enough to consume merged test
fix, if I'm wrong please correct me.

On Thu, Feb 4, 2016 at 5:46 PM Timur Sufiev  wrote:

> That has been a hard week for integration tests, as soon as API-breaking
> change in xvfbwrapper had been worked around, we have been hit by a new
> Selenium release, see https://bugs.launchpad.net/horizon/+bug/1541876
>
> Investigation of a root cause is still in progress.
>
> On Mon, Feb 1, 2016 at 11:31 PM Richard Jones 
> wrote:
>
>> Ugh, dependencies with breaking API changes in minor point releases :/
>>
>> On 2 February 2016 at 04:53, Timur Sufiev  wrote:
>>
>>> Maintainers of outside dependencies continue to break our stuff :(. New
>>> issue is https://bugs.launchpad.net/horizon/+bug/1540495 patch is
>>> currently being checked by Jenkins
>>>
>>> On Sat, Jan 30, 2016 at 2:28 PM Timur Sufiev 
>>> wrote:
>>>
 Problematic Selenium versions have been successfully excluded from
 Horizon test-requirements, if you still experiencing the error described
 above, rebase your patch onto the latest master.
 On Fri, 29 Jan 2016 at 12:36, Itxaka Serrano Garcia 
 wrote:

> Can confirm, had the same issue locally, was fixed after a downgrade to
> selenium 2.48.
>
>
> Good catch!
>
> Itxaka
>
> On 01/28/2016 10:08 PM, Timur Sufiev wrote:
> > According to the results at
> > https://review.openstack.org/#/c/273697/1 capping Selenium to be not
> > greater than 2.49 fixes broken tests. Patch to global-requirements is
> > here: https://review.openstack.org/#/c/273750/
> >
> > On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev  > > wrote:
> >
> > Hello, Horizoneers
> >
> > You may have noticed recent integration tests failures seemingly
> > unrelated to you patches, with a stacktrace like:
> > http://paste2.org/2Hk9138U I've already filed a bug for that,
> > https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a
> > Selenium issue, currently investigating it.
> >
> >
> >
> >
> >
> __
> > OpenStack Development Mailing List (not for usage questions)
> > Unsubscribe:
> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> >
>
>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe:
> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>

>>>
>>> __
>>> OpenStack Development Mailing List (not for usage questions)
>>> Unsubscribe:
>>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>>
>>>
>> __
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe:
>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-02-04 Thread Timur Sufiev
That has been a hard week for integration tests, as soon as API-breaking
change in xvfbwrapper had been worked around, we have been hit by a new
Selenium release, see https://bugs.launchpad.net/horizon/+bug/1541876

Investigation of a root cause is still in progress.

On Mon, Feb 1, 2016 at 11:31 PM Richard Jones 
wrote:

> Ugh, dependencies with breaking API changes in minor point releases :/
>
> On 2 February 2016 at 04:53, Timur Sufiev  wrote:
>
>> Maintainers of outside dependencies continue to break our stuff :(. New
>> issue is https://bugs.launchpad.net/horizon/+bug/1540495 patch is
>> currently being checked by Jenkins
>>
>> On Sat, Jan 30, 2016 at 2:28 PM Timur Sufiev 
>> wrote:
>>
>>> Problematic Selenium versions have been successfully excluded from
>>> Horizon test-requirements, if you still experiencing the error described
>>> above, rebase your patch onto the latest master.
>>> On Fri, 29 Jan 2016 at 12:36, Itxaka Serrano Garcia 
>>> wrote:
>>>
 Can confirm, had the same issue locally, was fixed after a downgrade to
 selenium 2.48.


 Good catch!

 Itxaka

 On 01/28/2016 10:08 PM, Timur Sufiev wrote:
 > According to the results at
 > https://review.openstack.org/#/c/273697/1 capping Selenium to be not
 > greater than 2.49 fixes broken tests. Patch to global-requirements is
 > here: https://review.openstack.org/#/c/273750/
 >
 > On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev  > wrote:
 >
 > Hello, Horizoneers
 >
 > You may have noticed recent integration tests failures seemingly
 > unrelated to you patches, with a stacktrace like:
 > http://paste2.org/2Hk9138U I've already filed a bug for that,
 > https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a
 > Selenium issue, currently investigating it.
 >
 >
 >
 >
 >
 __
 > OpenStack Development Mailing List (not for usage questions)
 > Unsubscribe:
 openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
 > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
 >


 __
 OpenStack Development Mailing List (not for usage questions)
 Unsubscribe:
 openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

>>>
>> __
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe:
>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>
>>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-02-01 Thread Richard Jones
Ugh, dependencies with breaking API changes in minor point releases :/

On 2 February 2016 at 04:53, Timur Sufiev  wrote:

> Maintainers of outside dependencies continue to break our stuff :(. New
> issue is https://bugs.launchpad.net/horizon/+bug/1540495 patch is
> currently being checked by Jenkins
>
> On Sat, Jan 30, 2016 at 2:28 PM Timur Sufiev  wrote:
>
>> Problematic Selenium versions have been successfully excluded from
>> Horizon test-requirements, if you still experiencing the error described
>> above, rebase your patch onto the latest master.
>> On Fri, 29 Jan 2016 at 12:36, Itxaka Serrano Garcia 
>> wrote:
>>
>>> Can confirm, had the same issue locally, was fixed after a downgrade to
>>> selenium 2.48.
>>>
>>>
>>> Good catch!
>>>
>>> Itxaka
>>>
>>> On 01/28/2016 10:08 PM, Timur Sufiev wrote:
>>> > According to the results at
>>> > https://review.openstack.org/#/c/273697/1 capping Selenium to be not
>>> > greater than 2.49 fixes broken tests. Patch to global-requirements is
>>> > here: https://review.openstack.org/#/c/273750/
>>> >
>>> > On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev >> > > wrote:
>>> >
>>> > Hello, Horizoneers
>>> >
>>> > You may have noticed recent integration tests failures seemingly
>>> > unrelated to you patches, with a stacktrace like:
>>> > http://paste2.org/2Hk9138U I've already filed a bug for that,
>>> > https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a
>>> > Selenium issue, currently investigating it.
>>> >
>>> >
>>> >
>>> >
>>> >
>>> __
>>> > OpenStack Development Mailing List (not for usage questions)
>>> > Unsubscribe:
>>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>>> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>> >
>>>
>>>
>>> __
>>> OpenStack Development Mailing List (not for usage questions)
>>> Unsubscribe:
>>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>>
>>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-02-01 Thread Timur Sufiev
Maintainers of outside dependencies continue to break our stuff :(. New
issue is https://bugs.launchpad.net/horizon/+bug/1540495 patch is currently
being checked by Jenkins

On Sat, Jan 30, 2016 at 2:28 PM Timur Sufiev  wrote:

> Problematic Selenium versions have been successfully excluded from Horizon
> test-requirements, if you still experiencing the error described above,
> rebase your patch onto the latest master.
> On Fri, 29 Jan 2016 at 12:36, Itxaka Serrano Garcia 
> wrote:
>
>> Can confirm, had the same issue locally, was fixed after a downgrade to
>> selenium 2.48.
>>
>>
>> Good catch!
>>
>> Itxaka
>>
>> On 01/28/2016 10:08 PM, Timur Sufiev wrote:
>> > According to the results at
>> > https://review.openstack.org/#/c/273697/1 capping Selenium to be not
>> > greater than 2.49 fixes broken tests. Patch to global-requirements is
>> > here: https://review.openstack.org/#/c/273750/
>> >
>> > On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev > > > wrote:
>> >
>> > Hello, Horizoneers
>> >
>> > You may have noticed recent integration tests failures seemingly
>> > unrelated to you patches, with a stacktrace like:
>> > http://paste2.org/2Hk9138U I've already filed a bug for that,
>> > https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a
>> > Selenium issue, currently investigating it.
>> >
>> >
>> >
>> >
>> >
>> __
>> > OpenStack Development Mailing List (not for usage questions)
>> > Unsubscribe:
>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>> >
>>
>> __
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe:
>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-01-30 Thread Timur Sufiev
Problematic Selenium versions have been successfully excluded from Horizon
test-requirements, if you still experiencing the error described above,
rebase your patch onto the latest master.
On Fri, 29 Jan 2016 at 12:36, Itxaka Serrano Garcia 
wrote:

> Can confirm, had the same issue locally, was fixed after a downgrade to
> selenium 2.48.
>
>
> Good catch!
>
> Itxaka
>
> On 01/28/2016 10:08 PM, Timur Sufiev wrote:
> > According to the results at
> > https://review.openstack.org/#/c/273697/1 capping Selenium to be not
> > greater than 2.49 fixes broken tests. Patch to global-requirements is
> > here: https://review.openstack.org/#/c/273750/
> >
> > On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev  > > wrote:
> >
> > Hello, Horizoneers
> >
> > You may have noticed recent integration tests failures seemingly
> > unrelated to you patches, with a stacktrace like:
> > http://paste2.org/2Hk9138U I've already filed a bug for that,
> > https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a
> > Selenium issue, currently investigating it.
> >
> >
> >
> >
> >
> __
> > OpenStack Development Mailing List (not for usage questions)
> > Unsubscribe:
> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> >
>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-01-29 Thread Itxaka Serrano Garcia
Can confirm, had the same issue locally, was fixed after a downgrade to 
selenium 2.48.



Good catch!

Itxaka

On 01/28/2016 10:08 PM, Timur Sufiev wrote:

According to the results at
https://review.openstack.org/#/c/273697/1 capping Selenium to be not
greater than 2.49 fixes broken tests. Patch to global-requirements is
here: https://review.openstack.org/#/c/273750/

On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev > wrote:

Hello, Horizoneers

You may have noticed recent integration tests failures seemingly
unrelated to you patches, with a stacktrace like:
http://paste2.org/2Hk9138U I've already filed a bug for that,
https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a
Selenium issue, currently investigating it.




__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev



__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Horizon] Recent integration tests failures

2016-01-28 Thread Timur Sufiev
According to the results at https://review.openstack.org/#/c/273697/1 capping
Selenium to be not greater than 2.49 fixes broken tests. Patch to
global-requirements is here: https://review.openstack.org/#/c/273750/

On Thu, Jan 28, 2016 at 9:22 PM Timur Sufiev  wrote:

> Hello, Horizoneers
>
> You may have noticed recent integration tests failures seemingly unrelated
> to you patches, with a stacktrace like: http://paste2.org/2Hk9138U I've
> already filed a bug for that,
> https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a Selenium
> issue, currently investigating it.
>
>
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


[openstack-dev] [Horizon] Recent integration tests failures

2016-01-28 Thread Timur Sufiev
Hello, Horizoneers

You may have noticed recent integration tests failures seemingly unrelated
to you patches, with a stacktrace like: http://paste2.org/2Hk9138U I've
already filed a bug for that,
https://bugs.launchpad.net/horizon/+bug/1539197 Appears to be a Selenium
issue, currently investigating it.
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev