[openstack-dev] [magnum] Maintaining cluster API in upgrades

2015-09-14 Thread Ryan Rossiter
I have some food for thought with regards to upgrades that was provoked by some incorrect usage of Magnum which led me to finding [1]. Let's say we're running a cloud with Liberty Magnum, which works with Kubernetes API v1. During the Mitaka release, Kubernetes released v2, so now Magnum

Re: [openstack-dev] [magnum] Maintaining cluster API in upgrades

2015-09-14 Thread Hongbin Lu
] Sent: September-14-15 6:49 PM To: openstack-dev@lists.openstack.org Subject: [openstack-dev] [magnum] Maintaining cluster API in upgrades I have some food for thought with regards to upgrades that was provoked by some incorrect usage of Magnum which led me to finding [1]. Let's say we're running