Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-12 Thread Michel Peterson
On Tue, Sep 11, 2018 at 7:29 AM, Tony Breeds wrote: > > So I think we have the required reviews lined up to fix master, but they > need votes from zuul and core teams. > > Thanks a lot for the work, Tony. On the n-odl side, when the Depends-On gets merged I'll give it a +W.

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-10 Thread Tony Breeds
On Wed, Sep 05, 2018 at 10:03:09AM -0500, Matthew Thode wrote: > The requirements team has gone ahead and made a aweful hack to get gate > unwedged. The commit message is a very good summary of our reasoning > why it has to be this way for now. My comment explains our plan going > forward

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-06 Thread Matthew Thode
On 18-09-06 13:33:12, Michel Peterson wrote: > On Wed, Sep 5, 2018 at 6:03 PM, Matthew Thode > wrote: > > > On 18-08-31 19:52:09, Matthew Thode wrote: > > > The requirements project has a co-installability test for the various > > > projects, networking-odl being included. > > > > > > Because of

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-06 Thread Michel Peterson
On Wed, Sep 5, 2018 at 6:03 PM, Matthew Thode wrote: > On 18-08-31 19:52:09, Matthew Thode wrote: > > The requirements project has a co-installability test for the various > > projects, networking-odl being included. > > > > Because of the way the dependancy on ceilometer is done it is blocking

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-05 Thread Matthew Thode
On 18-09-05 17:50:59, thomas.mo...@orange.com wrote: > Mathew, > > networking-odl has now been removed from the requirements of > networking-bgpvpn [1], on master, so networking-odl could be removed from > requirements. > > This is not the case on stable branches, though. > > -Thomas > > [1]

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-05 Thread thomas.morin
Mathew, networking-odl has now been removed from the requirements of networking-bgpvpn [1], on master, so networking-odl could be removed from requirements. This is not the case on stable branches, though. -Thomas [1] https://review.openstack.org/#/c/599422/ On 05/09/2018 17:03, Matthew

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-05 Thread Matthew Thode
On 18-08-31 19:52:09, Matthew Thode wrote: > The requirements project has a co-installability test for the various > projects, networking-odl being included. > > Because of the way the dependancy on ceilometer is done it is blocking > all reviews and updates to the requirements project. > >

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-03 Thread Thomas Morin
Thomas Morin, 2018-09-03 13:31: > Matthew Thode, 2018-08-31 19:52: > > > > If networking-odl is not meant to be used as a library I'd > > recommend > > it's removal from networking-bgpvpn (it's test-requirements.txt > > file). > > We can work at removing this historical driver from networking- >

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-03 Thread Thomas Morin
Hi Mathew, Matthew Thode, 2018-08-31 19:52: > The requirements project has a co-installability test for the various > projects, networking-odl being included. > > Because of the way the dependancy on ceilometer is done it is > blocking all reviews and updates to the requirements project. (also

Re: [openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-09-02 Thread Tony Breeds
On Fri, Aug 31, 2018 at 07:52:09PM -0500, Matthew Thode wrote: > The requirements project has a co-installability test for the various > projects, networking-odl being included. > > Because of the way the dependancy on ceilometer is done it is blocking > all reviews and updates to the

[openstack-dev] [networking-odl][networking-bgpvpn][ceilometer] all requirement updates are currently blocked

2018-08-31 Thread Matthew Thode
The requirements project has a co-installability test for the various projects, networking-odl being included. Because of the way the dependancy on ceilometer is done it is blocking all reviews and updates to the requirements project.