Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-16 Thread Alex Xu
2015-07-16 7:54 GMT+08:00 Ken'ichi Ohmichi ken1ohmi...@gmail.com: 2015-07-16 3:03 GMT+09:00 Sean Dague s...@dague.net: On 07/15/2015 01:44 PM, Matt Riedemann wrote: The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT API and the v2 API is marked as

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-16 Thread Sean Dague
On 07/15/2015 08:12 PM, GHANSHYAM MANN wrote: On Thu, Jul 16, 2015 at 3:03 AM, Sean Dague s...@dague.net wrote: On 07/15/2015 01:44 PM, Matt Riedemann wrote: The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT API and the v2 API is marked as SUPPORTED

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-16 Thread Alex Xu
FYI, this should be part work of https://github.com/openstack/nova-specs/blob/master/specs/liberty/approved/nova-api-remove-v3.rst 2015-07-16 16:27 GMT+08:00 Alex Xu sou...@gmail.com: 2015-07-16 7:54 GMT+08:00 Ken'ichi Ohmichi ken1ohmi...@gmail.com: 2015-07-16 3:03 GMT+09:00 Sean Dague

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-16 Thread Ed Leafe
-BEGIN PGP SIGNED MESSAGE- Hash: SHA512 On 07/16/2015 03:27 AM, Alex Xu wrote: Honestly, we should probably deprecate out osapi_v3.enabled make it osapi_v21 (or osapi_v2_microversions) so as to not confuse people further. +1 for renaming it to osapi_v21 (or

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-16 Thread Matt Riedemann
On 7/16/2015 4:57 AM, Sean Dague wrote: On 07/15/2015 08:12 PM, GHANSHYAM MANN wrote: On Thu, Jul 16, 2015 at 3:03 AM, Sean Dague s...@dague.net wrote: On 07/15/2015 01:44 PM, Matt Riedemann wrote: The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT

[openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-15 Thread Matt Riedemann
The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT API and the v2 API is marked as SUPPORTED (and we've frozen it for new feature development). I got looking at this because osapi_v3.enabled is True in nova.conf in both the

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-15 Thread Sean Dague
On 07/15/2015 01:44 PM, Matt Riedemann wrote: The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT API and the v2 API is marked as SUPPORTED (and we've frozen it for new feature development). I got looking at this because osapi_v3.enabled is True in

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-15 Thread Ken'ichi Ohmichi
2015-07-16 3:03 GMT+09:00 Sean Dague s...@dague.net: On 07/15/2015 01:44 PM, Matt Riedemann wrote: The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT API and the v2 API is marked as SUPPORTED (and we've frozen it for new feature development). I got

Re: [openstack-dev] [nova] Why is osapi_v3.enabled = False by default?

2015-07-15 Thread GHANSHYAM MANN
On Thu, Jul 16, 2015 at 3:03 AM, Sean Dague s...@dague.net wrote: On 07/15/2015 01:44 PM, Matt Riedemann wrote: The osapi_v3.enabled option is False by default [1] even though it's marked as the CURRENT API and the v2 API is marked as SUPPORTED (and we've frozen it for new feature