Re: [openstack-dev] [devstack] Installation problem

2015-01-26 Thread Abhishek Shrivastava
Hi Rajdeep, Can you please send the details of how are you trying to install the latest devstack and complete log so that it will be easy to now where are you failing. On Mon, Jan 26, 2015 at 4:56 PM, Rajdeep Dua rajdeep@gmail.com wrote: Getting following exception on latest devstack

[openstack-dev] Fwd: Image Upload error while installing devstack on CI slave machine.

2015-02-02 Thread Abhishek Shrivastava
Hi all, For the past few days I have been facing the problem of getting the image upload error while installation of devstack in my CI. The devstack installation is triggered in CI when someone does the checkin, and the failure cause comes out to be the same. Below is the log for the error:

Re: [openstack-dev] Fwd: Image Upload error while installing devstack on CI slave machine.

2015-02-02 Thread Abhishek Shrivastava
. The fix is at https://review.openstack.org/#/c/151506/ which has not yet been approved, but if you can cherry-pick it for your CI it should get it working again. Thanks, Bob *From:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com] *Sent:* 02 February 2015 09:35

Re: [openstack-dev] [devstack] Installation problem

2015-01-27 Thread Abhishek Shrivastava
'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): cannot import name types On Mon, Jan 26, 2015 at 7:33 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi Rajdeep, Can you please send the details of how are you trying to install the latest devstack

Re: [openstack-dev] Problem installing devstack

2015-01-05 Thread Abhishek Shrivastava
Hi Rajdeep, Can you tell me the exact configuration (i.e;OS) you are using for installing devstack. On Tue, Jan 6, 2015 at 10:16 AM, Rajdeep Dua rajdeep@gmail.com wrote: Thanks for the response, in my case i am still getting the same error.. On Tue, Jan 6, 2015 at 9:28 AM, Ken'ichi

Re: [openstack-dev] 答复: [devstack] Opensatck installation issue.

2015-01-12 Thread Abhishek Shrivastava
Hi all, I am still getting the same error while installing the Openstack through devstack, If someone know the solution please reply. On Fri, Jan 9, 2015 at 1:53 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi Liuxinguo, Thanks for the suggestion, I'll try and make it work

Re: [openstack-dev] 答复: [devstack] Opensatck installation issue.

2015-01-12 Thread Abhishek Shrivastava
: in my environment I had to edit the file sudoers with a text editor (echoing the string didn't work). On 01/12/15 09:33, Abhishek Shrivastava wrote: Hi all, I am still getting the same error while installing the Openstack through devstack, If someone know the solution please reply

Re: [openstack-dev] 答复: [devstack] Opensatck installation issue.

2015-01-12 Thread Abhishek Shrivastava
://www.cloudbyte.com/ On Mon, Jan 12, 2015 at 3:55 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: I tried that also but still the error is same. On Mon, Jan 12, 2015 at 3:32 PM, Pasquale Porreca pasquale.porr...@dektech.com.au wrote: Since it seems a permission error, this may help: http

Re: [openstack-dev] [devstack]Openstack installation issue.

2015-01-12 Thread Abhishek Shrivastava
this line with adding sudo sudo cp -p $KEYSTONE_DIR/etc/keystone.conf.sample $KEYSTONE_CONF Regards Samta On Mon, Jan 12, 2015 at 4:01 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi all, I am writing this again because I am getting the same error from past week while I'm

Re: [openstack-dev] [devstack]Openstack installation issue.

2015-01-12 Thread Abhishek Shrivastava
Same as before. On Mon, Jan 12, 2015 at 5:04 PM, Samta Rangare samtarang...@gmail.com wrote: Whats the log now? On Mon, Jan 12, 2015 at 4:53 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi Samta, Thanks for the suggestion but still problem remains the same. On Mon, Jan 12

Re: [openstack-dev] 答复: [devstack] Opensatck installation issue.

2015-01-09 Thread Abhishek Shrivastava
to create symbolic link `/logs/screen/screen-key.log': No such file or directory” The stack user does not have the permission on “/” so it can not create directory `/logs'. Please check the permission. liu *发件人:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com] *发送时间:* 2015年1月9

Re: [openstack-dev] 答复: [devstack] Opensatck installation issue.

2015-01-14 Thread Abhishek Shrivastava
created earlier. On Mon, Jan 12, 2015 at 4:07 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Its showing the same error on Ubuntu 13.10, so I think its not a Ubuntu Version issue. On Mon, Jan 12, 2015 at 4:02 PM, Amit Das amit@cloudbyte.com wrote: Is this related to the version

Re: [openstack-dev] [devstack]Openstack installation issue.

2015-01-14 Thread Abhishek Shrivastava
created earlier. On Mon, Jan 12, 2015 at 6:23 PM, Sean Dague s...@dague.net wrote: Is your root filesystem full? The log clearly shows the chown stack /etc/keystone passing right before the copy is attempted. -Sean On 01/12/2015 06:59 AM, Abhishek Shrivastava wrote: Same as before

Re: [openstack-dev] Help needed

2015-04-09 Thread Abhishek Shrivastava
You can get the logs in /opt/stack/logs folder as stack.sh.log On Thu, Apr 9, 2015 at 3:03 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Can you give the full log. On Thu, Apr 9, 2015 at 2:57 PM, Deepika Agrawal deepika...@gmail.com wrote: hi guys! i am geting attribute error

Re: [openstack-dev] Help needed

2015-04-09 Thread Abhishek Shrivastava
, line 128, in url return self.link.url AttributeError: 'NoneType' object has no attribute 'url' On Thu, Apr 9, 2015 at 3:03 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Can you give the full log. On Thu, Apr 9, 2015 at 2:57 PM, Deepika Agrawal deepika...@gmail.com wrote

Re: [openstack-dev] Help needed

2015-04-09 Thread Abhishek Shrivastava
Can you give the full log. On Thu, Apr 9, 2015 at 2:57 PM, Deepika Agrawal deepika...@gmail.com wrote: hi guys! i am geting attribute error nonetype has no attribute URL in python update.py /opt/stack/keystone when i am going to run stack.sh. Please help! -- Deepika Agrawal

Re: [openstack-dev] [OpenStack-Infra] [openstack-infra][third-paty][CI][nodepool]Using Nodepool for creating slaves.

2015-08-18 Thread Abhishek Shrivastava
://solinea.com Remo Inviato da iPhone Il giorno 18 ago 2015, alle ore 07:41, Abhishek Shrivastava abhis...@cloudbyte.com ha scritto: Hi Folks, I was going through Ramy's guide for setting up CI, there I found out the following: - https://github.com/rasselin/os-ext-testing

Re: [openstack-dev] [openstack-infra][third-paty][CI][nodepool]Using Nodepool for creating slaves.

2015-08-17 Thread Abhishek Shrivastava
don't have to configure slaves in Jenkins. A bit confusing for me so if anyone can explain it to me then it will be very helpful. On Tue, Aug 18, 2015 at 11:11 AM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi Folks, I was going through Ramy's guide for setting up CI, there I found out

[openstack-dev] [openstack-infra][third-paty][CI][nodepool]Using Nodepool for creating slaves.

2015-08-17 Thread Abhishek Shrivastava
Hi Folks, I was going through Ramy's guide for setting up CI, there I found out the following: - https://github.com/rasselin/os-ext-testing#setting-up-nodepool-jenkins-slaves But I don't get the fact on how to create the image, also what major settings need to be done to make the config

Re: [openstack-dev] [openstack-infra][third-paty][CI][nodepool]Using Nodepool for creating slaves.

2015-08-19 Thread Abhishek Shrivastava
VM for this testcase. Hope this might help you. Xiexs *From:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com] *Sent:* Tuesday, August 18, 2015 1:46 PM *To:* openstack-in...@lists.openstack.org; OpenStack Development Mailing List (not for usage questions) *Subject:* Re

Re: [openstack-dev] [openstack-deb] Devstack stable/juno fails to install

2015-08-17 Thread Abhishek Shrivastava
Put PIP_UPGRADE=True in your local.conf, then try reinstalling it. On Mon, Aug 17, 2015 at 1:26 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, I noticed that devstack stable/juno fails to install on our CI with error: 2015-08-17 01:55:59.794 | + /usr/local/bin/cinder-manage db

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Abhishek Shrivastava
Hi Eduard, Can you please send the snippet of failed tests along with their error cause from your Build Logs. On Mon, Aug 17, 2015 at 12:02 PM, Eduard Matei eduard.ma...@cloudfounders.com wrote: Hi, I'm working on getting our CI working again, and i left it running over the weekend. Of

Re: [openstack-dev] [third-party-ci]Tests randomly failing because of lvm

2015-08-17 Thread Abhishek Shrivastava
Hi Eduard, This is what I gathered the cause of the test failure: 2015-08-17 03:13:44.239 ERROR oslo_messaging.rpc.dispatcher [req-95c1bc0f-e333-493b-9730-cfba9c3dfd9a tempest-VolumesV1ActionsTest-418947994] Exception during message handling: 500 Internal Server Error: Failed to upload image

Re: [openstack-dev] How to use the log server in CI ?

2015-07-30 Thread Abhishek Shrivastava
Hi Tang, You can give any name in $DOMAIN, also try to run a build then see if the logs are going to the LogServer, but before that clear that folder so that you can see the difference. On Thu, Jul 30, 2015 at 3:15 PM, Tang Chen tangc...@cn.fujitsu.com wrote: On 07/30/2015 04:54 PM, Abhishek

Re: [openstack-dev] How to use the log server in CI ?

2015-07-30 Thread Abhishek Shrivastava
I am talking about /srv/static/logs folder. On Thu, Jul 30, 2015 at 3:18 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi Tang, You can give any name in $DOMAIN, also try to run a build then see if the logs are going to the LogServer, but before that clear that folder so that you

Re: [openstack-dev] How to use the log server in CI ?

2015-07-30 Thread Abhishek Shrivastava
You should setup the LogServer in another machine apart from master/slave because the logs machine should be a separate one not any other master/slave. On Thu, Jul 30, 2015 at 3:49 PM, Tang Chen tangc...@cn.fujitsu.com wrote: On 07/30/2015 05:48 PM, Abhishek Shrivastava wrote: I am talking

Re: [openstack-dev] How to use the log server in CI ?

2015-07-30 Thread Abhishek Shrivastava
Hi Tang, After completing the logServer installation the logs will go to your machine automatically after each build run. On Thu, Jul 30, 2015 at 2:19 PM, Tang Chen tangc...@cn.fujitsu.com wrote: Hi Asselin, Abhishek, Sorry, it is about the CI again. I run install_log_server.sh to setup

Re: [openstack-dev] How to use the log server in CI ?

2015-08-08 Thread Abhishek Shrivastava
Hi Tang, The domain name is not important here, also the master found the log server using the host you have mentioned in the vars.sh file [1]. [1] https://github.com/rasselin/os-ext-testing-data/blob/master/vars.sh.sample#L10 On Fri, Aug 7, 2015 at 9:47 AM, Tang Chen tangc...@cn.fujitsu.com

Re: [openstack-dev] [CI] Jenkins jobs are not executed when setting up a new CI system.

2015-07-22 Thread Abhishek Shrivastava
​Hi Tang, ​ Reboot your master vm and then try the same. Also after restarting check the status of zuul and zuul-merger. On Wed, Jul 22, 2015 at 12:14 PM, Tang Chen tangc...@cn.fujitsu.com wrote: On 07/22/2015 12:49 PM, Tang Chen wrote: Hi all, When I send a patch to gerrit, my zuul is

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-13 Thread Abhishek Shrivastava
Updating jobs using sudo jenkins-jobs --flush-cache update /etc/jenkins_jobs/config/. Also update the myvendor in examples.yaml On Mon, Jul 13, 2015 at 1:45 PM, Tang Chen tangc...@cn.fujitsu.com wrote: On 07/13/2015 03:50 PM, Abhishek Shrivastava wrote: ​Use tester or something, also

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-13 Thread Abhishek Shrivastava
--flush-cache update /etc/jenkins_jobs/config/ And I did configure openstack-dev/sandbox in layout.yaml. Do you have any idea what's wrong here ? Thanks. On 07/13/2015 05:58 PM, Tang Chen wrote: On 07/13/2015 04:35 PM, Abhishek Shrivastava wrote: Updating jobs using sudo jenkins-jobs

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-14 Thread Abhishek Shrivastava
Also if you want to change it you will need to talk with Asselin Ramy who is the owner of the repo you followed. On Tue, Jul 14, 2015 at 12:18 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: ​Basically it is not required, and if you see /etc/jenkins_jobs/config folder you will find one

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-14 Thread Abhishek Shrivastava
, Abhishek Shrivastava wrote: Instead of it use reusable_node option. Thanks. Problem resolved. :) BTW, single_use_node is written in layout.yaml by default. If it doesn't exist anymore, do we need a patch to fix it ? For someone who uses CI for the first time, it is really a problem

[openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout.

2015-07-17 Thread Abhishek Shrivastava
Hi Folks, In my CI I see the following tempest tests failure for a past couple of days. - tempest.scenario.test_minimum_basic.TestMinimumBasicScenario.test_minimum_basic_scenario [361.274316s] ... FAILED -

Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout.

2015-07-19 Thread Abhishek Shrivastava
never found the root cause, but I found a work-around: Use neutron-networking instead of the default nova-networking. If you’re using devstack-gate, it’s as simple as: export DEVSTACK_GATE_NEUTRON=1 Then run the job as usual. Ramy *From:* Abhishek Shrivastava [mailto:abhis

Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout.

2015-07-19 Thread Abhishek Shrivastava
here [1]. Ramy [1] http://git.openstack.org/cgit/openstack-infra/project-config/tree/jenkins/jobs/devstack-gate.yaml#n467 *From:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com] *Sent:* Sunday, July 19, 2015 2:24 AM *To:* OpenStack Development Mailing List (not for usage questions

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-20 Thread Abhishek Shrivastava
For writing a Jenkins Job you can refer *dsvm-cinder-driver.yaml.sample* as a reference. On Mon, Jul 20, 2015 at 12:04 PM, Tang Chen tangc...@cn.fujitsu.com wrote: Hi Abhishek, On 07/20/2015 02:09 PM, Abhishek Shrivastava wrote: .. ​ Quite a nice explanation +1 for all the things

Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout.

2015-07-19 Thread Abhishek Shrivastava
/devstack-gate/tree/devstack-vm-gate.sh#n76 *From:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com] *Sent:* Sunday, July 19, 2015 10:37 AM *To:* OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-20 Thread Abhishek Shrivastava
/dafe822be7813522a6c7361993169da20b37ffb7 [2] https://github.com/openstack-infra/project-config/blob/master/zuul/openstack_functions.py [3] http://git.openstack.org/cgit/openstack-dev/ci-sandbox/ [4] http://eavesdrop.openstack.org/#Third_Party_Meeting *From:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-13 Thread Abhishek Shrivastava
First of all, change the vendor to your vendor name in /etc/jenkins_jobs/config/projects.yaml file. Also, restart the zuul and zuul merger. On Mon, Jul 13, 2015 at 12:29 PM, Tang Chen tangc...@cn.fujitsu.com wrote: Hi all, I have constructed my CI system. When I tested it with sandbox

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-13 Thread Abhishek Shrivastava
Also check that Gearman is connecting or not through Jenkins UI. On Mon, Jul 13, 2015 at 12:45 PM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: First of all, change the vendor to your vendor name in /etc/jenkins_jobs/config/projects.yaml file. Also, restart the zuul and zuul merger

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-21 Thread Abhishek Shrivastava
Hi Tang, Can you please send me the whole job snippet you wrote. On Tue, Jul 21, 2015 at 12:52 PM, Tang Chen tangc...@cn.fujitsu.com wrote: Hi Asselin, Abhishek, I got some problems when I was trying to write a jenkins job. I found that when zuul received the notification from gerrit,

Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout.

2015-07-20 Thread Abhishek Shrivastava
*From:* Abhishek Shrivastava [mailto:abhis...@cloudbyte.com] *Sent:* Sunday, July 19, 2015 10:37 AM *To:* OpenStack Development Mailing List (not for usage questions) *Subject:* Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout. Hi Ramy

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-21 Thread Abhishek Shrivastava
If you want to create a new job then refer *dsvm-cinder-driver.yaml.sample*, and regarding *noop-check-communication* its just for testing the first time don't modify it. On Tue, Jul 21, 2015 at 1:19 PM, Tang Chen tangc...@cn.fujitsu.com wrote: On 07/21/2015 03:35 PM, Abhishek Shrivastava

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-21 Thread Abhishek Shrivastava
Its just because what kind of file are you creating, as touch /tmp/noop-check-communication doesn't makes any sense to it. On Tue, Jul 21, 2015 at 2:48 PM, Tang Chen tangc...@cn.fujitsu.com wrote: On 07/21/2015 04:05 PM, Abhishek Shrivastava wrote: If you want to create a new job then refer

Re: [openstack-dev] [openstack-infra] [CI] [tempest] Tempest tests failing with SSH timeout.

2015-07-21 Thread Abhishek Shrivastava
Also, can't we stop downloading all those projects and let them include them in the DevStack using the ENABLED_SERVICES parameter, like we usually do while installing devstack. On Tue, Jul 21, 2015 at 11:18 AM, Abhishek Shrivastava abhis...@cloudbyte.com wrote: Hi Ramy, - The project

Re: [openstack-dev] [CI] How to set a proxy for zuul.

2015-07-13 Thread Abhishek Shrivastava
​Use tester or something, also are you updating the jobs or not?​ On Mon, Jul 13, 2015 at 1:16 PM, Tang Chen tangc...@cn.fujitsu.com wrote: Hi Abhishek, Thanks for the quick reply. On 07/13/2015 03:16 PM, Abhishek Shrivastava wrote: Also check that Gearman is connecting or not through

Re: [openstack-dev] [third-party] Timeout waiting for ssh access

2015-08-25 Thread Abhishek Shrivastava
Hi Ramy, Can you mention the steps for glance scripts? On Tue, Aug 25, 2015 at 7:49 PM, Asselin, Ramy ramy.asse...@hp.com wrote: Hi Tang, I haven’t seen this issue. Which approach are you using to build the image? DIB or via glance scripts? Do you get the same result when using both

[openstack-dev] [openstack][devstack]Openstack devstack installation failing.

2015-11-13 Thread Abhishek Shrivastava
Hi Folks, I have been trying to install devstack on Ubuntu 14.04 for the last 5 times but I am still getting the following error message while it is Initializing tempest: *ERROR (ConnectionRefused): Unable to establish connection to http://127.0.0.1:8774/v2.1/ * So,

[openstack-dev] [openstack-infra][third-party][CI][nodepool] Uploading images to nodepool.

2015-08-26 Thread Abhishek Shrivastava
Hi Folks, I am following Ramy's new guide for setting up the CI. Till now I have installed master and created the slave node image using [1]. Now I want to upload the image to nodepool, so can I use [2] to do so, or is there any other way also to do so. - Also is there any other changes that

Re: [openstack-dev] [third-party] [CI] The dsvm-tempest-full job failed

2015-08-31 Thread Abhishek Shrivastava
Hi Xianshan , So after starting nodepool you have configured the slave in Jenkins or it was done automatically? On Mon, Aug 31, 2015 at 1:15 PM, Xie, Xianshan wrote: > Hi, all, > > I`m trying to run the job "dsvm-tempest-full" in a slave node which > built and managed

[openstack-dev] [devstack] Upgrading Icehouse to Juno

2015-12-06 Thread Abhishek Shrivastava
Hi Folks, I have a stable/icehouse devstack setup and I am planning to upgrade it to stable/kilo but following the guide mentioned in Openstack Manuals does not seems to work correctly. So if anyone can help me regarding this issue, please send your suggestion and guidance. -- *Thanks &

Re: [openstack-dev] [devstack] How to start all OpenStack services after restarting system?

2016-08-18 Thread Abhishek Shrivastava
Hi Zhi, Use "screen -c stack-screenrc" this will take you to the services screen. On Thu, Aug 18, 2016 at 3:03 PM, zhi wrote: > hi, all. > > Currently, there is no "rejoin-stack.sh" script in devstack. > > It will clear all resources and create all resources if