[openstack-dev] [Congress]How to add tempest tests for testing murano drive

2015-03-09 Thread Wong, Hong
on this, but we don?t have anything in place yet, as far as I know. He?s a starting point. https://review.openstack.org/#/c/157166/ Tim On Feb 26, 2015, at 2:56 PM, Wong, Hong hong.w...@hp.commailto:hong.w...@hp.commailto:hong.w...@hp.com%3cmailto:hong.w...@hp.com wrote: Hi Aaron

Re: [openstack-dev] [Congress]How to add tempest tests for testing murano drive

2015-03-10 Thread Wong, Hong
they should be installed by the devstack script. If you want to run tempest via tox and venv you'll need to do: echo python-congressclient requirements.txt echo python-muranoclient requirements.txt Then have tox build the venv. Best, Aaron On Mon, Mar 9, 2015 at 8:28 PM, Wong, Hong hong.w

[openstack-dev] [Congress]How to add tempest tests for testing murano driver

2015-02-26 Thread Wong, Hong
Hi Aaron, I am new to congress and trying to write tempest tests for the newly added murano datasource driver. Since the murano datasource tempest tests require both murano and python-congress clients as the dependencies. I was told that I can't just simply add the requirements in the

[openstack-dev] [Congress] How to start a replica ?

2015-07-27 Thread Wong, Hong
Hi Tim and Alex, I see congress recently added the HA functionality, and I was looking at the tempest test code to understand how to start a replica. I created a new congress.conf file with the different bind_port and set the datasource_sync_period value to 5. However, I got the errors below