Re: [openstack-dev] [savanna] paramiko requirement of = 1.9.0?

2014-01-27 Thread Sergey Lukjanov
Currently we have paramiko = 1.9.0 in both global-requirements and savanna: https://review.openstack.org/#/c/68088/ https://review.openstack.org/#/c/69045/ On Tue, Jan 21, 2014 at 3:41 PM, Sergey Lukjanov slukja...@mirantis.comwrote: Here is a change for global-requirements

Re: [openstack-dev] [savanna] paramiko requirement of = 1.9.0?

2014-01-21 Thread Sergey Lukjanov
Hey Matt, that's correct, we should bump paramiko version to = 1.9.0. It was released more than year ago and so all of us use paramiko = 1.9.0 Thanks for catching this. On Sun, Jan 19, 2014 at 7:44 AM, Matthew Farrellee m...@redhat.com wrote: jon, please confirm a suspicion of mine. the

Re: [openstack-dev] [savanna] paramiko requirement of = 1.9.0?

2014-01-21 Thread Sergey Lukjanov
Here is a change for global-requirements https://review.openstack.org/#/c/68088/ On Tue, Jan 21, 2014 at 3:30 PM, Sergey Lukjanov slukja...@mirantis.comwrote: Hey Matt, that's correct, we should bump paramiko version to = 1.9.0. It was released more than year ago and so all of us use

[openstack-dev] [savanna] paramiko requirement of = 1.9.0?

2014-01-18 Thread Matthew Farrellee
jon, please confirm a suspicion of mine. the neutron-private-net-provisioning bp impl added a sock= parameter to the ssh.connect call in remote.py (https://github.com/openstack/savanna/commit/9afb5f60). we currently require paramiko = 1.8.0, but it looks like the sock param was only added