Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-12 Thread urgensherpa
hello there,i setup using devstack ..below is my docker version output -- redhat@test:~/devstack$ docker version Client version: 0.7.6 Go version (client): go1.2 Git commit (client): bc3b2ec Server

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-12 Thread Russell Bryant
Note that devstack is going to break for docker and Nova master right now. We're in the middle of moving the docker driver. In the meantime, use a rev of Nova before this merge: https://review.openstack.org/#/c/79740/ Once the following change for the new repo merges, we can update

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-12 Thread Sean Dague
On 03/12/2014 07:36 AM, Russell Bryant wrote: Note that devstack is going to break for docker and Nova master right now. We're in the middle of moving the docker driver. In the meantime, use a rev of Nova before this merge: https://review.openstack.org/#/c/79740/ Once the following

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-12 Thread Russell Bryant
On 03/12/2014 08:02 AM, Sean Dague wrote: On 03/12/2014 07:36 AM, Russell Bryant wrote: Note that devstack is going to break for docker and Nova master right now. We're in the middle of moving the docker driver. In the meantime, use a rev of Nova before this merge:

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-12 Thread Paul Czarkowski
There is a bug in the default docker registry. Set this is your localrc and it should work DOCKER_REGISTRY_IMAGE=samalba/docker-registry On 3/12/14 1:35 AM, urgensherpa sherpa.ur...@outlook.com wrote: hello there,i setup using devstack ..below is my docker version output

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-11 Thread urgensherpa
Hello!, i can run docker containers and push it to docker io but i failed to push it for local glance.and get the same error mentioned here. Could you please show some more light on how you resolved it. i started settingup openstack and docker using devstack. here is my localrc

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-03-11 Thread Daniel Kuffner
Hi, what is the error reported by docker? Can you post the docker registry log? What version of docker do you use? I assume you use devstack master branch? thank you, Daniel On Tue, Mar 11, 2014 at 1:19 PM, urgensherpa sherpa.ur...@outlook.com wrote: Hello!, i can run docker containers and

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread Swapnil Kulkarni
Thanks Danilel. I tried adding the iptable rules but I am still getting error 500 with docker push I have added the container logs and iptables output at [1] [1] http://paste.openstack.org/show/61251/ Best Regards, Swapnil On Mon, Jan 13, 2014 at 7:28 PM, Daniel Kuffner

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread John Eckersberg
Swapnil Kulkarni swapnilkulkarni2...@gmail.com writes: Thanks Danilel. I tried adding the iptable rules but I am still getting error 500 with docker push I have added the container logs and iptables output at [1] [1] http://paste.openstack.org/show/61251/ Best Regards, Swapnil Swapnil,

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread Eric Windisch
I think this is because your OS_GLANCE_URL and OS_AUTH_URL are set to 127.0.0.1, and that address inside of the docker container is different than the address outside (e.g. on the host itself). If you have glance and keystone running on a non-localhost address, then the traffic inside of

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread Swapnil Kulkarni
Thanks a ton John! It finally worked! @Daniel, no firewall update is required. @Eric, At the same time, I had to update /home/dstack/devstack/lib/nova_plugins/hypervisor-docker to include sudo for all docker commands. I think that could be one change we would need in docker and a documentation

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread Eric Windisch
@Eric, At the same time, I had to update /home/dstack/devstack/lib/nova_plugins/hypervisor-docker to include sudo for all docker commands. I think that could be one change we would need in docker and a documentation update for not using 127.0.0.1. I will create a bug and will submit a patch

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread Swapnil Kulkarni
Okay I will give a try adding the stack user to docker group and adding error message if it fails due to 127.0.0.1. Also will file a bug report for the same. Best Regards, Swapnil On Wed, Jan 15, 2014 at 9:53 PM, Eric Windisch ewindi...@docker.com wrote: @Eric, At the same time, I had to

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-15 Thread John Utz
Hi Eric Small world dude. :-) Have a nice day! johnu From: Eric Windisch [e...@windisch.us] Sent: Wednesday, January 15, 2014 7:33 AM To: OpenStack Development Mailing List (not for usage questions) Subject: Re: [openstack-dev] [Openstack][Nova][Docker] Devstack

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-13 Thread Daniel Kuffner
Hello, I just had the same problem today with a openstack installation form packstack. The problem was the firewall so I had to open 9292, 35357 iptables -I INPUT -p tcp --dport 9292 -j ACCEPT iptables -I INPUT -p tcp --dport 35357 -j ACCEPT Daniel On Thu, Jan 9, 2014 at 3:24 PM, Swapnil

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-09 Thread Daniel Kuffner
Hi Swapnil, Looks like the docker-registry image is broken, since it cannot find run.sh inside the container. 2014/01/09 06:36:15 Unable to locate ./docker-registry/run.sh Maybe you could try to remove and re-import image docker rmi docker-registry and then execute

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-09 Thread Daniel Kuffner
The tar file seem to be corrupt, the tools script downloads it to: ./files/docker-registry.tar.gz On Thu, Jan 9, 2014 at 11:17 AM, Swapnil Kulkarni swapnilkulkarni2...@gmail.com wrote: Hi Daniel, I removed the existing images and executed ./tools/docker/install_docker.sh. I am facing new

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-09 Thread Swapnil Kulkarni
Hi Daniel, I think it was some proxy issue prohibiting from the download. I downloaded the correct docker-registry.tar.gz and stack.sh completed but with some issues remain related to image availability. The docker push is getting *HTTP code 500 while uploading metadata: invalid character ''

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-08 Thread Eric Windisch
On Tue, Jan 7, 2014 at 11:13 PM, Swapnil Kulkarni swapnilkulkarni2...@gmail.com wrote: Let me know in case I can be of any help getting this resolved. Please try running the failing 'docker run' command manually and without the '-d' argument. I've been able to reproduce an error myself, but

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-08 Thread Swapnil Kulkarni
Hi Eric, I tried running the 'docker run' command without -d and it gets following error $ sudo docker run -d=false -p 5042:5000 -e SETTINGS_FLAVOR=openstack -e OS_USERNAME=admin -e OS_PASSWORD=password -e OS_TENANT_NAME=admin -e OS_GLANCE_URL=http://127.0.0.1:9292 -e OS_AUTH_URL=

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-07 Thread Eric Windisch
On Tue, Jan 7, 2014 at 1:16 AM, Swapnil Kulkarni swapnilkulkarni2...@gmail.com wrote: Thanks Eric. I had already tried the solution presented on ask.openstack.org. It was worth a shot. I also found a bug [1] and applied code changes in [2], but to no success. Ah. I hadn't seen that

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-07 Thread Swapnil Kulkarni
Let me know in case I can be of any help getting this resolved. Best Regards, Swapnil On Wed, Jan 8, 2014 at 12:38 AM, Eric Windisch ewindi...@docker.com wrote: On Tue, Jan 7, 2014 at 1:16 AM, Swapnil Kulkarni swapnilkulkarni2...@gmail.com wrote: Thanks Eric. I had already tried the

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-06 Thread Eric Windisch
On Tue, Jan 7, 2014 at 12:27 AM, Swapnil Kulkarni swapnilkulkarni2...@gmail.com wrote: Hello, I am trying to setup devstack with docker driver and facing some issues related to docker-registry. Opened an issue with docker team [1] but to no response. Has anybody done devstack setup with

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-06 Thread Eric Windisch
I am trying to setup devstack with docker driver and facing some issues related to docker-registry. Opened an issue with docker team [1] but to no response. Has anybody done devstack setup with docker driver? Also, I'm sorry you didn't get a speedy response through other means, but we

Re: [openstack-dev] [Openstack][Nova][Docker] Devstack with docker driver

2014-01-06 Thread Swapnil Kulkarni
Thanks Eric. I had already tried the solution presented on ask.openstack.org. I also found a bug [1] and applied code changes in [2], but to no success. I was just curious to know if anyone else is working on this or can provide some pointers from development front. [1]