Re: [openstack-dev] [Release-job-failures][release][horizon] Release of openstack/xstatic-angular-material failed

2018-06-25 Thread Sean McGinnis
> 
> Apart from the fix, is there any good way to detect this kind of errors in
> individual project reviews?
>

I've added xstatic version checking to our release request validation. Once
this merges, we should be able to automatically catch and error on these types
of conditions:

https://review.openstack.org/577828


__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Release-job-failures][release][horizon] Release of openstack/xstatic-angular-material failed

2018-06-25 Thread Akihiro Motoki
First of all, thanks for the release team and Radomir.

Apart from the fix, is there any good way to detect this kind of errors in
individual project reviews?
xstatic-cores have new members and all of them are not necessarily super
familiar with the xstatic process.
In addition, updates in xstatic repos do not happen often, so we
xstatic-cores (including horizon-cores)
tend to forget minor corner cases

I believe this failure is a symptom that we should add more checks in
xstatic repo gates rather than "noop" :(

Akihiro


2018年6月25日(月) 22:37 Radomir Dopieralski :

> A fix for it is in review: https://review.openstack.org/577820
>
> On Mon, Jun 25, 2018 at 3:07 PM, Andreas Jaeger  wrote:
>
>> On 2018-06-25 14:57, Radomir Dopieralski wrote:
>> > Any idea where it took the 1.1.5.0 version from?
>>
>> git grep 1.1.5 shows at least:
>>
>> setup.cfg:description = Angular-Material 1.1.5 (XStatic packaging
>> standard)
>> xstatic/pkg/angular_material/__init__.py:VERSION = '1.1.5'  # version of
>> the packaged files, please use the upstream
>>
>> Not sure whether that's the right place, I suggest you build locally and
>> check the build tarball,
>>
>> Andreas
>>
>> > On Mon, Jun 25, 2018 at 2:38 PM, Doug Hellmann > > > wrote:
>> >
>> > Excerpts from zuul's message of 2018-06-25 12:14:34 +:
>> > > Build failed.
>> > >
>> > > - xstatic-check-version
>> >
>> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/
>> > <
>> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/
>> >
>> > : FAILURE in 1m 31s
>> > > - release-openstack-python release-openstack-python : SKIPPED
>> > > - announce-release announce-release : SKIPPED
>> > > - propose-update-constraints propose-update-constraints : SKIPPED
>> > >
>> >
>> > "git tag version (1.1.5.1) does not match package version (1.1.5.0)"
>> >
>> >
>> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/job-output.txt.gz#_2018-06-25_12_14_11_034599
>> > <
>> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/job-output.txt.gz#_2018-06-25_12_14_11_034599
>> >
>> >
>> >
>>  __
>> > OpenStack Development Mailing List (not for usage questions)
>> > Unsubscribe:
>> > openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> > <
>> http://openstack-dev-requ...@lists.openstack.org?subject:unsubscribe>
>> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>> > 
>> >
>> >
>> >
>> >
>> >
>> __
>> > OpenStack Development Mailing List (not for usage questions)
>> > Unsubscribe:
>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>> >
>>
>>
>> --
>>  Andreas Jaeger aj@{suse.com,opensuse.org} Twitter: jaegerandi
>>   SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
>>GF: Felix Imendörffer, Jane Smithard, Graham Norton,
>>HRB 21284 (AG Nürnberg)
>> GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126
>>
>>
>> __
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe:
>> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>
>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Release-job-failures][release][horizon] Release of openstack/xstatic-angular-material failed

2018-06-25 Thread Radomir Dopieralski
A fix for it is in review: https://review.openstack.org/577820

On Mon, Jun 25, 2018 at 3:07 PM, Andreas Jaeger  wrote:

> On 2018-06-25 14:57, Radomir Dopieralski wrote:
> > Any idea where it took the 1.1.5.0 version from?
>
> git grep 1.1.5 shows at least:
>
> setup.cfg:description = Angular-Material 1.1.5 (XStatic packaging standard)
> xstatic/pkg/angular_material/__init__.py:VERSION = '1.1.5'  # version of
> the packaged files, please use the upstream
>
> Not sure whether that's the right place, I suggest you build locally and
> check the build tarball,
>
> Andreas
>
> > On Mon, Jun 25, 2018 at 2:38 PM, Doug Hellmann  > > wrote:
> >
> > Excerpts from zuul's message of 2018-06-25 12:14:34 +:
> > > Build failed.
> > >
> > > - xstatic-check-version
> > http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41a
> c8a67d909b/release/xstatic-check-version/a501dba/
> >  c8a67d909b/release/xstatic-check-version/a501dba/>
> > : FAILURE in 1m 31s
> > > - release-openstack-python release-openstack-python : SKIPPED
> > > - announce-release announce-release : SKIPPED
> > > - propose-update-constraints propose-update-constraints : SKIPPED
> > >
> >
> > "git tag version (1.1.5.1) does not match package version (1.1.5.0)"
> >
> > http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41a
> c8a67d909b/release/xstatic-check-version/a501dba/job-
> output.txt.gz#_2018-06-25_12_14_11_034599
> >  c8a67d909b/release/xstatic-check-version/a501dba/job-
> output.txt.gz#_2018-06-25_12_14_11_034599>
> >
> > 
> __
> > OpenStack Development Mailing List (not for usage questions)
> > Unsubscribe:
> > openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> >  unsubscribe>
> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> > 
> >
> >
> >
> >
> > 
> __
> > OpenStack Development Mailing List (not for usage questions)
> > Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:
> unsubscribe
> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> >
>
>
> --
>  Andreas Jaeger aj@{suse.com,opensuse.org} Twitter: jaegerandi
>   SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
>GF: Felix Imendörffer, Jane Smithard, Graham Norton,
>HRB 21284 (AG Nürnberg)
> GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126
>
>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Release-job-failures][release][horizon] Release of openstack/xstatic-angular-material failed

2018-06-25 Thread Andreas Jaeger
On 2018-06-25 14:57, Radomir Dopieralski wrote:
> Any idea where it took the 1.1.5.0 version from?

git grep 1.1.5 shows at least:

setup.cfg:description = Angular-Material 1.1.5 (XStatic packaging standard)
xstatic/pkg/angular_material/__init__.py:VERSION = '1.1.5'  # version of
the packaged files, please use the upstream

Not sure whether that's the right place, I suggest you build locally and
check the build tarball,

Andreas

> On Mon, Jun 25, 2018 at 2:38 PM, Doug Hellmann  > wrote:
> 
> Excerpts from zuul's message of 2018-06-25 12:14:34 +:
> > Build failed.
> >
> > - xstatic-check-version
> 
> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/
> 
> 
> : FAILURE in 1m 31s
> > - release-openstack-python release-openstack-python : SKIPPED
> > - announce-release announce-release : SKIPPED
> > - propose-update-constraints propose-update-constraints : SKIPPED
> >
> 
> "git tag version (1.1.5.1) does not match package version (1.1.5.0)"
> 
> 
> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/job-output.txt.gz#_2018-06-25_12_14_11_034599
> 
> 
> 
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe:
> openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> 
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> 
> 
> 
> 
> 
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> 


-- 
 Andreas Jaeger aj@{suse.com,opensuse.org} Twitter: jaegerandi
  SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
   GF: Felix Imendörffer, Jane Smithard, Graham Norton,
   HRB 21284 (AG Nürnberg)
GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126


__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Release-job-failures][release][horizon] Release of openstack/xstatic-angular-material failed

2018-06-25 Thread Radomir Dopieralski
Any idea where it took the 1.1.5.0 version from?

On Mon, Jun 25, 2018 at 2:38 PM, Doug Hellmann 
wrote:

> Excerpts from zuul's message of 2018-06-25 12:14:34 +:
> > Build failed.
> >
> > - xstatic-check-version http://logs.openstack.org/59/
> 592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-
> check-version/a501dba/ : FAILURE in 1m 31s
> > - release-openstack-python release-openstack-python : SKIPPED
> > - announce-release announce-release : SKIPPED
> > - propose-update-constraints propose-update-constraints : SKIPPED
> >
>
> "git tag version (1.1.5.1) does not match package version (1.1.5.0)"
>
> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41a
> c8a67d909b/release/xstatic-check-version/a501dba/job-
> output.txt.gz#_2018-06-25_12_14_11_034599
>
> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [Release-job-failures][release][horizon] Release of openstack/xstatic-angular-material failed

2018-06-25 Thread Doug Hellmann
Excerpts from zuul's message of 2018-06-25 12:14:34 +:
> Build failed.
> 
> - xstatic-check-version 
> http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/
>  : FAILURE in 1m 31s
> - release-openstack-python release-openstack-python : SKIPPED
> - announce-release announce-release : SKIPPED
> - propose-update-constraints propose-update-constraints : SKIPPED
> 

"git tag version (1.1.5.1) does not match package version (1.1.5.0)"

http://logs.openstack.org/59/592a9d4c90f37cd33c6f861120f41ac8a67d909b/release/xstatic-check-version/a501dba/job-output.txt.gz#_2018-06-25_12_14_11_034599

__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev