Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-05-07 Thread John Dickinson
I've discovered that eventlet 0.23.0 (released April 6) does break things for Swift. I'm not sure about other projects yet. https://bugs.launchpad.net/swift/+bug/1769749 --John On 7 May 2018, at 13:50, Doug Hellmann wrote: Excerpts from Michel Peterson's message of 2018-05-07 17:54:02

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-05-07 Thread Doug Hellmann
Excerpts from Michel Peterson's message of 2018-05-07 17:54:02 +0300: > On Fri, Apr 20, 2018 at 11:06 PM, Doug Hellmann > wrote: > > > > > We have made great progress on this but we do still have quite a > > few of these patches that have not been approved. Many are

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-05-07 Thread Michel Peterson
On Fri, Apr 20, 2018 at 11:06 PM, Doug Hellmann wrote: > > We have made great progress on this but we do still have quite a > few of these patches that have not been approved. Many are failing > test jobs and will need a little attention ( the failing requirements > jobs

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-20 Thread Doug Hellmann
Excerpts from Doug Hellmann's message of 2018-04-11 12:20:46 -0400: > Excerpts from Matthew Thode's message of 2018-04-05 10:47:37 -0500: > > eventlet-0.22.1 has been out for a while now, we should try and use it. > > Going to be fun times. > > > > I have a review projects can depend upon if they

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-11 Thread Doug Hellmann
Excerpts from Doug Hellmann's message of 2018-04-11 12:20:46 -0400: > Excerpts from Matthew Thode's message of 2018-04-05 10:47:37 -0500: > > eventlet-0.22.1 has been out for a while now, we should try and use it. > > Going to be fun times. > > > > I have a review projects can depend upon if they

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-11 Thread Doug Hellmann
Excerpts from Matthew Thode's message of 2018-04-05 10:47:37 -0500: > eventlet-0.22.1 has been out for a while now, we should try and use it. > Going to be fun times. > > I have a review projects can depend upon if they wish to test. > https://review.openstack.org/533021 I have proposed a bunch

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-11 Thread Doug Hellmann
t; > > > From:Doug Hellmann <d...@doughellmann.com> > To: openstack-dev <openstack-dev@lists.openstack.org> > Date:04/11/2018 08:56 PM > Subject:Re: [openstack-dev] [all][requirements] uncapping eventlet > > Excerpts from IWAM

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-11 Thread Chen CH Ji
llmann <d...@doughellmann.com> To: openstack-dev <openstack-dev@lists.openstack.org> Date: 04/11/2018 08:56 PM Subject: Re: [openstack-dev] [all][requirements] uncapping eventlet Excerpts from IWAMOTO Toshihiro's message of 2018-04-11 18:19:02 +0900: > On Mon, 09 Apr 201

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-11 Thread Doug Hellmann
Excerpts from IWAMOTO Toshihiro's message of 2018-04-11 18:19:02 +0900: > On Mon, 09 Apr 2018 22:58:28 +0900, > Doug Hellmann wrote: > > > > Excerpts from Tony Breeds's message of 2018-04-09 13:39:30 +1000: > > > On Fri, Apr 06, 2018 at 09:41:07AM -0700, Clark Boylan wrote: > > > > > > > My

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-11 Thread IWAMOTO Toshihiro
On Mon, 09 Apr 2018 22:58:28 +0900, Doug Hellmann wrote: > > Excerpts from Tony Breeds's message of 2018-04-09 13:39:30 +1000: > > On Fri, Apr 06, 2018 at 09:41:07AM -0700, Clark Boylan wrote: > > > > > My understanding of our use of upper constraints was that this should > > > (almost) always

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-10 Thread Ben Nemec
On 04/09/2018 04:32 PM, Ben Nemec wrote: On 04/09/2018 01:12 PM, Ben Nemec wrote: On 04/06/2018 04:02 AM, Jens Harbott wrote: 2018-04-05 19:26 GMT+00:00 Matthew Thode : On 18-04-05 20:11:04, Graham Hayes wrote: On 05/04/18 16:47, Matthew Thode wrote:

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-09 Thread Tony Breeds
On Mon, Apr 09, 2018 at 09:58:28AM -0400, Doug Hellmann wrote: > Now that projects don't have to match the global requirements list > entries exactly we should be able to remove caps from within the > projects and keep caps in the global list for cases like this where we > know we frequently

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-09 Thread Ben Nemec
On 04/09/2018 01:12 PM, Ben Nemec wrote: On 04/06/2018 04:02 AM, Jens Harbott wrote: 2018-04-05 19:26 GMT+00:00 Matthew Thode : On 18-04-05 20:11:04, Graham Hayes wrote: On 05/04/18 16:47, Matthew Thode wrote: eventlet-0.22.1 has been out for a while now, we

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-09 Thread Ben Nemec
On 04/06/2018 04:02 AM, Jens Harbott wrote: 2018-04-05 19:26 GMT+00:00 Matthew Thode : On 18-04-05 20:11:04, Graham Hayes wrote: On 05/04/18 16:47, Matthew Thode wrote: eventlet-0.22.1 has been out for a while now, we should try and use it. Going to be fun times.

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-09 Thread Doug Hellmann
Excerpts from Tony Breeds's message of 2018-04-09 13:39:30 +1000: > On Fri, Apr 06, 2018 at 09:41:07AM -0700, Clark Boylan wrote: > > > My understanding of our use of upper constraints was that this should > > (almost) always be the case for (almost) all dependencies. We should > > rely on

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-08 Thread Tony Breeds
On Fri, Apr 06, 2018 at 09:41:07AM -0700, Clark Boylan wrote: > My understanding of our use of upper constraints was that this should > (almost) always be the case for (almost) all dependencies. We should > rely on constraints instead of requirements caps. Capping libs like > pbr or eventlet and

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-06 Thread Matthew Thode
On 18-04-06 09:41:07, Clark Boylan wrote: > On Fri, Apr 6, 2018, at 9:34 AM, Matthew Thode wrote: > > On 18-04-06 09:02:29, Jens Harbott wrote: > > > 2018-04-05 19:26 GMT+00:00 Matthew Thode : > > > > On 18-04-05 20:11:04, Graham Hayes wrote: > > > >> On 05/04/18 16:47,

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-06 Thread Clark Boylan
On Fri, Apr 6, 2018, at 9:34 AM, Matthew Thode wrote: > On 18-04-06 09:02:29, Jens Harbott wrote: > > 2018-04-05 19:26 GMT+00:00 Matthew Thode : > > > On 18-04-05 20:11:04, Graham Hayes wrote: > > >> On 05/04/18 16:47, Matthew Thode wrote: > > >> > eventlet-0.22.1 has

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-06 Thread Matthew Thode
On 18-04-06 09:02:29, Jens Harbott wrote: > 2018-04-05 19:26 GMT+00:00 Matthew Thode : > > On 18-04-05 20:11:04, Graham Hayes wrote: > >> On 05/04/18 16:47, Matthew Thode wrote: > >> > eventlet-0.22.1 has been out for a while now, we should try and use it. > >> > Going

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-06 Thread Jens Harbott
2018-04-05 19:26 GMT+00:00 Matthew Thode : > On 18-04-05 20:11:04, Graham Hayes wrote: >> On 05/04/18 16:47, Matthew Thode wrote: >> > eventlet-0.22.1 has been out for a while now, we should try and use it. >> > Going to be fun times. >> > >> > I have a review projects

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-05 Thread Matthew Thode
On 18-04-05 20:11:04, Graham Hayes wrote: > On 05/04/18 16:47, Matthew Thode wrote: > > eventlet-0.22.1 has been out for a while now, we should try and use it. > > Going to be fun times. > > > > I have a review projects can depend upon if they wish to test. > > https://review.openstack.org/533021

Re: [openstack-dev] [all][requirements] uncapping eventlet

2018-04-05 Thread Graham Hayes
On 05/04/18 16:47, Matthew Thode wrote: > eventlet-0.22.1 has been out for a while now, we should try and use it. > Going to be fun times. > > I have a review projects can depend upon if they wish to test. > https://review.openstack.org/533021 It looks like we may have an issue with oslo.service