Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-24 Thread Zane Bitter
On 24/03/16 04:29, Steven Hardy wrote: On Thu, Mar 24, 2016 at 01:39:01AM -0400, Rabi Mishra wrote: On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: Hello, It looks similar on issue, which was discussed here [1] I suppose, that the root cause is incorrect using

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-24 Thread Zane Bitter
On 24/03/16 01:39, Rabi Mishra wrote: On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: Hello, It looks similar on issue, which was discussed here [1] I suppose, that the root cause is incorrect using get_attr for your case. Probably you got "list" instead of

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-24 Thread Steven Hardy
On Wed, Mar 23, 2016 at 05:05:17PM -0400, Zane Bitter wrote: > On 23/03/16 13:35, Steven Hardy wrote: > >On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: > >>Hello, > >>It looks similar on issue, which was discussed here [1] > >>I suppose, that the root cause is

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-24 Thread Steven Hardy
On Thu, Mar 24, 2016 at 01:39:01AM -0400, Rabi Mishra wrote: > > On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: > > >Hello, > > >It looks similar on issue, which was discussed here [1] > > >I suppose, that the root cause is incorrect using get_attr for your > > >

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-24 Thread Sergey Kraynev
Rabi, Good point. I suppose, that the root cause of it is gap in our documentation. Unfortunately I can not find any clear description what's the differences or how it should work (especially with examples) in our documentation. [1] May be we need to improve it by adding more examples ? [1]

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-23 Thread Rabi Mishra
> On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: > >Hello, > >It looks similar on issue, which was discussed here [1] > >I suppose, that the root cause is incorrect using get_attr for your > >case. > >Probably you got "list"  instead of "string". > >F.e. if

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-23 Thread Zane Bitter
On 23/03/16 13:35, Steven Hardy wrote: On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: Hello, It looks similar on issue, which was discussed here [1] I suppose, that the root cause is incorrect using get_attr for your case. Probably you got "list" instead of

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-23 Thread Sergey Kraynev
Steven, Honestly I thought about it, but I am not sure, which behavior was before for both. I don't mind if we create such bug and investigate the root cause (unfortunately I had not time to do it yet). The my main point was to provide workable way for mentioned issue. p.s. there is

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-23 Thread Steven Hardy
On Wed, Mar 23, 2016 at 05:25:57PM +0300, Sergey Kraynev wrote: >Hello, >It looks similar on issue, which was discussed here [1]  >I suppose, that the root cause is incorrect using get_attr for your case. >Probably you got "list"  instead of "string". >F.e. if I do something

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-23 Thread Sergey Kraynev
Hello, It looks similar on issue, which was discussed here [1] I suppose, that the root cause is incorrect using get_attr for your case. Probably you got "list" instead of "string". F.e. if I do something similar: outputs: rg_1: value: {get_attr: [rg_a, rg_a_public_ip]} rg_2:

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-14 Thread Duan, Li-Gong (Gary, HPServers-Core-OE-PSC)
List (not for usage questions) <openstack-dev@lists.openstack.org> Subject: Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template Hi Gary, I have tried your template and it works for me correctly. Note, that I used private network (because my servers have not any pub

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-11 Thread Zane Bitter
, March 10, 2016 5:40 AM To: openstack-dev@lists.openstack.org Subject: Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template On 09/03/16 05:42, Sergey Kraynev wrote: Hi Gary, First of all you don't need to use "depends_on", because using "get_attr" already create impl

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-11 Thread Sergey Kraynev
to get it until the creation of the 2 resource > groups(rg_a and rg_b) is completed? > > Regards, > Gary > > -Original Message- > From: Sergey Kraynev [mailto:skray...@mirantis.com] > Sent: Wednesday, March 09, 2016 6:42 PM > To: OpenStack Development Mailing List (no

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-10 Thread Duan, Li-Gong (Gary, HPServers-Core-OE-PSC)
1 is just for testing purpose and my end goal is that the count should be inputed as paramaters. Regards, Gary -Original Message- From: Jay Dobies [mailto:jason.dob...@redhat.com] Sent: Thursday, March 10, 2016 5:55 AM To: openstack-dev@lists.openstack.org Subject: Re: [openstack-dev] [he

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-10 Thread Duan, Li-Gong (Gary, HPServers-Core-OE-PSC)
interface up, IP assigned. Regards, Gary -Original Message- From: Zane Bitter [mailto:zbit...@redhat.com] Sent: Thursday, March 10, 2016 5:40 AM To: openstack-dev@lists.openstack.org Subject: Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template On 09/03/16 05:42, Sergey

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-10 Thread Duan, Li-Gong (Gary, HPServers-Core-OE-PSC)
resource groups(rg_a and rg_b) is completed? Regards, Gary -Original Message- From: Sergey Kraynev [mailto:skray...@mirantis.com] Sent: Wednesday, March 09, 2016 6:42 PM To: OpenStack Development Mailing List (not for usage questions) Subject: Re: [openstack-dev] [heat] issue of ResourceGr

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-09 Thread Jay Dobies
On 3/9/16 4:39 PM, Zane Bitter wrote: On 09/03/16 05:42, Sergey Kraynev wrote: Hi Gary, First of all you don't need to use "depends_on", because using "get_attr" already create implicit dependency from rg_a. About getting Null instead of real Ip address: It sounds like a bug, but IMO, it's

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-09 Thread Zane Bitter
On 09/03/16 05:42, Sergey Kraynev wrote: Hi Gary, First of all you don't need to use "depends_on", because using "get_attr" already create implicit dependency from rg_a. About getting Null instead of real Ip address: It sounds like a bug, but IMO, it's expected behavior, because I suppose it

Re: [openstack-dev] [heat] issue of ResourceGroup in Heat template

2016-03-09 Thread Sergey Kraynev
Hi Gary, First of all you don't need to use "depends_on", because using "get_attr" already create implicit dependency from rg_a. About getting Null instead of real Ip address: It sounds like a bug, but IMO, it's expected behavior, because I suppose it happens due to: - you create in rg_a some