Re: [openstack-dev] [nova][libvirt] The None and 'none' for CONF.libvirt.cpu_mode

2015-03-05 Thread Jiang, Yunhong
-Original Message- From: Daniel P. Berrange [mailto:berra...@redhat.com] Sent: Wednesday, March 4, 2015 9:56 AM To: Jiang, Yunhong Cc: openstack-dev@lists.openstack.org; Xu, Hejie Subject: Re: [nova][libvirt] The None and 'none' for CONF.libvirt.cpu_mode On Wed, Mar 04, 2015 at

Re: [openstack-dev] [nova][libvirt] The None and 'none' for CONF.libvirt.cpu_mode

2015-03-04 Thread Daniel P. Berrange
On Wed, Mar 04, 2015 at 02:52:06PM +, Jiang, Yunhong wrote: Hi, Daniel I'm a bit confused of the None/'none' for CONF.libvirt.cpu_mode. Per my understanding, None means there is no configuration provided and libvirt will select the default value based on the virt_type, none means

Re: [openstack-dev] [nova][libvirt] The None and 'none' for CONF.libvirt.cpu_mode

2015-03-04 Thread Daniel P. Berrange
On Wed, Mar 04, 2015 at 05:24:53PM +, Jiang, Yunhong wrote: Daniel, thanks for your clarification. Another related question is, what will be the guest's real cpu model is the cpu_model is None? This is about a reported regression at The guest CPU will be unspecified - it will be some

Re: [openstack-dev] [nova][libvirt] The None and 'none' for CONF.libvirt.cpu_mode

2015-03-04 Thread Jiang, Yunhong
Daniel, thanks for your clarification. Another related question is, what will be the guest's real cpu model is the cpu_model is None? This is about a reported regression at https://bugs.launchpad.net/nova/+bug/1082414 . When the instance.vcpu_model.mode is None, we should compare the