Re: [openstack-dev] [qa][tempest][rally] Seems like Tempest breaks Rally gates

2014-11-18 Thread Matthew Treinish
On Tue, Nov 18, 2014 at 06:29:55PM +0400, Boris Pavlovic wrote:
 Hi stackers,
 
 
 As far as you maybe know Rally has rally verify command that simplifies
 usage of tempest.
 
 We are testing this functionality in our gates on every patch (for about
 month).
 Everything was fine until today when it started failing.
 
 We are running 2 different tempest sets (image and smoke). And smoke one
 started failing.
 
 I thought that something is wrong with Rally  Tempst integration, and
 tried to run on fresh DevStack node just smoke tests from tempest via next
 command:  ./run_tempest.sh -s
 
 I got next result:
 
 Ran 0 tests in 4.499s
  OK
  stack@akurilin-virt-0:~/tempest$ git log -1
  commit 9556987fbfc906f386939b3903253aa8ff17d91d
  Merge: aee83e2 cd4a51e
  Author: Jenkins jenk...@review.openstack.org
  Date:   Tue Nov 18 12:42:41 2014 +
  Merge Add internal methods for setting compute clients
 
 
 
 Any thoughts?
 

This is actually an issue that the entire gate was hitting yesterday, not just
Rally. With the release of testtools 1.4.0, attrs in tempest broke, (which is
probably a unittest2 bug being exposed) this caused the regex filters on
attributes to stop working which broke a bunch of jobs. In the short term we've
landed global requirements changes to exclude that testtools version, you
probably just need to do the same on Rally to avoid the version which doesn't
work.

There is also tempest-side fix in progress here:

https://review.openstack.org/#/c/135115/

But, that will take a bit longer to land.


-Matt Treinish


pgpfXXn8YKJUs.pgp
Description: PGP signature
___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [qa][tempest][rally] Seems like Tempest breaks Rally gates

2014-11-18 Thread Boris Pavlovic
Matthew,


Thanks for quick reply!


Best regards,
Boris Pavlovic

On Tue, Nov 18, 2014 at 6:46 PM, Matthew Treinish mtrein...@kortar.org
wrote:

 On Tue, Nov 18, 2014 at 06:29:55PM +0400, Boris Pavlovic wrote:
  Hi stackers,
 
 
  As far as you maybe know Rally has rally verify command that simplifies
  usage of tempest.
 
  We are testing this functionality in our gates on every patch (for about
  month).
  Everything was fine until today when it started failing.
 
  We are running 2 different tempest sets (image and smoke). And smoke one
  started failing.
 
  I thought that something is wrong with Rally  Tempst integration, and
  tried to run on fresh DevStack node just smoke tests from tempest via
 next
  command:  ./run_tempest.sh -s
 
  I got next result:
 
  Ran 0 tests in 4.499s
   OK
   stack@akurilin-virt-0:~/tempest$ git log -1
   commit 9556987fbfc906f386939b3903253aa8ff17d91d
   Merge: aee83e2 cd4a51e
   Author: Jenkins jenk...@review.openstack.org
   Date:   Tue Nov 18 12:42:41 2014 +
   Merge Add internal methods for setting compute clients
  
 
 
  Any thoughts?
 

 This is actually an issue that the entire gate was hitting yesterday, not
 just
 Rally. With the release of testtools 1.4.0, attrs in tempest broke, (which
 is
 probably a unittest2 bug being exposed) this caused the regex filters on
 attributes to stop working which broke a bunch of jobs. In the short term
 we've
 landed global requirements changes to exclude that testtools version, you
 probably just need to do the same on Rally to avoid the version which
 doesn't
 work.

 There is also tempest-side fix in progress here:

 https://review.openstack.org/#/c/135115/

 But, that will take a bit longer to land.


 -Matt Treinish

 ___
 OpenStack-dev mailing list
 OpenStack-dev@lists.openstack.org
 http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


___
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev