Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-25 Thread Sean McGinnis
On Thu, Jan 25, 2018 at 10:49:10AM +0100, Alfredo Moralejo Alonso wrote:
> Hi,
> 
> We had the same issue again in release-post job for
> https://review.openstack.org/#/c/536927/
> 
> Logs in
> http://logs.openstack.org/32/323c387a2d1794e0679510657629470da8f7de92/release-post/tag-releases/b2091f1/job-output.txt.gz
> shows a similar issue. The script stuck at doing a "git fetch"
> 
> Best regards,
> 
> Alfredo
> 

Thanks Alfredo. I have requested that job be run again.

Sean


__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-25 Thread Alfredo Moralejo Alonso
Hi,

We had the same issue again in release-post job for
https://review.openstack.org/#/c/536927/

Logs in
http://logs.openstack.org/32/323c387a2d1794e0679510657629470da8f7de92/release-post/tag-releases/b2091f1/job-output.txt.gz
shows a similar issue. The script stuck at doing a "git fetch"

Best regards,

Alfredo


On Fri, Jan 19, 2018 at 6:29 PM, Alfredo Moralejo Alonso <
amora...@redhat.com> wrote:

>
>
> On Fri, Jan 19, 2018 at 5:50 PM, Sean McGinnis 
> wrote:
>
>> >
>> > Just an update - it does look like it was just the one job failure.
>> There are
>> > multiple puppet-* releases done as part of the one job, and it appears
>> they are
>> > processed in alphabetically order. So this last time it got as far as
>> > puppet-swift (at least further along than puppet-horizon) before it hit
>> this
>> > timeout.
>> >
>> > I'm fairly confident once we get the job to run again it should make it
>> through
>> > these last few releases.
>> >
>>
>> Jeremy was able to re-queue the job, and it appears everything completed
>> as
>> expected. I've taken a quick look through the tarballs, and I think
>> everything
>> is there. Please take a look and let me know if you see anything unusual.
>>
>>
> Yeah, everything looks ok to me now.
>
> Thanks for your help,
>
> Alfredo
>
>
>> 
>> __
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscrib
>> e
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>
>
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-19 Thread Alfredo Moralejo Alonso
On Fri, Jan 19, 2018 at 5:50 PM, Sean McGinnis 
wrote:

> >
> > Just an update - it does look like it was just the one job failure.
> There are
> > multiple puppet-* releases done as part of the one job, and it appears
> they are
> > processed in alphabetically order. So this last time it got as far as
> > puppet-swift (at least further along than puppet-horizon) before it hit
> this
> > timeout.
> >
> > I'm fairly confident once we get the job to run again it should make it
> through
> > these last few releases.
> >
>
> Jeremy was able to re-queue the job, and it appears everything completed as
> expected. I've taken a quick look through the tarballs, and I think
> everything
> is there. Please take a look and let me know if you see anything unusual.
>
>
Yeah, everything looks ok to me now.

Thanks for your help,

Alfredo


> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-19 Thread Sean McGinnis
> 
> Just an update - it does look like it was just the one job failure. There are
> multiple puppet-* releases done as part of the one job, and it appears they 
> are
> processed in alphabetically order. So this last time it got as far as
> puppet-swift (at least further along than puppet-horizon) before it hit this
> timeout.
> 
> I'm fairly confident once we get the job to run again it should make it 
> through
> these last few releases.
> 

Jeremy was able to re-queue the job, and it appears everything completed as
expected. I've taken a quick look through the tarballs, and I think everything
is there. Please take a look and let me know if you see anything unusual.


__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-19 Thread Sean McGinnis
> 
> There appears to have been a transient failure with a timeout on a git pull
> request in the job. I have asked in -infra if there is anyone that can just
> re-enque the job for us. It should pass this time. This one is for
> puppet-swift.
> 
> There was another failure yesterday with puppet-horizon that ianw was able to
> rerun for us that did succeed the second time around.
> 

Just an update - it does look like it was just the one job failure. There are
multiple puppet-* releases done as part of the one job, and it appears they are
processed in alphabetically order. So this last time it got as far as
puppet-swift (at least further along than puppet-horizon) before it hit this
timeout.

I'm fairly confident once we get the job to run again it should make it through
these last few releases.


__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-19 Thread Sean McGinnis
On Fri, Jan 19, 2018 at 11:54:09AM +0100, Alfredo Moralejo Alonso wrote:
> Looking at
> http://logs.openstack.org/0f/0f0c9871144bf3b658f73f60f35f3068612a6bb2/release-post/tag-releases/629d779/job-output.txt.gz
> (thanks ykarel for pointing it out) it seems the "run releases script"
> tasks timed out and some releases were not properly created. I'd say that
> the script stuck doing a "git pull --ff-only" for a repo.
> 
> Is it safe to revert/resend the review to get the missing releases?
> 
> Best regards,
> 
> Alfredo
> 

There appears to have been a transient failure with a timeout on a git pull
request in the job. I have asked in -infra if there is anyone that can just
re-enque the job for us. It should pass this time. This one is for
puppet-swift.

There was another failure yesterday with puppet-horizon that ianw was able to
rerun for us that did succeed the second time around.

I didn't see any release job failure emails for the other ones here, though
it's possible the failure could have included the ability to send out the email
notification for it. I will check in to the rest of these.

Worse case in these scenarios - yes, we can revert and redo the release patch,
but I'm hoping we can just manually rerun the few left that had failed.

Thanks,
Sean


> 
> On Fri, Jan 19, 2018 at 10:07 AM, Alfredo Moralejo Alonso <
> amora...@redhat.com> wrote:
> 
> > Hi,
> >
> > Review https://review.openstack.org/#/c/535206/ was merged yesterday to
> > create some new releases for puppet modules in pike. I've observed that
> > releases were not created for following modules:
> >
> > puppet-tacker
> > puppet-zaqar
> > puppet-tempest
> > puppet-vswitch
> > puppet-vitrage
> > puppet-trove
> >
> > I couldn't find the logs to the release create jobs so i'm not sure what
> > the problem was. What's the best way to proceed here?, revert and resend
> > the review would work?
> >
> > Best regards,
> >
> > Alfredo
> >
> >

> __
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


Re: [openstack-dev] [release][puppet] Tarballs missing for some puppet modules in pike

2018-01-19 Thread Alfredo Moralejo Alonso
Looking at
http://logs.openstack.org/0f/0f0c9871144bf3b658f73f60f35f3068612a6bb2/release-post/tag-releases/629d779/job-output.txt.gz
(thanks ykarel for pointing it out) it seems the "run releases script"
tasks timed out and some releases were not properly created. I'd say that
the script stuck doing a "git pull --ff-only" for a repo.

Is it safe to revert/resend the review to get the missing releases?

Best regards,

Alfredo


On Fri, Jan 19, 2018 at 10:07 AM, Alfredo Moralejo Alonso <
amora...@redhat.com> wrote:

> Hi,
>
> Review https://review.openstack.org/#/c/535206/ was merged yesterday to
> create some new releases for puppet modules in pike. I've observed that
> releases were not created for following modules:
>
> puppet-tacker
> puppet-zaqar
> puppet-tempest
> puppet-vswitch
> puppet-vitrage
> puppet-trove
>
> I couldn't find the logs to the release create jobs so i'm not sure what
> the problem was. What's the best way to proceed here?, revert and resend
> the review would work?
>
> Best regards,
>
> Alfredo
>
>
__
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev