Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-23 Thread Doug Hellmann
The question was never whether it could be made to do it (we'd have to change it, but it's just code). The question was whether allowing extra data was a good idea at all. If it's a real requirement, we just need a patch to WSME to support it. Doug On Sat, Jan 18, 2014 at 8:30 PM, Morgan

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-19 Thread Kenichi Oomichi
-Original Message- From: Kurt Griffiths [mailto:kurt.griffi...@rackspace.com] Sent: Saturday, January 18, 2014 4:47 AM To: OpenStack Development Mailing List (not for usage questions) Subject: Re: [openstack-dev] [wsme] Undefined attributes in WSME FWIW, I believe Nova is looking

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-18 Thread Yuriy Taraday
On Tue, Jan 14, 2014 at 6:09 PM, Doug Hellmann doug.hellm...@dreamhost.comwrote: On Mon, Jan 13, 2014 at 9:36 PM, Jamie Lennox jamielen...@redhat.comwrote: On Mon, 2014-01-13 at 10:05 -0500, Doug Hellmann wrote: What requirement(s) led to keystone supporting this feature? I've got no idea

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-17 Thread Kurt Griffiths
FWIW, I believe Nova is looking at using JSON Schema as well, since they need to handle API extensions. This came up during a design session at the HK summit. On 1/12/14, 5:33 PM, Jamie Lennox jamielen...@redhat.com wrote: I would prefer not to have keystone using yet another framework from the

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-14 Thread Doug Hellmann
) Subject: Re: [openstack-dev] [wsme] Undefined attributes in WSME On Mon, Jan 13, 2014 at 3:29 AM, Ken'ichi Ohmichi ken1ohmi...@gmail.com wrote: Hi Doug, 2014/1/11 Doug Hellmann doug.hellm...@dreamhost.com: On Thu, Jan 9, 2014 at 12:02 AM, Jamie Lennox

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-14 Thread Kenichi Oomichi
Hi Doug, -Original Message- From: Doug Hellmann [mailto:doug.hellm...@dreamhost.com] Sent: Tuesday, January 14, 2014 11:10 PM To: OpenStack Development Mailing List (not for usage questions) Subject: Re: [openstack-dev] [wsme] Undefined attributes in WSME On Mon, Jan 13, 2014

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-13 Thread Ken'ichi Ohmichi
Hi Doug, 2014/1/11 Doug Hellmann doug.hellm...@dreamhost.com: On Thu, Jan 9, 2014 at 12:02 AM, Jamie Lennox jamielen...@redhat.com wrote: Is there any way to have WSME pass through arbitrary attributes to the created object? There is nothing that i can see in the documentation or code that

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-13 Thread Doug Hellmann
On Mon, Jan 13, 2014 at 3:29 AM, Ken'ichi Ohmichi ken1ohmi...@gmail.comwrote: Hi Doug, 2014/1/11 Doug Hellmann doug.hellm...@dreamhost.com: On Thu, Jan 9, 2014 at 12:02 AM, Jamie Lennox jamielen...@redhat.com wrote: Is there any way to have WSME pass through arbitrary attributes to the

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-13 Thread Doug Hellmann
On Sun, Jan 12, 2014 at 6:33 PM, Jamie Lennox jamielen...@redhat.comwrote: On Fri, 2014-01-10 at 10:23 -0500, Doug Hellmann wrote: On Thu, Jan 9, 2014 at 12:02 AM, Jamie Lennox jamielen...@redhat.com wrote: Is there any way to have WSME pass through arbitrary

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-13 Thread Jamie Lennox
On Mon, 2014-01-13 at 10:05 -0500, Doug Hellmann wrote: On Sun, Jan 12, 2014 at 6:33 PM, Jamie Lennox jamielen...@redhat.com wrote: On Fri, 2014-01-10 at 10:23 -0500, Doug Hellmann wrote: On Thu, Jan 9, 2014 at 12:02 AM, Jamie

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-13 Thread Kenichi Oomichi
Hi Doug, -Original Message- From: Doug Hellmann [mailto:doug.hellm...@dreamhost.com] Sent: Tuesday, January 14, 2014 12:07 AM To: OpenStack Development Mailing List (not for usage questions) Subject: Re: [openstack-dev] [wsme] Undefined attributes in WSME On Mon, Jan 13

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-12 Thread Jamie Lennox
On Fri, 2014-01-10 at 10:23 -0500, Doug Hellmann wrote: On Thu, Jan 9, 2014 at 12:02 AM, Jamie Lennox jamielen...@redhat.com wrote: Is there any way to have WSME pass through arbitrary attributes to the created object? There is nothing that i can see in the

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-10 Thread Doug Hellmann
On Thu, Jan 9, 2014 at 12:02 AM, Jamie Lennox jamielen...@redhat.comwrote: Is there any way to have WSME pass through arbitrary attributes to the created object? There is nothing that i can see in the documentation or code that would seem to support this. In keystone we have the situation

Re: [openstack-dev] [wsme] Undefined attributes in WSME

2014-01-09 Thread Jamie Lennox
On Thu, 2014-01-09 at 11:16 +0100, Julien Danjou wrote: On Thu, Jan 09 2014, Jamie Lennox wrote: Is there any way to have WSME pass through arbitrary attributes to the created object? There is nothing that i can see in the documentation or code that would seem to support this. In